Subject: RE: Example in draft-ietf-ldapbis-url-03.txt

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 23 May 2003 11:13:00 +1000

It's not really a good idea. Binary attributes should be encoded in ASN.1 and this one clearly isn't! What about using 'oct', say.

-----Original Message-----
From: Mark C Smith [mailto:[email-masked]]
Sent: Friday, 23 May 2003 02:36
To: Vithalprasad Gaitonde
Cc: [email-masked]
Subject: Re: Example in draft-ietf-ldapbis-url-03.txt

Vithalprasad Gaitonde wrote:
> Section 7 of this document gives an example of (int=\00\00\00\04) and
> shows hot the LDAP URL representation for the same.
> The use of "int" seems to indicate here that its an integer attribute
> which is being talked about. Its unlikely that an integer syntax
> attribute will encoded like this.
> Though its not technically incorrect, for better readability sake,
> would it be a good idea to choose some other attribute name than "int"
> like bin (bin=\00\00\00\04) as in section 7 of
> draft-ietf-ldapbis-filter-04.txt.

OK, this is a good suggestion.

-- 
Mark Smith
Netscape Directory Product Development
My words are my own, not my employer's.

---

From: [email-masked] (Mark C Smith)
Date: Fri, 30 May 2003 10:08:34 -0400

I don't think I responded to this... 'oct' is a little obscure, but your 
point is well taken. I view "binary" as a very general term, but it does 
carry some historical baggage from the LDAP point of view. Perhaps:

     (four-octet-attr=\00\00\00\04)

:)

-Mark

Ramsay, Ron wrote:
> It's not really a good idea. Binary attributes should be encoded in
 > ASN.1 and this one clearly isn't! What about using 'oct', say.
>