Subject: T.61 -> Unicode mapping

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 13 May 2003 11:38:27 -0700

One of the holes which needs to filled in the proposal
for Internationalization of X.500/LDAP Matching Rules
is a specification of the algorithm for mapping T.61
characters to Unicode characters.

Does anyone have a reference to a suitable algorithm?
If not, anyone willing to detail a suitable algorithm?

Kurt

---

From: "Howard Chu" <[email-masked]>
Date: Tue, 13 May 2003 12:35:01 -0700

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Kurt D. Zeilenga

> If not, anyone willing to detail a suitable algorithm?

I wrote a pretty good mapping in OpenLDAP's libldap/t61.c.

Part of the problem is that older software used "T.61" as "arbitrary 8-bit
text" and so used character values that don't exist in the actual T.61
definition. Of course, the T.61 definition was lacking some pretty essential
character codes to begin with, so this distortion of the spec is somewhat
unavoidable.

  -- Howard Chu
  Chief Architect, Symas Corp.       Director, Highland Sun
  http://www.symas.com               http://highlandsun.com/hyc
  Symas: Premier OpenSource Development and Support