Subject: name form for inetOrgPerson with uid as naming attribute?

From: "Jochen Keutel" <[email-masked]>
Date: Mon, 12 May 2003 09:56:05 +0200

Hello,
  it's common practice to store objects of object class
inetOrgPerson with uid as naming attribute in an LDAP directory.
But - AFAIK - there is no name form allowing that; so LDAP
servers which care about name forms (e.g. X.500 servers) reject this.

It's quite boring to define this name form in each new directory
project I have ... (and, additionally, it's always a new
object identifier of the OID branch of the customer ...).

Is it possible to define this name form in any of the LDAP
standard documents?

draft-zeilenga-ldap-user-schema-06.txt doesn't mention name forms.
Neither do draft-ietf-ldapbis-user-schema-05.txt or RFC2798.

Or is it outside the scope of LDAP to define name forms?

Regards,  Jochen Keutel.

---

From: Michael Ströder <[email-masked]>
Date: Mon, 12 May 2003 10:08:59 +0200

> Is it possible to define this name form in any of the LDAP

IMHO it would be most appropriate to define a name form applicable for a 
certain object class in the document defining this object class. How about 
starting a new revision of RFC 2798, e.g. draft-[something]-ldap-RFC2798bis?

BTW we could add other useful things needed by LDAP community...

Ciao, Michael.

---

From: [email-masked] (Mark C Smith)
Date: Mon, 12 May 2003 09:52:21 -0400

Michael Ströder wrote:
> certain object class in the document defining this object class. How 
> about starting a new revision of RFC 2798, e.g. 
> draft-[something]-ldap-RFC2798bis?
> 

Years ago John Dale proposed two name forms for inclusion in the 
inetOrgPerson document but, at the time, it was too late to include them 
(debate had been going on long enough about the document and we were 
about to send it to the IESG).  But revising 2798 seems like a good idea 
if there is sufficient interest.  I'd be happy to take on the editing 
tasks again.

For the record, here are the nameforms John proposed (I translated them 
to RFC 2252 syntax, so any syntax errors are mine):

nameForms: ( 2.16.840.1.113678.640.7.8
   NAME 'inetOrgPersonNameForm'
   OC inetOrgPerson
   MUST cn
   MAY ou )

nameForms: ( 2.16.840.1.113678.640.7.9
   NAME 'inetOrgPersonNameForm'
   OC inetOrgPerson
   MUST uid
   MAY ( cn $ ou ) )

-Mark Smith
  Netscape