Subject: I-D ACTION:draft-zeilenga-ldapbis-strprep-00.txt

From: [email-masked]
Date: Tue, 06 May 2003 07:40:56 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: LDAP: Internationalized String Preparation
	Author(s)	: K. Zeilenga
	Filename	: draft-zeilenga-ldapbis-strprep-00.txt
	Pages		: 10
	Date		: 2003-5-5
	
The previous Lightweight Directory Access Protocol (LDAP) technical
specifications did not precisely define how string matching is to be
performed.  This lead to a number of usability and interoperability
problems.  This document defines string preparation algorithms for
matching rules defined for use in LDAP.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-zeilenga-ldapbis-strprep-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-zeilenga-ldapbis-strprep-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-zeilenga-ldapbis-strprep-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 06 May 2003 07:35:26 -0700

This I-D describes stringprep-based algorithms for
preparing strings for matching.   They are compatible
with algorithms suggested for use in X.500:  "Internationalized String Matching Rules for X.500"
  <draft-zeilenga-ldapbis-strmatch-02.txt>

I believe this I-D should become a WG I-D and become
an integral part of the LDAP Technical Specification
[Roadmap] and that the LDAP: Syntaxes and Matching
Rules [Syntaxes] I-D be updated to require textual
strings be prepared for matching according to it.

Hence, I ask for your comments on this proposal.
As I authored this I-D, I defer chair responsibilities
with regard to this proposal and this I-D to my
co-chair.

Kurt

At 04:40 AM 5/6/2003, [email-masked] wrote:
>Content-Type: text/plain
>Content-ID:     <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-zeilenga-ldapbis-strprep-00.txt
>
><ftp://ftp.ietf.org/internet-drafts/draft-zeilenga-ldapbis-strprep-00.txt>