Subject: Re: REVISED protocol review notes [LONG]

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 21 Oct 2003 23:15:31 -0600

I have Attribute (at least one attribute value) being used by
AttributeList, which is used by AddRequest.
 
You're not saying that objectClass may have zero values in an add
request are you?
 
I have PartialAttribute being used by PartialAttributeList and by
ModifyRequest.changes.modification.
 
We could pare it down to a single definition (without the SIZE), and
add documentation where its needed, but these two definitions are more
precise.
 
Jim
 
>>> "Kurt D. Zeilenga" <[email-masked]> 10/21/03 10:12:15 PM >>>
At 08:50 PM 10/21/2003, Jim Sermersheim wrote:
>Actually my current plan is to define both:
> Attribute ::= SEQUENCE {
> type AttributeDescription,
> vals SET SIZE (1..MAX) OF AttributeValue }
>and
> PartialAttribute ::= SEQUENCE {
> type AttributeDescription,
> vals SET OF AttributeValue }
>
>and use them in the appropriate places.
>Does this sound reasonable?

Well, I had thought this made sense (as I suggest in my notes).

However, as almost all uses should be PartialAttribute
and not Attribute, it may make more sense just to have
Attribute and make it more clear that all uses allow can
be partial (not all values) and a few uses allow it to be
empty (no values).

(objectClass is an example of an attribute where not all
values are required to be transferred.)

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 21 Oct 2003 22:47:59 -0700

I'm fine with having both... having the explicit size constraint on
AddRequest.attributes will be nice.

At 10:15 PM 10/21/2003, Jim Sermersheim wrote:
>You're not saying that objectClass may have zero values in an add request are you?

No.  Just saying that Attribute can be partial in the sense of
not holding all values.

Kurt