Subject: RE: WG Last Call: draft-ietf-ldapbis-protocol-17.txt [corrected]

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 21 Oct 2003 21:46:55 -0600

>>> "Steven Legg" <[email-masked]> 10/5/03 11:50:20 PM >>>
>> 4.6. Modify Operation 
>
>>    Parameters of the Modify Request are: 
>>     
>>    - object: The object to be modified. The value of this field 
>>      contains the DN of the entry to be modified. The server will
not 
^^^^^^^^
>SHALL NOT ?

These are all on many operations. I think SHALL NOT is too strong. I
suspect there are implementations that allow the alias to be
dereferenced (whether by control, local policy, or both).

Do you think there is an interoperability issue here? If so, would
SHOULD NOT suffice?

Jim

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 21 Oct 2003 21:30:40 -0700

>Do you think there is an interoperability issue here? If so, would

I think, no.  A server which deferences the alias not only
prevents modification of the the alias object, it might
(quite inappropriately) modify the aliased object.  A
SHALL NOT here is appropriate as without it one could
not administrate alias objects in an interoperable fashion.
This applies to all other update operations as well.

Kurt

---

From: Steven Legg <[email-masked]>
Date: Wed, 22 Oct 2003 18:02:41 +1100

I agree completely with Kurt.