Subject: Re: More on DIT content rules

From: Jonghyuk Choi <[email-masked]>
Date: Thu, 30 Oct 2003 10:02:14 -0500

>I think the equivalent statements from X.501 are:
>
>----------
>If no DIT content rule is present for a structural object class, then
>entries of that class shall contain only the attributes
>permitted by the structural object class definition.
>
>An entry governed by a DIT content rule may, in addition to the 
structural
>object class of the DIT structure rule, be
>associated with a subset of the auxiliary object classes identified by 
the
>DIT content rule. This association is reflected in
>the entry's objectClass attribute.
>----------
>
>That does seem to say that if there is no DIT content rule, the entry
>cannot belong to any auxiliary object classes. And it does seem strange 
to
>me.

Yes. looks like X.501 requires a DIT content rule to be related with a 
structrual object class,
should an entry of the class be associated with any auxiliary object 
classes.
Is it the intention of the I-D to follow the X.501 model in this respect ?

------------------------
Jong Hyuk Choi
IBM Thomas J. Watson Research Center - Enterprise Linux Group
P. O. Box 218, Yorktown Heights, NY 10598
email: [email-masked]
(phone) 914-945-3979    (fax) 914-945-4425   TL: 862-3979

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 30 Oct 2003 07:45:29 -0800

>Is it the intention of the I-D to follow the X.501 model in this respect ?

The intention of the I-D is, in general, to follow X.500 models.
Some adaption is needed here and there, but that is kept to
a minimum.  Adaption here was not needed.  X.501 model can
be applied to LDAP without adaption and, given that LDAP
TS said that X.500 information models were to be applied, that's
what this draft does.

Kurt