Subject: RE: REVISED protocol review notes [LONG]

From: "Ramsay, Ron" <[email-masked]>
Date: Thu, 23 Oct 2003 11:27:18 +1000

I don't know what version of ASN.1 LDAPv3 should require. For X.500 it's the 1993 version, isn't it? But I don't remember any statement about ASN.1. I wouldn't like the ASN.1 issue to create a moving target.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Jim Sermersheim
Sent: Thursday, 23 October 2003 01:30
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: REVISED protocol review notes [LONG]

>>> Steven Legg <[email-masked]> 10/22/03 1:17:00 AM >>>
>Yes, but you could also do this:
>
>PartialAttribute ::= SEQUENCE {
>type AttributeDescription,
>vals SET OF AttributeValue }
>
>Attribute ::= PartialAttribute(WITH COMPONENTS {..., vals (SIZE(1..MAX))})

Wow. This looks cool... but having never seen such a thing, I had to do a double take. What do others think about using this kind of definition?

>You could also in-line the right hand side of the Attribute assignment
>statement everywhere Attribute is needed and then rename PartialAttribute
>to just Attribute.

True, it's only used in one place right now (AttributeList)

>By the way, are you intending to put identifiers into each of
>the SET OF and SEQUENCE OF notations ? I so, do you want me to
>make some appropriate suggestions ?

I think so, but I wanted to ping the list one more time about this before deciding.
 
Jim

---

From: Steven Legg <[email-masked]>
Date: Thu, 23 Oct 2003 13:05:19 +1100

Ron,

Ramsay, Ron wrote:
> I don't know what version of ASN.1 LDAPv3 should require. For X.500 it's 
> the 1993 version, isn't it? But I don't remember any statement about 
> ASN.1. I wouldn't like the ASN.1 issue to create a moving target.

At the request of the ITU-T ASN.1 working group we are referencing the
latest version of ASN.1. Since this version is fully backward compatible
with the version referenced by X.500:1993, and introduces no harmful effects,
we've agreed to the request. The version of ASN.1 referenced by X.500:1993
has been withdrawn by the ITU.

BTW, the "wow, cool" notation has been part of ASN.1 since at least 1993,
possibly longer.

Regards,
Steven

>     *From:* [email-masked]
>     [mailto:[email-masked]]*On Behalf Of *Jim Sermersheim
>     *Sent:* Thursday, 23 October 2003 01:30
>     *To:* [email-masked]
>     *Cc:* [email-masked]; [email-masked]
>     *Subject:* Re: REVISED protocol review notes [LONG]
> 
>     Wow. This looks cool... but having never seen such a thing, I had to
>     do a double take. What do others think about using this kind of
>     definition?
>