Subject: I-D ACTION:draft-ietf-ldapbis-models-09.txt

From: [email-masked]
Date: Tue, 28 Oct 2003 09:09:39 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the LDAP (v3) Revision Working Group of the IETF.

	Title		: LDAP: Directory Information Models
	Author(s)	: K. Zeilenga
	Filename	: draft-ietf-ldapbis-models-09.txt
	Pages		: 49
	Date		: 2003-10-27
	
The Lightweight Directory Access Protocol (LDAP) is an Internet
protocol for accessing distributed directory services which act in
accordance with X.500 data and service models.  This document
describes the X.500 Directory Information Models.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ldapbis-models-09.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ldapbis-models-09.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-ldapbis-models-09.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Michael Ströder <[email-masked]>
Date: Tue, 28 Oct 2003 16:50:16 +0100

HI!

Reviewing draft-ietf-ldapbis-models-09 I wonder whether a DIT content rule 
also applies to inherited structural object classes.

Example: If I have a content rule for object class 'person' does this also 
apply to object class 'inetOrgPerson'?

The implementation I'm testing with does not seem to apply the content rule 
to inherited object classes but section 4.1.6 "DIT Content Rules" is not 
very explicit on this.

The current text is:

   For DIT entries of a particular structural object class, [..]

The word "particular" might be too weak.

Ciao, Michael.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 28 Oct 2003 12:31:08 -0800

At 07:50 AM 10/28/2003, Michael Ströder wrote:
>Reviewing draft-ietf-ldapbis-models-09 I wonder whether a DIT content rule also applies to inherited structural object classes.

No.  

>The word "particular" might be too weak.

The word choice is due to X.501.
  A DIT content rule is a "rule governing the content of entries of
  a particular structural object class" [X.501].

I think the text is clear here an entry is governed by the
rule for its structural object class.  As discussed in 2.4.2,
an entry is of one structural object class (but may belong
to many structural object classes).

Anyways, please feel free to offer alternative text for
consideration.

Kurt