Subject: RE: Steven's protocol comments

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 20 Oct 2003 23:48:51 -0600

Hmm, I think Steven needs to comment on why he was questioning the
MUST.

>>> "Kurt D. Zeilenga" <[email-masked]> 10/20/03 11:39:34 PM >>>
At 10:13 PM 10/20/2003, Jim Sermersheim wrote:
>>>> "Kurt D. Zeilenga" < [email-masked] > 10/8/03 7:59:20 AM >>>
><snip>
>
>>> 4.13.3.1. Graceful Closure 
>>> The other party, if it receives a TLS closure alert, MUST
immediately 
>>> transmit a TLS closure alert. It will subsequently cease to send
TLS 
>>> ^^^^ MUST ?
>>
>>Please consider the replace text I offer in my comments. 
>Kurt, I didn't see any replacement text in your comments for this
section.

Sorry, how about?
The other party, upon receipt of a TLS closure alert, SHALL
immediately send a TLS closure alert and then terminate the
TLS connection. The LDAP connection remains established
unless subsequently terminated.

---

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 20 Oct 2003 23:51:45 -0600

I'm assuming that Steven had an issue with the fact that we're requiring
a protocol peer to send back a TLS closure alert, when really the
recipient may wish to just close the underlying connection. My current
wording basically says that if the recipient of the initial TLS closure
alert wishes to allow the underlying LDAP connection, *then* it must
immediately send its own TLS closure alter, etc.
 
Jim

immediately 
TLS 
section.

Sorry, how about?

---

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 21 Oct 2003 00:13:26 -0600

Ok, I finally read Steven's comments with a fixed pitch font so I could
see what he was *actually* pointing out. He was asking if the "will"
shoul dbe a MUST, which your re-wording does seem to cover.
 
Sorry for the noise.

immediately 
TLS 
section.

Sorry, how about?

---

From: Steven Legg <[email-masked]>
Date: Tue, 21 Oct 2003 17:12:50 +1100

Jim,

I was actually questioning the "It will subsequently cease", but
the pointer got moved by all the quoting. The sentence looked like an
implementation imperative in which case I was suggesting a rewording
to "It MUST subsequently cease". Kurt's rewording resolves my (minor)
concern.

Regards,
Steven

Jim Sermersheim wrote:
> Hmm, I think Steven needs to comment on why he was questioning the MUST.
> 
>  >>>> "Kurt D. Zeilenga" <_ [email-masked] 
> <mailto:[email-masked]>_ > 10/8/03 7:59:20 AM >>>
>  ><snip>
>  >
>  >>> The other party, if it receives a TLS closure alert, MUST immediately
>  >>> transmit a TLS closure alert. It will subsequently cease to send TLS
>  >>> ^^^^ MUST ?
>  >>
>  >Kurt, I didn't see any replacement text in your comments for this section.
> 
> Sorry, how about?

---

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 21 Oct 2003 00:44:27 -0600

>>> "Kurt D. Zeilenga" <[email-masked]> 10/8/03 7:59:20 AM >>>
<SNIP>
>> If the client wishes to progress the operation, it MUST follow the 
>> referral by contacting one of the servers.
>>
>>"If" and "MUST" make this an effective "MAY", e.g.
>>
>> "The Client MAY progress the operation by following the referral
and
>> contacting one of the servers."
>
>I think this MAY could be downcased.

First, I don't agree that the If and MUST equals a MAY. It says that
"If X is to happen, Y MUST be done"
 
Second (which makes my first statement moot), I agree that this doesn't
seem to have interoperability repercussions, so a rewording and removal
of MUST seems appropriate.
 
Jim