Subject: Re: REVISED protocol review notes [LONG]

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 21 Oct 2003 21:01:23 -0600

>>> Kurt Zeilenga <[email-masked]> 10/7/03 3:48:43 PM >>>
>>    
>>        Attribute ::= SEQUENCE { 
>>                type    AttributeDescription, 
>>                vals    SET OF AttributeValue } 
>>    
>>   Each attribute value is distinct in the set (no duplicates). The
set 
>>   of attribute values is unordered. Implementations MUST NOT reply
upon 
>>   any apparent ordering being repeatable. 
>>    
>
>This type is never explicitly used in the protocol.  
 
It is the type for ModifyRequest.changes.modification

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 21 Oct 2003 20:17:11 -0700

At 08:01 PM 10/21/2003, Jim Sermersheim wrote:
>>>   Each attribute value is distinct in the set (no duplicates). The set 
>>>   of attribute values is unordered. Implementations MUST NOT reply upon 

Okay... but I note that ModifyRequest.changes.modification is
a partial attribute.   I assume your other changes to clarify
Attribute may be partial will lead to PartialAttributeList
fading away.

Kurt