Subject: Re: DIT Content Rules

From: John McMeeking <[email-masked]>
Date: Tue, 28 Oct 2003 14:27:26 -0600

At least going back to X.501(1993):

   The DIT content rules of superclasses of the structural object class for
an entry do not apply to that entry.

For your example, I interpret that as meaning that a DIT content rule for
person does not apply to inetorgperson.

It looks like that specific statement is missing from [models] though much
of the text surrounding it (in X.501) is present.

I think it would be appropriate to add this statement to [models].

John  McMeeking

                      Michael Ströder                                                                                  
                      <[email-masked]        To:       [email-masked]                                  
                      m>                          cc:                                                                  
                      Sent by:                    Subject:  DIT Content Rules                                          
                      owner-ietf-ldapbis@O                                                                             
                      penLDAP.org                                                                                      

                      10/28/2003 09:50 AM                                                                              

HI!

Reviewing draft-ietf-ldapbis-models-09 I wonder whether a DIT content rule
also applies to inherited structural object classes.

Example: If I have a content rule for object class 'person' does this also
apply to object class 'inetOrgPerson'?

The implementation I'm testing with does not seem to apply the content rule
to inherited object classes but section 4.1.6 "DIT Content Rules" is not
very explicit on this.

The current text is:

   For DIT entries of a particular structural object class, [..]

The word "particular" might be too weak.

Ciao, Michael.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 28 Oct 2003 12:46:00 -0800

How about if I add:
  DIT content rules for superclasses of the structural object class
  of an entry are not applicable to that entry.

at the end of the paragraph which starts with "An entry is governed
by"?

---

From: "Howard Chu" <[email-masked]>
Date: Tue, 28 Oct 2003 12:39:13 -0800

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of John McMeeking

> I think it would be appropriate to add this statement to [models].

Wouldn't it be more accurate to say

  The DIT content rules of superclasses of a structural objectclass
do not apply to that objectclass.

?

  -- Howard Chu
  Chief Architect, Symas Corp.       Director, Highland Sun
  http://www.symas.com               http://highlandsun.com/hyc
  Symas: Premier OpenSource Development and Support

---

From: Michael Ströder <[email-masked]>
Date: Wed, 29 Oct 2003 08:57:15 +0100

> at the end of the paragraph which starts with "An entry is governed

I'm fine with that.

Ciao, Michael.