Subject: Re: Implementation of SASL security layer in LDAP clients/servers

From: "Vithalprasad Gaitonde" <[email-masked]>
Date: Mon, 03 Nov 2003 04:27:57 -0700

Novell eDirectory supports SASL. I think we have tested with most client
SDKs...dont know what are the clients you are looking for to do interop
testing of servers....

Prasad

>>> Alexey Melnikov <[email-masked]> 11/3/2003 4:07:03 PM
>>>
Kurt D. Zeilenga wrote:

>At 01:37 PM 11/1/2003, Alexey Melnikov wrote:
>  
>
>>Kurt D. Zeilenga wrote:
>>    
>>
>>>At 12:49 PM 11/1/2003, Alexey Melnikov wrote:
>>>      
>>>
>>>>Out of curiosity, I would like to know how many implementations
support SASL security layer?
>>>>        
>>>>
>>>Enough (more than zero) that significant changes the specification
>>>of SASL security layer would cause serious interoperability
problems.
>>>      
>>>
>>Kurt, that was not my question. You haven't named a single one.
>>    
>>
>
>Your question wasn't "who has implemented the feature?", but
>"how many implementations support the feature?".  I'm not going
>to attempt to answer the former.  Nor am I going to attempt to
>give a precise answer to the latter.  I will narrow my previous
>answer though.
>
>There are multiple independently developed LDAP implementations
>of SASL security layers.
>
Does anybody have a webpage listing different implementations
supporting 
SASL security layer and what kind of interoperability testing was
done?

I am not looking for precise number, but I would appreciate a detailed

answer.

Thanks,
Alexey

---

From: John McMeeking <[email-masked]>
Date: Mon, 3 Nov 2003 07:40:40 -0600

IBM directory products support various SASL mechanisms for authentication.
For that matter, all LDAP servers I have dealt with have SASL support of
some form.

John  McMeeking

---

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 6 Nov 2003 03:35:01 +0100

John McMeeking writes:

> IBM directory products support various SASL mechanisms for
> authentication.  For that matter, all LDAP servers I have dealt with
> have SASL support of some form.

The question was about SASL security layers, which encrypt data sent
_after_ auth, not just 'some' SASL support like SASL authentication.

-- 
Hallvard

---

From: John McMeeking <[email-masked]>
Date: Wed, 5 Nov 2003 22:12:03 -0600

In that context, I guess I would completely reverse my statement.  IBM
directory servers do not support the data integrity/privacy mechanisms
associated with SASL, just authentication.  I am completely ignorant on the
subject of such support by other LDAP servers (which is not to say that
they don't provide such support, just that I don't know if they do).

John  McMeeking

                      Hallvard B                                                                                         
                      Furuseth                 To:       John McMeeking/Rochester/IBM@IBMUS                              
                      <h.b.furuseth@usi        cc:       LDAPBis WG <[email-masked]>                          
                      t.uio.no>                Subject:  Re: Implementation of SASL security layer in LDAP               
                                                clients/servers                                                          
                      11/05/2003 08:35                                                                                   
                      PM                                                                                                 

--
 Hallvard