Subject: passwords in the clear

From: Chris Newman <[email-masked]>
Date: Tue, 11 Nov 2003 13:55:50 -0600

The recent IMAP revision spec used to allow the LOGIN command (equivalent to
simple bind) without requiring a security layer and this was rejected by the
IESG.

In RFC 3501, we developed compromise text that addressed the IESG's desire to
strongly deprecate passwords in the clear, while still allowing legacy
implementations.  Recasting that text in LDAP terms looks roughly like this:

----
   Use of simple bind sends passwords in the clear.  This can be
   avoided by using SASL bind [SASL] with a mechanism
   that does not use plaintext passwords, by first negotiating
   encryption via STARTTLS or some other protection mechanism.

   A server implementation MUST implement a configuration that, at the
   time of authentication, requires:
      (1) A STARTTLS encryption layer has been successfully negotiated.
   OR
      (2) Some other mechanism that protects the session from password
      snooping has been provided.
   OR
      (3) The following measures are in place:
         (a) The simple bind operation returns an error even if the
         password is correct.
      AND
         (b) The SASL bind operation returns an error with all [SASL]
         mechanisms that use plaintext passwords, even if the password
         is correct.
----

                - Chris

---

From: Hallvard B Furuseth <[email-masked]>
Date: Wed, 12 Nov 2003 15:17:55 +0100

Chris,

authmeth 7.1 (Simple Authentication) says:

   LDAP implementations SHOULD NOT support authentication 
   with the "simple" authentication choice unless the data on the 
   connection is protected using TLS or other data confidentiality and 
   data integrity protection. 

Are you saying this is insufficient?  How about just adding '...and
servers MUST support a configuration which rejects "simple"
authentication unless such protection is in place.'

Or maybe that should be 'MUST by default reject...'.

-- 
Hallvard

---

From: Chris Newman <[email-masked]>
Date: Wed, 12 Nov 2003 09:40:10 -0600

Hallvard B Furuseth wrote on 11/12/03 15:17 +0100:
> Are you saying this is insufficient?

Yes, that is insufficient.  That is equivalent to the initial text we had in
IMAP which was rejected by the security ADs.  Granted it went through when Jeff
was still an AD so it might slip through with today's security ADs, but I do
think the compromise text is actually an improvement.  And I'd rather have this
draft sail through quickly than get stuck with a discuss.

> How about just adding '...and

Either of these is acceptable if expressed with sufficient precision.

The requirement has to apply to all plain password mechanisms including simple
bind, SASL PLAIN and any other plain-password-based SASL mechanism.  And a bit
more detail about what sort of protection is needed.

                - Chris