Subject: Re: dITStructureRules

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 24 Feb 2004 09:59:39 -0700

It would be interesting to know what some X.500 vendors currently do.
This seems to beg for some kind of 'ambiguousStructuralRule' error.
 
Jim

>>> "Steve McLain" <[email-masked]> 2/22/04 8:28:10 PM >>>

What is the desired/proper behavior if when adding a new entry, there
are two or more possible dITStructureRules that could equally be the
governingStructureRule?  
 
For exampe:
NameForm1   mandatory cn, optional ou, namedObjectClass orgPerson 
NameForm2   mandatory cn, optional sn, namedObjectClass orgPerson
 
StructureRule5
     NameForm     nameForm1
     SuperiorRule   StructureRule4
 
StructureRule6
      NameForm     nameForm2
      SuperiorRule   StructureRule4
 
StructureRule7
       NameForm    nameform2
       SuperiorRule  Structurerule6
 
Attempting to add a orgPerson object with the rdn of "cn=ldapuser" to a
parent object that has a governingStructureRule
of StructureRule4.
 
What dITStructureRule is set for the governingStructureRule or should
this error?
I have looked through X.500 and the current model draft, I have not
found the answer yet.
 
Steve McLain

---

From: Steven Legg <[email-masked]>
Date: Wed, 25 Feb 2004 09:40:46 +1100

In the Adacel directory server we disallow ambiguous name forms in the
schema. An update that attempts to add an ambiguous name form to a
subschema subentry fails with a constraintViolation error.

To the best of my knowledge, X.500 doesn't say what to do with ambiguous
name forms. We chose to disallow them.

Regards,
Steven

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 24 Feb 2004 15:21:16 -0800

>name forms. We chose to disallow them.

I don't recall any specific statement, but doesn't X.501
contain a general statement that implies DSA are to ensure
that the subschema is, at least, self consistent.  Anyways,
folks who think some sort of specific statement is needed in
[Models] should offer text for the WG to consider.

Regards, Kurt

>Regards,
>Steven
>
>Jim Sermersheim wrote:
>>It would be interesting to know what some X.500 vendors currently do. This seems to beg for some kind of 'ambiguousStructuralRule' error.
>> 
>>Jim
>>What is the desired/proper behavior if when adding a new entry, there are two or more possible dITStructureRules that could equally be the governingStructureRule?  For exampe:
>>NameForm1   mandatory cn, optional ou, namedObjectClass orgPerson NameForm2   mandatory cn, optional sn, namedObjectClass orgPerson
>> 
>>StructureRule5
>>     NameForm     nameForm1
>>Attempting to add a orgPerson object with the rdn of "cn=ldapuser" to a parent object that has a governingStructureRule
>>of StructureRule4.
>> 
>>What dITStructureRule is set for the governingStructureRule or should this error?
>>I have looked through X.500 and the current model draft, I have not found the answer yet.
>> 
>>Steve McLain