Subject: Re: authmeth: missing protection

From: "Roger Harrison" <[email-masked]>
Date: Mon, 16 Feb 2004 02:03:56 -0700

> >>> Hallvard B Furuseth <[email-masked]> 1/3/2004 7:34:57
AM >>>
> authmeth-09 says:
> 
> > 6.2. Digest Authentication
> >
> > (...) [DIGEST-MD5]. This provides client
> > authentication with protection against passive eavesdropping
> > attacks, but does not provide protection against active
intermediary
> > attacks.
> 
> What does this mean? That DIGEST-MD5 is vulnerable to
> man-in-the-middle attacks? I didn't think it was.
 
I don't have enough experience with Digest Authentication to speak to
this. Can someone else in the WG please comment?

> 
> BTW, maybe 'simple anonymous bind' should be 'simple anonymous or
> unauthenticated bind'.
> 
> It goes on to say:
> 
> > 10.1. Start TLS Security Considerations
> 
> > The use of TLS does not provide or
> > ensure for confidentiality and/or non-repudiation of the data
housed
> > by an LDAP-based directory server.
> 
> I don't understand. I thought confidentiality was exactly one of
> the things TLS was for.
 
I think the point is that TLS protects the data in transit between
client and server, but it can't do anything to protect the data at the
point it is housed. E.g. if the data is all just in text files on the
LDAP server's file system with world-readable permissions, anyone with
access to the server's file system can see the data.

> -- 
> Hallvard

Roger

---

From: John McMeeking <[email-masked]>
Date: Mon, 16 Feb 2004 08:59:00 -0600

I can't speak to this issue specifically, but it raises a minor question:
Is there any reason to say anyhting about this in authmeth?  Weaknesses of
DIGEST-MD5 apply to any protocol that supports it, not just LDAP.  The same
thing applies to discussion of TLS ciphers that are recommended or not.  Is
it common practice to list such issues in standards for other protocols
that support such technologies?  It seems like the kind of thing that
should be said in one place, and applies to all applications of that
particular technology.

John  McMeeking

"Roger Harrison" <[email-masked]> wrote on 02/16/2004 03:03:56 AM:

>
> > >>> Hallvard B Furuseth <[email-masked]> 1/3/2004 7:34:57 AM
>>>
> > authmeth-09 says:
> >
> > > attacks, but does not provide protection against active intermediary
> > > attacks.
> >
> I don't have enough experience with Digest Authentication to speak
> to this. Can someone else in the WG please comment?
>
> >
> > > ensure for confidentiality and/or non-repudiation of the data housed
> client and server, but it can't do anything to protect the data at
> the point it is housed. E.g. if the data is all just in text files
> on the LDAP server's file system with world-readable permissions,
> anyone with access to the server's file system can see the data.
>
> >
> > --
> > Hallvard
> Roger

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 17 Feb 2004 18:00:27 -0800

At 01:03 AM 2/16/2004, Roger Harrison wrote:
>> >>> Hallvard B Furuseth <[email-masked]> 1/3/2004 7:34:57 AM >>>
>> authmeth-09 says:
>I don't have enough experience with Digest Authentication to speak to this. Can someone else in the WG please comment?

DIGEST-MD5 is prone to at least one active attack, qop substitution,
as discussed in 6.2 of RFC 2831.  The qop substitution attack can
be mitigated (as discussed in 6.2 of RFC 2831).

John asks:
>DIGEST-MD5 apply to any protocol that supports it, not just LDAP.

Given that DIGEST-MD5 is LDAP's "strong" authentication
mechanism, I believe it is appropriate for this I-D to state
that DIGEST-MD5 is prone to at least one active attack and
then refer readers to the DIGEST-MD5 specification for further
details.

>The same
>that support such technologies?

Yes, because the applicability of ciphers differ from protocol to
protocol.  We need to detail which are applicable to LDAP.

>It seems like the kind of thing that

But it doesn't necessarily apply to all applications.

Kurt