Subject: Re: Outstanding protocol issues

From: "Jim Sermersheim" <[email-masked]>
Date: Sun, 15 Feb 2004 21:35:06 -0700

The last issue I'm tracking is this from a private message from
Hallvard:
 
>> 4.7. Add Operation
>
>>    If the parent entry exists
>>    but is not in a naming context held by the server, the server
SHOULD
>>    return a referral to the server holding the parent entry.
>
>This is wrong when adding the root entry of the naming context.

I believe that the act of adding a context prefix is still under
specified in LDAP (as is the entire distributed data model). But my read
of X.511 says that the ManageDsaIT control is used to add this and other
entries that make up the information tree.
 
I think that when the IETF defines the distributed data model, and the
management of that model, this statement will still be fine (it's just a
SHOULD).
 
Maybe what I'll do is change it to say:
 
In the absence of distributed data management directives, if the parent
entry exists but is not in a naming context held by the server, the
server SHOULD return a referral to the server holding the parent entry.
 
Jim

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sun, 15 Feb 2004 21:04:50 -0800

I think it could be argued that adding of the context prefix
to DSA is an implementation-specific issue and, hence, beyond
the scope of the specification.

I think the sentence in question was meant to not that where
the entry to add is not within any context this server masters,
and the server has superior knowledge, the server may return
a referral.

I think the sentence should be replaced with something that
captures this.   Additionally, it might be appropriate to say
that establishment of a naming context and addition of an entry
at the context prefix (as well as knowledge information in
the superior context) is not standardized.

Kurt

At 08:35 PM 2/15/2004, Jim Sermersheim wrote:
>The last issue I'm tracking is this from a private message from Hallvard:
> 
>>> 4.7. Add Operation
>>
>>>    but is not in a naming context held by the server, the server SHOULD
>I believe that the act of adding a context prefix is still under specified in LDAP (as is the entire distributed data model). But my read of X.511 says that the ManageDsaIT control is used to add this and other entries that make up the information tree.
> 
>I think that when the IETF defines the distributed data model, and the management of that model, this statement will still be fine (it's just a SHOULD).
> 
>In the absence of distributed data management directives, if the parent entry exists but is not in a naming context held by the server, the server SHOULD return a referral to the server holding the parent entry.
> 
>Jim