Subject: Re: Active Directory question

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 20 Apr 2004 10:57:10 -0600

Ok, then something to the effect of your last statement will be added?

>>> "Kurt D. Zeilenga" <[email-masked]> 4/20/04 10:37:22 AM >>>
At 08:35 AM 4/20/2004, Jim Sermersheim wrote:
>If only tagging options were allowed, then I wouldn't be going on and
on about it. 

To ensure interoperability between implementations which
support different options, we've adopted two basic rules:

Servers are to treat attribute descriptions with
unrecognized options as unrecognized.

Clients may treat attribute descriptions with
unrecognized options either as unrecognized or
subtypes of the attribute type in the description.

This means that server can return subtypes indicated by
tagging options just as they would for other subtypes
(e.g., without requiring explicit naming of the subtype
in the solicitation).

However, servers cannot return options (like a range
option) which have semantics incompatible/non-interoperable
with either of the allowed client treatments. To do so
would not be truly optional.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 20 Apr 2004 10:06:32 -0700

>Ok, then something to the effect of your last statement will be added?

If properly qualified (e.g., without solicitation), I
think I could live with something to that effect.  Of course,
devil is in the details (e.g., the particular wording).

>>If only tagging options were allowed, then I wouldn't be going on and on about it. 
>