Subject: RE: Distinguished values

From: "Ramsay, Ron" <[email-masked]>
Date: Mon, 5 Apr 2004 12:32:16 +1000

Have you got lost in the semantics. The values in the AVA *are* values from the entry. Naturally, when you specify a DN, you may choose values that match, but this is a choice that you make. The meaning of the AVA is that it identifies a distinguished value.

Ron

-----Original Message-----
From: Hallvard B Furuseth [mailto:[email-masked]]
Sent: Monday, 5 April 2004 02:34
To: Ramsay, Ron
Cc: Kurt D. Zeilenga; [email-masked]
Subject: RE: Distinguished values

Ramsay, Ron writes:
> Yes, but you can't match attributes, only attribute values!
> 
>Kurt D. Zeilenga writes:
>> For instance, 2.2.1's
>>   These AVAs are chosen from the attributes of the entry.
>> could be replaced with:
>>   These AVAs are chosen to match attributes of the entry.

"These AVAs are chosen to match values from the attributes of the
entry?"

I suppose one could quibble that one can then choose RDN cn=foo to
match street:foo when there is no cn:foo in the entry, but... um.

-- 
Hallvard

---

From: Hallvard B Furuseth <[email-masked]>
Date: Wed, 7 Apr 2004 15:23:05 +0200

Ramsay, Ron writes:

> Have you got lost in the semantics. The values in the AVA *are* values
> from the entry.

Not if they are different from the values in the entry.  Unless you mean
something else with "are" than I do:-)

> Naturally, when you specify a DN, you may choose values that match,

...but are not identical, you mean?  Yes, that's my point.

> but this is a choice that you make. The meaning of the AVA is that it
> identifies a distinguished value.

Sure.

Anyway, if we are talking past each other here, maybe that means
Kurt's original suggestion is best despite your original objection.

-- 
Hallvard