Subject: models: objectClass;option

From: Hallvard B Furuseth <[email-masked]>
Date: Fri, 16 Apr 2004 16:44:29 +0200

Should [Models] say anything about objectClass attributes with
options?  I can't say it worries me, but maybe someone else cares.

That is, MAY/SHOULD/MUST [NOT] the implementation treat an object class
attribute with a recognized option as a normal object class unless the
option description says differently?

Example:
  dn: l=foo,o=mysil
  l: foo
  objectClass:         locality
  objectClass;lang-no: person
  objectClass;lang-en: country

-- 
Hallvard

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 16 Apr 2004 08:10:11 -0700

At 07:44 AM 4/16/2004, Hallvard B Furuseth wrote:
>options?

Well, should [Models] say anything about subtypes of this or
various other attributes.  I think not namely because one
could devise an extension where that made sense.  For
sense, one could have 'objectClass;auxiliary'
'objectClass;abstract' and 'objectClass;structural' which
separately listed classes of each kind, if requested
that way.  I don't see much problem with that.

I do see a problem, in general, with extensions which
are not truly optional.  While I think that's mostly a
topic for an extension guidelines document, I think it
would be wise for to make a statement in this area in
an appropriate place.
        LDAP is an extensible protocol.  Extensions are
        expected to be truly optional.

>I can't say it worries me, but maybe someone else cares.
>