Subject: Re: registration of LDAP syntax OIDs

From: "Jim Sermersheim" <[email-masked]>
Date: Fri, 22 Oct 2004 22:54:43 -0600

I favor #2 for forward compatibility.
 
There may be future features which either cause the syntax oid to be
stored or transmitted as an oid syntax. These features may wish to allow
(mainly for consistency with other uses of the oid syntax) these oid
values to be transmitted in descr form. Also, a future extension of
SyntaxDescription may specify a "NAME" field.
 
In these cases, a table containing oid/descr associations will allow
existing and future syntaxes to be assigned descr's.
 
Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 10/22/04 9:49:04 PM >>>
IANA recently asked me whether LDAP syntaxes should be
registered and, if so, how.

Given our prior decision to provide a listing of certain
other OIDs solely for informational purposes (as opposes to
ensuring value uniqueness), I think we should.

Three options come to mind on how to handling syntax
registration:

1) Add a new table specifically for Syntaxes. This
table would look basically like Descriptors table,
except the syntax name would be some string (like
the name of the associated ASN.1 data type) instead
of a descriptor.

2) Use the descriptor table to register syntaxes.
While that would imply descriptors would be assigned
to syntaxes, we'd have to be clear that these
descriptors are not used in the protocol.

3) Use the protocol mechanisms table to register syntaxes.

I prefer option 1 over 2. I dislike option 3.

Comments?

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sat, 23 Oct 2004 17:03:55 -0700

>I favor #2 for forward compatibility.

I'm thinking of inserting the something like:

  Additionally, short descriptive names may be used outside
  of the protocol to identity these and other objects.  In
  particular, short descriptive names (based on the name
  of the ASN.1 data type name) may be used to refer to LDAP              
  syntax.

as the second paragraph of Section 3.3 of [BCP64bis].
Comments?

Kurt

> 
>There may be future features which either cause the syntax oid to be stored or transmitted as an oid syntax. These features may wish to allow (mainly for consistency with other uses of the oid syntax) these oid values to be transmitted in descr form. Also, a future extension of SyntaxDescription may specify a "NAME" field.
> 
>In these cases, a table containing oid/descr associations will allow existing and future syntaxes to be assigned descr's.
> 
>Jim
>