Subject: Re: protocol-27 comments

From: "Jim Sermersheim" <[email-masked]>
Date: Fri, 29 Oct 2004 09:13:25 -0600

>>> Hallvard B Furuseth <[email-masked]> 10/29/04 6:40:42 AM
>>>
>Jim Sermersheim writes:
<snip>
>> How about: "Whether the modification was applied or not is
indeterminate..."?
>> 
>>>Also, I think s/received/sent/. This sentence is about what the
server
>>>does, not about what the client knows.
>> 
>> Well, who is making the determination? The client. And the client
receives
>> the response.
>
>Or rather it doesn't in this case. But that's implicit from the fact
>that it receives no response.
>
>My point is, we need something which says that the _server_ may
either
>perform the modification or not.

I don't think it really matters, but I can change it to:
"Whether the modification is applied or not is indeterminate if the
Modify Response is not sent or received (e.g. the LDA exchange is
terminated or the Modify Operation is abandoned)."
 
Note that the server may have sent the response, but it was never
received due to a communincations problem, so it's still indeterminate
from the client's point of view.
 
Of course this is true of any update operation, and maybe it belongs
somewhere else.
 
Jim

---

From: Hallvard B Furuseth <[email-masked]>
Date: Fri, 29 Oct 2004 19:38:06 +0200

Jim Sermersheim writes:
>> My point is, we need something which says that the _server_ may either

Yes, that's true.  We have already got section 3.1 (Operation and LDAP
Exchange Relationship), and I'd missed that 4.6 already says:

   - changes: A list of modifications to be performed on the entry. The 
     entire list of modifications MUST be performed in the order they 
     are listed as a single atomic operation.

Maybe all the text from "Due to the requirement for atomicity..." in the
section we are discussing be deleted in favor of adding this after the
text above:

     The server MUST perform either all the changes or (e.g. if the
     operation fails or is abandoned) none of the changes.

-- 
Hallvard

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 29 Oct 2004 15:02:21 -0700

The server is presumed to know whether it applied the update
or not (irregardless of whether it sent an response or not).
The text was intended to warn the client developer that
in absence of an update response, the client cannot assume
that the update was applied and cannot assume the update was
not applied.

At 08:13 AM 10/29/2004, Jim Sermersheim wrote:
>>>> Hallvard B Furuseth <[email-masked]> 10/29/04 6:40:42 AM >>>
>>Jim Sermersheim writes:
><snip>
>>> How about: "Whether the modification was applied or not is indeterminate..."?
>>> 
>>>>Also, I think s/received/sent/. This sentence is about what the server
>>> Well, who is making the determination? The client. And the client receives
>>> the response.
>>
>"Whether the modification is applied or not is indeterminate if the Modify Response is not sent or received (e.g. the LDA exchange is terminated or the Modify Operation is abandoned)."
> 
>Note that the server may have sent the response, but it was never received due to a communincations problem, so it's still indeterminate from the client's point of view.
> 
>Of course this is true of any update operation, and maybe it belongs somewhere else.
> 
>Jim