Subject: entries below subentries/aliases

From: Hallvard B Furuseth <[email-masked]>
Date: Mon, 7 Mar 2005 15:08:58 +0100

This message of 7 May 2004 has not been addressed:
http://www.openldap.org/lists/ietf-ldapbis/200405/msg00008.html

Is it legal to add a non-subentry below a subentry?
If not, what result code should be returned?

Also, what result code should be returned for an attempt
to add an entry below an alias?

-- 
Hallvard

---

From: Steven Legg <[email-masked]>
Date: Tue, 08 Mar 2005 09:58:59 +1100

Hallvard,

> Is it legal to add a non-subentry below a subentry?

It's not legal in X.500 to add an entry or subentry below a subentry.

> If not, what result code should be returned?

We return namingViolation - it seems the best fit.

> to add an entry below an alias?

namingViolation - the description of the error in X.511 explicitly mentions
this case.

Regards,
Steven