Subject: Re: Fwd: Re: draft-ietf-ldapbis-protocol - controls

From: "Jim Sermersheim" <[email-masked]>
Date: Fri, 01 Apr 2005 11:26:57 -0700

>>> "Kurt D. Zeilenga" <[email-masked]> 4/1/05 11:06:03 AM >>>
>At 08:25 AM 4/1/2005, Jim Sermersheim wrote:
>>I also think we are not actually solving the real original issues of:
>> 
>>a) how does a server fronting other servers/services advertise support for extensions
>
>A server only publishes what controls it recognizes. The
>client's expectation is that a server will ignore any control
>which the server doesn't recognize. However, the client
>should expect servers to ignore other non-critical controls,
>as the server might implement a different specification
>which considers the control not to be applicable, or
>the server is otherwise unwilling or able to perform the
>operation as extended by these controls. As you noted,
>this expectation is necessary to set if were ever going
>to support distributed directory services.
>
>The issue now is whether the client expects the server to
>return an error in this case, or does the client expect
>the server to ignore the non-critical controls in
>performing the operation. I believe it reasonable and
>quite appropriate for clients to expect servers to
>provide service when the able and willing.
>
>>b) how does that server treat non-critical controls as they are applied over the distributed servers/services
>
>The same as it would in single server system... in
>a manner consistent with the client's expectations.
>
>Or more to the point, the client's expectations are the
>same regardless of whether the service is distributed or
>not. Why do you think the server is free to ignore
>some or all of those expectations simply because it
>fronting a distributed service?

I don't. What I'm saying is there was a message from Howard which seemed to me to raise these two issues (a and b). Relaxing what "appropriate" means doesn't address either of these issues. Maybe I'm wrong and the only issue raised was that we want "appropriate for the operation" to mean more than specified as appropriate for the operation by the control spec. No response is needed though, I'm too tired of this issue to argue anymore, no one else is concerned. I'll make the change.

---

From: Howard Chu <[email-masked]>
Date: Fri, 01 Apr 2005 11:07:13 -0800

>  >>b) how does that server treat non-critical controls as they are 
> applied over the distributed servers/services
>  >
> I don't. What I'm saying is there was a message from Howard which seemed 
> to me to raise these two issues (a and b). Relaxing what "appropriate" 
> means doesn't address either of these issues. Maybe I'm wrong and the 
> only issue raised was that we want "appropriate for the operation" to 
> mean more than specified as appropriate for the operation by the control 
> spec. No response is needed though, I'm too tired of this issue to argue 
> anymore, no one else is concerned. I'll make the change.

Yes, I raised at least (a) but only to provide background for the 
current problem. I think it might be nice if we had a mechanism for 
advertising support that worked for this case, but I'm not looking to 
design it today, here in LDAPbis. Sorry if that muddied the water too much.

-- 
   -- Howard Chu
   Chief Architect, Symas Corp.       Director, Highland Sun
   http://www.symas.com               http://highlandsun.com/hyc
   Symas: Premier OpenSource Development and Support

---

From: Howard Chu <[email-masked]>
Date: Fri, 15 Apr 2005 13:00:23 -0700

> anymore, no one else is concerned. I'll make the change.

Since the Last Call just went out for draft 30, I just wanted to check 
the status of this change.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 15 Apr 2005 18:59:24 -0700

At 01:00 PM 4/15/2005, Howard Chu wrote:
>Since the Last Call just went out for draft 30, I just wanted to check the status of this change.

There are a number of issues, including the above, raised
since we progressed -30 which will need to be addressed prior
to publication as an RFC.   I'll ask Jim to post a summary
of changes he thinks are supported by WG consensus for
brief discussions, then I'll revise the summary based on
those discussions and forward it to the IESG.   Individuals
are, of course, free to comment separately (before and/or
after) I forward the summary to the IESG.

Kurt, as LDAPBIS co-chair