Subject: Re: Draft-ietf-ldapext-ldap-java-api-07.txt - syntaxes

From: "Steve Sonntag" <[email-masked]>
Date: Fri, 08 Oct 1999 10:01:49 -0600

I didn't understand your second answer.  I wasn't implying that getSyntax (class LDAPAttributeSchema) had a argument of LDAPAttributeSchema, but just that it is a method of LDAPAttributeSchema.  Bad notation on my part.

The thing that prompted the question in the firstplace is that the getSyntax function in both cases returns an int. and I don't see way to correlate the return values cis, ces, binary, int,telephone, or dn to an int. What is returned if the syntax class isn't one of these?

------------------------
Steve Sonntag
Novell Directory Services
+1 801 861 7097

>>> Rob Weltman <[email-masked]> 07-Oct-99 4:19:58 PM >>>
Rob Weltman wrote:

> Steve Sonntag wrote:
>
> > from the .07 draft
> >
> > > 5.2.2 getSyntax (class LDAPAttributeSchema)
> > > Returns the type of the attribute - one of cis, ces, binary, int,telephone, or dn.
> > > 5.14.3 getSyntax (class LDAPMatchingRuleSchema)
> > > Returns the type of the matching rule - one of cis, ces, binary, int, telephone, or dn.
> >
> > Should these really say something like
> >
> > Returns the syntax of the xxxx as defined in [2]
>
> Yes.

  Or rather, no! That would break backwards compatibility. It should be

getSyntaxString(class LDAPAttributeSchema)
getSyntaxString(class LDAPMatchingRuleSchema)

Rob

>
>
> Rob
>
> >
> >
> > ------------------------
> > Steve Sonntag
> > Novell Directory Services
> > +1 801 861 7097

---

From: Chris Tomlinson <[email-masked]>
Date: Fri, 08 Oct 1999 12:05:45 -0500

The intention is that the method getSyntax() will be dropped from the spec and the method getSyntaxString() will be added. In each case the result is a string representation of the OID of the syntax for the attribute.

ciao,
Christine Tomlinson

---

From: Mark Wahl <[email-masked]>
Date: Fri, 08 Oct 1999 12:27:43 -0500

> The thing that prompted the question in the firstplace is that the getSyntax 
> function in both cases returns an int. and I don't see way to correlate the 
> return values cis, ces, binary, int,telephone, or dn to an int. What is 
> returned if the syntax class isn't one of these?

The cis/ces/binary are older proprietary implementation specific notations that
are replaced by functions which return in a string form the OIDs of the 
syntaxes.

Mark Wahl, Directory Product Architect
Innosoft International, Inc.