Subject: draft-...-java-api-07 - LDAPConnection.getAuthenticationPassword()

From: "Steve Sonntag" <[email-masked]>
Date: Mon, 11 Oct 1999 15:05:57 -0600

From draft-...-api-07

> 5.6.5 getAuthenticationPassword> >    public String getAuthenticationPassword()> >    Returns the password used for simple authentication by this object.>   null is returned if no authentication has been performed.

Should there be a behavior defined when authentication is not simple?

------------------------
Steve Sonntag
Novell Directory Services
+1 801 861 7097

---

From: [email-masked] (Rob Weltman)
Date: Mon, 11 Oct 1999 16:11:03 -0700

> Should there be a behavior defined when authentication is not simple?

  How about returning null?

  Maybe there is a need for a method to determine the type of authentication in effect?

Rob

---

From: [email-masked] (Mark C Smith)
Date: Mon, 11 Oct 1999 19:39:29 -0400

> authentication in effect?

That sounds useful to me.

-- 
Mark Smith
iPlanet Directory Architect / Sun-Netscape Alliance
My words are my own, not my employer's.   Got LDAP?