Subject: Draft-ietf-ldapext-ldap-java-api-07.txt - syntaxes

From: "Steve Sonntag" <[email-masked]>
Date: Thu, 07 Oct 1999 16:05:36 -0600

from the .07 draft

> 5.2.2 getSyntax (class LDAPAttributeSchema)
> Returns the type of the attribute - one of cis, ces, binary, int,telephone, or dn.
> 5.14.3 getSyntax (class LDAPMatchingRuleSchema)
> Returns the type of the matching rule - one of cis, ces, binary, int, telephone, or dn.

Should these really say something like

Returns the syntax of the xxxx as defined in [2]

------------------------
Steve Sonntag
Novell Directory Services
+1 801 861 7097

---

From: [email-masked] (Rob Weltman)
Date: Thu, 07 Oct 1999 15:18:24 -0700

> Returns the syntax of the xxxx as defined in [2]

Yes.

Rob

---

From: [email-masked] (Rob Weltman)
Date: Thu, 07 Oct 1999 15:19:58 -0700

> > Returns the syntax of the xxxx as defined in [2]

  Or rather, no! That would break backwards compatibility. It should be

getSyntaxString(class LDAPAttributeSchema)
getSyntaxString(class LDAPMatchingRuleSchema)

Rob