Subject: draft-ietf-ldapext-ldap-java-api-07 modify schema

From: "Steve Sonntag" <[email-masked]>
Date: Thu, 07 Oct 1999 15:01:12 -0600

I am having trouble inderstanding modify method (5.22.12) in the abstract class LDAPSchemaElement.

The text from the draft with my questions follow:

> 5.22.12 modify> >    public void modify(LDAPConnection ld>                       LDAPAttributeSchema newValue) throws LDAPException> 
Why are we passing the parameter newValue as a LDAPAttributeSchema type.  LDAPAttributeSchema is a class that implements class LDAPSchemaElement (this class).  Should this parameter be type LDAPSchemaElement?
>    public void modify(LDAPConnection ld>                       LDAPAttributeSchema newValue,>                       String dn) throws LDAPException> >    Replace a single value of the schema element definition in the>    schema. An exception is thrown if the definition can't be modified.> 
I don't understand what the modify call does.  Are we changing the value of single a qualifier here or something else?  If sq qualifier, how is it determined which one is changed?  If using LDAPSchemaElement as the parameter, are all qualifiers with values in the class designated by "newValue" used to change to the designated LDAPSchemaElement?  Only the non-standard qualifiers can be set to a value using setQualifier() so this would modify only not-standard qualifiers.  Enough rambling - I'm lost on this one.

>    Parameters are:> >       ld             An open connection to a Directory Server.>                       Typically the connection must have been>                       authenticated to modify a schema definition.> >       newValue       The new schema element value.> >       dn             Entry at which to determine the SubschemaSubentry>                       to store the schema change in.

------------------------
Steve Sonntag
Novell Directory Services
+1 801 861 7097

---

From: [email-masked] (Rob Weltman)
Date: Thu, 07 Oct 1999 15:11:57 -0700

> Why are we passing the parameter newValue as a LDAPAttributeSchema type.  LDAPAttributeSchema is a class that implements class LDAPSchemaElement (this class).  Should this parameter be type LDAPSch…

Yes

> I don't understand what the modify call does.  Are we changing the value of single a qualifier here or something else?  If sq qualifier, how is it determined which one is changed?  If using LDAPSch…

 It replaces the entire definition with the new one.

Rob