Subject: Use of criticality in dupent-04

From: "David Chadwick" <[email-masked]>
Date: Sun, 23 Jul 2000 19:18:07 +0100

Jim

In your ID you mention the use of the criticality field in a control 
response. e.g    criticality is FALSE (MAY be absent). 

In fact, RFC2251 says nothing about the use of the criticality field in a 
response. The functionality has been lifted from X.500(93) and criticality 
only has meaning in a request sent to a server. I suggest you remove the text 
about criticality in a response.

David
***************************************************

David Chadwick
IS Institute, University of Salford, Salford M5 4WT
Tel +44 161 295 5351  Fax +44 161 745 8169
Mobile +44 790 167 0359
Email [email-masked]
Home Page  http://www.salford.ac.uk/its024/chadwick.htm
Understanding X.500  http://www.salford.ac.uk/its024/X500.htm
X.500/LDAP Seminars http://www.salford.ac.uk/its024/seminars.htm
Entrust key validation string MLJ9-DU5T-HV8J

***************************************************

---

From: Bruce Greenblatt <[email-masked]>
Date: Fri, 28 Jul 2000 23:43:07 -0700

At 04:50 PM 7/28/2000 -0400, Mircea Pana wrote:
>I'd say that if a response operation has a control and the client does not
understand it  then: 
>a) if the control is critical then the client SHOULD NOT make use of this
response or 
>(obviously) the associated control 
>

But the client already has the whole response.  What does it mean to "not
make use of the control"?  Aren't we only concerned with across the wire
behavior?  This appears to be an unenforceable mandate...
==============================================
Bruce Greenblatt, Ph. D.
Directory Tools and Application Services, Inc.
http://www.directory-applications.com
See my new Book on Internet Directories:
http://www.phptr.com/ptrbooks/ptr_0139744525.html

---

From: "Jim Sermersheim" <[email-masked]>
Date: Sat, 29 Jul 2000 15:20:21 -0600

I'm changing the text of the dupent draft to read "The criticality is ignored".

Jim

>>> "David Chadwick" <[email-masked]> 7/28/00 12:07:56 PM >>>
Date forwarded: 	Wed, 26 Jul 2000 00:11:06 -0700 (PDT)
Date sent:      	Wed, 26 Jul 2000 01:09:47 -0600
From:           	"Jim Sermersheim" <[email-masked]>
To:             	<[email-masked]>, <[email-masked]>
Subject:        	Re: Use of criticality in dupent-04
Forwarded by:   	[email-masked] 

> I wouldn't mind removing this, but... 2251 is ambiguous in this area.
> If 2251 were to state that the criticality field is only valid and
> checked in requests, and ignored for responses, I'd feel more
> comfortable. Note also that there are a number of other drafts that
> have the same language (see SSS and VLV).

Yep - they are wrong as well. Seems like you all copied from each 
other

David

David Chadwick

---

From: "David Chadwick" <[email-masked]>
Date: Sun, 30 Jul 2000 13:16:58 +0100

Date sent:      	Sat, 29 Jul 2000 15:20:21 -0600
From:           	"Jim Sermersheim" <[email-masked]>
To:             	<[email-masked]>,<[email-masked]>
Subject:        	Re: Use of criticality in dupent-04

> I'm changing the text of the dupent draft to read "The criticality is
thanks
David

David Chadwick