Subject: attribute type inheritence..

From: sanjay jain <[email-masked]>
Date: Thu, 13 Jul 2000 10:48:13 -0700

Could somebody please clarify if any or all of

SINGLE-VALUE/MULT-VALUE, COLLECTIVE/

non-COLLECTIVE and NO-USER-MODIFICATION/

USER-MODIFICATION specs are inherited while defining

a new attribute type as a subtype of another attribute.

Its not clear to me either from RFC 2252 or X.501 (1993)

Section 12.4.2.

thanks

sanjay

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 13 Jul 2000 11:14:12 -0700

>Its not clear to me either from RFC 2252 or X.501 (1993) 

X.501 could be clarified a bit in this area.

I would think they should be inherited if not explicitly
specified.

foo;lang-en should be X if foo is X

(where X is any of the above characteristics)

I would also think some restrictions upon changes are likely
appropriate.  I don't think it makes much sense to have a
non-collective subtype of a collective attribute.