Subject: a compare operation question ...

From: sanjay jain <[email-masked]>
Date: Thu, 18 Jan 2001 18:02:48 -0800

If the attribute used in the AVA in a compare operation

does not have an equality matching rule then is the compare

result FALSE (similar to search filter semantics) or is it

an error case ?

thanks

sanjay

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 18 Jan 2001 18:54:12 -0800

At 06:02 PM 1/18/01 -0800, sanjay jain wrote:
>result FALSE (similar to search filter semantics)

A search filter in this case would actually be Undefined.
While search does not return entries where the filter
evaluates to Undefined, compare returns true iff the
assertion is true, false iff false, and an error if the
assertion cannot be evaluated/reported for any reason.

>or is it 

It's an error case, specifically inappropriateMatching.

Kurt