Subject: LDAP Enhancement Style Guide

From: Bruce Greenblatt <[email-masked]>
Date: Fri, 30 Mar 2001 16:51:21 -0800

I have been requested to publish an update of this draft.  So, attached is 
an update of my "LDAP Enhancement Style Guide" internet draft.  Please 
publish it as an update to draft-greenblatt-ldapextstyle-00.txt.  Several 
comments were received on the previous edition, and have been 
incorporated.  Many thanks to those who responded, especially Kurt Z!  Thanks,

Bruce Greenblatt

==============================================
Bruce Greenblatt, Ph. D.
Directory Tools and Application Services, Inc.
http://www.directory-applications.com

---

From: Rob Weltman <[email-masked]>
Date: Sat, 31 Mar 2001 13:56:27 -0800

> incorporated.  Many thanks to those who responded, especially Kurt Z!  Thanks,

  Interesting about control extensibility. My first draft on the proxy auth control didn't include extensibility hooks. It only specified the fields required by the control as conceived. A couple of people suggested that perhaps in the future it could be extended to passing other credential fields, so I changed its value contents to a SEQUENCE in the second revision. Then other people (well-known within LDAPEXT) said no, that's wrong. An extension should result in a new control, rather than additional fields in an existing control. So a subsequent revision reverted to just specifying a single non-extensible credentials field.

  Your draft says:

"The definition of a control SHOULD be defined in such a manner that 
it is extensible.  For extensibility, extra binary fields SHOULD be 
built into the definition.  In ASN.1, use of a SEQUENCE is helpful."

  Has there been a change in the opinion generally among the LDAP luminaries on extensibility in controls, or are the opinions strongly divergent?

Rob

>                                                   ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>                          Name: ldapstyleguide.out
>    ldapstyleguide.out    Type: Plain Text (text/plain)
>                      Encoding: base64