Subject: imperatives (Was: WG last call on the Java API)

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 13 Mar 2001 16:14:48 -0800

Why are RFC 2119 imperatives not used?

Kurt

---

From: Rob Weltman <[email-masked]>
Date: Wed, 14 Mar 2001 08:56:14 -0800

> Why are RFC 2119 imperatives not used?

  Aren't they?

"Implementations of the API MUST ensure that the LDAPConnection class 
is thread-safe. Other classes and methods MAY be thread-safe and the 
implementor MUST indicate which classes and methods are thread-safe."

  I guess there are instances where the MUST/MAY/SHOULD words are not in all caps, but the usage is as prescribed by RFC 2119 as far as I know.

Rob