Subject: Encoding for server side sorting and virtual list view

From: "John Liang" <[email-masked]>
Date: Wed, 11 Apr 2001 23:20:43 -0400

HI there,

For RFC2891(server side sorting) and the draft of Virutal
List View, Do both client requests of these two controls 
require DER encoding(Distinguished Encoding Rules)? 
Is a BER encoded request also acceptable at this case?

If only DER is allowed, then for SortKeyList in Server Side
Sorting, the tag of "orderingRule [0] MatchingRuleId OPTIONAL"
should be 0x80 or 0xA0?

Same question for VirtualListViewRequest, the tag of 
 CHOICE {
	byoffset [0] SEQUENCE {
	  offset       INTEGER (0 .. maxInt)
	  contentCount INTEGER (0 .. maxInt)
should be 0x80 or 0xA0?

The Netscape Java API uses 0x80 for Server Side Sorting 
and 0xA0 for Virtual List View? Any reson for the difference?

Thanks,
--
John Liang

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 11 Apr 2001 20:38:36 -0700

>Is a BER encoded request also acceptable at this case?

Actually, I would suggest they be BER encoded per RFC 2251, 5.1.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 12 Apr 2001 07:38:39 -0700

>Sorting, the tag of "orderingRule [0] MatchingRuleId OPTIONAL"

They 0x80 and 0xA0 difference indices the kind of data
type being encoded.  0x80 indicates a PRIMITIVE data type
encoding while 0xA0 indicates a CONSTRUCTED data type
encoding.  Both are context specific, zero valued tags.

MatchingRuleId is an OCTET STRING which is a PRIMITIVE
data type while byoffset is a SEQUENCE which is a
CONSTRUCTED data type. 

The following page provide a number of good links to
ASN.1 resources:
  http://www.cs.columbia.edu/~hgs/internet/asn.1.html

Kurt