Subject: java getAuthenticationMethod

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 03 Apr 2001 16:40:27 -0700

This is described as:

>4.6.14 getAuthenticationMethod 
>    
>   public String getAuthenticationMethod() 
>    
>   Returns the method used to authenticate the connection. The return 
>   value is one of the following: 
>    
>      "none"         If the connection is not authenticated 
>       
>      "simple"       If simple authentication was used, also if a null 
>                      or empty authentication DN was specified 
>       
>      "sasl"         If a SASL mechanism was used to authenticate 4.6.14 

I'm a bit confused by the "also if a null or empty authentication
DN was specified" clause upon "simple".  An empty bind name in
simple bind may be used for anonymous authentication.  I assume
it wasn't meant to encompass SASL bind operations where the bind
name was empty.

Hence, I assume, "simple" implies:
	The current authentication state was established by
	the successful completion of simple bind (including
	anonymous, unauthenticated, or authenticated).

and "sasl":
	The current authentication state was established by
	the successful completion of a sasl bind.

and "none":
	The current authentication state has not been established
	by use of the bind operation.  This is the initial state
	upon connect().  The issuing of any bind request also
	returns the method associated with the connection to bind.

Also, in regards to getAuthenticationDN(), after rereading the
I-D, I assume it just returns whatever DN was passed into a bind()
method and used as the bind name during the authentication.

That is:
   public String getAuthenticationDN()

   Returns the distinguished name (DN) used as the bind name
   during the last successful bind operation.

---

From: Rob Weltman <[email-masked]>
Date: Wed, 04 Apr 2001 09:04:48 -0700

>    during the last successful bind operation.

  Yes

Rob