Subject: PSearch / LCUP moving base

From: "Jim Sermersheim" <[email-masked]>
Date: Sat, 28 Apr 2001 01:24:32 -0600

If the search base of a persistent search (or LCUP search) is moved or deleted, what is the expected behavior? I assume the event is sent to the client, then the operation fails with a noSuchObject, as there is no longer a search base.

Jim

---

From: [email-masked] (Mark C Smith)
Date: Mon, 30 Apr 2001 15:08:05 -0400

Jim Sermersheim wrote:
> 
> If the search base of a persistent search (or LCUP search) is moved or deleted,
> what is the expected behavior? I assume the event is sent to the client, then
> the operation fails with a noSuchObject, as there is no longer a search base.

As far as I know the behavior in this situation is undefined (which is
to say it is implementation dependent).  We should address this in the
LCUP specification.  Note that we also need to consider what happens if
an ancestor of the LCUP search base is renamed (I believe you or someone
else raised that issue earlier).

-- 
Mark Smith
Netscape