Subject: LDAP Result Codes

From: "Karen Gdaniec" <[email-masked]>
Date: Fri, 8 Jun 2001 16:12:38 -0400

Folks,
We have been looking at the expired result codes draft,
draft-just-ldapv3-rescodes-02.txt, which someone on this list indicated
would be "folded into" an updated RFC 2251 sometime.

We have a question regarding the result code LDAP_OPERATIONS_ERROR.  Our
current server support uses this return code to indicate that an internal
server error occurred while handling the request.  This differs vastly from
the definition in the draft, which indicates this return code should only
be returned if a bind is required prior to some operation and the bind was
not performed.

We have searched the draft and found no other result code that seems to
satisfy our need for an "internal server error".  We tend to try to avoid
using LDAP_OTHER because it is so ambiguous.

What is the intent of LDAP_OPERATIONS_ERROR?  What result code should be
used for internal problems at the server?  Does another result code need to
be defined?

Thanks in advance,

Karen

Internet: [email-masked]
Internal: Karen Gdaniec/Endicott/IBM@IBMUS or
                 IBMUSM10(KGDANIEC)
phone: 607.752.1075   tie-line: 8/852-1075
fax: 607.752.3681

---

From: Bruce Greenblatt <[email-masked]>
Date: Sun, 10 Jun 2001 14:49:10 -0700

In looking back at RFC 2251, I see that it indicates that in the case of a 
Bind, RFC specifically states in clause 4.2.3 that the server returns 
operationsError in the case that: "server encountered an internal 
error".  It doesn't state this any place else, but one could logically 
deduce that any time that the server encounters an internal error that an 
operationsError can be returned, irrespective of which LDAP operation is 
being implemented.  So, I think that your interpretation is correct, and 
the result codes draft is in error.

Bruce Greenblatt

>phone: 607.752.1075   tie-line: 8/852-1075

==============================================
Bruce Greenblatt, Ph. D.
Directory Tools and Application Services, Inc.
http://www.directory-applications.com

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sun, 10 Jun 2001 22:29:19 -0700

At 02:49 PM 6/10/2001, Bruce Greenblatt wrote:
>In looking back at RFC 2251, I see that it indicates that in the case of a Bind, RFC specifically states in clause 4.2.3 that the server returns operationsError in the case that: "server encountered an internal error".  It doesn't state this any place else, but one could logically deduce that any time that the server encounters an internal error that an operationsError can be returned, irrespective of which LDAP operation is being implemented.  So, I think that your interpretation is correct, and the result codes draft is in error.

I believe this was discussed previously (on this list) and
likely will be discussed again (on LDAPbis list).

Basically, the folks seemed to agree that 'other' should be
used for 'internal' errors and that 'operationsError' should be
used for indicating an operation could not be processed because
some other operation was outstanding.  E.g., 'operationsError'
should be return for any operation issues during processing of
a StartTLS operation or any non-bind operation during a SASL bind.

I recommend 'other' be used to indicate internal errors.
I also recommend that no extension specifically call for
'other' to be returned in any particular exception case.
'other' should be unambiguous refer to an condition for
which there is not a more specific resultCode.

Kurt

---

From: "John Liang" <[email-masked]>
Date: Mon, 11 Jun 2001 09:53:42 -0400

Also we need a result code for Virtual List View related
control error. And if we want to change RFC 2289, Server
Side Sorting, we will need another one for SSS too.

Does anyone know when it will happen?

Thanks,
--
Xiaojun Liang

> -----Original Message-----
> From: Kurt D. Zeilenga [mailto:[email-masked]]
> Sent: Monday, June 11, 2001 1:29 AM
> To: Bruce Greenblatt
> Cc: Karen Gdaniec; [email-masked]
> Subject: Re: LDAP Result Codes
>
>
> >In looking back at RFC 2251, I see that it indicates that in the
> case of a Bind, RFC specifically states in clause 4.2.3 that the
> server returns operationsError in the case that: "server
> encountered an internal error".  It doesn't state this any place
> else, but one could logically deduce that any time that the
> server encounters an internal error that an operationsError can
> be returned, irrespective of which LDAP operation is being
> implemented.  So, I think that your interpretation is correct,
> and the result codes draft is in error.
>

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 14 Jun 2001 15:25:13 -0700

>Side Sorting, we will need another one for SSS too.

It's my understanding that only one resultCode is needed
as outlined in Michael's control error I-D. 
  draft-armijo-ldap-control-error-01.txt

Kurt