Subject: Re: [ldapext] VLV: a particular target entry

From: Roland Hedberg <[email-masked]>
Date: Tue, 1 Oct 2002 07:52:04 +0200

On Friday 27 September 2002 15:07, Mark C Smith wrote:
> John McMeeking wrote:
> > I agree with Kurt that positioning by DN would be useful, and it seems
> > simple to implement.
> > ...
>
> The real question in my mind is whether additional features like this
> should be added to the VLV protocol now. I say no, it is too late: the
> current VLV specification has been extensively reviewed and has been
> held up on a minor issue for about 2 years now. Let's publish it as a
> Proposed Standard and move on. Extensions to VLV or a VLV2 can of course
> be pursued by anyone with time and interest.

I totally agreee with this. 
This workinggroup will not make a complete remake of VLV. Anyone wanting
to do so should seriously consider forming a new working group.
If there is not consensus within this group to continue with the VLV draft 
with only minor modifications, I would propose that the group drops it and 
let the authors publish it as an individual contribution.

Please bear in mind that this group is no more, it's just formally around 
since all its drafts aren't through to RFC status yet.

-- Roland
_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 01 Oct 2002 07:10:16 -0700

>I totally agreee with this. 

Do you not see that VLV is broken without selection by DN.
That is, the VLV scroll up/down mechanism fails in the
general case, e.g. when content is unstable.

This isn't about a NEW feature.  It's about scrolling
that works.

Kurt

---

From: "David Boreham" <[email-masked]>
Date: Tue, 1 Oct 2002 07:21:41 -0700

> general case, e.g. when content is unstable.

Highly unstable content isn't within the scope of this
protocol. Directories typically don't have highly unstable
content.

> This isn't about a NEW feature.  It's about scrolling

Strangely, the existing protocol has been 'working' for
many folks for many years. AFAIK in the IETF culture,
working interoperable implementations are considered
something of an advantage vs theoretical complaints.

Kurt: do you have a counterexample ? e.g. something
you tried to implement with the current protocol but failed 
to get to work ? Tell us about it.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 01 Oct 2002 08:09:11 -0700

At 07:21 AM 2002-10-01, David Boreham wrote:
>protocol.

Note that I did not say "highly unstable".  I said "unstable".
That is, one entry add/modification/delete is sufficient
to cause this protocol to fail.

>Directories typically don't have highly unstable content.

But directories typically do change.  And any change is
sufficient to cause failure in this protocol.

>to get to work ? Tell us about it.

Based upon my operational experience with implementing similar
controls, it is obvious to me that the current protocol fails
where contain is not stable.  In particular, were DIT
modification causes the positioning of entries in the list to
shift.

Kurt