Subject: Fwd: RE: [ldapext] RE:draft-behera-ldap-password-policy-07.txt

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 03 Mar 2004 08:08:17 -0700

The original intent was that it would be returned (when requested) only
when information needed to be conveyed.
 
We can clarify if needed, but I'm interested if you see a reason to
prefer one of your other possibilities.
 
Thanks,
 
Jim

>>> [email-masked] 3/2/04 7:07:02 PM >>>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On 
>Behalf Of
>Howard Chu
>Sent: Wednesday, 3 March 2004 4:07
>To: [email-masked] 
>Subject: Re: [ldapext] RE:draft-behera-ldap-password-policy-07.txt

<snip>

>... Following
>this argument, I wouldn't even provide any special information in the
>passwordPolicyResponse control.
>

Bringing us back to the question: When is the password policy control
returned?
* Always, or
* Every time important information needs to be conveyed, or
* Only for specific operations as stated in section 5.2
* Only for specific operations as stated in section 5.2 and important
information must be conveyed, or
* When the operation has succeeded/failed due to the password policy
regardless of the operation and whether we have important information
to
convey.

(The above list is based on the fact that the client has provided a
request
control)

Cheers,
Andrew Sciberras.

_______________________________________________
Ldapext mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Andrew Sciberras" <[email-masked]>
Date: Thu, 4 Mar 2004 12:49:54 +1100

G'Day

Since the next revision of the draft will indicate the servers should
include the control in the 'SupportedControls' attribute, I can respect the
fact the control should only be returned (when requested) to convey
important information.

That being said, the draft is counter to this by returning controls that
only contain an empty sequence (E.g. Bind and Compare).
Some may also interpret section to 5.2 to suggest that the control is always
returned (when requested) for specific operations.

Cheers,
Andrew Sciberras