Subject: [ldapext] Searchable distinguishedValue operational attribute

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 26 Jul 2004 14:19:34 -0600

Do any LDAP servers support a searchable attribute which matches on (one
or more of) an entry's RDN values? This would allow a search like
(distinguishedValue=abc) to match for all entries that have abc as a
distinguished value (i.e. dc=abc,dc=com. or cn=xyz+ou=abc,o=acme)

We're receiving pressure to support such a thing, and are interested in
finding out if there is already a precedent.

Thanks,
Jim

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 28 Jul 2004 08:14:46 -0700

>distinguished value (i.e. dc=abc,dc=com. or cn=xyz+ou=abc,o=acme)

I believe you should be able to use the componentFilterMatch rule,
in combination with the entryDN operational attribute (or other
attribute which holds the entry's DN) to accomplish such matching.

Kurt

---

From: Steven Legg <[email-masked]>
Date: Thu, 29 Jul 2004 12:04:09 +1000

> attribute which holds the entry's DN) to accomplish such matching.

Yes, that will work. The search filter would look something like this
(the identified component is a DirectoryString value):

(entryDN:componentFilterMatch:=
     item:{ component "-1.*.value.(dc)",
            rule caseIgnoreMatch,
            value "abc" })

     or

(entryDN:componentFilterMatch:=
     item:{ component "-1.*.value.(ou)",
            rule caseIgnoreMatch,
            value "abc" })

Note that a specific attribute type needs to be nominated.

The following would also work (the identified component is an
AttributeTypeAndValue):

(entryDN:componentFilterMatch:=
     item:{ component "-1.*",
            rule directoryComponentsMatch,
            value { type dc, value "abc" }})

Regards,
Steven