Subject: Re: [ldapext] Searchable distinguishedValue operational attribute

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 28 Jul 2004 22:47:50 -0600

Interesting.

The requirement for this is that one wants to find entries named by abc
regardless of type (the type is unknown). I haven't digested the RFC
yet. Is there a way to omit the type, or to specify 'any' type?

Jim

>>> Steven Legg <[email-masked]> 7/28/04 8:04:09 PM >>>

Kurt D. Zeilenga wrote:
> At 01:19 PM 7/26/2004, Jim Sermersheim wrote:
> 
>>Do any LDAP servers support a searchable attribute which matches on
(one
>>or more of) an entry's RDN values? This would allow a search like
>>(distinguishedValue=abc) to match for all entries that have abc as a
>>distinguished value (i.e. dc=abc,dc=com. or cn=xyz+ou=abc,o=acme)
> 
> 
> I believe you should be able to use the componentFilterMatch rule,
> in combination with the entryDN operational attribute (or other
> attribute which holds the entry's DN) to accomplish such matching.

Yes, that will work. The search filter would look something like this
(the identified component is a DirectoryString value):

(entryDN:componentFilterMatch:=
     item:{ component "-1.*.value.(dc)",
            rule caseIgnoreMatch,
            value "abc" })

     or

(entryDN:componentFilterMatch:=
     item:{ component "-1.*.value.(ou)",
            rule caseIgnoreMatch,
            value "abc" })

Note that a specific attribute type needs to be nominated.

The following would also work (the identified component is an
AttributeTypeAndValue):

(entryDN:componentFilterMatch:=
     item:{ component "-1.*",
            rule directoryComponentsMatch,
            value { type dc, value "abc" }})

Regards,
Steven

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: Steven Legg <[email-masked]>
Date: Thu, 29 Jul 2004 17:01:41 +1000

Jim,

> yet. Is there a way to omit the type, or to specify 'any' type?

Not with component matching.

Your other option is to add a BOOLEAN flag to MatchingRuleAssertion,
say distinguishedValuesOnly, to allow an extensible match to be
restricted to only distinguished values in an entry.

The attribute type can be omitted in a MatchingRuleAssertion if
a matching rule is specified (e.g. caseIgnoreMatch).

Regards,
Steven