Subject: [ldapext] Re: I-D ACTION:draft-sciberras-xed-eldif-03.txt

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 21 Oct 2004 17:08:02 -0700

I really hate the empty line caused by the trailing EOL
of the XML value.  I think this will lead to confusion.
I suggest replacing xml-value-spec with:

   xml-value-spec    = ">:" FILL SEP
                RANGLE XML-STRING RANGLE SEP
                       ; See section 3.4 for details

to avoid this problem.  For the example, that would produce

        postalAddress;transfer-rxer>:
      ><?xml version='1.0'?>
      ><value>
      > <item>250 Bay Street</item>
      > <item>Brighton Victoria 3186</item>
      > <item>Australia</item>
      ></value>
        >
        sn: Sciberras

And for a like XML value which didn't have a trailing EOL character,

        postalAddress;transfer-rxer>:
      ><?xml version='1.0'?>
      ><value>
      > <item>250 Bay Street</item>
      > <item>Brighton Victoria 3186</item>
      > <item>Australia</item>
      ></value>>
        sn: Sciberras

While this is also a bit of an oddity, I think it occur less
often and not result in as many problems as empty line would.

At 12:49 PM 10/21/2004, [email-masked] wrote:
>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>        Title           : The Extended LDAP Data Interchange Format (ELDIF)
>        Author(s)       : A. Sciberras, S. Legg
>        Filename        : draft-sciberras-xed-eldif-03.txt
>        Pages           : 9
>        Date            : 2004-10-21
>        
>This document extends the Lightweight Directory Access Protocol
>(LDAP) Data Interchange Format (LDIF) to permit Extensible Markup
>Language (XML) encoded directory attribute values to be represented
>in a human readable format, instead of Base64.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-sciberras-xed-eldif-03.txt
>
>To remove yourself from the I-D Announcement list, send a message to 
>[email-masked] with the word unsubscribe in the body of the message.  
>You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
>to change your subscription settings.
>
>
>Internet-Drafts are also available by anonymous FTP. Login with the username
>"anonymous" and a password of your e-mail address. After logging in,
>type "cd internet-drafts" and then
>        "get draft-sciberras-xed-eldif-03.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html 
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>        [email-masked].
>In the body type:
>        "FILE /internet-drafts/draft-sciberras-xed-eldif-03.txt".
>        
>NOTE:   The mail server at ietf.org can return the document in
>        MIME-encoded form by using the "mpack" utility.  To use this
>        feature, insert the command "ENCODING mime" before the "FILE"
>        command.  To decode the response(s), you will need "munpack" or
>        a MIME-compliant mail reader.  Different MIME-compliant mail readers
>        exhibit different behavior, especially when dealing with
>        "multipart" MIME messages (i.e. documents which have been split
>        up into multiple messages), so check your local documentation on
>        how to manipulate these messages.
>                
>                
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>Content-Type: text/plain
>Content-ID: <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-sciberras-xed-eldif-03.txt
>
><ftp://ftp.ietf.org/internet-drafts/draft-sciberras-xed-eldif-03.txt>
>_______________________________________________
>I-D-Announce mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: Andrew Sciberras <[email-masked]>
Date: Fri, 22 Oct 2004 11:57:26 +1000

Hmm.... the problem actually lies in my example.

Following the text within section 3.4, even if the last character of the 
XML data is a line separator then a RANGLE character should follow it.

Using your examples, without changing my ABNF for xml-value-spec, the 
output should actually look like this:

  sn: Sciberras

  sn: Sciberras

I will make changes to the draft to correct this mistake and provide 
some addition clarification as to when RANGLE characters are inserted 
into the XML Value.

Thanks for the comments,
_________________________________________
Andrew Sciberras
eB2Bcom - Software Engineer