Subject: RE: [ldapext] Re: Gen-Art Review: <draft-zeilenga-ldap-incr-01.txt>

From: "Paul Leach" <[email-masked]>
Date: Thu, 7 Jul 2005 01:43:20 -0700

To really motivate it, you need to explain why it won't work to read the
old value, add one, and write back the new value.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Kurt D. Zeilenga
Sent: Thursday, July 07, 2005 1:26 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [ldapext] Re: Gen-Art Review:
<draft-zeilenga-ldap-incr-01.txt>

Adding to following sentence to the end of the first paragraph
would clarify that the first paragraph is merely providing
background information as to why this extension was developed.

  To avoid the problems of this approach, an extension
  is needed that allows a client to increment attribute values without

  any requirement for that client to have prior knowledge of the
  attribute values.

comments?

Kurt

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: [email-masked]
Date: Fri, 8 Jul 2005 10:41:34 +0300

That's fine by me then.

thanks,
John

> From: ext Brian E Carpenter [mailto:[email-masked]]
> Sent: 08 July, 2005 10:31
> To: Loughney John (Nokia-NRC/Helsinki)
> Cc: Ted Hardie; [email-masked]; [email-masked]
> Subject: Re: Gen-Art Review: <draft-zeilenga-ldap-incr-01.txt>
> 
> 
> [email-masked] wrote:
> ...
> > 
> > One line summary: This document is not ready for 
> publication as a Informational
> > publication.  More text on how to deal with race conditions 
> need to be added.
> 
> John, as it happens, I queried Kurt about atomicity and was satisfied by his
> response that LDAP intrinsically provides the required atomicity. That is kind
> of basic in transaction processing, so I don't think it needs spelling out
> in terms of race conditions.
> 
>     Brian
> 
>