Subject: [ldapext] Re: I-D ACTION:draft-zeilenga-ldap-dontusecopy-01.txt

From: Andrew Sciberras <[email-masked]>
Date: Wed, 20 Jul 2005 16:13:08 +1000

Hi Kurt,

>  The control is appropriate for both LDAP interrogation operations,
>  including Compare and Search operations [Protocol].  
>  
>
I would probably replace the word 'both' with 'all' and include a little 
comment about Extended Operations. This way, Extended Operations that 
perform interrogation operations will also be deemed appropriate to have 
a dontUseCopy control attached.

>When the control is attached to an LDAP request, the requested
>operation MUST NOT be performed on copied information.  That is, the
>requested operation MUST be performed on original information.
>  
>
With LDAP directory's that support an implementation of multi-master 
replication, do you deem both Masters as containing 'original' 
information? I think that this must be the case, in which case the word 
'original' might also be a little misleading.

Cheers,
Andrew.

[email-masked] wrote:

>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>	Title		: The LDAP Don't Use Copy Control
>	Author(s)	: K. Zeilenga
>	Filename	: draft-zeilenga-ldap-dontusecopy-01.txt
>	Pages		: 5
>	Date		: 2005-7-19
>	
>This document defines the Lightweight Directory Access Protocol (LDAP)
>  Don't Use Copy control extension which allows a client to specify that
>  copied information should not be used in providing service.  This
>  control is based upon the X.511 dontUseCopy service control option.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-zeilenga-ldap-dontusecopy-01.txt
>  
>

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 20 Jul 2005 03:47:51 +0200

At 08:13 AM 7/20/2005, Andrew Sciberras wrote:
>I would probably replace the word 'both' with 'all' and include a little comment about Extended Operations. This way, Extended Operations that perform interrogation operations will also be deemed appropriate to have a dontUseCopy control attached.
>
>
>With LDAP directory's that support an implementation of multi-master replication, do you deem both Masters as containing 'original' information? 

I assume that there must be some agreement between the client
and server that allows the server to alter the service model
to support multi-master replication (as the X.500(93) service
model clearly requires a single master for every object) and
that this agreement would be responsible for detailing whether
or not both masters are viewed as containing 'original'
information.

Specification of alternative service models, as well as mechanisms
for agreeing to an alternative service model, are well beyond
the scope of this document. 

>I think that this must be the case, in which case the word 'original' might also be a little misleading.

See X.500(93).  It uses the same terminology when detailing
the service control this control is based upon.