Subject: [ldapext] support for Assertion Control

From: Michael Ströder <[email-masked]>
Date: Wed, 13 Jan 2016 14:50:14 +0100

HI!

I need to do some interop-testing for a work-around in case an Assertion Control
[1] is sent along with modify requests. I currently only know two LDAP servers
supporting it:
OpenDJ
OpenLDAP

Any other LDAP servers supporting [1] which I should test with?
Do they have attribute 'entryDN' [2] in their entries and support for at least
EQUALITY matching?

Ciao, Michael.

[1] https://tools.ietf.org/html/rfc4528
[2] https://tools.ietf.org/html/rfc5020

---

From: "Neil A. Wilson" <[email-masked]>
Date: Wed, 13 Jan 2016 10:56:29 -0600

> Do they have attribute 'entryDN' [2] in their entries and support for at least

The UnboundID Directory Server supports both the assertion control and
the entryDN operational attribute.  And while not a "real" directory
server intended for production use (it's more intended for testing
purposes and simple interaction with small data sets), the in-memory
directory server included as part of the UnboundID LDAP SDK for Java
also supports both of these features.

> _______________________________________________
> Ldapext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ldapext
>