Subject: LDAP Replication Architecture Document.

From: "Natarajan SK" <[email-masked]>
Date: Mon, 11 Oct 1999 05:31:34 -0600

Hi, 
      In the LDAP Replication Architecture document, we specify that Fractional Replicas are to be read only. Why is this? Can't it be that these replicas also get updated (without passing a referral to the Supplier) and these changes in turn are replicated across. Is there any specific reason for not allowing these Fractional Replicas to be updated. Maybe I'm overlooking something outright obvious.

Regards,
Natarajan

S.K.Natarajan
Senior Software Engineer
Novell Software, Bangalore
E-mail [email-masked]
Ph. no. 91-80-572-1856/58 Extn. 2213
Fx 91-80-572-1870

---

From: "Ed Reed" <[email-masked]>
Date: Mon, 11 Oct 1999 06:06:25 -0600

The specific reason is that we don't know how to specify how to manage the update vector for changes made at the fractional replica.  There are ideas, but there is so little real-world experience, by any of us, with including fractional replicas which are updateable in a multi-master replica community, we chose to simplify our task by precluding them.

We will gain operational experience with them as Novell deploys support for Virtual Replicas in upcoming releases of NDS, and as other vendors do, too.

But, it's not the job of an IETF working group to speculate on what might work in their protocol designs, but rather to document what has been shown will work if done correctly.  We're not that far along in the experience curve, yet, with updateable fractional replicas.  The only operational experience we've found, to date, is for single master configurations, where read-only shadow replicas may be fractional (ala X.500 DISP).

Regards,
Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 785 0315
[email-masked]

>>> Natarajan SK 10/11/1999 05:31:34 >>>
Hi, 

Regards,
Natarajan

S.K.Natarajan
Senior Software Engineer

---

From: "Sweigert, David" <[email-masked]>
Date: Tue, 12 Oct 1999 10:51:16 -0400

I am confused.  We can this document be obtained ?

Dave Sweigert
http://www.gd-cs.com

-----Original Message-----
From: Natarajan SK [mailto:[email-masked]]
Sent: Monday, October 11, 1999 7:32 AM
To: [email-masked]; [email-masked]; Ed Reed
Subject: LDAP Replication Architecture Document.

Hi, 
      In the LDAP Replication Architecture document, we specify that
Fractional Replicas are to be read only. Why is this? Can't it be that these
replicas also get updated (without passing a referral to the Supplier) and
these changes in turn are replicated across. Is there any specific reason
for not allowing these Fractional Replicas to be updated. Maybe I'm
overlooking something outright obvious.

Regards,
Natarajan

S.K.Natarajan
Senior Software Engineer