Subject: RE: WG Last Call on URP I-D

From: "Steven Legg" <[email-masked]>
Date: Thu, 6 Sep 2001 16:52:07 +1100

Kurt,

Kurt D. Zeilenga wrote:
> I think the editors need to review the document to
> ensure all necessary normative references are in
> place.  The document appears to be dependent on
> LCUP (for entryUUID) and a variety of other LDUP
> documents but contains no reference to them.

Earlier drafts of the URP document had a reference to the LDUP
architecture draft but this was taken out because it was decided
at an ad-hoc meeting of the LDUP document editors (IIRC it was
at the Washington IETF) that the architecture draft would reference
the part specifications like URP, the model, the protocol (separate
at that time), etc, and not the other way around. I think the reasoning
was that the part specifications could then be progressed as each was
completed instead of waiting until the whole of LDUP was ready.

I can put appropriate references back in but that presumably halts
progression of the URP document until the documents it references
go through last call. I'll leave it to our working group chairs to
advise how to proceed on this issue. 

> I note
> as well that no other LDUP document formally references
> this specification.

The architecture draft, at least, was supposed to.

> 
> As such, I am unsure of the context in which this
> specification is meant to be used and hence find it
> hard to perform a complete review.
> 
> I note the only context I have from the I-D is LDAPv3
> and X.500, both which provide no support for multiple
> master replication and, hence, have no need for such
> procedures.

Which is why they don't reference the URP document :-).

The references are there because URP relies on the concepts
of entries, attributes, values, matching rules, etc.

> It seems the Abstract and Introduction
> need more work to detail the context in which this
> specification is used.

The expection was (still is ?) that the architecture draft, in its final
edit, would be providing that context.

> Kurt

Regards,
Steven

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 06 Sep 2001 19:49:36 -0700

I think that appropriate references need to be added.
One cannot implement the specification without reading LCUP
and various LDUP documents.

I also of the opinion that it would be best to progress the
complete LDUP technical specification at one time, primarily
because reviewing it in piecewise is extremely difficult.

Kurt