Subject: Question on LCUP

From: [email-masked]
Date: Fri, 21 Sep 2001 08:56:12 +0300

Hi,

I have a question on LCUP scalability.

Shall the LCUP be scalable on number of persistent search requests ?

I suppose the main use of LCUP is the following:

	The client caches a well defined subset ( like one 
	subtree ) of the directory. 

Then there is propably only one or some Persistent Searches
per client ?

But suppose the client keeps a more dynamic cache in the sense
that when the client "gets interested" in a certain entry,
the client allways makes a Persistent Search ?

Shall the LCUP scale for such situations ? The implementation
of LCUP can then not be:

	Whenever an entry is modified go through all the Searches
	and act.
	
At least an index is needed to find the relevant Searches.

Is the scalability a standardisation issue at all ? 

Jukka Aakula

---

From: [email-masked] (Rich Megginson)
Date: Fri, 21 Sep 2001 09:04:28 -0600

> Then there is propably only one or some Persistent Searches

I should think the client would only have 1 Persistent Search at a time.

> the client allways makes a Persistent Search ?

Do you mean the client makes an additional Persistent Search?  I don't think that would be necessary.  If the client somehow
becomes interested in an entry outside the scope of the current LCUP request, the client could simply close the connection and
issue another LCUP request with a wider scope.

I suppose the worst case would be that a client is interested in checking for changes in several naming contexts.  In which case,
the client would need an LCUP search for each naming context.

> Is the scalability a standardisation issue at all ?

No, I don't think so.  There are ways to efficiently index (or otherwise lookup) Searches on the server.  LCUP does not (and I do
not think it should) address implementation details.