Subject: [ledbat] fairness...

From: "Wright, Steven" <[email-masked]>
Date: Wed, 29 Jul 2009 07:36:08 -0500

Is the fairness of LEDBAT vs TCP only during steady state ?
Or is LEDBAT required to give preference to TCP transactions that do not
reach steady state  as well?
I.e. you need to look at more than just the impact on steady state TCP
throughput

regards, 
Steven Wright, MBA,PhD. 
Strategic Standards 
AT&T Network Architecture 
phone (404) 499 7030 
fax (404) 986 6141 
email [email-masked] 

*****

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from all computers. GA625

---

From: Stanislav Shalunov <[email-masked]>
Date: Mon, 10 Aug 2009 11:39:32 -0700

The Ledbat backoff starts as delay starts to climb and so before loss  
occurs. TCP backoff only happens when loss does.  This does not  
require the TCP connections to be in steady state, or ever reach it.

This is an important consideration and thanks for bringing it up. HTTP  
connections are often so short-lived they don't make it to a steady  
state.

Stanislav Shalunov

On Jul 29, 2009, at 5:36 AM, "Wright, Steven" <[email-masked]> wrote:

> Or is LEDBAT required to give preference to TCP transactions that do  
> not reach steady state  as well?
>
> I.e. you need to look at more than just the impact on steady state  
> TCP throughput
>
> regards,
> Steven Wright, MBA,PhD.
> Strategic Standards
> The information transmitted is intended only for the person or  
> entity to which it is addressed and may contain confidential,  
> proprietary, and/or privileged material. Any review, retransmission,  
> dissemination or other use of, or taking of any action in reliance  
> upon this information by persons or entities other than the intended  
> recipient is prohibited. If you received this in error, please  
> contact the sender and delete the material from all computers. GA625
>
> _______________________________________________
> ledbat mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ledbat