Subject: [ledbat] draft-ietf-ledbat-congestion-01a.txt

From: Stanislav Shalunov <[email-masked]>
Date: Mon, 22 Mar 2010 03:55:51 -0700

draft-ietf-ledbat-congestion-01 missed the submission deadline, so
we'll will be discussing tentative textual changes in the presentation
tomorrow. However, since the text does exist, I thought I'd send it to
the mailing list -- attached.

-- Stas

--
Stanislav Shalunov
BitTorrent Inc
[email-masked]

personal: http://shlang.com

---

From: Stanislav Shalunov <[email-masked]>
Date: Mon, 22 Mar 2010 14:49:35 -0700

The current draft version is now at
http://tools.ietf.org/id/draft-ietf-ledbat-congestion-01.txt

-- 
Stanislav Shalunov
BitTorrent Inc
[email-masked]

---

From: "Joerg Wagner" <[email-masked]>
Date: Tue, 23 Mar 2010 13:05:59 +0100

Hello,

I cannot follow this statement:

> However, once the initial flow yields, the late comer immediately
>   measures the true base delay and the two flows operate from the same
>   (correct) inputs.

What we observed was that the decrease of the first flow and the increase of the second one resulted in a roughly constant amount of filling state in the modem's buffer. Even if the late comer eventually takes over the whole queue it was unable to correctly measure the base delay (self-measuring problem, same reason why the base delay gets wrong after 10 minutes free of cross-traffic).

If one extends this issue to more than 2 competing LEDBAT flows it becomes rather unlikely that the late comer will measure the correct base delay during the startup phase.

Joerg

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Stanislav Shalunov
> Sent: Montag, 22. März 2010 22:50
> To: [email-masked]
> Subject: Re: [ledbat] draft-ietf-ledbat-congestion-01a.txt
> 
> _______________________________________________
> ledbat mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ledbat