Subject: [ledbat] NEW! draft-ietf-ledbat-congestion-04

From: Janardhan Iyengar <[email-masked]>
Date: Tue, 15 Mar 2011 17:53:39 -0400

Dear all,

The latest version of draft-ietf-ledbat-congestion (-04) is now available at http://datatracker.ietf.org/doc/draft-ietf-ledbat-congestion/.
Besides editorial changes (some significant) to make the language consistent and precise, specific content changes in -04 from -03 are listed below.

1.  LEDBAT now includes bytes_newly_acked as a variable that is taken into account in the cwnd computations,
   -> similar to ABC for TCP, and
   -> to reduce differences in behavior due to differences in framing.

2. off_target changed to off_target = (TARGET - queuing_delay) / TARGET
   -> This ensures that GAIN = 1 (or less) actually limits the cwnd to rampup not faster than standard TCP in congestion avoidance

3.  A LEDBAT sender clamps down its cwnd if the sender has a "data lull"--the cwnd is clamped down to flightsize ("use-it-or-lose-it").
   ->This makes sense for LEDBAT since performance is not the highest priority concern.

4. random_input() removed
   -> see discussion on the list

5. INIT_CWND and MIN_CWND params introduced, and param values finalized.
   -> see discussion in '3.5.  Parameter Values'

6. Further discussion in '5.3.  Fairness Among LEDBAT Flows' on random fluctuations in inter-packet transmission and late-comer's advantage.

We think the draft is close to getting done.  Please read the draft and send comments to the list!
(We'll let the chairs push for going towards WGLC as they see appropriate, but we would like to see it go there as quickly as it can.)

Thanks,
Jana and Mirja

-- 
Janardhan Iyengar
Assistant Professor, Computer Science
Franklin & Marshall College
http://www.fandm.edu/jiyengar

---

From: Rolf Winter <[email-masked]>
Date: Wed, 16 Mar 2011 12:43:39 +0000

Thanks Mirja and Jana,

With you two aboard, the congestion control draft is making some real progress again. WG please review the draft! We would like to last call this draft soon. Given the new content and the upcoming meeting, this will likely be sometime soon after the Prague meeting.

Best,

Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: Janardhan Iyengar [mailto:[email-masked]]
> Sent: Dienstag, 15. März 2011 22:54
> To: [email-masked]
> Cc: Mirja Kuehlewind; Rolf Winter; Murari Sridharan
> Subject: NEW! draft-ietf-ledbat-congestion-04
> 
> Dear all,
> 
> The latest version of draft-ietf-ledbat-congestion (-04) is now
> available at http://datatracker.ietf.org/doc/draft-ietf-ledbat-
> congestion/.
> Besides editorial changes (some significant) to make the language
> consistent and precise, specific content changes in -04 from -03 are
> listed below.
> 
>    -> This ensures that GAIN = 1 (or less) actually limits the cwnd to
> rampup not faster than standard TCP in congestion avoidance
> 
> 3.  A LEDBAT sender clamps down its cwnd if the sender has a "data
> lull"--the cwnd is clamped down to flightsize ("use-it-or-lose-it").
> 6. Further discussion in '5.3.  Fairness Among LEDBAT Flows' on random
> fluctuations in inter-packet transmission and late-comer's advantage.
> 
> (We'll let the chairs push for going towards WGLC as they see
> appropriate, but we would like to see it go there as quickly as it
> can.)
> 
> Thanks,
> Jana and Mirja
> 
> --
> Janardhan Iyengar