Subject: [lemonade] RE: expunged draft

From: [email-masked]
Date: Wed, 2 Feb 2005 12:44:33 -0600

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of ext Timo Sirainen
> Sent: Monday, January 31, 2005 3:52 PM
...
> 
> It shows that HIGHESTMODSEQ update is sent after EXPUNGE command. What
> about when other session did the EXPUNGE and we're seeing untagged
> EXPUNGEs? Maybe always send it after untagged expunges (and don't
> mention EXPUNGE command at all)?
...
> Maybe rename the EXPUNGED to UIDEXPUNGE or similar to make it 
> more clear
> that it's sending UIDs and not sequences?

What about something like ...

* EXPUNGE (UID N MODSEQ (MMMM))

This would disambiguate nicely ...
1) Covers unsolicited as well as untagged solicited EXPUNGE responses.
2) The parenthetical element is just a subset of a FETCH response, meaning I
see some nice code reuse potential.

Mike

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 02 Feb 2005 20:28:10 +0000

>* EXPUNGE (UID N MODSEQ (MMMM))
Dave Cridland has suggested something similar during a private conversation.

>see some nice code reuse potential.
I am not sure the parsing code is going to be as big so it can benefit 
from code reuse.

I will change the draft to have something like:

* UIDEXPUNGE 1:5,7,505 (MODSEQ MMMM)

I.e., it will contain UID set and modification sequence at the end.