Subject: RE: [lemonade] I-D ACTION:draft-ietf-lemonade-futuredelivery-02.t xt

From: "Vaudreuil, Greg M (Greg)" <[email-masked]>
Date: Wed, 21 Sep 2005 08:14:29 -0500

Can anyone on this list tell us if the mobile network (GSM and/or CDMA) provides timezone information to the handset along with local time?

Greg V.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Arnt Gulbrandsen
Sent: Wednesday, September 21, 2005 6:39 AM
To: [email-masked]
Cc: Eric Burger; Lyndon Nerenberg
Subject: Re: [lemonade] I-D
ACTION:draft-ietf-lemonade-futuredelivery-02.t xt

Lyndon Nerenberg writes:
> On Sep 19, 2005, at 8:24 PM, Eric Burger wrote:
>
>> Once that is magically done, the protocol using UTC or delta-time is
>> identical.  Pick one and only one, please.
>
> The UI implementation issues are irrelevant. What this boils down to,  
> at the protocol level, is:
>
>     Who's time do you trust? The clients or the servers?
>
> If you answer "the client" then you use deltas; If you answer "the  
> server" then you use (absolute) UTC. They aren't mutually exclusive,  
> they are complimentary.

Aren't you assuming that the client's timezone is reliable? If the 
client asks its user in local time and tells the server in UTC, it 
needs an accurate time zone.

If the timezone is wrong and the local time is right, that problem 
doesn't usually show up, so it can remain undetected for quite some 
time.

Arnt

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Anil SRIVASTAVA <[email-masked]>
Date: Wed, 21 Sep 2005 07:23:36 -0700 (Pacific Daylight Time)

Looks like the Cingular GSM network provides both time and timezone 
information.  I deliberitely changed the timezone to GMT (I am in PDT) 
on my phone and when I restarted the phone it retreived the local time 
and timezone and reset the local clock AND timezone correctly.

Anil

On 2005-09-21/08:14 [-0500], [email-masked] [Vaudreuil, Greg M (Greg)] wrote:

> 
> Can anyone on this list tell us if the mobile network (GSM and/or 
> CDMA) provides timezone information to the handset along with local 
> time?
> 
> Greg V.
> 

-- 
_______________
Anil SRIVASTAVA
[email-masked]