Subject: RE: [lemonade] RE: PIPELINING, AUTH, and CHUNKING

From: "Vaudreuil, Greg M (Greg)" <[email-masked]>
Date: Thu, 23 Feb 2006 15:51:10 -0600

So...

The big question for me is the following:

Is pipelining between transactions something that should be specified in CHUNKING or a revision to PIPELINING?  My view is that pipelining across transactions is completely orthoganal to CHUNKING, and the language in this draft should neither permit nor deny such behavior, defering to the base PIPELINING document.

If so, the only clarification here is that it is explicitly acceptable to pipeline the BDAT commands following the envelope without a synchronization.  

Reasonable?

Greg V.

-----Original Message-----
From: Dave Cridland [mailto:[email-masked]]
Sent: Thursday, February 23, 2006 2:20 PM
To: Tony Finch
Cc: Enhancements to Internet email to support diverse service
enivronments
Subject: Re: [lemonade] RE: PIPELINING, AUTH, and CHUNKING

On Thu Feb 23 19:07:04 2006, Tony Finch wrote:
> On Thu, 23 Feb 2006, Dave Cridland wrote:
> >
> > > The sender-SMTP MAY use the NOOP command to introduce a
> > > synchronization point.
> >
> > Why?
> 
> RFC 2920 says NOOP is included in the group of commands that can 
> only
> appear as the last command in a group so that it can be used as a
> synchronization point. Perhaps I'm suggesting defences against bugs 
> that
> don't exist...

I think so.

The only way that would help is if the client couldn't track 
completion of the individual commands. In which case it's really not 
going to work anyway.

Dave.
-- 
           You see things; and you say "Why?"
   But I dream things that never were; and I say "Why not?"
    - George Bernard Shaw

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 23 Feb 2006 21:55:00 +0000

>Is pipelining between transactions something that should be specified in CHUNKING or a revision to PIPELINING?  My view is that pipelining across transactions is completely orthoganal to CHUNKING, a…
Yes.

>If so, the only clarification here is that it is explicitly acceptable to pipeline the BDAT commands following the envelope without a synchronization.  
Yes.

---

From: Tony Finch <[email-masked]>
Date: Fri, 24 Feb 2006 09:56:51 +0000

On Thu, 23 Feb 2006, Vaudreuil, Greg M (Greg) wrote:
> Is pipelining between transactions something that should be specified in
> CHUNKING or a revision to PIPELINING?  My view is that pipelining across
> transactions is completely orthoganal to CHUNKING, and the language in
> this draft should neither permit nor deny such behavior, defering to the
> base PIPELINING document.

The PIPELINING spec already allows the next message envelope to be
pipelined after the previous message data, i.e. pipelining from one
transaction to the next. The only required synchronization point is
in the middle of a transaction, at DATA.

> If so, the only clarification here is that it is explicitly acceptable
> to pipeline the BDAT commands following the envelope without a
> synchronization.

I think that would have the effect I am after, since it eliminates the
remaining synchronization point.

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
LOUGH FOYLE TO CARLINGFORD LOUGH: EAST OR NORTHEAST 5 OR 6, BUT 7 SOUTH OF
BALLYQUINTIN POINT AT FIRST. RAIN THEN FAIR. GOOD, OCCASIONALLY MODERATE.
MODERATE OR ROUGH.