Subject: RE: [lemonade] Draft Liaison to OMA

From: "Stephane H. Maes" <[email-masked]>
Date: Wed, 1 Feb 2006 01:15:47 -0800

As I stated: "fixing the concerns of OMA", tehrefore ensuring no duplication etc...

This doc will explain the pieces that Lemonade profile and the items it address for MEM.

Stephane 

_____
Stephane H. Maes, PhD,
Director of Architecture, Mobile, Voice, and Communications Platforms, Oracle.
Ph: +1-203-300-7786 (mobile/SMS); Fax / Office UM: +1-650-607-6296
e-mail: [email-masked]
IM: shmaes (AIM/Y!/skype) or [email-masked] (MSN Messenger)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, February 01, 2006 1:13 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [lemonade] Draft Liaison to OMA

Hi Stephane,
while the techincal content of the draft is valid and I agree to it (well, most if it anyway), I would not go for the RFC status.
What will happen when there is an IETF mobile email AD and there is an OMA mobile email AD?
Customers will be confused which one to implement and we are going to be the ones who have to explain which one they should choose and why - this will be difficult. Also, there might be interoperability issues later on. So there should be only one AD. I do not have a preference on where the AD is, the important thing is that there is only one. If it is IETF, then the OMA AD should not be progressed any further and dropped and all future OMA specs shall reference the IETF AD, or vice versa.
This is the reason I would like to clarify the statement in the LS - I believe it is vague - we need a clear message what is going to happen.
Thank You.

Best regards: Zoltán Ördögh
E-mail: [email-masked]
Phone: +358 50 386 0566

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Stephane H. Maes
Sent: 31 January, 2006 16:49
To: [email-masked]; [email-masked]
Subject: Re: [lemonade] Draft Liaison to OMA

Zoltan, 

It seems correct to me:
1) its the LEMONADE WG view as agreed hence a ietf deaft
2) this way its is documented, visible and stored somewhere as a working document hence a draft.

This does not imply bor discuss its long term status hence again beung a draft. I personally believe that it makes a lot of sense to have it become RFC (fizing the concrens raised by OMA of course) when work and relationship between specs stabilize.

Stephane
_____
Stephane H. Maes, PhD,
Director of Architecture, Mobile, Voice, and Communications Platforms, Oracle
Ph: +1-203-300-7786 (mobile/SMS/skype); Fax / Office UM: +1-650-607-6296.
e-mail: [email-masked]
IM: shmaes (AIM/Y!) or [email-masked] (MSN Messenger)

-----Original Message-----
From: [email-masked]
Date: Tue, 31 Jan 2006 15:30:34
To:<[email-masked]>, <[email-masked]>
Subject: RE: [lemonade] Draft Liaison to OMA

"The purpose of the WG Internet Draft is to allow this to be documented in the IETF and to further affirm its status as a WG view."
What does it mean? Will it become an RFC later on? Could You please clarify/reword this sentence?

Best regards: Zoltán Ördögh
E-mail: [email-masked]
Phone: +358 50 386 0566 

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Glenn Parsons
Sent: 25 January, 2006 23:31
To: [email-masked]
Subject: [lemonade] Draft Liaison to OMA

Folks, 

As agreed, we will be sending a liaison to OMA MEM in time for their Feb meeting. 

As a result, please provide comment on the proposed liaison to OMA by Jan 30th.  We will send it on Jan 31st if there is no objection.

Cheers,
Glenn. 

From: IETF LEMONADE Working Group 
To: OMA MWG MEM Sub Working Group 
Title: Regarding the LEMONADE Profile   
Response contact:  [email-masked] 
Purpose:  For Action 
Deadline:  March 13, 2006 

The LEMONADE working group (WG) would like to thank the OMA Mobile Email Sub Working Group for your latest liaison. 

Our previous liaison indicated that we have proposed a realization of the OMA MEM architecture using IETF protocols and that we documented this in an Internet Draft (see draft-ietf-lemonade-oma-mem-realization-00.txt).  The purpose of the WG Internet Draft is to allow this to be documented in the IETF and to further affirm its status as a WG view.

There is no intent to publish the OMA MEM RD, AD or TS in IETF. 

As we have indicated before, the LEMONADE WG is working on a set of extensions to IMAP and ESMTP to support mobile email.  This set will be succinctly described in the LEMONADE profile (draft-ietf-lemonade-profile-bis).  This will cover interface ME-2 as well as the notifications aspects of ME-3 in the OMA MEM AD.  The OMA TS can normatively reference the LEMONADE profile.

We appreciate your response to the questions that we had asked in our previous liaison.  We have a number of follow-on comments/questions:

1.  We will support signed notifications but will add the ability to turn it off. 
2.  OMA STI is currently being used in CONVERT.  However we are concerned with the large number of optional parameters.  We would prefer a shorter finite mandatory set (that is extensible).  What advice can you offer on a shorter set?

3.  We will be providing managed SIEVE to manage the filters.  Additional methods (such as XDMS) could be used as well. 
4.  We are evaluating where in our protocols delays may play a role.  We note that there may be a tradeoff in mobile phones on battery life vs delay.   What delay aspects are of concern to the OMA - is it roundtrip, network or service level?

5.  We are aware of the limitations for mutual authentication on mobile devices.  TLS is not required, and this could be handled by SASL mechanisms which are already on mobile phones.

6.  Message recall is possible within the submit (i.e., administrative) domain.  We indicated that we could design protocol for this based on MSGTRK.  However, in the general end-to-end Internet Mail case it is practically impossible to design a message recall solution that will reliably work.

We would like to draw your attention to the fact that LEMONADE has wrapped up the first phase of its work.  We are currently working on finalizing the content of Profile bis. Additional input on details required to meet OMA requirements have been reviewed, and most have become WG documents.  The timeline would likely result in conclusion later in early 2006.

Up-to-date information on LEMONADE Internet-Drafts and RFCs can always be found at http://www.ietf.org/html.charters/lemonade-charter.html <http://www.ietf.org/html.charters/lemonade-charter.html>  with more detail tracked on the supplemental site.

Finally, as information, the next meetings of the IETF LEMONADE WG are: 

*	Mar 20-24 - IETF 65 plenary - Dallas, TX 
*	Jul 10-14 - IETF 66 plenary - TBD 

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: [email-masked]
Date: Wed, 1 Feb 2006 11:12:38 +0200

Hi Stephane,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Stephane H. Maes
Sent: 31 January, 2006 16:49
To: [email-masked]; [email-masked]
Subject: Re: [lemonade] Draft Liaison to OMA

Zoltan, 

It seems correct to me:

Stephane
_____
Stephane H. Maes, PhD,

-----Original Message-----
From: [email-masked]
Date: Tue, 31 Jan 2006 15:30:34 

Folks, 

Cheers, 
Glenn.

---

From: [email-masked]
Date: Wed, 1 Feb 2006 11:34:44 +0200

This is exactly what I am missing from the LS. The message in the LS in unclear. 

-----Original Message-----
From: ext Stephane H. Maes [mailto:[email-masked]] 
Sent: 01 February, 2006 11:16
To: Ordogh Zoltan (Nokia-TP-MSW/Tampere); [email-masked]; [email-masked]
Subject: RE: [lemonade] Draft Liaison to OMA

Stephane 

_____
Stephane H. Maes, PhD,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, February 01, 2006 1:13 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [lemonade] Draft Liaison to OMA

Hi Stephane,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Stephane H. Maes
Sent: 31 January, 2006 16:49
To: [email-masked]; [email-masked]
Subject: Re: [lemonade] Draft Liaison to OMA

Zoltan, 

It seems correct to me:

Stephane
_____
Stephane H. Maes, PhD,

-----Original Message-----
From: [email-masked]
Date: Tue, 31 Jan 2006 15:30:34

Folks, 

Cheers,
Glenn.

---

From: "Stephane H. Maes" <[email-masked]>
Date: Wed, 1 Feb 2006 07:19:15 -0800

Oh I see. Good point.

Stephane 

_____
Stephane H. Maes, PhD,

-----Original Message-----
From: ext Stephane H. Maes [mailto:[email-masked]]
Sent: 01 February, 2006 11:16
To: Ordogh Zoltan (Nokia-TP-MSW/Tampere); [email-masked]; [email-masked]
Subject: RE: [lemonade] Draft Liaison to OMA

Stephane 

_____
Stephane H. Maes, PhD,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, February 01, 2006 1:13 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [lemonade] Draft Liaison to OMA

Hi Stephane,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Stephane H. Maes
Sent: 31 January, 2006 16:49
To: [email-masked]; [email-masked]
Subject: Re: [lemonade] Draft Liaison to OMA

Zoltan, 

It seems correct to me:

Stephane
_____
Stephane H. Maes, PhD,

-----Original Message-----
From: [email-masked]
Date: Tue, 31 Jan 2006 15:30:34

Folks, 

Cheers,
Glenn.