Subject: [lemonade] Client identification

From: <[email-masked]>
Date: Fri, 12 May 2006 15:04:47 +0300

Hi all,
I would need some help.
How are the clients identified?

I would need this information to figure out how to store client-specific preferences - like outband notification address - to be able to tell the server to notify my laptop client via WLAN (address UDP x.x.x.x:nn), and my mobile phone via SMS (address +1234567890, port yy).

Thank You.

Best regards: Zoltán Ördögh
E-mail: [email-masked]
Phone: +358 50 386 0566

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Randall Gellens <[email-masked]>
Date: Wed, 17 May 2006 15:39:19 -0700

At 3:04 PM +0300 5/12/06, <[email-masked]> wrote:

>  Content-class: urn:content-classes:message
>  Content-Type: multipart/alternative;
>  	boundary="----_=_NextPart_001_01C675BC.47A238F3"
>
>  Hi all,
>  I would need some help.
>  I would need this information to figure out how to store 
> client-specific preferences - like outband notification address - 
> to be able to tell the server to notify my laptop client via WLAN 
> (address UDP x.x.x.x:nn), and my mobile phone via SMS (address 
> +1234567890, port yy).

This could be a mail server per-user data item, as you suggest, but 
it could also be done with Sieve filters.  That allows notification 
preferences to in effect be different for different devices.  So a 
Sieve script could test messages and, depending on which criteria 
match, send notification to specific addresses.
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
In the long-run every Government is the exact symbol of its People,
with their wisdom and unwisdom. --Thomas Carlyle, _Past and Present_

---

From: <[email-masked]>
Date: Thu, 18 May 2006 10:46:36 +0300

Thank You for Your respose Randall.
So, what You are saying is that each client could modify the SIEVE filter which would then instruct the server to notify all clients listed in the SIEVE script. There is only two problems I see with this:
1. Concurrent updates (one of the updates is prone to be lost because the latter one will obsolete the first update).
2. We still need to figure out how to identify the clients - a client will want to update its own preference only, not other client's preferences. Let me explain. You are using Your mobile phone via GRPS, and Your notification address is UDP/10.1.1.1:34765 currently. You walk on the airplane and switch off Your phone. You enjoy Your flight and walk off the plane to switch the phone back. The question is now that how can the client identify Your old preference that exists on the server? The client will be required to track its own addresses? UDP address depends on the network - far from unique so it's not going to work even if the client remembers.

Thank You.

-----Original Message-----
From: ext Randall Gellens [mailto:[email-masked]] 
Sent: 18 May, 2006 01:39
To: Ordogh Zoltan (Nokia-TP-MSW/Tampere); [email-masked]
Subject: Re: [lemonade] Client identification

At 3:04 PM +0300 5/12/06, <[email-masked]> wrote:

> client-specific preferences - like outband notification address - to 
> be able to tell the server to notify my laptop client via WLAN