Subject: [lemonade] I-D ACTION:draft-ietf-lemonade-vfolder-01.txt

From: [email-masked]
Date: Tue, 30 May 2006 18:50:01 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Enhancements to Internet email to support diverse service environments Working Group of the IETF.

	Title		: Persistent Virtual Folder extension to the IMAP Protocol
	Author(s)	: S. Maes, et al.
	Filename	: draft-ietf-lemonade-vfolder-01.txt
	Pages		: 12
	Date		: 2006-5-30
	
Persistent Extensions to the IMAP Protocol (LPSEARCH) defines 
extension parameters to the [RFC3501] CREATE command to allow virtual 
mailboxes to be created which are views of other mailboxes narrowed 
by search criteria.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-lemonade-vfolder-01.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-lemonade-vfolder-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-lemonade-vfolder-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: <[email-masked]>
Date: Wed, 31 May 2006 13:02:55 +0300

Hi Stephane,
Few comments:
 - what is a "potentially large or high velocity mailbox" 
 - "APPEND/COPY to a vfolder SHOULD be supported as well, but may not on some implementations" - how does one determine whether it is supported or not?
 - "a vfolder should appear to function as a regular mailbox" Question: Can one create a VFOLDER based on a VFOLDER?
- "A server which supports LVFOLDER" -> "A server which supports VFOLDER"
- "S: a2 OK CREATE LPSEARCH Completed" -> "S: a2 OK CREATE VFOLDER Completed"
- "existing vfolders which reference the mailbox should be deleted and not" -> "existing vfolders which reference the mailbox MUST be deleted and MUST NOT"
- "server MAY treat it in the same way as a DELETE command by removing all vfolders attached to the old mailbox name, OR it MAY track the new name and modify all dependent vfolders to use the new folder name" Would it be possible to mandate updating the vfolders to use the new name instead and disallow deletions? It would be better for user experience and interoperability.
- "MAY be used to append/copy messages to vfolder, depending on the implementation" Could we drop ", depending on the implementation" from this sentence?
- "A NO response should be	generated if the server lacks APPEND/COPY support on VFOLDER." What is the reason for not making this a MUST?
- "Servers SHOULD expunge only the messages visible in the view, or MAY expunge the entire mailbox. The former is more desirable, if possible." Could we make the first one mandatory and get rid of the latter one? It would be better for user experience and interoperability.
- "The i right (COPY/APPEND) MAY or MAY NOT be granted on a view." -> "The 'i' right (COPY/APPEND) MAY or MAY NOT be granted on a view." Also, what does MAY NOT mean? It MUST be either granted or not (like any other right), so is this sentence useful?
- "However, it may or may not consider the underlying mailbox ACL," Same comment as above about the "may or may not".
- "Clients wishing to check if a message is a duplicate at..." Compating headers vs the local database consumes memory, processing power, and ultimately battery power. Would it be possible to do this on the server side and make sure that duplicate mails always have the same UID? Or, add a new flag 'LEMONADE-Duplicate-Of:' and include the old UID there? It should not be in a future version.
 - The WITHIN extension is referenced and the WITHIN command is used in example(s) in section 6: "C: a2 CREATE mobile (VFOLDER (INBOX FROM "[email-masked]" WITHIN	3))" - however the WITHIN extension does not have such comment (the latest draft).

Best regards: Zoltán Ördögh
E-mail: zoltan.ordogh at nokia.com
Phone: +358 50 386 0566

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]] 
Sent: 31 May, 2006 01:50
To: [email-masked]
Cc: [email-masked]
Subject: [lemonade] I-D ACTION:draft-ietf-lemonade-vfolder-01.txt 

	
Persistent Extensions to the IMAP Protocol (LPSEARCH) defines extension parameters to the [RFC3501] CREATE command to allow virtual mailboxes to be created which are views of other mailboxes narrowed by search criteria.

To remove yourself from the I-D Announcement list, send a message to [email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username "anonymous" and a password of your e-mail address. After logging in, type "cd internet-drafts" and then
	"get draft-ietf-lemonade-vfolder-01.txt".

A list of Internet-Drafts directories can be found in http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Send a message to:
	[email-masked].
In the body type:

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 31 May 2006 13:41:28 +0200

Hi Stephane,

here's a few comments from me too. Most of this would benefit from other 
people's comment, so I'm sending it to the list as well as directly to 
you.

I see you've merged my VIEW into VFOLDER and added me as author. Fine 
with me. The vfolder-01 draft is IMO perfectly adequate. I'll modify my 
VIEW implementation to be a VFOLDER implementation.

Some nits. Some text refers to view instead of vfolder and to underlying 
instead of backing. Better change that. (I actually think backing is 
the better term and would have used that if I'd thought of it.) The 
Abstract says LPSEARCH where it shouldn't. In section 2, the term "high 
velocity" is a little odd, I'd prefer "frequently changing". The final 
sentence of section 4 uses the verb "correct"; I think "modify" is a 
better word there.

The draft uses the word folder throughout. In IMAP, the word mailbox is 
used. (I don't know why, though, perhaps Mark can elaborate?) Anyway, I 
think there is value in consistency, ie. it's better to say mailbox 
than folder simply because that's what RFC 3501 says. (I'm using 
vfolder, not vmailbox, here, because in a message about vfolder-01, I'd 
better be consistent with _its_ terminology.)

And there are some substantive issues.

1. APPEND/COPY.

In section 1 and 8, APPEND and COPY are explicitly permitted on 
vfolders. I think that's desirable, but there's a problem, perhaps a 
nasty one: A client may expect that if it appends/copies a message to a 
mailbox, that message shows up in that mailbox. If the mailbox happens 
to be a vfolder and the message doesn't match the search, the message 
may (apparently) disappear without a trace.

There are three possibilities: Either the message must be made to fit 
the search (e.g. by setting the right flags if the search uses flags), 
or the search must be modified to include that message's UID, or the WG 
considers it acceptable that the message sometimes goes only to the 
backing mailbox, not to the vfolder. Personally, I think the first two 
are horrid and strongly favour the latter, I'm just a little nervous 
that it might confuse some IMAP clients.

Section 8 should probably get a sentence or paragraph on this, once 
there's consensus.

2. VFOLDER on VFOLDER.

In section 2, a vfolders may be created with another vfolder as backing. 
I don't see a use-case for that, and I do see one drawback, namely that 
it complicates making a vfolder "users.stephane.blah" with 
"users.stephane.*" as backing. The present draft does not permit 
multi-mailbox backing, but I don't expect that state of affairs to last 
very long. People want multi-mailbox backing. More on that below.

Can anyone think of a use-case or other argument for allowing vfolders 
on vfolders?

3. ACL.

In the security considerations, the ACL issue needs mentioning.

4. Catchall vfolders.

One thing people ask for is a way to catch the rest of the mail. Suppose 
you sort your inbox into seven vfolders. What happens to the messages 
that fit none of the seven searches? The answer is a vfolder catching 
the rest, e.g. "INBOX.other" with has search expression "UNKEYWORD 
$Spam NOT INVFOLDER" (showing all messages which don't have the $spam 
flag and which aren't in any other view).

I can supply exact text for INVFOLDER, but not right now. (It's a little 
bit tricky, since if the MUA selects the catchall vfolder before it has 
selected all of the others, the server may not have updated the others 
with the most recent messages yet, so some messages may appear to not 
be in any view.)

5. Vfolders with multiple backing mailboxes.

People want it. If you look at e.g. Apple Mail, it has that feature and 
people use it. I didn't specify anything in the VIEW draft because I 
didn't know how it ought to be done.

The key question is how to specify the backing. Should the backing be 
specified as a mailbox name prefix, as a wildcard pattern, as a list of 
mailboxes or perhaps as "all mailboxes I own"? There are arguments for 
all four. The main difference is what happens when mailboxes are 
created or renamed.

I'd like to hear what people on this list would use themselves, and what 
they think would be useful in general.

Arnt

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 31 May 2006 13:51:01 +0200

Arnt Gulbrandsen writes:
> People want it. If you look at e.g. Apple Mail, it has that feature 
> and people use it. I didn't specify anything in the VIEW draft 
> because I didn't know how it ought to be done.
>
> specified as a mailbox name prefix, as a wildcard pattern, as a list 
> of mailboxes or perhaps as "all mailboxes I own"? There are arguments 
> for all four. The main difference is what happens when mailboxes are 
> created or renamed.
>
> I'd like to hear what people on this list would use themselves, and 
> what they think would be useful in general.

Ack. I forgot that ACL becomes a twisted maze once a vfolder has 
multiple backing mailboxes with potentially different owners or ACLs.

Arnt

---

From: Randall Gellens <[email-masked]>
Date: Wed, 31 May 2006 12:20:32 -0700

>   - what is a "potentially large or high velocity mailbox"

I thought this was amusing wording.  I suppose "high velocity" 
mailbox is one that resides on a mobile device that has been hurtled 
at high speed towards someone or something?  (I assume the intent is 
one whose contents change frequently.)

>   - "a vfolder should appear to function as a regular mailbox" 
> Question: Can one create a VFOLDER based on a VFOLDER?

The draft says this is supported.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Nine out of 10 doctors agree that 1 out of 10 doctors is an idiot.

---

From: "Stephane H. Maes" <[email-masked]>
Date: Wed, 31 May 2006 12:55:48 -0700

I thought this was amusing wording.  I suppose "high velocity"
mailbox is one that resides on a mobile device that has been hurtled at high speed towards someone or something?  (I assume the intent is one whose contents change frequently.)<<

Yeah...

Stephane

_____
Stephane H. Maes, PhD,
Director of Architecture, Mobile, Voice, and Communications Platforms, Oracle.
Ph: +1-203-300-7786 (mobile/SMS); Fax / Office UM: +1-650-607-6296
e-mail: [email-masked]
IM: shmaes (AIM/Y!/skype) or [email-masked] (MSN Messenger) or [email-masked] (Google)

-----Original Message-----
From: Randall Gellens [mailto:[email-masked]] 
Sent: Wednesday, May 31, 2006 12:21 PM
To: [email-masked]; [email-masked]
Subject: RE: [lemonade] I-D ACTION:draft-ietf-lemonade-vfolder-01.txt

I thought this was amusing wording.  I suppose "high velocity"
mailbox is one that resides on a mobile device that has been hurtled at high speed towards someone or something?  (I assume the intent is one whose contents change frequently.)

--
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: --------------- Nine out of 10 doctors agree that 1 out of 10 doctors is an idiot.