Subject: RE: [lemonade]About "Avoiding Duplicates"

From: Randall Gellens <[email-masked]>
Date: Fri, 25 Aug 2006 17:56:38 -0700

At 9:24 AM +0100 8/25/06, Ben Last wrote:

>  There's at least one server I'm aware of that can change the UIDVALIDITY
>  of mailboxes in response to (what I consider) quite common/low-level
>  operations, incurring a severe re-synchronization/download penalty for
>  our client.

Such a server would impose penalties on most clients, I think.  It's 
quite rude of the server, really.
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Eight out of every five people are math illiterate.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Philip Guenther <[email-masked]>
Date: Fri, 25 Aug 2006 19:23:17 -0600

>  operations, incurring a severe re-synchronization/download penalty for

Could you describe the operations that cause the UIDVALIDITY changes? 
RENAME _has_ to do that in some cases, but that's the only pure-IMAP 
operation I can think of that does so.

Philip Guenther

---

From: Lingyan Wu <[email-masked]>
Date: Sat, 26 Aug 2006 12:00:08 +0800

---

From: "Ben Last" <[email-masked]>
Date: Tue, 29 Aug 2006 12:23:52 +0100

It's not a pure IMAP operation, it happens in response to changing some
parameters for mobile clients, via a webmail interface.  A number of our
users were doing this quite often and that's what clued us in to why we
were seeing frequent complete resynchronizations.
Regards
Ben

Ben Last
EMCC Software
[email-masked]
direct: +44 161 919 0178
mobile: +44 7966 136572
skype: bjlast
MSN Messenger: [email-masked]

-----Original Message-----
From: Philip Guenther [mailto:[email-masked]] 
Sent: 26 August 2006 02:23
To: Ben Last
Cc: [email-masked]
Subject: RE: [lemonade]About "Avoiding Duplicates"

At 9:24 AM +0100 8/25/06, Ben Last wrote:
>  There's at least one server I'm aware of that can change the 
> UIDVALIDITY  of mailboxes in response to (what I consider) quite 
> common/low-level  operations, incurring a severe 
> re-synchronization/download penalty for  our client.

Philip Guenther