Subject: [lemonade] WGLC reconnect-client-01

From: <[email-masked]>
Date: Wed, 23 Aug 2006 20:28:11 +0300

Hi all,
here are my findings - all are editorial.

1. Title: "IMAP4 Extensions for" -> "IMAP4 Extension for"
2. Page 1. "Changes since draft-ietf-lemonade-reconnect-client-01.txt" Since? It is -01 that I am reading now. Will the change history be kept or removed?
3. Section 2, par. 1. "since a known moment" Could we be more specific?
4. Section 2, par. 4. "In particular this extension can be useful" wording change suggestion to: "This extension can be particularly useful" or "In particular this extension is useful"
5. Section 2, par. 4. "Such clients would need a way
   to quickly reconnect to the IMAP server, without forcing the user to
   experience long delay and pay big bills for the amount of traffic
   generated by resynchronization." Aye, I agree, but this extension is not about reconnecting but resynch. Hence, I propose to change the wording to:
"Such clients would need a way
   to quickly resynchronize with the IMAP server, without forcing the user to
   experience long delays and pay big bills for the amount of traffic
   generated by a less efficient resynchronization mechanism."
6. Section 2, par. 5. "By extending the SELECT command to perform the additional
   resynchronization, this also allows" wording change suggestion to: "Extending the SELECT command to perform the additional
   resynchronization also allows"
7. Section 5. "This document doesn't raise any new security concerns not already
   raised by [CONDSTORE]." Suggest adding "or [EXPUNGED]" to the end of the sentence.

Thank You for considering them.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 24 Aug 2006 12:59:41 +0100

> here are my findings - all are editorial.
Thanks for the comments. They all look fine. Some minor comments below.

> 2. Page 1. "Changes since draft-ietf-lemonade-reconnect-client-01.txt" 
> Since? It is -01 that I am reading now. Will the change history be 
> kept or removed?
>
Ah, my mistake. Somehow I've decided that we are at -02. Anyway, this 
section will be removed.

> 3. Section 2, par. 1. "since a known moment" Could we be more specific?
CONDSTORE uses modification sequences, which effectively define moment 
in time. Do you think this should be spelled out?

> 4. Section 2, par. 4. "In particular this extension can be useful" 
> wording change suggestion to: "This extension can be particularly 
> useful" or "In particular this extension is useful"
>
>    generated by resynchronization." Aye, I agree, but this extension 
> is not about reconnecting but resynch. Hence, I propose to change the 
> wording to:
>
>    resynchronization, this also allows" wording change suggestion to: 
> "Extending the SELECT command to perform the additional
Sure.

---

From: <[email-masked]>
Date: Fri, 25 Aug 2006 06:48:24 +0300

Hi Alexey,

>CONDSTORE uses modification sequences, which effectively 
>define moment in time. Do you think this should be spelled out?

No, I mean the "known moment". It does not sound very good. "since a
known moment" -> "using timestamps"?
Since it is in the introduction section, I do not have strong feelings
about this.

Thank You.

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 25 Aug 2006 12:43:55 +0100

[email-masked] wrote:

>Hi Alexey,
>  
>
>>>3. Section 2, par. 1. "since a known moment" Could we be 
>>>      
>>>
>>more specific?
>>    
>>
Modsequences are not timestamps, they are counters. Thus the current 
wording.

---

From: Randall Gellens <[email-masked]>
Date: Fri, 25 Aug 2006 17:40:52 -0700

At 8:28 PM +0300 8/23/06, <[email-masked]>
wrote:

Hence, I propose to change the wording to:

"Such clients
would need a way

to quickly resynchronize with the IMAP server, without
forcing the user to

experience long delays and pay big bills for the amount
of traffic

generated by a less efficient resynchronization
mechanism."

I'd suggest making it:

"Such clients need a way to quickly resynchronize without
exposing the user to long delays or charges for data traffic caused by
less efficient mechanisms."

--

Randall Gellens

Opinions are personal;    facts are
suspect;    I speak for myself only

-------------- Randomly-selected tag: ---------------

It is a general popular error to imagine the loudest

complainers for the public to be the most anxious for

its welfare.                     --Edmund Burke, 1769

---

From: Randall Gellens <[email-masked]>
Date: Fri, 25 Aug 2006 17:43:26 -0700

>  Since it is in the introduction section, I do not have strong feelings

Personally, I think "known moment" is OK here, since it is a 
deterministic point in the mailbox history that is known to both 
client and server (the modseq).
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Invention is the mother of necessity.       --Thorstein Veblen

---

From: <[email-masked]>
Date: Sat, 26 Aug 2006 06:20:31 +0300

Hi Randall,
yes, even better.

________________________________

	From: ext Randall Gellens [mailto:[email-masked]] 
	Sent: 26 August, 2006 03:41
	To: Ordogh Zoltan (Nokia-TP-MSW/Tampere); [email-masked]
	Subject: Re: [lemonade] WGLC reconnect-client-01

	At 8:28 PM +0300 8/23/06, <[email-masked]> wrote:

	I'd suggest making it:

	"Such clients need a way to quickly resynchronize without exposing the user to long delays or charges for data traffic caused by less efficient mechanisms."
	-- 
	Randall Gellens
	Opinions are personal;    facts are suspect;    I speak for myself only

---

From: <[email-masked]>
Date: Sat, 26 Aug 2006 06:20:58 +0300

Ok, let's keep the existing one then.

>-----Original Message-----
>Sent: 26 August, 2006 03:43
>To: Ordogh Zoltan (Nokia-TP-MSW/Tampere); [email-masked]
>Cc: [email-masked]
>Subject: RE: [lemonade] WGLC reconnect-client-01
>
>>  Since it is in the introduction section, I do not have strong 
>> feelings  about this.
>
>deterministic point in the mailbox history that is known to 
>both client and server (the modseq).
>--
>Randall Gellens