Subject: Re: [lemonade] 'MOVE' (was Notifications for multiple devicesper user)

From: "Burger, Eric" <[email-masked]>
Date: Tue, 22 Aug 2006 21:57:32 -0400

[Speaking as a paricipant, NOT as a Chair]

I have never, EVER, in my experience had a service provider or netowrk operator mandate that level of protocol operation.  Mandating a protocol suite, yes.  Dictating the mechanics of the suite, NEVER.  OK, there is one caveat: when a service provider or operator cares that much about the operation of a protocol, you will usuallly see they are one of the authors of the protocol.

Much to my chagrin (or, admittedly, sometimes to my benefit), most operators, when asked about their standards participation, say, "we monitor the standards bodies, but we rely on our vendors to tell us what is important."

WHY would they care about a trash mailbox?  Their specifying the user interface I would believe.  However, their specifying the underlying protocol mechanics is way beyond my experience.  How would they know?  Who is driving them to want this one feature, which by the way reduces their choice of IMAP-complient servers and independent IMAP-compliant clients to exactly zero?

I will happily bend over to do this if one could produce three service prividers or operators that really want to dictate the protocol operation at that level AND UNDERSTAND THE IMPLICATIONS to demand trash mailboxes.

--
Sent from my less-than-ideal, non-Palm wireless device; I can't wait for LEMONADE!!!

----- Original Message -----
From: Randall Gellens <[email-masked]>
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Sent: Tue Aug 22 17:03:12 2006
Subject: RE: [lemonade] 'MOVE' (was Notifications for multiple devicesper user)

At 7:56 AM +0300 8/22/06, <[email-masked]> wrote:

>   >There's a difference between where a message is on the server,
>>and how the message is presented to the user.  If clients want
>>to present a distinct "Trash" mailbox to the user, that is
>>fine.  Forcing the metaphor to be literally true is a poor use
>>of IMAP and causes problems.  Making it easy for clients to
>>efficiently present a Trash metaphor to users is a good thing.
>>  I assume the users don't care which elements of the protocol
>>are used in which ways by the client.
>>They want to manage messages in a way that feels natural for them.
>
>  Somehow this thread went back to discussing Trash instead of MOVE.
>  I read through Mark's email as well. I accept what You are saying - my
>  worry is that the operators will say at the last minute (when LEMONADE
>  is already done) that they want a separate trash and force us to do
>  something proprietary (I mean it will be a standard anyway in OMA, but
>  might not be in line with LEMONADE).

If operators try to mandate a Trash mailbox in OMA, my advise would 
be to try and focus the requirement on what is necessary to permit 
the desired user experience and on interoperability.  In other words, 
if operators want to be sure that their users will see a trash 
metaphor, it should not matter to them if this is implemented with a 
distinct trash mailbox on the server or on the client, as long as the 
solution interoperates.  Doing it on the client is actually more 
interoperable, since it is reversible by any client.
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
An algorithm must be seen to be believed.  -- Donald Knuth

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Mark Crispin <[email-masked]>
Date: Tue, 22 Aug 2006 19:56:40 -0700

On Tue, 22 Aug 2006, Burger, Eric wrote:
> I have never, EVER, in my experience had a service provider or netowrk 
> operator mandate that level of protocol operation.  Mandating a protocol 
> suite, yes.  Dictating the mechanics of the suite, NEVER.

+1

I take claims of "service provider or network operator mandates" with a 
rock of salt, equivalent to claims that "the protocol will die unless 
such-and-such feature is added."  Either way, it's hyperbole.

Sometimes I contact the service providers and/or network operators to 
verify that the claim is hyperbole without a shred of reality.  I have yet 
to be disappointed.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.