Subject: Re: [Lime] LIME OAM Yang Model Applicability

From: Gregory Mirsky <[email-masked]>
Date: Mon, 14 Sep 2015 20:55:47 +0000

Dear All,
I haven’t seen any discussion after the invitation from LIME WG chairs. Earlier I’ve sent my comments to authors of the applicability draft and, I understand, they are working on the update. Perhaps it would be more productive if we start our discussion of the new, updated version of the applicability document.

                Regards,
                                Greg

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Tuesday, August 18, 2015 3:49 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; Benoit Claise (bclaise)
Subject: LIME OAM Yang Model Applicability

Hi, All,

I am starting this thread, based on a discussion during the LIME meeting in Prague and subsequent action item.

LIME (https://datatracker.ietf.org/wg/lime) has a deliverable as follows:
- Applicability document: The YANG model(s) specified in this working group must be usable and extensible by the existing OAM technologies. This usability and extensibility must be demonstrated, for example with IP Ping, traceroute, BFD, and LSP Ping. Note the technology-specific data model extensions should ideally be worked on in the respective working groups.
which basically builds a working dependency on efforts that are building protocol-based OAM YANG models.
Based on this, I am copying the authors of the following 5 documents, and the chairs of the target WGs:

  1.  LIME Applicability http://datatracker.ietf.org/doc/draft-zhuang-lime-yang-oam-model-applicability
  2.  LIME YANG Model http://datatracker.ietf.org/doc/draft-tissa-lime-yang-oam-model
  3.  MPLS http://datatracker.ietf.org/doc/draft-zhang-mpls-tp-yang-oam
  4.  MPLS http://datatracker.ietf.org/doc/draft-zheng-mpls-lsp-ping-yang-cfg
  5.  BFD http://datatracker.ietf.org/doc/draft-zheng-bfd-yang
The main goal of this note is to explicitly connect all these streams of work, and ensure there is coherence and alignment. As LIME defines a protocol-independent YANG model (1), the Applicability document (2) should show how the model can be used, extended, and augmented to realize protocol-specific ones (3) (4) (5).

We would be happy to help facilitate this dialogue, which BTW can take the shape of an informal meeting or a virtual interim (thinking aloud) before next IETF.

Discuss!!! :-)

— Carlos.

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Tue, 15 Sep 2015 01:39:12 +0000

Dear Greg, and all,

Thanks for the email to bring the applicability document discussion back to the mailing list.
Yes, we’re working on the update. It takes a little time to gather as many comments as we can from people in different groups, including authors of specific OAM models.

Here we’d  like to share the initial update 01 version *soon* for people’s review based on comments received until now. Apologize to keep you wait…

The proposed changes we have already made in the new version include:

l  Updates based on Greg’s comments (thanks Greg for your comments and suggestions).

l  Rewrite guideline section to tell the location in the common structure of LIME base model we can insert the data.

l  Separate MPLS-TP OAM from MPLS OAM, Add MPLS-TP OAM support.

l  Add performance management support in the base model structure.

Please let us know if you have any other suggestions on the scope of LIME applicability.

Regards,

Yan

发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2015年9月15日 4:56
收件人: Carlos Pignataro (cpignata); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]; Benoit Claise (bclaise)
主题: RE: LIME OAM Yang Model Applicability

Dear All,

                Regards,
                                Greg

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Tuesday, August 18, 2015 3:49 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Benoit Claise (bclaise)
Subject: LIME OAM Yang Model Applicability

Hi, All,

Discuss!!! :-)

— Carlos.

---

From: Zhengguangying <[email-masked]>
Date: Tue, 15 Sep 2015 09:24:09 +0000

Dear Greg，

I am checking LIME  now， and think whether  lsp-ping YANG model can based on LIME, will share my opinion after confirm it.

Regards
Walker

________________________________
路在脚下，Walker

[Company_logo]业务支撑部 Business Support Dept
地址：南京市雨花区软件大道101号 邮编：210012
Huawei Nanjing R&D Center, 101 Software Avenue, Yuhua District, Nanjing, Jiangsu,
P.R.China. 210012
http://www.huawei.com

From: Gregory Mirsky [mailto:[email-masked]]
Sent: 2015年9月15日 4:56
To: Carlos Pignataro (cpignata); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; Benoit Claise (bclaise)
Subject: RE: LIME OAM Yang Model Applicability

Dear All,

                Regards,
                                Greg

Hi, All,

Discuss!!! :-)

— Carlos.

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 15 Sep 2015 16:33:43 +0000

Hi Yan,
thank you for the update regarding your work on the applicability document. As pointed in the mail from Carlos, work on YANG model of MPLS-TP OAM already in progress. In addition to that work I can refer you to RFC 7487 and draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf that respectively present MPLS-TP OAM configuration model through RSVP-TE and LSP Ping extensions.
RE: Performance Monitoring. I think we’ll have much to discuss and work on with proactive and on-demand Continuity Check and Connectivity Verification mechanisms. Perhaps analysis of PM may be in done in its own document.

                Regards,
                                Greg

From: Zhuangyan (Yan) [mailto:[email-masked]]
Sent: Monday, September 14, 2015 6:39 PM
To: Gregory Mirsky; Carlos Pignataro (cpignata); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; Benoit Claise (bclaise)
Subject: Re: LIME OAM Yang Model Applicability

Dear Greg, and all,

Regards,

Yan

发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2015年9月15日 4:56
收件人: Carlos Pignataro (cpignata); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Benoit Claise (bclaise)
主题: RE: LIME OAM Yang Model Applicability

Dear All,

                Regards,
                                Greg

Hi, All,

Discuss!!! :-)

— Carlos.

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Wed, 16 Sep 2015 02:01:07 +0000

Hi Greg,

Thank you very much for the suggestion and suggested documents.
And yes, we’re working on the draft based on Chair’s suggestion of these specific OAM model work.
The main idea of applicability document is to prove that the LIME base model can be used/applied to specific OAM technologies instead of defining the specific OAM models. Hence, the applicability document will investigate and evaluate specific OAM features/parameters from both these existing technology specific OAM model work as well as OAM protocols themselves, and then demonstrate how these specific features/parameters can be represented by augmenting the LIME base model to prove the extensibility and usability of the LIME base model.

Regarding the PM, agree that we’ll have much discussion on this. And definitely, we’d love to get input from groups or work with them to make our work more concrete.

Last but not least, comments and suggestions are welcomed and appreciated.

Regards,

Yan

发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2015年9月16日 0:34
收件人: Zhuangyan (Yan); Carlos Pignataro (cpignata); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]; Benoit Claise (bclaise)
主题: RE: LIME OAM Yang Model Applicability

Hi Yan,

                Regards,
                                Greg

To: Gregory Mirsky; Carlos Pignataro (cpignata); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Dear Greg, and all,

Regards,

Yan

Dear All,

                Regards,
                                Greg

Hi, All,

Discuss!!! :-)

— Carlos.

---

From: Qin Wu <[email-masked]>
Date: Wed, 16 Sep 2015 11:03:39 +0000

RFC7487 says:
“
   MPLS-TP, the Transport Profile of MPLS, must, by definition
   [RFC5654<https://tools.ietf.org/html/rfc5654>], be capable of operating without a control plane.
   Therefore, there are several options for configuring MPLS-TP OAM
   without a control plane by using either a Network Management System
   (NMS), an LSP Ping, or signaling protocols such as RSVP-TE in the
   control plane.
”
It is obvious that there are three ways to configure MPLS-TP OAM:

a.       Management plane solution

b.       Data plane solution (e.g., LSP Ping)

c.       Control plane solution (e.g.,RSVP-TE)
I don’t doubt the value of each solution, but they did compete with each other. If we go for control plane solution, it seems to me we should first configure RSVP-TE to support configuring MPLS-TP OAM and then we can use RSVP-TE to configure MPLS-TP OAM, that is to say, if a model is needed, we need a RSVP-TP model rather than we should build MPLS-TP model, so does data plane solution.

Secondly, if my understanding is correct, what we should focus here is to use management plane to configure OAM technology,
Use data plane OAM to execute OAM command and collect defects, network failure and other state. The management plane solution should not bother or change how data plane OAM works
Or add configuration burden to data plane OAM.

-Qin

Hi Yan,

                Regards,
                                Greg

Dear Greg, and all,

Regards,

Yan

Dear All,

                Regards,
                                Greg

Hi, All,

Discuss!!! :-)

— Carlos.

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 16 Sep 2015 16:51:37 +0000

Hi Qin,
I’m bit confused by your suggestion that operator has to “first configure RSVP-TE” before using it to signal MPLS-TP configuration to LER. Perhaps you’ve meant to say that the LSP must be first signaled using RSVP-TE and then its OAM configuration. But wouldn’t that be the same order when using management plane, e.g. netconf?
I’ve pointed to RSVP-TE and LSP Ping solutions not as alternatives to MPLS-TP YANG data model but as additional to netconf ways to configure proactive OAM in the MPLS-TP LSP. I believe that solutions presented in both documents, RFC 7487 and draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf, are reflected in our MPLS-TP OAM model and can be used as one of use cases to test commonality of Generic YANG model for OAM.

                Regards,
                                Greg

From: Qin Wu [mailto:[email-masked]]
Sent: Wednesday, September 16, 2015 4:04 AM
To: Gregory Mirsky; Zhuangyan (Yan); Carlos Pignataro (cpignata); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; Benoit Claise (bclaise)
Subject: RE: LIME OAM Yang Model Applicability

RFC7487 says:
“

-Qin
发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2015年9月16日 0:34
收件人: Zhuangyan (Yan); Carlos Pignataro (cpignata); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Benoit Claise (bclaise)
主题: RE: LIME OAM Yang Model Applicability

Hi Yan,

                Regards,
                                Greg

Dear Greg, and all,

Regards,

Yan

Dear All,

                Regards,
                                Greg

Hi, All,

Discuss!!! :-)

— Carlos.

---

From: Qin Wu <[email-masked]>
Date: Thu, 17 Sep 2015 01:07:32 +0000

Hi, Greg:
发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2015年9月17日 0:52
收件人: Qin Wu; Zhuangyan (Yan); Carlos Pignataro (cpignata); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]; Benoit Claise (bclaise)
主题: RE: LIME OAM Yang Model Applicability

Hi Qin,
I’m bit confused by your suggestion that operator has to “first configure RSVP-TE” before using it to signal MPLS-TP configuration to LER. Perhaps you’ve meant to say that the LSP must be first signaled using RSVP-TE and then its OAM configuration.

[Qin]:Yes, that is close to what I am saying, what I am saying is when you rely on RSVP-TE to configure MPLS-TP OAM, you doesn’t need to rely on NMS or management plane to configure MPLS-TP OAM. When you rely on NMS to configure MPLS-TP OAM, you don’t have to use RSVP-TE to configure MPLS-TP OAM.

But wouldn’t that be the same order when using management plane, e.g. netconf?

[Qin]: As I said below, when using management plane, we will use management plane to configure MPLS-TP OAM, then use MPLS-TP OAM protocol to do troubleshooting, when using RSVP-TE,
You use RSVP-TE to setup path and then use RSVP-TE to exchange OAM configuration, you don’t need to have management plane to get involved when using RSVP-TE.

I’ve pointed to RSVP-TE and LSP Ping solutions not as alternatives to MPLS-TP YANG data model but as additional to netconf ways to configure proactive OAM in the MPLS-TP LSP.

[Qin]: Not additional but alternative way, See the paragraph I referenced below.

I believe that solutions presented in both documents, RFC 7487 and draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf, are reflected in our MPLS-TP OAM model and can be used as one of use cases to test commonality of Generic YANG model for OAM.

[Qin]: That’s a good point, I agree the protocol parameters modeled by MPLS-TP OAM model should get consistent with one defined in RFC 7487 and draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf,
Thanks for your clarification.

                Regards,
                                Greg

To: Gregory Mirsky; Zhuangyan (Yan); Carlos Pignataro (cpignata); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

RFC7487 says:
“

-Qin

Hi Yan,

                Regards,
                                Greg

Dear Greg, and all,

Regards,

Yan

Dear All,

                Regards,
                                Greg

Hi, All,

Discuss!!! :-)

— Carlos.