Subject: [Lime] One week on [Was: What is LIME really working on?]

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 25 Sep 2015 14:26:26 +0100

Hi,

It really wasn't my intent to shut down conversation on the LIME list :-)

The question I asked is, I think, fundamental to the working group making
progress and pulling together, and I believe that the answer needs to come from
the community and be shaped by guidance from the chairs and the AD.

My opinion (as usual) is just my opinion, and counts for nothing if there is
consensus in a different direction.

So, please speak up and agree or disagree with me (giving your reasons) so that
we can get on and complete the work.

Thanks!

Adrian

> -----Original Message-----
> From: Lime [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: 18 September 2015 16:49
> To: [email-masked]
> Subject: [Lime] What is LIME really working on?
> 
> Hello LIME WG,
> 
> You may be aware that L3SM is building a service model for L3VPN users. That
> model can be *mapped* to the models used to operate the network. But the
> L3SM
> model is not intended to provide a base model for L3VPN operation. And it is
not
> supposed to provide something that is extensible to the protocol models. Later
> work will check that the L3SM model can be mapped to the protocol models and
> that the protocol models have all the necessary objects for this to work.
> 
> But "mapping" is simply taking the description of the service and using the
data
> to work out what to ask the network to do. It's an orchestration thing and the
> model may describe some things that a particular network can't offer. That's
OK
> and it's what orchestrators do for a living.
> 
> Now, a while back when I was looking at the early LIME work I *thought* LIME
> was
> a similar play. That is, I thought its job was to produce a generic model for
> requesting OAM services. The model may describe services that can or can't be
> provided in a network, or can or can't be provided by a set of specific
network
> nodes (such as those along a path). A user uses the LIME model to request
> services, and an "OAM manager" (or "OAM orchestrator"?) maps to the OAM
> control
> for the network nodes.
> 
> It may be that in both cases (L3SM and LIME) the mapping can be made simple if
> the base model is extensible to the protocol configuration model, but that is
> not a requirement.
> 
> IMHO, L3SM makes this clear in the charter, and I *thought* that the LIME
> charter was clear on this.
> 
> But a lot of the recent LIME discussion seems to focus on:
> 
> - can all the function in the base model be provided by the network?
>    (for example, things must be left out of the base model because
>     ping in an IP network can't support it)
> 
> - the base model must only contain things that are needed for
>    extending the model to specific protocol models
> 
> Now, what have I missed? Where did what I thought was the case change to
> what
> people are talking about?
> 
> If I'm crazy-wrong, please tell me.
> 
> Thanks,
> Adrian
> 
> _______________________________________________
> Lime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lime

---

From: Qin Wu <[email-masked]>
Date: Fri, 25 Sep 2015 14:35:55 +0000

Adrian:
I believe you gave a good analogy to explain what LIME is doing. That's to say, user sitting on top of OSS/NMS doesn't need to care about which specific OAM technology is used, which is shielded from the user by some kind of orchestrator or OSS/NMS, user only cares about whether there is fault, defect, what kind of fault, defect it is, where to locate these fault, defect; when diagnose is needed, user more cares about whether Bob is reachable by Alice, by which path, what path performance looks like, OSS or OAM manager should know which part of the network is applied, what OAM tools are available, what OAM functions are supported. And then OSS/OAM manager maps fault management parameters and/or performance measurement parameters to protocol parameters specific to OAM technology.

-Qin
-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Adrian Farrel
发送时间: 2015年9月25日 21:26
收件人: [email-masked]
主题: [Lime] One week on [Was: What is LIME really working on?]

Hi,

The question I asked is, I think, fundamental to the working group making progress and pulling together, and I believe that the answer needs to come from the community and be shaped by guidance from the chairs and the AD.

My opinion (as usual) is just my opinion, and counts for nothing if there is consensus in a different direction.

So, please speak up and agree or disagree with me (giving your reasons) so that we can get on and complete the work.

Thanks!

Adrian

> You may be aware that L3SM is building a service model for L3VPN 
> users. That model can be *mapped* to the models used to operate the 
> network. But the L3SM model is not intended to provide a base model 
> for L3VPN operation. And it is
not
> supposed to provide something that is extensible to the protocol 
> models. Later work will check that the L3SM model can be mapped to the 
> protocol models and that the protocol models have all the necessary objects for this to work.
> 
data
> to work out what to ask the network to do. It's an orchestration thing 
> and the model may describe some things that a particular network can't 
> offer. That's
OK
> Now, a while back when I was looking at the early LIME work I 
> *thought* LIME was a similar play. That is, I thought its job was to 
> produce a generic model for requesting OAM services. The model may 
> describe services that can or can't be provided in a network, or can 
> or can't be provided by a set of specific
network
> nodes (such as those along a path). A user uses the LIME model to 
> request services, and an "OAM manager" (or "OAM orchestrator"?) maps 
> to the OAM control for the network nodes.
> 
> It may be that in both cases (L3SM and LIME) the mapping can be made 
> simple if the base model is extensible to the protocol configuration 
> model, but that is not a requirement.
> 
> IMHO, L3SM makes this clear in the charter, and I *thought* that the 
> LIME charter was clear on this.
> 
> Now, what have I missed? Where did what I thought was the case change 
> to what people are talking about?
>

---

From: <[email-masked]>
Date: Fri, 25 Sep 2015 16:42:10 +0200

Hi,

LIME WG is chartered to work on generic YANG model for OAM and provides a common structure for various OAM technologies, technology specific OAM data models will be worked on respective protocol WGs(e.g., BFD, MPLS).

I think that is what LIME is working on.

The model must contain things that are needed for
extending the model to specific protocol models, but not only
and because it is common and it is extensible.

Regards

Roland

-----Ursprüngliche Nachricht-----
Von: Lime [mailto:[email-masked]] Im Auftrag von Adrian Farrel
Gesendet: Freitag, 25. September 2015 15:26
An: [email-masked]
Betreff: [Lime] One week on [Was: What is LIME really working on?]

Hi,

Thanks!

Adrian

not
data
OK
network

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Mon, 28 Sep 2015 13:03:04 +0000

Hi, all,

Firstly, thanks Adrian for the question and sorry for the late response.

I think it is an important question for LIME WG now, since the answer matters how we demonstrate work of LIME base model in the applicability document.

And I agree that the LIME base model should be mapped into specific OAM models deployed onto network nodes, while provide a generic model for users to request their OAM services regardless of technology details.

For this usage, in order to make the mapping simple, an easy way is to extend the base model with specific OAM parameters and features to produce specific OAM models, which is what we are doing in applicability document.

However, it is not a requirement. So we think people might have other ideas on what LIME base model can do and how should it be mapped to their specific OAM models.

For this, we're happy to discuss and include reasonable options into the applicability document.

Please don't hesitate to share your ideas. Thanks a lot.

Regards,

Yan

-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Adrian Farrel
发送时间: 2015年9月25日 21:26
收件人: [email-masked]
主题: [Lime] One week on [Was: What is LIME really working on?]

Hi,

Thanks!

Adrian

> To: [email-masked]<mailto:[email-masked]>

not

> But "mapping" is simply taking the description of the service and

> using the

data

OK

network

> [email-masked]<mailto:[email-masked]>

Lime mailing list

[email-masked]<mailto:[email-masked]>

---

From: Benoit Claise <[email-masked]>
Date: Tue, 29 Sep 2015 23:52:43 +0200

Hi Adrian,

Good job describing the L3SM service model, and the related mapping 
function to the models used to operate the network.

LIME is slightly different.
Let me quote the charter:

    - YANG data model(s) for generic layer-independent and
    technology-independent configuration, reporting and presentation for
    OAM mechanisms.
    - Applicability document: The YANG model(s) specified in this
    working group must be usable and extensible by the existing OAM
    technologies. This usability and extensibility must be demonstrated,
    for example with IP Ping, traceroute, BFD, and LSP Ping

So LIME is a generic YANG model for OAM that provides a common structure 
for various OAM technologies. The specific OAM technologies will 
_augment _ the generic model. "Augmenting", as opposed to the generic 
model "mapping to" the OAM technologies. This is a major difference with 
L3SM, and this is the reason why L3SM speaks of service YANG model, 
while LIME does not. I consider L3SM as the only WG in the IETF 
dedicated to a service YANG model.

However, quoting the charter again "This work will enable consistent 
configuration, reporting, and presentation for the OAM mechanisms used 
to manage the network, regardless of the layers and technologies": so, 
if we execute well, working with OAM across technologies will be greatly 
facilitated, providing some level of abstraction.

I hope that it clarifies the situation. If one of the LIME contributors 
didn't understand the charter this way, let me know.
I would like to evaluate if the LIME documents go in the right direction.

Regards, Benoit (OPS AD)

> .