Subject: Re: [Lime] Call for Adoption: draft-tissa-lime-yang-oam-model-06

From: Benoit Claise <[email-masked]>
Date: Fri, 4 Sep 2015 12:25:45 +0200

On 23/08/2015 04:43, Tom Taylor wrote:
> For the record, I support adoption of this document as a WG draft. 
> There are changes I want to see in it, but these can come about 
> through ordinary WG process. This is a first call, not a last call. 
Thanks Tom. This is an important point.
Adopting a document as WG item means that the WG considers it is a good 
basis for the WG deliverable. It also implies that the document now 
belongs to the WG, and the WG can and should improve it based on the 
group consensus. Greg's list of concerns could be the basis used in an 
issue tracker.

Regards, Benoit
> As to the points Greg puts forward below, I think his subtext is that 
> if there is inconsistency between the LIME model and the work done in 
> the MPLS WG, it is the LIME model that has to change. Obviously there 
> is room for negotiation, but I believe the LIME charter gives LIME the 
> priority here.
>
> Tom Taylor
>
> On 21/08/2015 12:32 PM, Gregory Mirsky wrote:
>> I do not support adoption of this document as WG item.
>>
>> I believe that until Applicability of Generic YANG Data Model for layer
>> Independent OAM Management demonstrates that the proposed model indeed
>> is common among OAM technologies developed at IETF, e.g. IP, IP/MPLS,
>> MPLS-TP, and TRILL, beyond just YANG customization mechanisms adopting
>> this draft as WG item is premature. And the applicability document has
>> not demonstrated that yet as you can see from the attached comments to
>> the  Applicability of the draft-tissa-lime-yang-oam-model and couple
>> more generic notes:
>>
>>   * Operations, Administration and Maintenance address Fault Management
>>     and Performance Monitoring of the FCAPS. If the scope of the
>>     document does not include both then I suggest not to refer to is as
>>     OAM but perhaps On-demand Continuity Check and Connectivity
>>     Verification, i.e. ping and traceroute, Common YANG model;
>>   * section 4 is more about general YANG extensibility than of the
>>     proposed OAM YANG data model;
>>   * IP/MPLS OAM not being separated from MPLS-TP OAM;
>>   * Performance Monitoring arbitrary being left outside the scope for
>>     some technologies, e.g. Ethernet;
>>   * often Service OAM being presented as Transport OAM, e.g. VPLS, NVO3.
>>
>> Regards,
>>
>>          Greg
>>
>> *From:*Lime [mailto:[email-masked]] *On Behalf Of *Carlos
>> Pignataro (cpignata)
>> *Sent:* Saturday, August 08, 2015 1:12 PM
>> *To:* [email-masked]
>> *Cc:* [email-masked]
>> *Subject:* [Lime] Call for Adoption: draft-tissa-lime-yang-oam-model-06
>>
>> LIME,
>>
>>
>> This email starts a two-week poll on
>> adopting draft-tissa-lime-yang-oam-model-06 [1] as a LIME working group
>> item.
>>
>> Please send comments to the list and state if you support adoption
>> or not (in the later case, please also state the reasons).
>>
>> This poll runs until ** August 24th, 2015 **.
>>
>> We are also polling for knowledge of any IPR that applies to this draft,
>> to ensure that IPR has been disclosed in compliance with IETF IPR rules
>> (see RFCs 3979, 4879, 3669 and 5378 for more details).
>>
>> *If you are listed as a document author or contributor*, please respond
>> to this email and indicate whether or not you are aware of any 
>> relevant IPR.
>>
>> The draft will not be adopted until a response has been received from
>> each author and contributor.
>>
>> If you are not listed as an author or contributor, then
>> please explicitly respond only if you are aware of any IPR that has
>> not yet been disclosed in conformance with IETF rules.
>>
>> Thank you,
>>
>> Ron Bonica / Carlos Pignataro
>> LIME co-chairs
>>
>> [1] http://datatracker.ietf.org/doc/draft-tissa-lime-yang-oam-model/
>>
>>
>>
>> _______________________________________________
>> Lime mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/lime
>>
>
> _______________________________________________
> Lime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lime
> .
>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 7 Sep 2015 02:39:25 +0000

Hi, Mahesh,

Please find one comment inline.

> On Aug 26, 2015, at 9:56 PM, Qin Wu <[email-masked]> wrote:
> 
> Hi, Mahesh:
> -----邮件原件-----
> 发件人: Lime [mailto:[email-masked]] 代表 Mahesh Jethanandani
> 发送时间: 2015年8月27日 5:11
> 收件人: Tom Taylor
> 抄送: [email-masked]; [email-masked]
> 主题: Re: [Lime] Call for Adoption: draft-tissa-lime-yang-oam-model-06
> 
> [Adding BFD mailing list back because this decision affects them]
> 
> Tom,
> 
> I was hoping for a rational that went beyond  “and you shall …”

In addition to what Qin said below, the main rational is to provide higher-level abstractions, beyond the specifics of configuring individual protocols.

Thanks,

— Carlos, as individual.

> 
> Something along the lines of why /lime/bfd is better than /lime -> /bfd. Or why almost all configuration models for BFD that currently work just fine, now have to start supporting CFM like semantics in Maintenance Domain (MD), Maintenance Association (MA) or Maintenance Endpoint (MEP) configuration to realize a BFD session.
> 
> You might find a similar discussion around the devices YANG model germane to this thought process. In particular, the thread titled "issue Y34 - root node" on the netmod mailing list.
> 
> [Qin]: See
> http://www.ietf.org/mail-archive/web/netmod/current/msg12986.html
> http://www.ietf.org/mail-archive/web/netmod/current/msg13113.html
> 
> What device YANG model is applied to this WG is about the following substructure:
>     +--rw device
>          +--rw logical-network-elements
>                +--rw networking-instances
>                   +--rw networking-instance* [networking-instance-name]
>                      +--rw oam-protocols
>                      |  +--rw bfd
>                      |  +--rw cfm
>                      |  +--rw twamp
> Rather than the example quoted in Y-34 (http://www.ietf.org/mail-archive/web/netmod/current/msg12986.html)
>   +--rw device
>          +--rw info
>          |  +--rw device-type?   enumeration
>          +--rw hardware
>          +--rw interfaces
>          |  +--rw interface* [name]
>          |     ...
>          +--rw qos
> 
> So In my understanding, device model is more focusing on discussing organizing different type of models in a
>  comprehensive structure. For the same type of models(e.g., OAM type), we can find common structure to make different technology specific OAM models with same type (i.e.,OAM type)work together. The relationship between these models are described as several models are extension to one base model.
> 
> The debate on Y-34 is about whether we should add new top level node (device) on top of another existing top level node(e.g., interface). Device and interface are of two different types,
> 
> One interesting proposal raised by Lada in http://www.ietf.org/mail-archive/web/netmod/current/msg12986.html is:
> "Extend YANG so that a *specific* schema tree can be grafted at a given data node."
> One example given by Lada in the discussion is:
> "
> I believe there are other use cases in the existing modules. For
> example, the ietf-routing module could simply define the data model for
> a single routing instance (i.e. without "routing-instance" list at the
> top), and it can be then used without changes on simple devices, and
> more complex router implementations can graft it as a subtree under
> "routing-instance", "networking-instance" or whatever.
> 
> "
> I think this is something more relevant to what we are doing. I think we should consider to take this approach.
> 
> Cheers.
> 
>> On Aug 24, 2015, at 6:10 PM, Tom Taylor <[email-masked]> wrote:
>> 
>> It comes from making the making the draft Standards Track. If you claim to implement the ultimate RFC, this is a logical consequence, just as for any other Standards Track RFC.
>> 
>> Tom Taylor
>> 
>> On 24/08/2015 8:41 PM, Mahesh Jethanandani wrote:
>>> Agree with Greg.
>>> 
>>> I have particular concern about this statement in the draft:
>>> 
>>> All implementations that follow the YANG framework presented in this
>>>   document MUST implement the generic YANG model presented here.
>>> 
>>> 
>>> This seems to stipulate a requirement that neither YANG as a language
>>> nor any existing technology requires, except maybe CFM itself. Where
>>> is this stipulation coming from and why is it a MUST?
>>> 
>> 
> Mahesh Jethanandani
> [email-masked]

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 7 Sep 2015 02:39:35 +0000

Hi, Qin,

Please see inline — with apologies for the delay.

> On Aug 25, 2015, at 10:38 PM, Qin Wu <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hi, All:
> Do we poll for adoption on draft-tissa-lime-yang-oam-model-06? Do we poll for adoption on draft-zhuang-lime-yang-oam-model-applicability?
> I became a little confused by  this call now.

Since you ask, this is a poll for draft-tissa-lime-yang-oam-model-06. This model is a portion of the LIME set of goals, and is interrelated to other documents and not a fully independent entity.

Ultimately, our collective higher goal, and what we should focus on, is to drive the complete set of LIME goals and milestones — in particular, a YANG model that is not applicable or used is not what we are after.

At the same time, we need to as a WG figure out the best way to untangle dependencies to advance appropriate chunks.

> As LIME charter said:
> “
> Goals and Milestones:
>   Feb 2015 - Adopt the WG draft on YANG data model(s)
>   Aug 2015 - Adopt the WG draft for Applicability of the generic model
> ”

As co-chair, I’d like to drive the higher WG goal, in addition to driving the specific milestones. Either of this documents does not make sense, ultimately, as an RFC, without the other.

> LIME YANG model should be developed before Applicability document work item based on Charter said. The key reason for this order is without knowing what LIME base model look like, how do we know how to apply LIME YANG model to various technologies.
> 

Thanks, Qin. All pieces of technical discussion help.

— Carlos.

> LIME YANG model and Applicability document are completely two separated two work items.
> draft-zhuang-lime-yang-oam-model-applicability was just called out just before Prague meeting to show an example on what Applicability document looks like when Chairs called for progress on Applicability document before IETF93. In Prague, draft-zhuang-lime-yang-oam-model-applicability was presented and got a lot of discussion, the most of important goal of discussing draft-zhuang-lime-yang-oam-model-applicability is to seek the opinion on the scope of LIME applicability rather than contents of LIME Applicability document.
> 
> Yes, LIME Applicability document is not perfect since it is just a infant and hasn’t grown up, please be patient and give it some time,e.g., section 4 needs to be rewritten to focus on how to extend base model to support different OAM technologies, we can discuss this,
> Yes, IP/MPLS OAM needs to be separated from MPLS-TP OAM in the Applicability draft.
> Yes, Fault Management and Performance monitoring are two important aspects,  Ethernet section need to cover performance measurement based on Y.1731 in the Applicability draft. in Prague meeting, we discussed both  Fault management and performance monitoring separately in one joint session, but our proposal is not to separate performance monitoring from LIME base model, we just leave it in the separate draft for now and we can put it back if the WG has consensus. So all of these are something we can be fixed in the applicability document. It is useful input to shape the scope of Applicability document not LIME base model.
> 
> -Qin
> 发件人: Lime [mailto:[email-masked] <mailto:[email-masked]>] 代表 Zhuangyan (Yan)
> 发送时间: 2015年8月25日 10:18
> 收件人: Gregory Mirsky; [email-masked] <mailto:[email-masked]>
> 抄送: Carlos Pignataro (cpignata)
> Hi Greg and all,
> “And the applicability document has not demonstrated that yet as you can see from the attached comments and couple more generic notes:
> Operations, Administration and Maintenance address Fault Management and Performance Monitoring of the FCAPS. If the scope of the document does not include both then I suggest not to refer to is as OAM but perhaps On-demand Continuity Check and Connectivity Verification, i.e. ping and traceroute, Common YANG model;
> section 4 is more about general YANG extensibility than of the proposed OAM YANG data model;
> IP/MPLS OAM not being separated from MPLS-TP OAM;
> Performance Monitoring arbitrary being left outside the scope for some technologies, e.g. Ethernet;
> often Service OAM being presented as Transport OAM, e.g. VPLS, NVO3.”
> 
> [Yan] Thanks for your general comments and input on Applicability document (the relevant draft is draft-zhuang-lime-yang-oam-model-applicability), we are happy to address these in the update of applicability document.
> Other's contribution to applicability document are also welcome.
> 
> Regards,
>         Greg
> 
> From: Lime [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Carlos Pignataro (cpignata)
> Sent: Saturday, August 08, 2015 1:12 PM
> To: [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>
> Subject: [Lime] Call for Adoption: draft-tissa-lime-yang-oam-model-06
> 
> LIME,
> 
> This email starts a two-week poll on adopting draft-tissa-lime-yang-oam-model-06 [1] as a LIME working group item.
> 
> Please send comments to the list and state if you support adoption or not (in the later case, please also state the reasons).
> 
> We are also polling for knowledge of any IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
> 
> *If you are listed as a document author or contributor*, please respond to this email and indicate whether or not you are aware of any relevant IPR.
> 
> The draft will not be adopted until a response has been received from each author and contributor.
> 
> If you are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.
> 
> Thank you,
> 
> [1] http://datatracker.ietf.org/doc/draft-tissa-lime-yang-oam-model/ <http://datatracker.ietf.org/doc/draft-tissa-lime-yang-oam-model/>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 7 Sep 2015 02:39:45 +0000

Hi, LIME,

The goal of this email is to provide an update on the call-for-adoption of draft-tissa-lime-yang-oam-model-06, and share a couple of associated notes:
We have now received an IPR statements from all Authors and Contributors (the last one from Tissa), all of which were copied to the LIME list.
We have also implicitly extended this Call for Adoption, to allow not only for all IPR disclosures to arrive, but also for technical discussion to happen.
We have now closed the lime-oam-model Mailing list, as the DT work finished.

Looking forward, we will extend the call for adoption a few more days, to allow for any final comments and discussions. Technical arguments are particularly encouraged!

Thanks,

— Carlos & Ron.