Subject: [lisp] Request to LISP working group for GB-LISP ATN use cases to facilitate its adoption in ICAO.

From: HAINDL Bernhard <[email-masked]>
Date: Fri, 25 Mar 2022 11:01:41 +0000

After a few aisle conversations following Tuesday’s GB-LISP presentation, here is a revised list of asks to the LISP WG:

•        Bring RFC 6830 and RFC 6833 to Standard Track (pending since more than 400 days).
o   The aviation community needs standards for LISP Control and Data plane protocols. The lack of these standards is currently a major risk for GB-LISP
•        “Publish/Subscribe Functionality for LISP” - > Move from Experimental to Standards Track
o   More details on some pubsub operations – what happens with subscription after deregistration, explicit selective unsubscription, wildcard subscription and unsubscription
•        Include network mobility features to draft-ietf-lisp-eid-mobility
o   Add network mobility support – flag network prefixes as fixed or mobile to automatic remove all longer sub-prefixes inside the mapping system
•        Transport more information inside LISP
o   4D trajectory snapshot = timestamp (in seconds) + aircraft 3D coordinates
o   Digital signature from the aircraft for the AGMI Request message
o   “Suggest” messages on foreign report received instead of direct deregistration of a foreign link -> “Solicit Deregistration”

Regards
Bernhard

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 25 Mar 2022 12:34:33 -0700

> After a few aisle conversations following Tuesday’s GB-LISP presentation, here is a revised list of asks to the LISP WG:

I was going to summarize your asks after hearing them this week. But I'm glad you beat me to it and refined them a bit. See comments inline.

> •        Bring RFC 6830 and RFC 6833 to Standard Track (pending since more than 400 days).

Yes, we are working hard on these. And now its a process issue out of the hands of the working group. I believe the chairs are keeping close watch on this.

But I think you can count on them being standards. The question is when.

> o   The aviation community needs standards for LISP Control and Data plane protocols. The lack of these standards is currently a major risk for GB-LISP

Your message was clear about that and we will do whatever we can to get you there.

> •        “Publish/Subscribe Functionality for LISP” - > Move from Experimental to Standards Track

I support this request. I have an implemenation of the latest PubSub and put in specific features for the ATN use case.

> o   More details on some pubsub operations – what happens with subscription after deregistration, explicit selective unsubscription, wildcard subscription and unsubscription

Well since the subscription state is stored in the map-server for the registration, when the registration goes away there will be no more Map-Notifies going to the subscribers. Except for the last one when the RLOC-set goes from its current state to an empty RLOC-set (since the deregistration indicates to remove the entire EID entry).

What do you mean by your last two points "explicit selective unsubscription" and "wildcard …". Are you asking what happens to these subscription types when a deregitration occurs?

> o   Add network mobility support – flag network prefixes as fixed or mobile to automatic remove all longer sub-prefixes inside the mapping system

I know two implementations that already do this. Maybe we haven't spec'ed it well, please confirm. But when a host EID is dynamically learned, the xTR can be configured to register a network prefix instead of the host EID.

> o   “Suggest” messages on foreign report received instead of direct deregistration of a foreign link -> “Solicit Deregistration”

Look at the functionality that draft-kowal-lisp-policy-distribution-02 is spec'ing. Using JSON-formatted RLOC encodings, you can encode the attributes you list above. We can do digital signatures for Map-Requests and Map-Registers. Did you need it for another LISP packet type?

Please explain your last bullet in more detail so we can get a better understanding about the functionality you are requesting.

Thanks for sending this email,
Dino