Subject: [lisp] Comments on draft-ietf-lisp-eid-mobility-09 from the LISP WG presentation

From: Dino Farinacci <[email-masked]>
Date: Tue, 22 Mar 2022 06:17:11 -0700

I know I made a comment previously about this that we should use the site-id for this purpose but a discussion came up about electing a DF per VLAN hence why I think the ES-ID is being introduced.

If we want the DF to be per MAC EID, then the ES-ID would need to be included in the EID-record and not the Map-Register message format. But I don't support this. The cost for changing this is too great for the benefit IMO. Since LISP is primarily used for L3 overlays, the extra cost of 32-bits per EID for EVERY message is not merited.

I think we should stay with using the site-id where the DF is elected per site for ALL VLANs. We still get L2 overlay broadcast/multicast loop-free functionality and there are no packet changes (and complexities with moving bis documents to standards track).

Dino

---

From: "Marc Portoles Comeras (mportole)" <[email-masked]>
Date: Tue, 22 Mar 2022 17:31:16 +0000

Dino,

I believe we discussed this last time but, with the new perspective, couldn’t we just use the pair <IID, site-ID> to at least get per VLAN granularity in some of these decisions.
We get the same benefits: no impact on the bis document, and some extra granularity in the choice of DF or more detail when implementing split horizon on the xTRs.

And just to complete the story. When we use site-IDs this means that:

  *   An EID registered with the same site-ID (and merge-bit) from different xTRs is merged. If site-IDs differ this is considered a move.
  *   For “discovery” purposes in multihomed groups: An L2 EID registered from one xTR and a specific site-ID, needs to be notified to all xTRs that are using that same site-ID

Thanks,
Marc

From: lisp <[email-masked]> on behalf of Dino Farinacci <[email-masked]>
Date: Tuesday, March 22, 2022 at 6:17 AM
To: [email-masked] list <[email-masked]>
Subject: [lisp] Comments on draft-ietf-lisp-eid-mobility-09 from the LISP WG presentation

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 22 Mar 2022 11:36:21 -0700

> I believe we discussed this last time but, with the new perspective, couldn’t we just use the pair <IID, site-ID> to at least get per VLAN granularity in some of these decisions.

Yes, that would work better since the site-ID is in the Map-Register (where you need the xTR distinction) and the IID is in the EID encoding of the EID-record where you need the VLAN association. So this is ideal. 

> We get the same benefits: no impact on the bis document, and some extra granularity in the choice of DF or more detail when implementing split horizon on the xTRs.

Right. Agree.

> 	• An EID registered with the same site-ID (and merge-bit) from different xTRs is merged. If site-IDs differ this is considered a move.

Correct. But you have to deal with misconfiguration so 2 xTRs at the same site advertising a different site-ID doesn't look like a move. So the xTR-ID needs to be checked as well.

> 	• For “discovery” purposes in multihomed groups: An L2 EID registered from one xTR and a specific site-ID, needs to be notified to all xTRs that are using that same site-ID

You have to keep a list of xTR-IDs for a merged registration over time. And the list is cleared when a new xTR-ID is discovered with a different site-ID. Right?

Dino

---

From: "Marc Portoles Comeras (mportole)" <[email-masked]>
Date: Tue, 22 Mar 2022 22:18:21 +0000

>Correct. But you have to deal with misconfiguration so 2 xTRs at the same site advertising a different site-ID doesn't look like a move. So the xTR-ID needs to be checked as well.

Perfect, let me add this to the updated version

>You have to keep a list of xTR-IDs for a merged registration over time. And the list is cleared when a new xTR-ID is discovered with a different site-ID. Right?

Agree. I’ll also clarify this point in the updated version

Thanks!
Marc

From: Dino Farinacci <[email-masked]>
Date: Tuesday, March 22, 2022 at 11:36 AM
To: Marc Portoles Comeras (mportole) <[email-masked]>
Cc: [email-masked] list <[email-masked]>
Subject: Re: [lisp] Comments on draft-ietf-lisp-eid-mobility-09 from the LISP WG presentation

Right. Agree.

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 22 Mar 2022 15:31:46 -0700

Oh that is great. What do others in the WG think?

Dino

> On Mar 22, 2022, at 3:18 PM, Marc Portoles Comeras (mportole) <[email-masked]> wrote:
> 
>