Subject: [LOOPS] Narrowing the scope: (1) Encapsulation

From: Carsten Bormann <[email-masked]>
Date: Tue, 26 May 2020 00:35:14 +0200

In tomorrow’s LOOPS side meeting, we want to discuss whether we can narrow the initial scope of the WG sufficiently that the resulting charter looks more tractable (we can then recharter after delivering on the initial scope).

One source of complexity of the current charter is that we want to embrace different encapsulation techniques.  But maybe one is enough for the beginning?

Some objectives of this choice would be:
– encapsulation should have good consensus and be active in products (at least by 2021)
– easy deployment (e.g., UDP-based)
– reasonable overhead (but it seems current schemes don’t differ that much here)

Geneve (draft-ietf-nvo3-geneve-16, approved 2020-04-28, now in RFC editor queue), seems to fulfill these objectives.

Runner-ups:
– SRv6: This is lower in the stack and might get stuck in the IPv6 header wars
– GRE: Great established workhorse, but also a separate protocol lower in the stack:  Harder to deploy

The decision would not be to give up encapsulation-agnosticity, but to focus on one of them for now.

Comments are welcome on the list and/or in the meeting in ~16.5 hours.

Grüße, Carsten

---

From: <[email-masked]>
Date: Tue, 26 May 2020 07:21:59 +0000

Hi Cartsen, all, 

An approach that would avoid us to have to select an encap scheme (but still be applicable to any encap running over UDP) is the use of UDP options: https://tools.ietf.org/html/draft-ietf-tsvwg-udp-options-08. Unfortunately, that spec is not progressing as I expect. 

Cheers,
Med 

> -----Message d'origine-----
> De : LOOPS [mailto:[email-masked]] De la part de Carsten
> Bormann
> Envoyé : mardi 26 mai 2020 00:35
> À : [email-masked]
> Objet : [LOOPS] Narrowing the scope: (1) Encapsulation
> 
> In tomorrow’s LOOPS side meeting, we want to discuss whether we can
> narrow the initial scope of the WG sufficiently that the resulting
> charter looks more tractable (we can then recharter after delivering
> on the initial scope).
> 
> One source of complexity of the current charter is that we want to
> embrace different encapsulation techniques.  But maybe one is enough
> for the beginning?
> 
> Geneve (draft-ietf-nvo3-geneve-16, approved 2020-04-28, now in RFC
> editor queue), seems to fulfill these objectives.
> 
> Runner-ups:
> --
> LOOPS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/loops