Subject: [lp-wan] hardware for IP over lp-wan?

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 5 Feb 2016 15:46:50 +0100

Hi,

Are there some small LP-WAN interfaces or modules that run on linux or 
are compatible with linux?

LP-WAN (low power wide-area networking?) is a promising technology for 
communicating applications embedded in consumer devices or other 
assets.  It is being considered by NB IoT at 3GPP (Narrow-Band IoT), 
among others.  Some operators exist: SigFox, Neul.

In automobile communications LP-WAN may be relevant for applications 
such as tracking after a steal event.  Today this uses VHF or UHF (very 
or ultra high frequency modulation) penetrating underground hideouts, 
effectively a "low power" and "long range" requirement.  Also, some 
vehicles are equipped with simple GPRS modules running IP.

These VHF/UHF or GPRS are small modules, some 3G/USBnet IPv6 routers 
being as small as 16x26x3mm.  They can run linux and IPv6.

Are there some small LP-WAN interfaces or modules that run on linux or 
are compatible with linux?

Thanks,

Alex

---

From: Alexander Pelov <[email-masked]>
Date: Sun, 7 Feb 2016 23:35:44 +0100

Dear Alexandre,

Depending on the technology you’re using, you’ll find different vendors of hardware devices that will allow you to run your prototypes.

For SemTech LoRa, we’ve been using Arduino-compatible shields from Wi6Labs (open-source, branded as FroggyFactory): http://www.froggyfactory.com/froggy/

They have a simple SPI bus, so you can plug them to a Raspberry PI (or something compatible). 

You have (many) more vendors of LoRa compatible devices. The same goes for SigFox. I’m not sure about the availability of other modules, but there should be some out there for sure.

Best,
Alexander

> Le 5 févr. 2016 à 15:46, Alexandre Petrescu <[email-masked]> a écrit :
> 
> Hi,
> 
> Are there some small LP-WAN interfaces or modules that run on linux or are compatible with linux?
> 
> LP-WAN (low power wide-area networking?) is a promising technology for communicating applications embedded in consumer devices or other assets.  It is being considered by NB IoT at 3GPP (Narrow-Band IoT), among others.  Some operators exist: SigFox, Neul.
> 
> In automobile communications LP-WAN may be relevant for applications such as tracking after a steal event.  Today this uses VHF or UHF (very or ultra high frequency modulation) penetrating underground hideouts, effectively a "low power" and "long range" requirement.  Also, some vehicles are equipped with simple GPRS modules running IP.
> 
> These VHF/UHF or GPRS are small modules, some 3G/USBnet IPv6 routers being as small as 16x26x3mm.  They can run linux and IPv6.
> 
> Are there some small LP-WAN interfaces or modules that run on linux or are compatible with linux?
> 
> Thanks,
> 
> Alex
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan