Subject: Re: [lp-wan] A non WG forming BoF at IETF 95?

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 15 Feb 2016 14:08:08 +0000

Dear all

I added an entry to request a non WG forming BoF at IETF 95 in Buenos Aires.

The text is found here: https://trac.tools.ietf.org/bof/trac/wiki/WikiStart

Feedback is welcome, and if you publish new documents or think of some existing reference that should be added, please let me know.

Cheers,

Pascal

---

From: Ari Keränen <[email-masked]>
Date: Tue, 16 Feb 2016 14:52:44 +0000

Hi,

Thanks for setting this up Pascal. Looking forward to the BoF.

I noticed the BoF description currently says "Low-Power Wide Area Networks (LP-WAN) are long range Lowpower Lossy Networks operating in license-exempt bands". The "license-exempt" part seems to unnecessarily restrict the scope of discussion, ruling out e.g., cellular technologies. I'd suggest we simply remove that part from the description.

Also, please add T2TRG to the conflict list.

Thanks,
Ari

> On 15 Feb 2016, at 16:08, Pascal Thubert (pthubert) <[email-masked]> wrote:
> 
>  
> Dear all
>  
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 16 Feb 2016 16:31:07 +0100

Hello,

Le 16/02/2016 15:52, Ari Keränen a écrit :
> I noticed the BoF description currently says "Low-Power Wide Area
> Networks (LP-WAN) are long range Lowpower Lossy Networks operating
> in license-exempt bands".

What is long-range lowpower? It sounds illogic.

By definition the lower the power the shorter the range.

Maybe long-range low-bandwidth?

> The "license-exempt" part seems to unnecessarily restrict the scope
> of discussion, ruling out e.g., cellular technologies. I'd suggest we
> simply remove that part from the description.

I think cellular technologies like 4G have nothing new to talk about at 
IETF (maybe in the 5gangip email list?).

I would be more interested in a license-exempt domain because there 
would be more users who could develop open source software and test, the 
hardware to test would be cheap, and there would be no need of SIM card 
with a monthly plan to pay.

In a licensed domain the source code would be closed, hardware would be 
expensive and a SIM card would be needed to play with.

Alex

> Thanks, Ari
>> The text is found here:
>> https://trac.tools.ietf.org/bof/trac/wiki/WikiStart
>>
>> Feedback is welcome, and if you publish new documents or think of
>> some existing reference that should be added, please let me know.
>>
>> Cheers,
>>
>> Pascal _______________________________________________ lp-wan
>> mailing list [email-masked]
> _______________________________________________ lp-wan mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/lp-wan
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 16 Feb 2016 16:39:50 +0100

> Also, please add T2TRG to the conflict list.

It may also be worth pointing out that much of the COOL work that was
presented to T2TRG was motivated by what I'm calling "millibit" networks
-- networks that have so little capacity per node that the sustained
throughput is measured in millibit/second (e.g., the current values for
Sigfox seem to be: 150 mbit/s up, 3 mbit/s down).

Many LP-WAN proposals are essentially millibit networks.

Grüße, Carsten

---

From: Ari Keränen <[email-masked]>
Date: Tue, 16 Feb 2016 15:57:30 +0000

Hi Alexandre,

On 16 Feb 2016, at 17:31, Alexandre Petrescu <[email-masked]<mailto:[email-masked]>> wrote:
[...]

I think cellular technologies like 4G have nothing new to talk about at IETF (maybe in the 5gangip email list?).

Some new cellular technologies, e.g., NB-IoT are very interesting in this domain. For example, how can we manage networks with variety of LPWAN techs on licensed and license-exempt bands?

I would be more interested in a license-exempt domain because there would be more users who could develop open source software and test, the hardware to test would be cheap, and there would be no need of SIM card with a monthly plan to pay.

In a licensed domain the source code would be closed, hardware would be expensive and a SIM card would be needed to play with.

Also in licensed domain you can use open source in many parts of the system, the new cellular hardware for IoT use cases is going to be much simpler and cheaper than current modules in the market, and there are many options on how 3GPP credentials could be handled in the future.

Anyway, all I'm saying is that we should not restrict licensed band technologies out from the discussion at this stage.

Cheers,
Ari

---

From: Alexander Pelov <[email-masked]>
Date: Tue, 16 Feb 2016 17:09:26 +0100

Dear Ari,

Thanks for pointing this out! Indeed, it would be quite unfortunate to leave license-bands technologies out of the discussion. The licence-exempt bands impose for more stringent constraints (most notably the duty cycling restrictions), but I don’t see why we should not consider cases where these restrictions are not applicable.

In any case, it would seem to me that what we should be considering is mostly the relevant repercussions from the L2 technologies to the IETF stack. 

How about if we add the clarification that the gap analysis should cover LP-WANs based on technologies working in licence-exempt frequencies, licensed frequencies, or both?

Best,
Alexander 

> Le 16 févr. 2016 à 16:57, Ari Keränen <[email-masked]> a écrit :
> 
> Hi Alexandre,
> 
>> On 16 Feb 2016, at 17:31, Alexandre Petrescu <[email-masked] <mailto:[email-masked]>> wrote:
> [...]
>>>

---

From: Ari Keränen <[email-masked]>
Date: Tue, 16 Feb 2016 16:19:12 +0000

Hi Alexander,

On 16 Feb 2016, at 18:09, Alexander Pelov <[email-masked]<mailto:[email-masked]>> wrote:

Dear Ari,

Exactly. I think we could take the constraints due to licence-exempt band (e.g., duty cycling) simply as one class of constraints among others and hence cover both cases.

Both should be covered; and I think the simplest thing for now would be dropping the "license-exempt" part from the BoF description so that folks who are interested also in licensed band technologies don't think they are not in scope.

Cheers,
Ari

Le 16 févr. 2016 à 16:57, Ari Keränen <[email-masked]<mailto:[email-masked]>> a écrit :

Hi Alexandre,

Cheers,
Ari
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 16 Feb 2016 17:24:59 +0100

Le 16/02/2016 17:19, Ari Keränen a écrit :
>> Thanks for pointing this out! Indeed, it would be quite unfortunate to
>> leave license-bands technologies out of the discussion. The
>> licence-exempt bands impose for more stringent constraints (most
>> notably the duty cycling restrictions), but I don’t see why we should
>> not consider cases where these restrictions are not applicable.
>
> Exactly. I think we could take the constraints due to licence-exempt
> band (e.g., duty cycling) simply as one class of constraints among
> others and hence cover both cases.
>
>> In any case, it would seem to me that what we should be considering is
>> mostly the relevant repercussions from the L2 technologies to the IETF
>> stack.
>>
>> How about if we add the clarification that the gap analysis should
>> cover LP-WANs based on technologies working in licence-exempt
>> frequencies, licensed frequencies, or both?
>
> Both should be covered; and I think the simplest thing for now would be
> dropping the "license-exempt" part from the BoF description so that
> folks who are interested also in licensed band technologies don't think
> they are not in scope.

It is a good intention that I can agree with - for now keep all together 
with respect to frequency licensing.

Please let me clarify just these points:

- do I need a SIM card in order to run lp-wan?
   Or can I run lp-wan w/o SIM card?

- what is the longest range I can achieve with a lp-wan hardware
   without needing a SIM card?

Yours,

Alex

>
>
> Cheers,
> Ari
>
>>
>>> Le 16 févr. 2016 à 16:57, Ari Keränen <[email-masked]
>>> <mailto:[email-masked]>> a écrit :
>>>
>>> Hi Alexandre,
>>>
>>>> On 16 Feb 2016, at 17:31, Alexandre Petrescu
>>>> <[email-masked] <mailto:[email-masked]>>
>>>> wrote:
>>> [...]
>>>>>
>>>> I think cellular technologies like 4G have nothing new to talk about
>>>> at IETF (maybe in the 5gangip email list?).
>>>
>>> Some new cellular technologies, e.g., NB-IoT are very interesting in
>>> this domain. For example, how can we manage networks with variety of
>>> LPWAN techs on licensed and license-exempt bands?
>>>
>>>> would be more users who could develop open source software and test,
>>>> the hardware to test would be cheap, and there would be no need of
>>>> SIM card with a monthly plan to pay.
>>>>
>>>> In a licensed domain the source code would be closed, hardware would
>>>> be expensive and a SIM card would be needed to play with.
>>>
>>> Also in licensed domain you can use open source in many parts of the
>>> system, the new cellular hardware for IoT use cases is going to be
>>> much simpler and cheaper than current modules in the market, and
>>> there are many options on how 3GPP credentials could be handled in
>>> the future.
>>>
>>> Anyway, all I'm saying is that we should not restrict licensed band
>>> technologies out from the discussion at this stage.
>>>
>>>
>>> Cheers,
>>> Ari
>>> [email-masked] <mailto:[email-masked]>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 16 Feb 2016 17:56:35 +0000

Hello Ari:

I made some changes accordingly;

Take care,

Pascal

> -----Original Message-----
> From: Ari Keränen [mailto:[email-masked]]
> Sent: mardi 16 février 2016 15:53
> To: Pascal Thubert (pthubert) <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [lp-wan] A non WG forming BoF at IETF 95?
> 
> Hi,
> 
> I noticed the BoF description currently says "Low-Power Wide Area Networks
> (LP-WAN) are long range Lowpower Lossy Networks operating in license-
> exempt bands". The "license-exempt" part seems to unnecessarily restrict
> the scope of discussion, ruling out e.g., cellular technologies. I'd suggest we
> > Feedback is welcome, and if you publish new documents or think of some
> existing reference that should be added, please let me know.
> >
> > Cheers,
> >
> > Pascal