Subject: [lp-wan] data aggregation in lpwan

From: "[email-masked]" <[email-masked]>
Date: Wed, 27 Apr 2016 15:10:38 +0800

Hi,folks

Considering the large-scale but small-sized information exchange in the IOT, in order to make the data generated by IOT devices transmission more efficient, we may need a data aggregation scheme in IOT. 
Consider this scenario: a home network may consist of many sensors, such as light sensor, meter, and fire detector, etc, each frame has very small payload(15 – 100 byte) and limit number of frames per day(10). IOT users need remote access these sensors for the easy management and safety of house. If initiate an internet transmission for every frame of each sensor, the payload must account very low percent of the whole frame(because of the IP header, MAC header and PHY header). 
So,IMO, several these small frame should be aggregated at the transmitter and de-aggregated by the receiver for more efficient.

Regards
Xiaowei Qin

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 27 Apr 2016 07:19:55 +0000

I completely buy the concept, Xiaowei.

For now, the app is hardwired in the LPWA device, even when it really acts as an app layer bridge.

Being able to plug and play would be fantastic but certainly quite complex to generalize. Not a low hanging fruit for us.

Are there papers/experiments going on?

Pascal

Le 27 avr. 2016 ? 09:11, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> a ?crit :

Hi,folks

Considering the large-scale but small-sized information exchange in the IOT, in order to make the data generated by IOT devices transmission more efficient, we may need a data aggregation scheme in IOT.
Consider this scenario: a home network may consist of many sensors, such as light sensor, meter, and fire detector, etc, each frame has very small payload(15 - 100 byte) and limit number of frames per day(10). IOT users need remote access these sensors for the easy management and safety of house. If initiate an internet transmission for every frame of each sensor, the payload must account very low percent of the whole frame(because of the IP header, MAC header and PHY header).
So,IMO, several these small frame should be aggregated at the transmitter and de-aggregated by the receiver for more efficient.

Regards
Xiaowei Qin
________________________________
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 27 Apr 2016 15:54:39 +0800

Hi，Pascal and folks
The follows are main two use case：
One use case is that several frames generated by one IOT device are aggregated into one IP packet. 
This use case suits none-real-time requirements scenario. Data generated by each IOT device can be stored temporarily at local cache, and then send with frame aggregation chain. 
The second use case is that several frames generated by some different IOT devices are aggregated into one IP packet. This use case suits real-time requirements scenario. Data generated by different IOT devices will be transmitted immediately with frame aggregation chain. 

I have been doing the work of frame aggregation for several years. In 2007, I did A-MPDU (Aggregation MAC Protocol Data Units) of WI-FI access point in HUAWEI(Based on 802.11n protocol). From 2012, I try to use frame aggregation to send IOT data. I have done several practical tests based on Crossbow sensors, and have some papers and experimental data. I will collect them and present them to you as soon as possible. 

Regards
Xiaowei Qin

From: Pascal Thubert (pthubert)
Date: 2016-04-27 15:19
To: [email-masked]
CC: lp-wan
Subject: Re: [lp-wan] data aggregation in lpwan
I completely buy the concept, Xiaowei.

Pascal

Le 27 avr. 2016 à 09:11, "[email-masked]" <[email-masked]> a écrit :

Hi,folks

Regards
Xiaowei Qin

[email-masked]