Subject: [lp-wan] proposed charter: comments please!

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 24 Apr 2016 10:09:03 +0000

6LPWA: "IPv6 over Low-Power Wide-Area networks".

Background/Introduction:
------------------------

A new generation of Low-power and Lossy Networks (LLNs) is emerging under the
generic name of Low-Power Wide-Area. Though a wide variety of technologies
is already proposed on the market, a number of common characteristics can be
gathered, which make these technologies unique and disruptive for wireless IOT
applications. Those common family traits include ultra-low bitrate, frames size,
and very rare transmissions to reach orders of magnitude longer range and
battery lifetime. 

Those benefits come at a price: the MAC-layer formats are optimized and very
specific to each individual technology. There is no network layer and the 
application is often hard wired to the MAC, leading to very silo'ed deployments,
managed, secured and operated individually. Migrating from one access technology
to another implies rebuilding the whole chain.

To unleash the full power of these new technologies and their new ecosystems,
there is a need to couple them with other ecosystems that will guarantee the 
interworking at the network layer and enable common components for management
and security, as well as shared application profiles. The IETF can contribute
by enabling IPv6/UDP/COAP to the devices, and propose technology to secure the
operations and manage the devices and their gateways.

Description of Working Group:
-----------------------------

The Working Group will focus on enabling IPv6 over LPWA, focusing on selected 1
to 3 technologies, and will leverage cross-participation with the related bodies
to ensure that real demands are being served and the proposed solutions are
applicable. 

The group will produce informational work describing LPWA technologies for IETF
consumption, best practice documents on using IETF technology in LPWA networks
directed to the selected partnering bodies, and new standards work to optimize
IPv6 operations to the device.

The WG will interface with other appropriate groups in the IETF Internet,
Operations and Management, and Security Areas.

Work Items:
-----------

The group will:

1. Produce an Informational document describing and relating existing LPWA
technologies. This document will highlight the common characteristics but will
not aim at providing a competitive analysis.

2. Produce requirements documents for security and management, highlighting
potential areas where IETF technologies may be leveraged; these documents may
eventually be published as Informational RFCs.

3. Produce Standard Track documents to enable the compression of IPv6 over LPWA.
Considering the extreme constraints, the work will focus on a generic YANG data
model to enable the compression, and related flows to install the related state
at the end compression points; the work will also include, for selected 
technologies, specific Standard Track documents to carry the required encoding
over the air.

4. Produce a document to enable the fragmentation of larger packets over LPWA,
either as a Best Practice leveraging existing technology, or as new Standard
Track document is that is deemed necessary.

---

From: Mischa Dohler <[email-masked]>
Date: Sun, 24 Apr 2016 11:30:09 +0100

Pascal, that has come a long way after our discussions right after my 
ETSI keynote on the death of Zigbee a few years back ... :)

The charter reads well. A few minor comments:
- replace "and propose technology" by "and propose technologies"or "and 
propose a technology"
- remove "1 to 3"
- replace "is that" by "if that"

Thanks and with kind regards,
Mischa.

______________________________________

Prof Mischa Dohler
Head, Centre for Telecom Research
Chair Professor, King's College London
Fellow & Distinguished Lecturer, IEEE
Board of Directors, Worldsensing
Editor-in-Chief, ETT & IoT

www.mischadohler.com
______________________________________

On 24/04/2016 11:09, Pascal Thubert (pthubert) wrote:
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Alexander Pelov <[email-masked]>
Date: Sun, 24 Apr 2016 13:16:48 +0200

Dear Mischa,

Thanks for the fast feedback! It is highly appreciated! Hope to meet you 
in Berlin for the next IETF!

One of the main comments of the BoF in BA was that we need to do focused 
work on no more than 3 LPWA technologies. I think we should reflect this 
in our DNA from the start. We don't want to boil the ocean.

For me, there are two main questions here
- Do we adopt the 6TiSCH way of addressing LPWAs?
- Do we like 6LPWA as a name of the group?

I vote yes for the two questions. The first was summarized by Ana and 
discussed in length during the past week. On the second one - 6LPWA 
provides visibility both to the IETF and to the outside world. It is 
different enough from 6LoWPAN so that we don't risk any confusions.

Best,
Alexander

Le 2016-04-24 12:30, Mischa Dohler a écrit :
> - replace "and propose technology" by "and propose technologies"or
> "and propose a technology"
> - remove "1 to 3"

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Sun, 24 Apr 2016 08:42:39 -0400

Hi all,

On Mischa's point of "1 to 3", even though I agree that this was the feedback from the group in BA, it reads a little strange.

How about removing "1 to 3" as suggested, but listing the three technologies that were identified as examples of the specific technologies we want to address?

- "... focusing on a limited number of selected technologies (e.g., TechA, TechB, TechC), and will leverage cross-participation..."

Best,

Juan Carlos

> On Apr 24, 2016, at 07:16, Alexander Pelov <[email-masked]> wrote:
> 
> Dear Mischa,
> 
> Thanks for the fast feedback! It is highly appreciated! Hope to meet you in Berlin for the next IETF!
> 
> One of the main comments of the BoF in BA was that we need to do focused work on no more than 3 LPWA technologies. I think we should reflect this in our DNA from the start. We don't want to boil the ocean.
> 
> I vote yes for the two questions. The first was summarized by Ana and discussed in length during the past week. On the second one - 6LPWA provides visibility both to the IETF and to the outside world. It is different enough from 6LoWPAN so that we don't risk any confusions.
> 
> Best,
> Alexander
> 
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 24 Apr 2016 13:50:08 +0000

Hello Mischa : )

Yes, we went through a lot, and that includes your eye-opener talk on LPWA years back in Lyon as well ; ) 

The major change is that we now figured that it would take more than scattered work in existing WGs (e.g. 6lo) to contribute efficiently to the rise of this technology. Will you join/help us, should we get this WG formed?

Thanks a bunch for the suggestions, I'll incorporate and repost.

Cheers,

Pascal

> -----Original Message-----
> From: lp-wan [mailto:[email-masked]] On Behalf Of Mischa Dohler
> Sent: dimanche 24 avril 2016 12:30
> To: [email-masked]
> Subject: Re: [lp-wan] proposed charter: comments please!
> 
> Pascal, that has come a long way after our discussions right after my ETSI
> keynote on the death of Zigbee a few years back ... :)
> 
> > A new generation of Low-power and Lossy Networks (LLNs) is emerging
> > under the generic name of Low-Power Wide-Area. Though a wide variety
> > of technologies is already proposed on the market, a number of common
> > characteristics can be gathered, which make these technologies unique
> > and disruptive for wireless IOT applications. Those common family
> > traits include ultra-low bitrate, frames size, and very rare
> > transmissions to reach orders of magnitude longer range and battery
> lifetime.
> >
> > Those benefits come at a price: the MAC-layer formats are optimized
> > and very specific to each individual technology. There is no network
> > layer and the application is often hard wired to the MAC, leading to
> > very silo'ed deployments, managed, secured and operated individually.
> > Migrating from one access technology to another implies rebuilding the
> whole chain.
> >
> > To unleash the full power of these new technologies and their new
> > ecosystems, there is a need to couple them with other ecosystems that
> > will guarantee the interworking at the network layer and enable common
> > components for management and security, as well as shared application
> > profiles. The IETF can contribute by enabling IPv6/UDP/COAP to the
> > devices, and propose technology to secure the operations and manage the
> devices and their gateways.
> >
> > The Working Group will focus on enabling IPv6 over LPWA, focusing on
> > selected 1 to 3 technologies, and will leverage cross-participation
> > with the related bodies to ensure that real demands are being served
> > and the proposed solutions are applicable.
> >
> > The group will produce informational work describing LPWA technologies
> > for IETF consumption, best practice documents on using IETF technology
> > in LPWA networks directed to the selected partnering bodies, and new
> > standards work to optimize
> > The WG will interface with other appropriate groups in the IETF
> > Internet, Operations and Management, and Security Areas.
> >
> > Work Items:
> > -----------
> >
> > The group will:
> >
> > 1. Produce an Informational document describing and relating existing
> > LPWA technologies. This document will highlight the common
> > characteristics but will not aim at providing a competitive analysis.
> >
> > 2. Produce requirements documents for security and management,
> > highlighting potential areas where IETF technologies may be leveraged;
> > these documents may eventually be published as Informational RFCs.
> >
> > Considering the extreme constraints, the work will focus on a generic
> > YANG data model to enable the compression, and related flows to
> > install the related state at the end compression points; the work will
> > also include, for selected technologies, specific Standard Track
> > documents to carry the required encoding over the air.
> >
> > 4. Produce a document to enable the fragmentation of larger packets
> > over LPWA, either as a Best Practice leveraging existing technology,
> > or as new Standard Track document is that is deemed necessary.
> >
> >
> >
> >
> >

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 25 Apr 2016 10:28:30 -0500

Hi Pascal,

Thanks for posting the charter.
Reading it, I could not see the analogy with 6tisch.6tisch was based
on a synchronous MAC layer which needed special work in IP layer.
While in lpwan, the technologies to be considered do not seem to have
similar requirements.

Regards,

Behcet

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 25 Apr 2016 15:50:46 +0000

Hello Behcet:

Certainly LPWA is radically different from what we have today in groups like 6lo and 6TiSCH, and the proposed charter indicates ample room for a separate WG. If an analogy is to be found with 6TiSCH, that would be on the principles to:

>  introduce new technologies to the IETF 
>  work with external bodies leveraging cross-participation
>  form a nexus where the problem space coming from outside of the IETF meets a solution space distributed over multiple IETF WGs,
>  seek for best practice work at least as much as new std track work.

Cheers,

Pascal

> From: lp-wan [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
> Sent: lundi 25 avril 2016 17:29
> To: Pascal Thubert (pthubert) <[email-masked]>
> Cc: [email-masked]
> Reading it, I could not see the analogy with 6tisch.6tisch was based on a
> synchronous MAC layer which needed special work in IP layer.

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 25 Apr 2016 11:03:51 -0500

Hello Pascal,

>>  seek for best practice work at least as much as new std track work.

Hope these are convincing to IETF.

Regards,

Behcet