Subject: [lp-wan] IP LP-WAN capable routers

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 4 Apr 2016 19:12:05 -0300

Hello LP-WANers,

I am interested in the use of IP-over-LP-WAN because we need an IP 
router which has an LP-WAN interface on one side and a 6Lo interface on 
the other side.

This is to be able to do remote software update to manage multiple 6Lo 
sensors via a single LP-WAN connection.

The topology considered by LP-WAN seems to be star:

         O   O
      O    +    O       Legend: O is a LP-WAN device
         O   O

whereas what we need is:

    o     O   O
      oO    +    O      Legend: o is a 6LO device connected to a LP-WAN 
device
    o     O   O

Alex

---

From: "weigengyu" <[email-masked]>
Date: Tue, 5 Apr 2016 22:26:01 +0800

Hi,

At the LP-WAN interface, one possible solution is  
1 keep a mapping beween each IPv6 address and the node’s L2 address plus one byte;
2 have dummy network layer (IPv6) and transport layer (UDP); 
3 Put CoAP directly over L2frame.

It is similar to application protocol over data link layer protocol.
And such a means was used in communication over some low rate wired links.
The difference is each node of LP-WAN has an IPv6 address which is tightly related to its L2address plus one-byte. 

Regards, 

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Alexandre Petrescu 
Sent: Tuesday, April 05, 2016 6:12 AM
To: [email-masked] 
Subject: [lp-wan] IP LP-WAN capable routers

Hello LP-WANers,

I am interested in the use of IP-over-LP-WAN because we need an IP router which has an LP-WAN interface on one side and a 6Lo interface on the other side.

This is to be able to do remote software update to manage multiple 6Lo sensors via a single LP-WAN connection.

        O   O

whereas what we need is:

   o     O   O
     oO    +    O      Legend: o is a 6LO device connected to a LP-WAN device
   o     O   O

Alex

--------------------------------------------------------------------------------
_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 5 Apr 2016 17:52:38 -0300

Hi,

> 1 keep a mapping beween each IPv6 address and the node’s L2 address plus

YEs, that is a Neighbor Cache.  What is the one byte supplementary 
dedicated to?

> 2 have dummy network layer (IPv6) and transport layer (UDP);

I propose to have network layer IPv6.  In the gateway UDP may not be 
needed, because the gateway may just forward packets.

> 3 Put CoAP directly over L2frame.

That is possible.  Another possibility is to put CoAP on IP packets 
which sit on L2frame.

> The difference is each node of LP-WAN has an IPv6 address which is
> tightly related to its L2address plus one-byte.

I think we should have all 40bytes of an IPv6 header, not just one byte.

Alex

> *From:* Alexandre Petrescu <mailto:[email-masked]>
> *Sent:* Tuesday, April 05, 2016 6:12 AM
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [lp-wan] IP LP-WAN capable routers
> Hello LP-WANers,
>
> ------------------------------------------------------------------------