Subject: Re: [lp-wan] Proposed charter v3

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Tue, 26 Apr 2016 04:11:17 +0000

Pascal / All,

> 1. Produce an Informational document describing and relating existing LPWA
technologies. This document will highlight the common characteristics but will
not aim at providing a competitive analysis.

I realize IETF is in no position to compare and/or promote a specific access technology, but it is important to characterize a given access technology. In that sense, there should be room for publishing measurement data on system/radio performance as informational specs. At some points coexistence of various LPWAN technologies in unlicensed bands will be the major issue and the problem will only get worse as the noise in the channels goes up with the technology adoption.  This measurement data/reports from IETF community will be useful to drive/recommend approaches to SDO's such LBT, or other modes of peaceful coexistence of various LPWAN technologies.

My suggestion is to allow such work under work item#1.

Comments ?

Sri

From: lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>
Date: Sunday, April 24, 2016 at 9:03 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [lp-wan] Proposed charter v3

6LPWA: "IPv6 over Low-Power Wide-Area networks".

Background/Introduction:
------------------------

A new generation of Low-power and Lossy Networks (LLNs) has emerged under the
generic name of Low-Power Wide-Area (LPWA). From the variety of LPWA technologies
that is already proposed in this market, a number of common characteristics can
be gathered which make these technologies unique and disruptive for wireless
Internet of Things (IOT) applications.

Those common family traits include ultra low bit-rate and small frame sizes,
rare transmissions, specific radio modulations, and basic topologies. This
provides a significant improvement in range and battery lifetime, simplifies and
lowers the cost of deployments at large scale.

Those benefits come at a price: the MAC-layer formats are optimized and very
specific to each individual technology. There is no network layer and the
application is often hard wired to the MAC, leading to very silo'ed deployments,
managed, secured and operated individually. Migrating from one access technology
to another implies rebuilding the whole chain.

To unleash the full power of these new technologies and their new ecosystems,
there is a need to couple them with other ecosystems that will guarantee the
interworking at the network layer and enable common components for management
and security, as well as shared application profiles. The IETF can contribute
by enabling IPv6/UDP/COAP to the devices, and propose technologies to secure the
operations and manage the devices and their gateways.

Description of Working Group:
-----------------------------

The Working Group will focus on enabling IPv6 over selected Low-Power Wide-Area
technologies <tech1>, <Tech2> and <Tech3>, and will leverage cross-participation
with the associated set of stakeholders to ensure that the work taking place
corresponds to real demands and the proposed solutions are applicable.

The group will produce informational work describing LPWA technologies for IETF
consumption, best practice documents on using IETF technology in LPWA networks
directed to the selected partner bodies, and new standards work to optimize IPv6
operations to the device.

The WG will interface with other appropriate groups in the IETF Internet,
Operations and Management, and Security Areas.

Work Items:
-----------

The group will:

1. Produce an Informational document describing and relating existing LPWA
technologies. This document will highlight the common characteristics but will
not aim at providing a competitive analysis.

2. Produce best practice documents for security and management, highlighting
potential areas where IETF technologies may be leveraged; these documents may
eventually be published as Informational RFCs.

3. Produce Standard Track documents to enable the compression of IPv6 over LPWA.
Considering the extreme constraints, the work will focus on a generic YANG data
model to enable the compression, and protocols to install the related state
at the compression end-points; the work will also include, for the selected
technologies, specific Standard Track documents to describe how the fields
relevant to the decompression are encoded over the air, if any.

4. Produce a document to enable the fragmentation of larger packets over LPWA,
either as a Best Practice leveraging existing technology, or as new Standard
Track document if that is deemed necessary.

---

From: Alexander Pelov <[email-masked]>
Date: Tue, 26 Apr 2016 08:31:39 +0200

Dear Sri,

Thanks a lot for your input! I am fully aligned with you when you say 
that coexistence of various LPWA technologies is something that if not 
handled properly, could lead to troubles in the future. This is 
especially true if we consider the densities of devices predicted today 
(e.g. 100 000 devices per Access Point).

We will definitely need some base characteristics for the chosen three 
main technologies. I'd like to see Plugfests happening quite rapidly - 
which will be one way of seeing how different technologies work 
together. And I definitely would be interested in having open 
discussions on what we've seen on the field.

One question I am asking myself is if the IETF is the right place to 
publish documents, which present this type of data? This would be a 
perfect topic for IEEE conferences and workshops. I think that for the 
moment we should keep this out of the Charter, keeping a special place 
for this type of information in our meetings.

Best,
Alexander

Le 2016-04-26 06:11, Sri Gundavelli (sgundave) a écrit :
> I realize IETF is in no position to compare and/or promote a specific
> access technology, but it is important to characterize a given access
> technology. In that sense, there should be room for publishing
> measurement data on system/radio performance as informational specs.
> At some points coexistence of various LPWAN technologies in unlicensed
> bands will be the major issue and the problem will only get worse as
> the noise in the channels goes up with the technology adoption. This
> measurement data/reports from IETF community will be useful to
> drive/recommend approaches to SDO's such LBT, or other modes of
> peaceful coexistence of various LPWAN technologies.
> 
>  From: lp-wan <[email-masked]> on behalf of "Pascal Thubert
> (pthubert)" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Tue, 26 Apr 2016 09:27:12 +0200

I agree with Alexander. Even though this is very relevant to the group, and information will be useful, I don't think IETF is the right place to discuss or decide anything about radio coexistence and spectrum issues. 

I would welcome informational presentations on this topic, but I would rather not have it in the Charter of the group.

Juan Carlos

> On Apr 26, 2016, at 08:31, Alexander Pelov <[email-masked]> wrote:
> 
> Dear Sri,
> 
> Thanks a lot for your input! I am fully aligned with you when you say that coexistence of various LPWA technologies is something that if not handled properly, could lead to troubles in the future. This is especially true if we consider the densities of devices predicted today (e.g. 100 000 devices per Access Point).
> 
> We will definitely need some base characteristics for the chosen three main technologies. I'd like to see Plugfests happening quite rapidly - which will be one way of seeing how different technologies work together. And I definitely would be interested in having open discussions on what we've seen on the field.
> 
> One question I am asking myself is if the IETF is the right place to publish documents, which present this type of data? This would be a perfect topic for IEEE conferences and workshops. I think that for the moment we should keep this out of the Charter, keeping a special place for this type of information in our meetings.
> 
> Best,
> Alexander
> 
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 26 Apr 2016 08:03:29 +0000

What do others think?

This is slippery grounds for IETF. I'd like to see papers coming from Academia.

Cheers,

Pascal

From: Sri Gundavelli (sgundave)
Sent: mardi 26 avril 2016 06:11
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: Re: [lp-wan] Proposed charter v3

Pascal / All,

Comments ?

Sri

Background/Introduction:
------------------------

Work Items:
-----------

The group will:

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 26 Apr 2016 08:11:13 +0000

Same here... 

if there's a mutual benefit for the LPWA technologies that IETF or IEEE produces work to improve coexistence then we're certainly interested. 
But we cannot serve as playground for marketing or competitive work.

Cheers,

Pascal

> -----Original Message-----
> From: Juan Carlos Zuniga [mailto:[email-masked]]
> Sent: mardi 26 avril 2016 09:27
> To: Alexander Pelov <[email-masked]>
> Cc: Sri Gundavelli (sgundave) <[email-masked]>; [email-masked];
> Pascal Thubert (pthubert) <[email-masked]>
> I agree with Alexander. Even though this is very relevant to the group, and
> information will be useful, I don't think IETF is the right place to discuss or
> decide anything about radio coexistence and spectrum issues.
> 
> I would welcome informational presentations on this topic, but I would
> rather not have it in the Charter of the group.
> 
> Juan Carlos
> 
> > Thanks a lot for your input! I am fully aligned with you when you say that
> coexistence of various LPWA technologies is something that if not handled
> properly, could lead to troubles in the future. This is especially true if we
> consider the densities of devices predicted today (e.g. 100 000 devices per
> Access Point).
> >
> main technologies. I'd like to see Plugfests happening quite rapidly - which
> will be one way of seeing how different technologies work together. And I
> definitely would be interested in having open discussions on what we've
> seen on the field.
> >
> > One question I am asking myself is if the IETF is the right place to publish
> documents, which present this type of data? This would be a perfect topic
> for IEEE conferences and workshops. I think that for the moment we should
> keep this out of the Charter, keeping a special place for this type of
> information in our meetings.
> >
> > Best,
> > Alexander
> >
> >
> >> technologies. This document will highlight the common characteristics
> >> but will not aim at providing a competitive analysis.
> >> At some points coexistence of various LPWAN technologies in
> >> unlicensed bands will be the major issue and the problem will only
> >> get worse as the noise in the channels goes up with the technology
> >> adoption. This measurement data/reports from IETF community will be
> >> useful to drive/recommend approaches to SDO's such LBT, or other
> >> modes of peaceful coexistence of various LPWAN technologies.
> >> A new generation of Low-power and Lossy Networks (LLNs) has emerged
> >> under the generic name of Low-Power Wide-Area (LPWA). From the
> >> variety of LPWA technologies that is already proposed in this market,
> >> a number of common characteristics can be gathered which make these
> >> technologies unique and disruptive for wireless Internet of Things
> >> (IOT) applications.
> >> Those common family traits include ultra low bit-rate and small frame
> >> sizes, rare transmissions, specific radio modulations, and basic
> >> topologies.
> >> This
> >> provides a significant improvement in range and battery lifetime,
> >> simplifies and lowers the cost of deployments at large scale.
> >> Those benefits come at a price: the MAC-layer formats are optimized
> >> and very specific to each individual technology. There is no network
> >> layer and the application is often hard wired to the MAC, leading to
> >> very silo'ed deployments, managed, secured and operated individually.
> >> Migrating from one access technology to another implies rebuilding
> >> the whole chain.
> >> To unleash the full power of these new technologies and their new
> >> ecosystems, there is a need to couple them with other ecosystems that
> >> will guarantee the interworking at the network layer and enable
> >> common components for management and security, as well as shared
> >> application profiles. The IETF can contribute by enabling
> >> IPv6/UDP/COAP to the devices, and propose technologies to secure the
> >> The Working Group will focus on enabling IPv6 over selected Low-Power
> >> Wide-Area technologies <tech1>, <Tech2> and <Tech3>, and will
> >> leverage cross-participation with the associated set of stakeholders
> >> to ensure that the work taking place corresponds to real demands and
> >> the proposed solutions are applicable.
> >> The group will produce informational work describing LPWA
> >> technologies for IETF consumption, best practice documents on using
> >> IETF technology in LPWA networks directed to the selected partner
> >> bodies, and new standards work to optimize IPv6 operations to the
> >> device.
> >> The WG will interface with other appropriate groups in the IETF
> >> Internet, Operations and Management, and Security Areas.
> >> Work Items:
> >> -----------
> >> The group will:
> >> 1. Produce an Informational document describing and relating existing
> >> LPWA technologies. This document will highlight the common
> >> characteristics but will not aim at providing a competitive analysis.
> >> 2. Produce best practice documents for security and management,
> >> highlighting potential areas where IETF technologies may be
> >> leveraged; these documents may eventually be published as
> >> Informational RFCs.
> >> Considering the extreme constraints, the work will focus on a generic
> >> YANG data model to enable the compression, and protocols to install
> >> the related state at the compression end-points; the work will also
> >> include, for the selected technologies, specific Standard Track
> >> documents to describe how the fields relevant to the decompression
> >> are encoded over the air, if any.
> >> 4. Produce a document to enable the fragmentation of larger packets
> >> over LPWA, either as a Best Practice leveraging existing technology,
> >> or as new Standard Track document if that is deemed necessary.

---

From: Mischa Dohler <[email-masked]>
Date: Tue, 26 Apr 2016 09:17:26 +0100

I personally think this is a little off-track but referencing it in our 
documentation seems a good idea! The topic itself is of course 
super-important ... and the main reason LPWAN won't make it beyond 2025 
(no panic, Pascal, we have time for impact). Mischa.

______________________________________

Prof Mischa Dohler
Head, Centre for Telecom Research
Chair Professor, King's College London
Board of Directors, Worldsensing
Editor-in-Chief, ETT & IoT
Fellow, IEEE

www.mischadohler.com
______________________________________

On 26/04/2016 09:03, Pascal Thubert (pthubert) wrote:
>
> What do others think?
>
> This is slippery grounds for IETF. I’d like to see papers coming from 
> Academia.
>
> Cheers,
>
> Pascal
>
> *From:* Sri Gundavelli (sgundave)
> *Sent:* mardi 26 avril 2016 06:11
> *To:* Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
> *Subject:* Re: [lp-wan] Proposed charter v3
>
> Pascal / All,
>
> but will
> drive/recommend approaches to SDO’s such LBT, or other modes of 
> *From: *lp-wan <[email-masked] 
> <mailto:[email-masked]>> on behalf of "Pascal Thubert 
> (pthubert)" <[email-masked] <mailto:[email-masked]>>
> *Date: *Sunday, April 24, 2016 at 9:03 AM
> *To: *"[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
> *Subject: *[lp-wan] Proposed charter v3
>
> under the
> sizes,
> simplifies and
> and very
> ecosystems,
> Wide-Area
> but will
> highlighting
> YANG data
> over LPWA,

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Tue, 26 Apr 2016 10:21:30 +0200

+1

Carles

> Same here...
>
> if there's a mutual benefit for the LPWA technologies that IETF or IEEE
> produces work to improve coexistence then we're certainly interested.
>> that
>> which
>> publish
>> > Le 2016-04-26 06:11, Sri Gundavelli (sgundave) a Ã©crit :
>> >> Pascal / All,
>> >> 3. Produce Standard Track documents to enable the compression of
>> IPv6
>> >> over LPWA.