Subject: [lp-wan] Fw: New Version Notification for draft-qin-lpwan-dau-00.txt

From: "[email-masked]" <[email-masked]>
Date: Mon, 9 May 2016 18:09:02 +0800

Hi, folks
I have submitted a draft.  Any comments are welcome. Thanks！

Regards
Xiaowei Qin

From: internet-drafts
Date: 2016-05-09 18:04
To: Xiaowei Qin; Ning Kong
Subject: New Version Notification for draft-qin-lpwan-dau-00.txt
 
A new version of I-D, draft-qin-lpwan-dau-00.txt
has been successfully submitted by Xiaowei Qin and posted to the
IETF repository.
 
Name: draft-qin-lpwan-dau
Revision: 00
Title: Data Aggregation Unit for LP-WAN 
Document date: 2016-05-09
Group: Individual Submission
Pages: 8
URL:            https://www.ietf.org/internet-drafts/draft-qin-lpwan-dau-00.txt
Status:         https://datatracker.ietf.org/doc/draft-qin-lpwan-dau/
Htmlized:       https://tools.ietf.org/html/draft-qin-lpwan-dau-00

Abstract:
   Connecting LP-WANs(Low-Power Wide Area Networks) to the Internet is
   expected to provide significant benefits to these networks in terms
   of interoperability, application deployment, and management,among
   others.  However, the specific characteristics of LP-WANs, such as
   very limited data unit size, and large-scale data sets make the
   network operation more complex: using one IP packet to send one LP-
   WAN data unit is a waste of bandwidth(because the packet header is
   much bigger than payload), and the large-scale LP-WAN data sets can
   also increase the Internet burden.  This specification defines a Data
   Aggregation Unit(DAU) for LP-WANs to aggregate small-size date units
   into bigger data chains so they can be sent through the Internet more
   efficiently.

 
Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.
 
The IETF Secretariat

---

From: Alexander Pelov <[email-masked]>
Date: Fri, 13 May 2016 09:02:34 +0200

Dear Xiaowei,

Thanks for submitting this work! I think it is a step in the right direction! We need to see how it relates to the IPv6 fragmentation draft ( draft-gomez-lpwan-fragmentation-header-01 ). Is it possible to remove the Delimeter Signature given that you already know the length of the L-DAU? Also, is it necessary to provide this length - most L2 technologies already provide the means of having this length?

You mentioned earlier that you’ve been doing work on the topic for quite some time now. What are the topics you would see addressed in the DAU draft for the future? 

Best,
Alexander

> Le 9 mai 2016 à 12:09, [email-masked] a écrit :
> 
> Hi, folks
> From: internet-drafts <mailto:[email-masked]>
> Date: 2016-05-09 18:04
> To: Xiaowei Qin <mailto:[email-masked]>; Ning Kong <mailto:[email-masked]>
> URL:            https://www.ietf.org/internet-drafts/draft-qin-lpwan-dau-00.txt <https://www.ietf.org/internet-drafts/draft-qin-lpwan-dau-00.txt>
> Status:         https://datatracker.ietf.org/doc/draft-qin-lpwan-dau/ <https://datatracker.ietf.org/doc/draft-qin-lpwan-dau/>
> Htmlized:       https://tools.ietf.org/html/draft-qin-lpwan-dau-00 <https://tools.ietf.org/html/draft-qin-lpwan-dau-00>
>  
>  
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>  
> The IETF Secretariat
>  
> _______________________________________________
> lp-wan mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 13 May 2016 18:55:36 +0800

Dear Alexander,
Thanks very much for your comments.

>>We need to see how it relates to the IPv6 fragmentation draft ( draft-gomez-lpwan-fragmentation-header-01 ).
L-DAU focus on how to transmit LP-WANs' data packets through the Internet more efficiently. L-DAU tried to aggregate several LP-WANs' data packets into an aggregation chain. The aggregation chain will be transmitted as the atomic payload of the IP packet. So, the aggregator/de-aggregator sits IP layer above and the application layer below. 
Gateways and other fragmentation/processing may use L-DAU on both sides to increase the proportion of the payload in the IP packet to improve the transmission efficiency, or cut down transmission times.

>> Is it possible to remove the Delimeter Signature given that you already know the length of the L-DAU? Also, is it necessary to provide this length - most L2 technologies already provide the means >>of having this length?
L-DAU tried to don't do any processing of the data packets and just aggregate them into an aggregation chain. The de-aggregator(receiver) just need “open” the aggregation chain. So, the length of the L-DAU might need.

>>You mentioned earlier that you’ve been doing work on the topic for quite some time now. What are the topics you would see addressed in the DAU draft for the future? 
IMO, L-DAU may address information retrieval and dissemination between two LP-WANs or between LP-WAN and remote users through the internet. Some specific scenarios we have deployed are the follows: The first is the intelligent agricultural systems(mentioned earlier).
The second is smart home. The home gateway will temporarily store the data packets transmitted by IOT devices(such as temperature sensors) and send them to users together using aggregation chain. By doing this, the users can also avoid many interruptions of their cell phone (If the packets were sent one by one) except for improving transmission efficiency. 
Other topics, IMO, are such as forest fires monitoring, smart city, etc.
In short, if the LP-WAN application consists of many sensors and the data packets generated by these sensors need be transmitted over the internet, it may need L-DAU.

Regards
Xiaowei Qin

From: Alexander Pelov
Date: 2016-05-13 15:02
To: qinxiaowei
CC: lp-wan; t2trg
Subject: Re: [lp-wan] New Version Notification for draft-qin-lpwan-dau-00.txt
Dear Xiaowei,

Best,
Alexander

Hi, folks

Regards
Xiaowei Qin

From: internet-drafts
Date: 2016-05-09 18:04

Abstract:

 
 
The IETF Secretariat
 
_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan