Subject: Re: [lp-wan] Proposed charter v5

From: "weigengyu" <[email-masked]>
Date: Mon, 9 May 2016 13:25:26 +0800

Hi Pascal,

It is great to read it.

My suggestions:

OLD:
Those common traits include an optimized radio modulation, a typical 
deployment
as a simple star topology, frame sizes in the order of tens of bytes 
transmitted
a few times per day, and, though downstream may be supported, a mostly 
upstream
transmission pattern that allows the devices to spend most of their time in
low-energy deep-sleep mode.

NEW:
Those common traits include an optimized radio modulation, a typical 
deployment as a star topology,
frame sizes in the order of tens of bytes and frames transmitted a few times 
per day,
and, the symmetry of downstream and upstream, though downstream may be 
supported, a mostly upstream
transmission pattern of low-energy deep-sleep mode.

OLD:
To unleash the full power of LPWA technologies and their ecosystems, there 
is a
need to couple them with other ecosystems that will guarantee the 
inter-working
by introducing a network layer, and enable common components for management 
and
security, as well as shared application profiles. The IETF can contribute by
providing IPv6 connectivity, and propose technologies to secure the 
operations
and manage the devices and their gateways.

NEW:
To unleash the full power of LPWA technologies and their ecosystems, there 
is a
need to couple them with other ecosystems that will guarantee the 
inter-working
by introducing a network layer, and enable common components for converying 
the context of IPv6, and of protocols above IPv6, management and
security, as well as shared application profiles. The IETF can contribute by
providing IPv6 connectivity, and propose technologies to secure the 
operations
and manage the devices and their gateways.

OLD:
These technologies present similar characteristics of rare and widely 
unbalanced
over-the-air transmissions, with little capability to alter the frame 
formats to
accommodate this work, which makes it so that existing IETF work (6lo) 
cannot be
trivially applied.

NEW:
These technologies present similar characteristics of rare and widely 
asymmetric
over-the-air transmissions, with little capacity to alter the frame formats 
to commodate the existing IETF work (6lo) for emerging IoT/M2M applications.

OLD:
The group will produce informational work, for IETF consumption, describing 
LPWA
technologies and their needs, best practice documents on using IETF 
technologies
in LPWA networks, and new standard work to optimize IPv6-based 
communications to
the end device, down to the remote-I/O model where the device is not fully 
aware
of the whole stack.

NEW:
The group will produce informational work, for IETF consumption, describing 
LPWA
technologies and their needs, best practice documents on using IETF 
technologies
in LPWA networks, and new standard work to introduce and optimize IPv6-based 
communications to the end device,
down to the remote-I/O model where the device is not fully aware of the 
whole stack.

Regards,

Gengyu WEI
Network Technology Center
School of Computer
Beijing University of Posts and Telecommunications
-----原始邮件----- 
From: Pascal Thubert (pthubert)
Sent: Wednesday, April 27, 2016 2:31 AM
To: [email-masked]
Subject: [lp-wan] Proposed charter v5

6LPWA: "IPv6 over Low-Power Wide-Area networks".

Background/Introduction:
------------------------

A new generation of wireless technologies has emerged under the generic name 
of
Low-Power Wide-Area (LPWA), with a number of common characteristics which 
make
these technologies unique and disruptive for Internet of Things 
applications.

Those common traits include an optimized radio modulation, a typical 
deployment
as a simple star topology, frame sizes in the order of tens of bytes 
transmitted
a few times per day, and, though downstream may be supported, a mostly 
upstream
transmission pattern that allows the devices to spend most of their time in
low-energy deep-sleep mode.

This enables a range of several kilometers and a long battery lifetime, 
possibly
ten years operating on a single coin-cell. This also enables simple and 
scalable
deployments with low-cost devices and thin infrastructures.

Those benefits come at a price: the MAC-layer formats are optimized and 
specific
to each individual technology. There is no network layer and the application 
is
often hard wired to the MAC, leading to siloed deployments that must be 
managed,
secured and operated individually. Migrating from one LPWA technology to 
another
implies rebuilding the whole chain.

To unleash the full power of LPWA technologies and their ecosystems, there 
is a
need to couple them with other ecosystems that will guarantee the 
inter-working
by introducing a network layer, and enable common components for management 
and
security, as well as shared application profiles. The IETF can contribute by
providing IPv6 connectivity, and propose technologies to secure the 
operations
and manage the devices and their gateways.

Description of Working Group:
-----------------------------

The Working Group will focus on enabling IPv6 connectivity over a selection 
of
Low-Power Wide-Area technologies, <tech1>, <Tech2> and <Tech3>.

These technologies present similar characteristics of rare and widely 
unbalanced
over-the-air transmissions, with little capability to alter the frame 
formats to
accommodate this work, which makes it so that existing IETF work (6lo) 
cannot be
trivially applied.

The Working Group will leverage cross-participation with the associated set 
of
stakeholders to ensure that the work taking place corresponds to real 
demands
and that the proposed solutions are indeed applicable.

The group will produce informational work, for IETF consumption, describing 
LPWA
technologies and their needs, best practice documents on using IETF 
technologies
in LPWA networks, and new standard work to optimize IPv6-based 
communications to
the end device, down to the remote-I/O model where the device is not fully 
aware
of the whole stack.

The WG will interface with other appropriate groups in the IETF Internet 
Area,
Operations and Management Area, and Security Area.

Work Items:
-----------

The group will:

1. Produce an Informational document describing and relating some selected 
LPWA
technologies. This work will document the common characteristics and 
highlight
actual needs that the IETF could serve; but it is not an intention to 
provide a
competitive analysis. It is expected that the information contained therein
originates from and is reviewed by LPWA stakeholders, and that this WG may
leverage the resulting document to suggest new activity in other WGs.

2. Produce best practice documents for security and management, highlighting
potential areas where IETF technologies may be leveraged; these documents 
may
eventually be published as Informational RFCs. It is an expectation that the
resulting document(s) may contribute to the interaction with LPWA 
stakeholders
and lead to additional work in the future.

3. Produce Standard Track documents to enable the compression of a 
CoAP/UDP/IPv6
packet over LPWA. Considering the extreme constraints, the work will focus 
on a
generic YANG data model to describe the compression, and protocols to 
install
the related state at the compression end-points; the work will also include, 
for
the selected technologies, specific Standard Track documents to describe how 
the
fields relevant to the decompression are encoded over the air, if any.

4. Produce a document to enable the fragmentation of larger packets over 
LPWA,
either as a Best Practice leveraging existing technology, or as new Standard
Track document if that is deemed necessary.

_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Alexander Pelov <[email-masked]>
Date: Fri, 13 May 2016 08:54:39 +0200

Dear Gengyu,

Thanks for the feedback! I appreciate the simplification and the clarity you are aiming to achieve. I’ll make the necessary changes (probably keeping the conveying IPv6 context part).

Best,
Alexander

> Le 9 mai 2016 à 07:25, weigengyu <[email-masked]> a écrit :
> 
> Hi Pascal,
> 
> It is great to read it.
> 
> My suggestions:
> 
> OLD:
> Those common traits include an optimized radio modulation, a typical deployment
> as a simple star topology, frame sizes in the order of tens of bytes transmitted
> a few times per day, and, though downstream may be supported, a mostly upstream
> Those common traits include an optimized radio modulation, a typical deployment as a star topology,
> frame sizes in the order of tens of bytes and frames transmitted a few times per day,
> and, the symmetry of downstream and upstream, though downstream may be supported, a mostly upstream
> To unleash the full power of LPWA technologies and their ecosystems, there is a
> need to couple them with other ecosystems that will guarantee the inter-working
> by introducing a network layer, and enable common components for management and
> providing IPv6 connectivity, and propose technologies to secure the operations
> To unleash the full power of LPWA technologies and their ecosystems, there is a
> need to couple them with other ecosystems that will guarantee the inter-working
> by introducing a network layer, and enable common components for converying the context of IPv6, and of protocols above IPv6, management and
> providing IPv6 connectivity, and propose technologies to secure the operations
> These technologies present similar characteristics of rare and widely unbalanced
> over-the-air transmissions, with little capability to alter the frame formats to
> accommodate this work, which makes it so that existing IETF work (6lo) cannot be
> trivially applied.
> 
> NEW:
> These technologies present similar characteristics of rare and widely asymmetric
> over-the-air transmissions, with little capacity to alter the frame formats to commodate the existing IETF work (6lo) for emerging IoT/M2M applications.
> 
> 
> OLD:
> The group will produce informational work, for IETF consumption, describing LPWA
> technologies and their needs, best practice documents on using IETF technologies
> in LPWA networks, and new standard work to optimize IPv6-based communications to
> the end device, down to the remote-I/O model where the device is not fully aware
> of the whole stack.
> 
> NEW:
> The group will produce informational work, for IETF consumption, describing LPWA
> technologies and their needs, best practice documents on using IETF technologies
> in LPWA networks, and new standard work to introduce and optimize IPv6-based communications to the end device,
> down to the remote-I/O model where the device is not fully aware of the whole stack.
> 
> Regards,
> 
> Gengyu WEI
> -----原始邮件----- From: Pascal Thubert (pthubert)
> A new generation of wireless technologies has emerged under the generic name of
> Low-Power Wide-Area (LPWA), with a number of common characteristics which make
> these technologies unique and disruptive for Internet of Things applications.
> 
> Those common traits include an optimized radio modulation, a typical deployment
> as a simple star topology, frame sizes in the order of tens of bytes transmitted
> a few times per day, and, though downstream may be supported, a mostly upstream
> This enables a range of several kilometers and a long battery lifetime, possibly
> ten years operating on a single coin-cell. This also enables simple and scalable
> Those benefits come at a price: the MAC-layer formats are optimized and specific
> to each individual technology. There is no network layer and the application is
> often hard wired to the MAC, leading to siloed deployments that must be managed,
> secured and operated individually. Migrating from one LPWA technology to another
> To unleash the full power of LPWA technologies and their ecosystems, there is a
> need to couple them with other ecosystems that will guarantee the inter-working
> by introducing a network layer, and enable common components for management and
> providing IPv6 connectivity, and propose technologies to secure the operations
> The Working Group will focus on enabling IPv6 connectivity over a selection of
> These technologies present similar characteristics of rare and widely unbalanced
> over-the-air transmissions, with little capability to alter the frame formats to
> accommodate this work, which makes it so that existing IETF work (6lo) cannot be
> trivially applied.
> 
> The Working Group will leverage cross-participation with the associated set of
> stakeholders to ensure that the work taking place corresponds to real demands
> The group will produce informational work, for IETF consumption, describing LPWA
> technologies and their needs, best practice documents on using IETF technologies
> in LPWA networks, and new standard work to optimize IPv6-based communications to
> the end device, down to the remote-I/O model where the device is not fully aware
> of the whole stack.
> 
> The WG will interface with other appropriate groups in the IETF Internet Area,
> 1. Produce an Informational document describing and relating some selected LPWA
> technologies. This work will document the common characteristics and highlight
> actual needs that the IETF could serve; but it is not an intention to provide a
> potential areas where IETF technologies may be leveraged; these documents may
> resulting document(s) may contribute to the interaction with LPWA stakeholders
> 3. Produce Standard Track documents to enable the compression of a CoAP/UDP/IPv6
> packet over LPWA. Considering the extreme constraints, the work will focus on a
> generic YANG data model to describe the compression, and protocols to install
> the related state at the compression end-points; the work will also include, for
> the selected technologies, specific Standard Track documents to describe how the
> 4. Produce a document to enable the fragmentation of larger packets over LPWA,

---

From: Alexander Pelov <[email-masked]>
Date: Thu, 26 May 2016 10:00:52 +0200

Hi Ana,

Thanks for the input!

> Le 27 avr. 2016 à 10:22, Ana Minaburo <[email-masked]> a écrit :
> 
> Hello Pascal,
> 
> I have some inputs or questions
> 
> On Tue, Apr 26, 2016 at 8:31 PM, Pascal Thubert (pthubert) <[email-masked] <mailto:[email-masked]>> wrote:
> Ana: Is it a good idea to mention that there is a variable MTU ? this will affect the way you make compression and fragmentation.

Thanks for catching this! Some technologies do have varying MTU and we should not forget about this. So yes, I’ll include it in the next version of the charter.

> Ana: In this first time we are going to work only in security and management? or we plan also to do BCP for other layers? How about the idea of working in a crosslayer approach and global solutions? do we need to mention it know or for later? 

Also an excellent point. One of the issues that we need to address that was suggested by Mischa was the cross-layer ACK optimization. I think that we should at least mention the possibility of producing BCP for the applications also. 

Thanks!

Best,
Alexander

> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> 
> Thanks for all your work!
> 
> Ana