Subject: [lp-wan] Fwd: New Version Notification for draft-vilajosana-6lpwa-lora-hc-01.txt

From: Xavier Vilajosana <[email-masked]>
Date: Mon, 6 Jun 2016 11:37:24 +0200

Dear all,

we updated the draft by addressing several comments we recevied during the
last days.

kind regards,
Xavi

*Xavier Vilajosana*
*CIO*

Mobile: (+34) 646 633 681 <%28%2B34%29%2093%20418%2005%2085>
Office: (+34) 93 418 05 85

Aragó, 383, 4th floor
08013 Barcelona, Spain

9-10 Carlos Place, Mayfair
London W1K 3AT, UK

*This email may contain confidential information and may be subject to
professional secrecy. Its dissemination, copying, distribution,
reproduction, forwarding or any other unauthorized use is strictly
prohibited. If you receive this email in error, please notify us
immediately and arrange for its deletion, together with any attached
documents.*

*Este correo electrónico puede contener información estrictamente
confidencial, y puede estar sometido al secreto profesional. Está prohibida
su difusión, copia, distribución, reproducción, reenvío o cualquier otro
uso no autorizado. En caso de recibir este correo por error, rogamos nos
lo comunique de inmediato y proceda a su eliminación, así como de cualquier
documento que se adjunte.*

---------- Forwarded message ----------
From: <[email-masked]>
Date: 2016-06-06 11:36 GMT+02:00
Subject: New Version Notification for draft-vilajosana-6lpwa-lora-hc-01.txt
To: Xavier Vilajosana <[email-masked]>, Mischa Dohler <
[email-masked]>

A new version of I-D, draft-vilajosana-6lpwa-lora-hc-01.txt
has been successfully submitted by Xavier Vilajosana and posted to the
IETF repository.

Name:           draft-vilajosana-6lpwa-lora-hc
Revision:       01
Title:          Transmission of IPv6 Packets over LoRaWAN
Document date:  2016-06-06
Group:          Individual Submission
Pages:          11
URL:
https://www.ietf.org/internet-drafts/draft-vilajosana-6lpwa-lora-hc-01.txt
Status:
https://datatracker.ietf.org/doc/draft-vilajosana-6lpwa-lora-hc/
Htmlized:
https://tools.ietf.org/html/draft-vilajosana-6lpwa-lora-hc-01
Diff:
https://www.ietf.org/rfcdiff?url2=draft-vilajosana-6lpwa-lora-hc-01

Abstract:
   This document describes how IPv6 is transmitted over LoRaWAN using
   6LowPAN techniques.  LoRaWAN is a wireless communication system for
   long-range low-power low-data-rate applications.  LoRaWAN networks
   typically are laid out in a star topology in the field with gateways
   relaying messages between end-devices and a central network server in
   the backend, the complete system referred to as star of stars
   network.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

-- 

Aragó, 383, 4th floor
08013 Barcelona, Spain

9-10 Carlos Place, Mayfair
London W1K 3AT, UK

*This email may contain confidential information and may be subject to 
professional secrecy. Its dissemination, copying, distribution, 
reproduction, forwarding or any other unauthorized use is strictly 
prohibited. If you receive this email in error, please notify us 
immediately and arrange for its deletion, together with any attached 
documents.*

*Este correo electrónico puede contener información estrictamente 
confidencial, y puede estar sometido al secreto profesional. Está prohibida 
su difusión, copia, distribución, reproducción, reenvío o cualquier otro 
uso no autorizado. En caso de recibir este correo por error, rogamos nos 
lo comunique de inmediato y proceda a su eliminación, así como de cualquier 
documento que se adjunte.*

---

From: Ana Minaburo <[email-masked]>
Date: Wed, 8 Jun 2016 11:32:14 +0200

Hello,

I've read your document and I have some questions:

-Why do you name your draft 'header compression' if you describe the IPv6
addressing in LORAWAN?
-Why do you talk only about LORAWAN and not a general solution for all the
lpwa technologies? which are the differences and how you can adapt your
work on Lorawan over all these technologies?
-Which are the differences with the draft-gomez-lpwan-ipv6-analysis-00
which also explain the IPv6 addressing?
-Which will be the differences with
the draft-gomez-lpwan-fragmentation-header-00 which already talk about the
fragmentation?
- Is not clear for me the input you want to do for header compression and
RoHC in the 4.2 section. Are you planning to use RoHC for the LORAWAN
network? we can discuss in detail if you want why this compression
mechanism is not adapted, have you already use RoHC over LORAWAN?

Thanks

Ana

On Mon, Jun 6, 2016 at 11:37 AM, Xavier Vilajosana <
[email-masked]> wrote:

> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>
>

---

From: Ana Minaburo <[email-masked]>
Date: Wed, 8 Jun 2016 11:42:47 +0200

Hello,

-Why do you name your draft 'header compression' if you describe the IPv6 addressing in LORAWAN?
-Why do you talk only about LORAWAN and not a general solution for all the lpwa technologies? which are the differences and how you can adapt your work on Lorawan over all these technologies?
-Which are the differences with the draft-gomez-lpwan-ipv6-analysis-00 which also explain the IPv6 addressing?
-Which will be the differences with the draft-gomez-lpwan-fragmentation-header-00 which already talk about the fragmentation?
- Is not clear for me the input you want to do for header compression and RoHC in the 4.2 section. Are you planning to use RoHC for the LORAWAN network? we can discuss in detail if you want why this compression mechanism is not adapted, have you already use RoHC over LORAWAN?

Thanks

Ana

> From: Xavier Vilajosana <[email-masked] <mailto:[email-masked]>>
> Date: Mon, Jun 6, 2016 at 11:37 AM
> Subject: [lp-wan] Fwd: New Version Notification for draft-vilajosana-6lpwa-lora-hc-01.txt
> To: [email-masked] <mailto:[email-masked]>
> 
> 
> Dear all,
> 
> we updated the draft by addressing several comments we recevied during the last days. 
> 
> kind regards,
> Xavi
> Xavier Vilajosana
> CIO
> Mobile: (+34) 646 633 681 <tel:%28%2B34%29%2093%20418%2005%2085>
> Office: (+34) 93 418 05 85 <tel:%28%2B34%29%2093%20418%2005%2085>
> 
> 
> Aragó, 383, 4th floor
> 08013 Barcelona, Spain
> 
> This email may contain confidential information and may be subject to professional secrecy. Its dissemination, copying, distribution, reproduction, forwarding or any other unauthorized use is strictly prohibited. If you receive this email in error, please notify us immediately and arrange for its deletion, together with any attached documents.
> 
> 
> Este correo electrónico puede contener información estrictamente confidencial, y puede estar sometido al secreto profesional. Está prohibida su difusión, copia, distribución, reproducción, reenvío o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminación, así como de cualquier documento que se adjunte.
> 
> From: <[email-masked] <mailto:[email-masked]>>
> To: Xavier Vilajosana <[email-masked] <mailto:[email-masked]>>, Mischa Dohler <[email-masked] <mailto:[email-masked]>>
> 
> 
> 
> URL:            https://www.ietf.org/internet-drafts/draft-vilajosana-6lpwa-lora-hc-01.txt <https://www.ietf.org/internet-drafts/draft-vilajosana-6lpwa-lora-hc-01.txt>
> Status:         https://datatracker.ietf.org/doc/draft-vilajosana-6lpwa-lora-hc/ <https://datatracker.ietf.org/doc/draft-vilajosana-6lpwa-lora-hc/>
> Htmlized:       https://tools.ietf.org/html/draft-vilajosana-6lpwa-lora-hc-01 <https://tools.ietf.org/html/draft-vilajosana-6lpwa-lora-hc-01>
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-vilajosana-6lpwa-lora-hc-01 <https://www.ietf.org/rfcdiff?url2=draft-vilajosana-6lpwa-lora-hc-01>
> 
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> The IETF Secretariat
> 
> 
> 
> 
> 
> Aragó, 383, 4th floor
> 08013 Barcelona, Spain
> 
> This email may contain confidential information and may be subject to professional secrecy. Its dissemination, copying, distribution, reproduction, forwarding or any other unauthorized use is strictly prohibited. If you receive this email in error, please notify us immediately and arrange for its deletion, together with any attached documents.
> 
> Este correo electrónico puede contener información estrictamente confidencial, y puede estar sometido al secreto profesional. Está prohibida su difusión, copia, distribución, reproducción, reenvío o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminación, así como de cualquier documento que se adjunte.
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> 
>

---

From: Xavier Vilajosana <[email-masked]>
Date: Thu, 9 Jun 2016 20:57:58 +0200

Hi Anna,

see inline.

> -Why do you name your draft 'header compression' if you describe the IPv6

because the intent was to add the HC at the end. I stopped waiting for the
RoHC approach proposed in the group. Our plan initially was to propose a HC
mechanism based on on 6lo contexts.

> work on Lorawan over all these technologies?

because we wanted to be specific on how to map the LoRaWAN PIB to IPv6. Do
other LPWA technologies have the same DevID fields for example? I wonder if
everything can be generalized and then be implementable by different
vendors so they can interop.

> which also explain the IPv6 addressing?
 for me Carles draft is an analysis of what are the challenges, and tries
to indicate directions, e.g giving some indications for address
autoconfiguration, fragmentation, etc.. but I guess if we want an standard
way to map IPv6 to a specific technology someone should say what are the
bits and bytes that we should use.

> the draft-gomez-lpwan-fragmentation-header-00 which already talk about the
We have a section for fragmentation, but is emptyl. When we started that
there were no other drafts talking about fragmentation, we also were aware
about some initiatives to add L2 fragmentation in LoRa.  So we thought to
talk about that. Then Carles came out with his draft and we follow it in
order to see if it works for LoRaWAN.  No problem on removing fragmentation
if the direction is clear with Carles approach.

> mechanism is not adapted, have you already use RoHC over LORAWAN?

this is an ongoing discussion. I prefer 6lo contexts but some people is
working on RoHC. Therefore, we wait again to see the directions. Note that
it is early and many things come up. Also the charter is still not approved
and the initial work items need to be decided. RoHC is an option as 6lo
contexts another. What is your opinion on this? do you have a preferred
approach? Do you have something implemented?

regards,
Xavi

> From: Xavier Vilajosana <[email-masked]>
> To: [email-masked]

-- 

Aragó, 383, 4th floor
08013 Barcelona, Spain

---

From: Ana Minaburo <[email-masked]>
Date: Wed, 15 Jun 2016 10:02:48 +0200

Hello,

> On 09 Jun 2016, at 20:57, Xavier Vilajosana <[email-masked]> wrote:
> 
> Hi Anna, 
> 
> see inline.
> 
> 2016-06-08 11:42 GMT+02:00 Ana Minaburo <[email-masked] <mailto:[email-masked]>>:
> Hello,
> 
> because the intent was to add the HC at the end. I stopped waiting for the RoHC approach proposed in the group. Our plan initially was to propose a HC mechanism based on on 6lo contexts. 
> 
AM: I think we need to discuss about this approaches, I think that RoHC is not adapted to these technologies.

> because we wanted to be specific on how to map the LoRaWAN PIB to IPv6. Do other LPWA technologies have the same DevID fields for example? I wonder if everything can be generalized and then be implementable by different vendors so they can intro. 

AM: Well, I see, but I think that we need to give a global solution to keep interoperability, we cannot study every single detail of each technology. and I think that describing the global architecture is very important in order to define the different solutions. 
>  for me Carles draft is an analysis of what are the challenges, and tries to indicate directions, e.g giving some indications for address autoconfiguration, fragmentation, etc.. but I guess if we want an standard way to map IPv6 to a specific technology someone should say what are the bits and bytes that we should use. 
> 
AM: For my understanding your draft is complementary to draft-gomez-lpwan-ipv6-analysis-00, it is very confusing to have two documents, perhaps you could work together?

> We have a section for fragmentation, but is emptyl. When we started that there were no other drafts talking about fragmentation, we also were aware about some initiatives to add L2 fragmentation in LoRa.  So we thought to talk about that. Then Carles came out with his draft and we follow it in order to see if it works for LoRaWAN.  No problem on removing fragmentation if the direction is clear with Carles approach.

AM: As with the other draft, I think your work is complementary and perhaps having a good draft will be better?
> this is an ongoing discussion. I prefer 6lo contexts but some people is working on RoHC. Therefore, we wait again to see the directions. Note that it is early and many things come up. Also the charter is still not approved and the initial work items need to be decided. RoHC is an option as 6lo contexts another. What is your opinion on this? do you have a preferred approach? Do you have something implemented?
> 
AM: Well, in my opinion we need a solution that could reduce the header to 1byte, that do not need to send refresh packets and that can be used for any header. 

Regards
Ana

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Wed, 15 Jun 2016 15:35:57 +0200

Hi Ana,

Please find below some inline comments:

>> -Why do you talk only about LORAWAN and not a general solution for all
>> the lpwa technologies? which are the differences and how you can adapt
>> your work on Lorawan over all these technologies?
>>
>> because we wanted to be specific on how to map the LoRaWAN PIB to IPv6.
>> Do other LPWA technologies have the same DevID fields for example? I
>> wonder if everything can be generalized and then be implementable by
>> different vendors so they can intro.
>
>
> AM: Well, I see, but I think that we need to give a global solution to
> keep interoperability, we cannot study every single detail of each
> technology. and I think that describing the global architecture is very
> important in order to define the different solutions.

[CG] A global architecture, comprising generic components to the extent
possible, is definitely desirable. However, there may be
technology-specific aspects that might not be possible to capture in a
generic solution. It will be important to identify these (if any). Input
in terms of target technology descriptions will be crucial here.

>>  for me Carles draft is an analysis of what are the challenges, and
>> tries to indicate directions, e.g giving some indications for address
>> autoconfiguration, fragmentation, etc.. but I guess if we want an
>> standard way to map IPv6 to a specific technology someone should say
>> what are the bits and bytes that we should use.
>>
> AM: For my understanding your draft is complementary to
> draft-gomez-lpwan-ipv6-analysis-00, it is very confusing to have two
> documents, perhaps you could work together?

[CG] draft-gomez-lpwan-ipv6-analysis mostly analyses the applicability of
existing specifications (mainly, 6Lo/6LoWPAN) to support IPv6 in the
LPWAN/6LPWA space, and highlights related challenges and existing gaps.
While there may be some overlap, I understand that
draft-vilajosana-6lpwa-lora-hc focuses specifically on IPv6 over LoRa.

>> -Which will be the differences with the
>> draft-gomez-lpwan-fragmentation-header-00 which already talk about the
>> fragmentation?
>> there were no other drafts talking about fragmentation, we also were
>> aware about some initiatives to add L2 fragmentation in LoRa.  So we
>> thought to talk about that. Then Carles came out with his draft and we
>> follow it in order to see if it works for LoRaWAN.  No problem on
>> removing fragmentation if the direction is clear with Carles approach.
>
> AM: As with the other draft, I think your work is complementary and
> perhaps having a good draft will be better?

[CG] draft-gomez-lpwan-fragmentation-header defines a generic mechanism
(i.e. it is not specific to one LPWAN technology in particular).

<snip>

Cheers,

Carles

---

From: Xavier Vilajosana <[email-masked]>
Date: Fri, 17 Jun 2016 05:18:28 +0200

Hi Carles, Ana,

see inline [XV],

2016-06-15 15:35 GMT+02:00 Carles Gomez Montenegro <[email-masked]>:

> [XV] +1, Carles is right. There are aspects that cannot be generalized.
E.g., an IPv6 address cannot be build from the same fields in different
technologies. Someone has to say in a specific document what are the fields
and how they are used for each particular technology. (e.g look at IPv6
over BTLE document or IPv6 over NFC).

> [XV] +1 draft-gomez-lpwan-ipv6-analysis is an informational work that aims
to identify gaps, etc.. We tried to be specific on how to map bits and
bytes in a specific technology which is LoRaWAN.

> [XV] we understand that and if this draft provides a solution that works
for LoRaWAN in our proposal we will point to it. There is no need to repeat
work.

Xavi

-- 

Aragó, 383, 4th floor
08013 Barcelona, Spain

---

From: "weigengyu" <[email-masked]>
Date: Fri, 17 Jun 2016 11:32:10 +0800

Hi Xavi, 

> [XV] +1 draft-gomez-lpwan-ipv6-analysis is an informational work that aims to identify gaps, etc.. 
> We tried to be specific on how to map bits and bytes in a specific technology which is LoRaWAN. 

My opinion is that the WG works to cover some technologies, which is being (or will be) specified in charter.
The technologies include LoRa, and others, but not only for LoRa.    

Regards,

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Xavier Vilajosana 
Sent: Friday, June 17, 2016 11:18 AM
To: Carles Gomez Montenegro 
Cc: [email-masked] ; [email-masked] ; [email-masked] ; Ana Minaburo 
Subject: Re: [lp-wan] New Version Notification for draft-vilajosana-6lpwa-lora-hc-01.txt

Hi Carles, Ana,  

see inline [XV],

  Hi Ana,

[XV] +1, Carles is right. There are aspects that cannot be generalized. E.g., an IPv6 address cannot be build from the same fields in different technologies. Someone has to say in a specific document what are the fields and how they are used for each particular technology. (e.g look at IPv6 over BTLE document or IPv6 over NFC).

[XV] +1 draft-gomez-lpwan-ipv6-analysis is an informational work that aims to identify gaps, etc.. We tried to be specific on how to map bits and bytes in a specific technology which is LoRaWAN. 

[XV] we understand that and if this draft provides a solution that works for LoRaWAN in our proposal we will point to it. There is no need to repeat work.   
  <snip>

  Cheers,

  Carles

regards,
Xavi

Aragó, 383, 4th floor
08013 Barcelona, Spain

--------------------------------------------------------------------------------
_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Xavier Vilajosana <[email-masked]>
Date: Fri, 17 Jun 2016 07:35:48 +0200

Dear Gengyu,
I agree with you, the WG works to cover some technologies that share some
concepts but have different implementation details. I understand that the
WG does not only cover LoRaWAN, in our case however we propose a specific
solution for the LoRaWAN technology. I hope others provide the same sort of
specifications with the particular details for Sigfox or other
technologies.

Look at 6lo WG for example. They have the 6lowpan framework for 15.4 and
then specific drafts mapping it to DECT-ULE. BTLE, NFC etc... as there are
particularities (call it profiles if you like) that need to be specified
for each of the underlying technologies.

hope we are inline.
X

*Xavier Vilajosana*
*CIO*

Aragó, 383, 4th floor
08013 Barcelona, Spain

2016-06-17 5:32 GMT+02:00 weigengyu <[email-masked]>:

> *From:* Xavier Vilajosana <[email-masked]>
> *Sent:* Friday, June 17, 2016 11:18 AM
> *To:* Carles Gomez Montenegro <[email-masked]>
> *Cc:* [email-masked] ; [email-masked] ;
> [email-masked] ; Ana Minaburo <[email-masked]>
> *Subject:* Re: [lp-wan] New Version Notification for
> draft-vilajosana-6lpwa-lora-hc-01.txt
>
> Hi Carles, Ana,
>
> see inline [XV],
>
> 2016-06-15 15:35 GMT+02:00 Carles Gomez Montenegro <[email-masked]
> >:
>
>> Hi Ana,
>>
>> [XV] +1 draft-gomez-lpwan-ipv6-analysis is an informational work that
> aims to identify gaps, etc.. We tried to be specific on how to map bits and
> uso no autorizado. En caso de recibir este correo por error, rogamos nos lo
> comunique de inmediato y proceda a su eliminación, así como de cualquier
> ------------------------------

-- 

Aragó, 383, 4th floor
08013 Barcelona, Spain

---

From: "weigengyu" <[email-masked]>
Date: Tue, 21 Jun 2016 15:27:09 +0800

Hi Xavier,

> Look at 6lo WG for example. They have the 6lowpan framework for 15.4 and then specific drafts mapping it to DECT-ULE. BTLE, 
> NFC etc... as there are particularities (call it profiles if you like) that need to be specified for each of the underlying technologies.

I agree that it is a good working approach.  
Wish that an framework for LP-WAN will appear. 

Regards, 

Gengyu WEI

From: Xavier Vilajosana 
Sent: Friday, June 17, 2016 1:35 PM
To: weigengyu 
Cc: [email-masked] ; [email-masked] ; Ana Minaburo ; Carles Gomez Montenegro ; [email-masked] 
Subject: Re: [lp-wan] New Version Notification for draft-vilajosana-6lpwa-lora-hc-01.txt

Dear Gengyu, 
I agree with you, the WG works to cover some technologies that share some concepts but have different implementation details. I understand that the WG does not only cover LoRaWAN, in our case however we propose a specific solution for the LoRaWAN technology. I hope others provide the same sort of specifications with the particular details for Sigfox or other technologies. 

Look at 6lo WG for example. They have the 6lowpan framework for 15.4 and then specific drafts mapping it to DECT-ULE. BTLE, NFC etc... as there are particularities (call it profiles if you like) that need to be specified for each of the underlying technologies.

hope we are inline.
X

Xavier Vilajosana
CIO

Mobile: (+34) 646 633 681

Aragó, 383, 4th floor
08013 Barcelona, Spain

  Hi Xavi, 

  Regards,

  Gengyu WEI

  From: Xavier Vilajosana 

  Hi Carles, Ana,  

  see inline [XV],

    Hi Ana,

    Cheers,

    Carles

  regards,
  Xavi

  Aragó, 383, 4th floor
  08013 Barcelona, Spain

------------------------------------------------------------------------------
  _______________________________________________
  lp-wan mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/lp-wan

Aragó, 383, 4th floor
08013 Barcelona, Spain

---

From: Ana Minaburo <[email-masked]>
Date: Wed, 22 Jun 2016 09:53:41 +0200

Hello Xavier, Carles,

> On 17 Jun 2016, at 05:18, Xavier Vilajosana <[email-masked]> wrote:
> 
> Hi Carles, Ana, 
> 
> see inline [XV],
> 
> 2016-06-15 15:35 GMT+02:00 Carles Gomez Montenegro <[email-masked] <mailto:[email-masked]>>:
> Hi Ana,
> 
> >> On 09 Jun 2016, at 20:57, Xavier Vilajosana
> >> <[email-masked] <mailto:[email-masked]>> wrote:
> >>
> >> Hi Anna,
> >>
AM: Yes for sure, but this details will be described after the global solution is completed for the global architecture. I think we need to solve first the global problem and see the particular details after. 

> [XV] +1 draft-gomez-lpwan-ipv6-analysis is an informational work that aims to identify gaps, etc.. We tried to be specific on how to map bits and bytes in a specific technology which is LoRaWAN. 
AM: OK

> [XV] we understand that and if this draft provides a solution that works for LoRaWAN in our proposal we will point to it. There is no need to repeat work.   
AM: ok, I’m agree with that.

AM: If you want we can start working in a global architecture description, what do you think? do you want that we work together in this definition?

Regards,
Ana

---

From: Xavier Vilajosana <[email-masked]>
Date: Thu, 23 Jun 2016 09:38:31 +0200

Hi Ana,

see inline please.
2016-06-22 9:53 GMT+02:00 Ana Minaburo <[email-masked]>:

>> >> <[email-masked]> wrote:
>> >>
>> >> Hi Anna,
>> >>
> AM: Yes for sure, but this details will be described after the global
> solution is completed for the global architecture. I think we need to solve
> first the global problem and see the particular details after.
>

XV> our idea is to solve easy and obvious things first and keep evolving
together with the other draft. As we progress we can give better input for
the global architecture.

> AM: If you want we can start working in a global architecture description,
> what do you think? do you want that we work together in this definition?
>

XV: Should not we wait for the final Charter after the BoF? Many things
will raise there. Anyway, all for it, I can help with that if we decide to
move forward.

cheers
X

-- 

Aragó, 383, 4th floor
08013 Barcelona, Spain