Subject: Re: [lp-wan] Updated charter

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Mon, 20 Jun 2016 07:53:08 +0000

We should be consistent with the names of the technologies. We had similar questions in a European SDO and we removed some of these names from our documents referencing only IEEE standards or “LPWAN".

WI-SUN is the name of an alliance.
SIGFOX is the name of a company which website says it is a registered trademark.
LORA is the name of an Alliance.

Probably NB-IOT is the only technology per se.

We have people belonging to these entities on this mailing list that may answer this question.

Thanks,

Patrick

On 17/06/16 15:04, "lp-wan on behalf of Pascal Thubert (pthubert)" <[email-masked] on behalf of [email-masked]> wrote:

>Dear all:
>
>The WG forming BoF was accepted, Suresh will be our A-D and Alex and I will serve as chair. 
>
>The IESG suggested that the name 6LPWA may not be appropriate and for the time being we'll live with LPWAN.
>
>Below is the updated charter, that now reflects the 4 technologies that we will be working with. Quick questions there:
>
>- We indicated LoRa for the technology; should I make it LoRaWAN?
>- Same goes for Wi-SUN. Should we indicate 802.15.4g in general?
>
>Take care,
>
>Pascal and Alex
>
>--------------------------------------------
>
>LPWAN: "IPv6 over Low-Power Wide-Area networks".
>
>Background/Introduction:
>------------------------
>
>A new generation of wireless technologies has emerged under the generic name of
>Low-Power Wide-Area (LPWA), with a number of common characteristics which make
>these technologies unique and disruptive for Internet of Things applications. 
>
>Those common traits include an optimized radio modulation, a typical deployment
>as a simple star topology, frame sizes in the order of tens of bytes transmitted
>a few times per day at ultra-low speeds and sometimes variable MTUs, and, though
>downstream may be supported, a mostly upstream transmission pattern that allows
>the devices to spend most of their time in low-energy deep-sleep mode.
>
>This enables a range of several kilometers and a long battery lifetime, possibly
>ten years operating on a single coin-cell. This also enables simple and scalable
>deployments with low-cost devices and thin infrastructures.
>
>Those benefits come at a price: the MAC-layer formats are optimized and specific
>to each individual technology. There is no network layer and the application is
>often hard wired to the MAC, leading to siloed deployments that must be managed,
>secured and operated individually. Migrating from one LPWA technology to another
>implies rebuilding the whole chain.
>
>To unleash the full power of LPWA technologies and their ecosystems, there is a
>need to couple them with other ecosystems that will guarantee the inter-working
>by introducing a network layer, and enable common components for management and
>security, as well as shared application profiles. The IETF can contribute by
>providing IPv6 connectivity, and propose technologies to secure the operations
>and manage the devices and their gateways.
>
>Description of Working Group:
>-----------------------------
>
>The Working Group will focus on enabling IPv6 connectivity over the following
>selection of Low-Power Wide-Area technologies: SIGFOX, LoRa, WI-SUN and NB-IOT.
>
>These technologies present similar characteristics of rare and widely unbalanced
>over-the-air transmissions, with little capability to alter the frame formats to
>accommodate this work, which makes it so that existing IETF work (6lo) cannot be
>trivially applied.
>
>The Working Group will leverage cross-participation with the associated set of
>stakeholders to ensure that the work taking place corresponds to real demands
>and that the proposed solutions are indeed applicable. 
>
>The group will produce informational work, for IETF consumption, describing LPWA
>technologies and their needs, best practice documents on using IETF technologies
>in LPWA networks, and new standard work to optimize IPv6-based communications to
>the end device, down to the remote-I/O model where the device is not fully aware
>of the whole stack.
>
>The WG will interface with other appropriate groups in the IETF Internet Area,
>Operations and Management Area, and Security Area.
>
>Work Items:
>-----------
>
>The group will:
>
>1. Produce an Informational document describing and relating some selected LPWA
>technologies. This work will document the common characteristics and highlight
>actual needs that the IETF could serve; but it is not an intention to provide a
>competitive analysis. It is expected that the information contained therein
>originates from and is reviewed by LPWA stakeholders, and that this WG may
>leverage the resulting document to suggest new activity in other WGs.
>
>2. Produce best practice documents highlighting potential areas where IETF
>technologies may be leveraged; these documents may eventually be published as
>Informational RFCs. It is an expectation that the resulting document(s) may
>contribute to the interaction with LPWA stakeholders and lead to additional work
>in the future. Envisioned topics include security, management, and cross-layer
>optimizations.
>
>3. Produce Standard Track documents to enable the compression of a CoAP/UDP/IPv6
>packet over LPWA. Considering the extreme constraints, the work will focus on a
>generic YANG data model to describe the compression, and protocols to install
>the related state at the compression end-points; the work will also include, for
>the selected technologies, specific Standard Track documents to describe how the
>fields relevant to the decompression are encoded over the air, if any.
>
>4. Produce a document to enable the fragmentation of larger packets over LPWA,
>either as a Best Practice leveraging existing technology, or as new Standard
>Track document if that is deemed necessary.
>
>_______________________________________________
>lp-wan mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Jonathan Muñoz <[email-masked]>
Date: Mon, 20 Jun 2016 11:52:18 +0200

Thanks Pascal and Alex for putting this together.

I agree with Patrick. Should we call the WI-SUN technology IEEE
802.15.4-SUN? Since it is referenced just as SUN in the IEEE 802.15.4 (2015
release).

Regards,

Jonathan M

2016-06-20 9:53 GMT+02:00 Patrick Wetterwald (pwetterw) <[email-masked]>
:

> We should be consistent with the names of the technologies. We had similar
> questions in a European SDO and we removed some of these names from our
> documents referencing only IEEE standards or “LPWAN".
>
> On 17/06/16 15:04, "lp-wan on behalf of Pascal Thubert (pthubert)" <
> [email-masked] on behalf of [email-masked]> wrote:
>
> >Dear all:
> >
> >Below is the updated charter, that now reflects the 4 technologies that
> we will be working with. Quick questions there:
> >

-- 
Jonathan Muñoz
PhD student at Gridbee Communications & INRIA Paris
+33 (0) 6 59 05 93 83

---

From: Benoit Ponsard <[email-masked]>
Date: Mon, 20 Jun 2016 10:50:05 +0000

Hi all,

Sigfox is the name of our company, but we see no objection to use it in the context of the IETF work.

BR

BPS

--
Benoît PONSARD
Director of Standardization
Cel: +33 6 84 74 70 71
SIGFOX – www.sigfox.com

De : lp-wan <[email-masked]> au nom de "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date : lundi 20 juin 2016 09:53
À : "Pascal Thubert (pthubert)" <[email-masked]>, lp-wan <[email-masked]>, Alexander Pelov <[email-masked]>, Erik Nordmark <[email-masked]>, Suresh Krishnan <[email-masked]>, "Bob Heile ([email-masked])" <[email-masked]>, Geoff Mulligan <[email-masked]>
Objet : Re: [lp-wan] Updated charter

Thanks,

Patrick

On 17/06/16 15:04, "lp-wan on behalf of Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Dear all:

Take care,

Pascal and Alex

Background/Introduction:
------------------------

Work Items:
-----------

The group will:

_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Bob Heile <[email-masked]>
Date: Mon, 20 Jun 2016 15:56:57 -0400

Hi all

Whatever we do we need to be consistent. Either all technology names (not 
sure what those would be for LORA and SIGFOX) or all vernacular names, ie 
names associated with the technologies (WI-SUN, LORA, SIGFOX).

Regards

Bob

At 11:52 AM 6/20/2016 +0200, Jonathan MuÃ±oz wrote:
>Thanks Pascal and Alex for putting this together.Â
>
>802.15.4-SUN? Since it is referenced just as SUN in the IEEE 802.15.4 
>(2015 release).
>
>Regards,
>
>Jonathan M
>
>
>
>2016-06-20 9:53 GMT+02:00 Patrick Wetterwald (pwetterw) 
><<mailto:[email-masked]>[email-masked]>:
>documents referencing only IEEE standards or â€œLPWAN".
>
>On 17/06/16 15:04, "lp-wan on behalf of Pascal Thubert (pthubert)" 
><<mailto:[email-masked]>[email-masked] on behalf of 
><mailto:[email-masked]>[email-masked]> wrote:
>
> >Dear all:
> >
> ><mailto:[email-masked]>[email-masked]
><mailto:[email-masked]>[email-masked]
>Jonathan MuÃ±oz

Bob Heile, Ph.D

Director of Standards, Wi-SUN Alliance
Chair, IEEE 802.15 Working Group on Wireless Specialty Networks
Chair IEEE 2030.5 Working Group for Smart Energy Profile 2
Co-Chair IEEE P2030 Task Force 3 on Smartgrid Communications

11 Robert Toner Blvd, Suite 5-301
North Attleboro, MA  02763   USA
Mobile: +1-781-929-4832
email:   [email-masked]

---

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Tue, 21 Jun 2016 09:31:40 +0000

Question to the chairs:

Is there an official IETF position on this subject as it implies IPR?

Thanks,

Patrick

From: Bob Heile <[email-masked]<mailto:[email-masked]>>
Date: Monday 20 June 2016 at 21:56
To: Jonathan MuÃ±oz <[email-masked]<mailto:[email-masked]>>, pwetterw <[email-masked]<mailto:[email-masked]>>
Cc: Pascal THUBERT <[email-masked]<mailto:[email-masked]>>, lp-wan <[email-masked]<mailto:[email-masked]>>, Alexander Pelov <[email-masked]<mailto:[email-masked]>>, Erik Nordmark <[email-masked]<mailto:[email-masked]>>, Suresh Krishnan <[email-masked]<mailto:[email-masked]>>, Bob Heile <[email-masked]<mailto:[email-masked]>>, Geoff Mulligan <[email-masked]<mailto:[email-masked]>>
Subject: Re: [lp-wan] Updated charter

Hi all

Whatever we do we need to be consistent. Either all technology names (not sure what those would be for LORA and SIGFOX) or all vernacular names, ie names associated with the technologies (WI-SUN, LORA, SIGFOX).

Regards

Bob

I agree with Patrick. Should we call the WI-SUN technology IEEE 802.15.4-SUN? Since it is referenced just as SUN in the IEEE 802.15.4 (2015 release).

Regards,

Jonathan M

2016-06-20 9:53 GMT+02:00 Patrick Wetterwald (pwetterw) <[email-masked]<mailto:[email-masked]>>:

We should be consistent with the names of the technologies. We had similar questions in a European SDO and we removed some of these names from our documents referencing only IEEE standards or â€œLPWAN".

Thanks,

Patrick

Bob Heile, Ph.D

11 Robert Toner Blvd, Suite 5-301
North Attleboro, MA  02763   USA
Mobile: +1-781-929-4832
email:   [email-masked]<mailto:[email-masked]>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 23 Jun 2016 14:42:59 +0000

Hello Bob:

Maybe LoRa could qualify as an LPWA Ultra Wide Band, and SIGFOX as a Ultra Narrow Band?

IOW, the IETF could be working on 802.15.4g, UWB and UNB technologies without giving names.

In the case of SIGFOX, we’d expecting that the standards proposed for UNB, apply to and beyond the very specific design of SIGFOX.

I’m OK with using vernacular as we speak, but the IETF may be concerned with producing work which would be aimed at a particular company.

What do others think ?

Pascal

From: Bob Heile [mailto:[email-masked]]
Sent: lundi 20 juin 2016 21:57
To: Jonathan MuÃ±oz <[email-masked]>; Patrick Wetterwald (pwetterw) <[email-masked]>
Cc: Pascal Thubert (pthubert) <[email-masked]>; lp-wan <[email-masked]>; Alexander Pelov <[email-masked]>; Erik Nordmark <[email-masked]>; Suresh Krishnan <[email-masked]>; Bob Heile ([email-masked]) <[email-masked]>; Geoff Mulligan <[email-masked]>
Subject: Re: [lp-wan] Updated charter

Hi all

Regards

Bob

Regards,

Jonathan M

Bob Heile, Ph.D

---

From: Alper Yegin <[email-masked]>
Date: Thu, 23 Jun 2016 23:40:25 +0300

> Maybe LoRa could qualify as an LPWA Ultra Wide Band, and SIGFOX as a Ultra
I'd be concerned about creating a new terminology here. It can be confusing.

As far as LoRa is concerned, IETF would be dealing with the technology
defined in an open industry alliance. Hence I don't see what the issue
would be.

Alper

> In the case of SIGFOX, we’d expecting that the standards proposed for UNB,
> apply to and beyond the very specific design of SIGFOX.
>
>
>
> I’m OK with using vernacular as we speak, but the IETF may be concerned
> with producing work which would be aimed at a particular company.
>
>
>
> What do others think ?
>
>
>
> Pascal
>
>
>
> *From:* Bob Heile [mailto:[email-masked]]
> *Sent:* lundi 20 juin 2016 21:57
> *To:* Jonathan MuÃ±oz <[email-masked]>; Patrick Wetterwald
> (pwetterw) <[email-masked]>
> *Cc:* Pascal Thubert (pthubert) <[email-masked]>; lp-wan <
> [email-masked]>; Alexander Pelov <[email-masked]>; Erik Nordmark <
> [email-masked]>; Suresh Krishnan <[email-masked]>; Bob
> Heile ([email-masked]) <[email-masked]>; Geoff Mulligan <
> [email-masked]>
> *Subject:* Re: [lp-wan] Updated charter
>
>
>
> Hi all
>
>
> 2016-06-20 9:53 GMT+02:00 Patrick Wetterwald (pwetterw) <
> [email-masked]>:
>

---

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Fri, 24 Jun 2016 12:19:46 +0000

In any case, if trademarks are used, we must refer to RFC 5378.

And probably IPR statements should be issued by the owners.

Thanks,

Patrick

From: Pascal THUBERT <[email-masked]<mailto:[email-masked]>>
Date: Thursday 23 June 2016 at 16:42
To: Bob Heile <[email-masked]<mailto:[email-masked]>>, pwetterw <[email-masked]<mailto:[email-masked]>>, Suresh Krishnan <[email-masked]<mailto:[email-masked]>>
Cc: lp-wan <[email-masked]<mailto:[email-masked]>>, Alexander Pelov <[email-masked]<mailto:[email-masked]>>, Erik Nordmark <[email-masked]<mailto:[email-masked]>>, Geoff Mulligan <[email-masked]<mailto:[email-masked]>>, Jonathan MuÃ±oz <[email-masked]<mailto:[email-masked]>>
Subject: RE: [lp-wan] Updated charter

Hello Bob:

What do others think ?

Pascal

From: Bob Heile [mailto:[email-masked]]
Sent: lundi 20 juin 2016 21:57
To: Jonathan MuÃ±oz <[email-masked]<mailto:[email-masked]>>; Patrick Wetterwald (pwetterw) <[email-masked]<mailto:[email-masked]>>
Cc: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>; lp-wan <[email-masked]<mailto:[email-masked]>>; Alexander Pelov <[email-masked]<mailto:[email-masked]>>; Erik Nordmark <[email-masked]<mailto:[email-masked]>>; Suresh Krishnan <[email-masked]<mailto:[email-masked]>>; Bob Heile ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; Geoff Mulligan <[email-masked]<mailto:[email-masked]>>
Subject: Re: [lp-wan] Updated charter

Hi all

Regards

Bob

Regards,

Jonathan M

Bob Heile, Ph.D