Subject: [lp-wan] IPv6/UDP/CoAP Static Context Header Compression for LPWA

From: Laurent Toutain <[email-masked]>
Date: Tue, 7 Jun 2016 00:40:33 +0200

Hi,

You will find a draft describing a hybrid method to compress headers for
LPWA.
The draft currently focuses on IPv6/UDP headers. We will soon complete the
proposal with CoAP, but we would like to have a feedback from the mailing
list on the method.

https://datatracker.ietf.org/doc/draft-toutain-6lpwa-ipv6-static-context-hc/

Laurent and Ana

-- 
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit
:
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+

---

From: "weigengyu" <[email-masked]>
Date: Wed, 8 Jun 2016 09:52:28 +0800

Hi Laurent and Ana， 

Problems on adopting DTLS should be concerned. 
Maybe there are not CoAP, IPv6 in the future LPWA, or the likes. 

Regards

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Laurent Toutain 
Sent: Tuesday, June 07, 2016 6:40 AM
To: [email-masked] 
Subject: [lp-wan] IPv6/UDP/CoAP Static Context Header Compression for LPWA

Hi, 

You will find a draft describing a hybrid method to compress headers for LPWA.
The draft currently focuses on IPv6/UDP headers. We will soon complete the proposal with CoAP, but we would like to have a feedback from the mailing list on the method.

Laurent and Ana

-- 

Laurent Toutain 
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit : 
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |  http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+

--------------------------------------------------------------------------------
_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Laurent Toutain <[email-masked]>
Date: Wed, 8 Jun 2016 06:21:06 +0200

Hi Weigengyu,

I agree DTLS should be investigated. The compression scheme I proposed
should be compatible
with DTLS since both ends can reconstruct exactly the same full IPv6/UDP
headers.

Laurent

On Wed, Jun 8, 2016 at 3:52 AM, weigengyu <[email-masked]> wrote:

> *From:* Laurent Toutain <[email-masked]>
> *Sent:* Tuesday, June 07, 2016 6:40 AM
> *To:* [email-masked]
> *Subject:* [lp-wan] IPv6/UDP/CoAP Static Context Header Compression for
> LPWA
>
> Hi,
>
> ------------------------------

---

From: Xavier Vilajosana <[email-masked]>
Date: Fri, 10 Jun 2016 05:26:21 +0200

Hi,

what about COSE instead of DTLS
https://datatracker.ietf.org/wg/cose/documents/

it seems less verbose.

regards,
Xavi

*Xavier Vilajosana*
*CIO*

Mobile: (+34) 646 633 681 <%28%2B34%29%2093%20418%2005%2085>
Office: (+34) 93 418 05 85

Aragó, 383, 4th floor
08013 Barcelona, Spain

9-10 Carlos Place, Mayfair
London W1K 3AT, UK

*This email may contain confidential information and may be subject to
professional secrecy. Its dissemination, copying, distribution,
reproduction, forwarding or any other unauthorized use is strictly
prohibited. If you receive this email in error, please notify us
immediately and arrange for its deletion, together with any attached
documents.*

*Este correo electrónico puede contener información estrictamente
confidencial, y puede estar sometido al secreto profesional. Está prohibida
su difusión, copia, distribución, reproducción, reenvío o cualquier otro
uso no autorizado. En caso de recibir este correo por error, rogamos nos
lo comunique de inmediato y proceda a su eliminación, así como de cualquier
documento que se adjunte.*

2016-06-08 6:21 GMT+02:00 Laurent Toutain <
[email-masked]>:

>> The draft currently focuses on IPv6/UDP headers. We will soon complete
>> the proposal with CoAP, but we would like to have a feedback from the
>> mailing list on the method.
>>
>>

-- 

Aragó, 383, 4th floor
08013 Barcelona, Spain

9-10 Carlos Place, Mayfair
London W1K 3AT, UK

*This email may contain confidential information and may be subject to 
professional secrecy. Its dissemination, copying, distribution, 
reproduction, forwarding or any other unauthorized use is strictly 
prohibited. If you receive this email in error, please notify us 
immediately and arrange for its deletion, together with any attached 
documents.*

*Este correo electrónico puede contener información estrictamente 
confidencial, y puede estar sometido al secreto profesional. Está prohibida 
su difusión, copia, distribución, reproducción, reenvío o cualquier otro 
uso no autorizado. En caso de recibir este correo por error, rogamos nos 
lo comunique de inmediato y proceda a su eliminación, así como de cualquier 
documento que se adjunte.*

---

From: "weigengyu" <[email-masked]>
Date: Sun, 12 Jun 2016 11:29:59 +0800

Hi Xavi, 

COSE is an approach to secure content of IOT. 
It seems that COSE is at application layer while DTLS is at transport layer. 
Each of them does its works. 

Regards, 

Gengyu WEI

From: Xavier Vilajosana 
Sent: Friday, June 10, 2016 11:26 AM
To: Laurent Toutain 
Cc: [email-masked] ; weigengyu 
Subject: Re: [lp-wan] IPv6/UDP/CoAP Static Context Header Compression forLPWA

Hi, 

it seems less verbose. 

regards,
Xavi

Xavier Vilajosana
CIO

Mobile: (+34) 646 633 681

Aragó, 383, 4th floor
08013 Barcelona, Spain

This email may contain confidential information and may be subject to professional secrecy. Its dissemination, copying, distribution, reproduction, forwarding or any other unauthorized use is strictly prohibited. If you receive this email in error, please notify us immediately and arrange for its deletion, together with any attached documents.

Este correo electrónico puede contener información estrictamente confidencial, y puede estar sometido al secreto profesional. Está prohibida su difusión, copia, distribución, reproducción, reenvío o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminación, así como de cualquier documento que se adjunte.

2016-06-08 6:21 GMT+02:00 Laurent Toutain <[email-masked]>:

  Hi Weigengyu, 

  I agree DTLS should be investigated. The compression scheme I proposed should be compatible
  with DTLS since both ends can reconstruct exactly the same full IPv6/UDP headers. 

  Laurent

    Hi Laurent and Ana， 

    Regards

    Gengyu WEI

    From: Laurent Toutain 

    Hi, 

    Laurent and Ana

    -- 

    Laurent Toutain 

----------------------------------------------------------------------------
    _______________________________________________
    lp-wan mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lp-wan

  -- 

  Laurent Toutain 

Aragó, 383, 4th floor
08013 Barcelona, Spain

This email may contain confidential information and may be subject to professional secrecy. Its dissemination, copying, distribution, reproduction, forwarding or any other unauthorized use is strictly prohibited. If you receive this email in error, please notify us immediately and arrange for its deletion, together with any attached documents.

Este correo electrónico puede contener información estrictamente confidencial, y puede estar sometido al secreto profesional. Está prohibida su difusión, copia, distribución, reproducción, reenvío o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminación, así como de cualquier documento que se adjunte.

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Mon, 13 Jun 2016 01:43:02 +0000

Hi Laurent, Ana,

I took a look at your draft and I have some questions/comments:

-        In section 2 you mention “a” static context. However, I think there could be multiple contexts per device. Do you agree?

-        You make several references about using the MAC address to identify the context. I think a more generic term applicable to several LPWA technologies would be “device identifier.”

-        In 3.1.8 you make reference to LPWA AP. Shouldn’t it be LC?

Best,

Juan Carlos

From: lp-wan [mailto:[email-masked]] On Behalf Of Laurent Toutain
Sent: June 7, 2016 12:41 AM
To: [email-masked]
Subject: [lp-wan] IPv6/UDP/CoAP Static Context Header Compression for LPWA

Hi,

Laurent and Ana

| [email-masked]<mailto:[email-masked]>         | [email-masked]<mailto:[email-masked]>    |

---

From: Laurent Toutain <[email-masked]>
Date: Mon, 13 Jun 2016 19:03:37 +0200

Hi Juan Carlos,

Thanks for your comments, see below;

On Mon, Jun 13, 2016 at 3:43 AM, Juan Carlos Zuniga <
[email-masked]> wrote:

> -        In section 2 you mention “a” static context. However, I think
> there could be multiple contexts per device. Do you agree?
>
In my view, there is a single context per LC or ES, the context contains a
set of rules identified by a context id.

>
> -        You make several references about using the MAC address to
> identify the context. I think a more generic term applicable to several
> LPWA technologies would be “device identifier.”
>
> yes, may be MAC is too specific to IEEE. LoRaWAN calls it DevAddr, I don't
know for Sigfox.

> -        In 3.1.8 you make reference to LPWA AP. Shouldn’t it be LC?
correct, I will change it.

Thanks,

Laurent

> Best,
>
>
>
> Juan Carlos
>
>
>
>
>
> *From:* lp-wan [mailto:[email-masked]] *On Behalf Of *Laurent
> Toutain
> *Sent:* June 7, 2016 12:41 AM
> *To:* [email-masked]

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Mon, 13 Jun 2016 19:13:26 +0000

Hi Laurent,

From: Laurent Toutain [mailto:[email-masked]]
Sent: June 13, 2016 2:04 PM
To: Juan Carlos Zuniga <[email-masked]>
Cc: Ana Minaburo <[email-masked]>; lp-wan <[email-masked]>
Subject: Re: [lp-wan] IPv6/UDP/CoAP Static Context Header Compression for LPWA

Hi Juan Carlos,

On Mon, Jun 13, 2016 at 3:43 AM, Juan Carlos Zuniga <[email-masked]<mailto:[email-masked]>> wrote:
Hi Laurent, Ana,

-        In section 2 you mention “a” static context. However, I think there could be multiple contexts per device. Do you agree?
In my view, there is a single context per LC or ES, the context contains a set of rules identified by a context id.
[JCZ] I see, then different rules can be applied for different situations.

-        You make several references about using the MAC address to identify the context. I think a more generic term applicable to several LPWA technologies would be “device identifier.”
yes, may be MAC is too specific to IEEE. LoRaWAN calls it DevAddr, I don't know for Sigfox.
[JCZ] Indeed MAC is more IEEE-specific. In the case of Sigfox it can be called End-Point ID, but I think for this draft Device ID would be a more generic term.

[JCZ] Cool. Thanks.

Juan Carlos

Thanks,

Laurent
Best,

Juan Carlos

From: lp-wan [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Laurent Toutain
Sent: June 7, 2016 12:41 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [lp-wan] IPv6/UDP/CoAP Static Context Header Compression for LPWA

Hi,

Laurent and Ana

--
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156<tel:%2B33%202%2022%2006%208156>    | Tel: + 33 2 99 12 7026<tel:%2B%2033%202%2099%2012%207026>                 | Visit :
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445<tel:%2B33%202%2022%2006%208445>    | Fax: +33 2 99 12 7030<tel:%2B33%202%2099%2012%207030>                  |  http://class.touta.in
| [email-masked]<mailto:[email-masked]>         | [email-masked]<mailto:[email-masked]>    |
+--------------------------+----------------------------------------+