Subject: [lp-wan] Draft agenda for the BoF in Berlin

From: Alexander Pelov <[email-masked]>
Date: Fri, 3 Jun 2016 16:19:11 +0200

Dear all,

Please find below a draft agenda for the 6LPWA BoF for Berlin. It is not settled yet, but I think we are looking at a good start for discussions.

* Note: I have arbitrarily assigned names for the presenters, coming from the mailing list activity. People that are mentioned - please confirm your availability and your willingness to work + present during the BoF. 
* Note 2: I’d expect all presentations mentioned in this program to be accompanied by a draft document which gives background to the presentation. We’ll have extremely tight schedule, so being able to look this in advance will be of great importance. I’d say that we should have the drafts by the end of June. 

The allocated slot is expected to be 2h, divided into two parts:
- 1h - Presentations - technologies, gaps, current drafts,
- 40mn -> 1h - Proposed charter and work items discussion / edition
- QSP solution drafts

The following subjects could be presented, in three groups - technology, gap analysis, solutions:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Technology (40 mins, < 10 min per presentation)

- General introduction, 6LPWA architecture - Alexander Pelov, P. Thubert
- Technology slot 1: 3GPP LPWA (NB-IoT / EC-GSM-IoT / Cat-M1) - Antti Ratilainen
- Technology slot 2: IEEE LPWA (Wi-SUN, IEEE 802.15.4g) - Bob Heile, Jonathan Munoz
- Technology slot 3: LoRa - Alper Yegin
- Technology slot 4: SIGFOX - Juan Carlos Zuniga 

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - WG scope, gaps, initial work (20 mins, < 10 min per presentation)

Gap analysis, IPv6 applicability for LPWA (20 min) 
- LPWA Gap analysis - Ana Minaburo ( draft-minaburo-lp-wan-gap-analysis-01 )
- Analysis of IPv6 over LPWA: design space and challenges - Carles Gomez ( draft-gomez-lpwan-ipv6-analysis-00 )

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Work items, charter  (Discussion, Charter text bashing, < 1H)

Charter and work Items Discussions, led by chairs (< 1H)
- Interaction model with LPWA technologies (just cross participations? ISGs?)
- Review proposed work items, one by one

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Work in progress  (QSP, < 5mn per presentation)

Solution drafts (QSP)
- IPv6 over LPWA with compression context - Laurent Toutain ( draft-toutain-lp-wan-compression-context-00 )
- Optimized 6LoWPAN Fragmentation Header for LPWA - Carles Gomez ( draft-gomez-lpwan-fragmentation-header-01 )
- AAA in LPWA : LoRaWAN Authentication in RADIUS and Diameter - Dan Garcia ( draft-garcia-radext-radius-lorawan-00 and draft-garcia-dime-diameter-lorawan-00 )
- Constrained Signaling over LPWA - Laurent Toutain ( draft-pelov-core-cosol-01 ) 

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - 

As you can see, the schedule is extremely tight. We do need to get a sense of the technologies. We do need to explore the gaps, areas where IETF work can be beneficial. On that foundation, we want to validate the proposed charter, to be confirmed on the ML, and that's probably the topic on which most of the discussion at the meeting should focus. If we can, we would also like to show that we already have meaningful solution work, be it only to demonstrate that we are not boiling the Ocean here. But then, that will be if time permits.

I would suggest that all presenters work with the chairs of the BoF (Pascal and I acting, to be confirmed by Suresh) so that we can streamline the process. In particular, we could agree on a skeleton 4-5 slides that would be instantiated for each technologies for their 10mn slot.

What do you all think?

Best,
Alexander

TLDR:
Proposed baseline technology presenters: OK/Not OK/Will see?
Baseline technology drafts: Deadline June 31st 
Presentation list: Add/Remove?

---

From: Alper Yegin <[email-masked]>
Date: Mon, 6 Jun 2016 11:09:18 +0300

Hello Alexander,

Looks good.

One comment: I suggest we don't discuss any solution drafts at this
meeting. If we can agree on the problem statement, and work scope, that's
already a major and important accomplishment. And we need to get it right.
It'd be too early to be looking at the solutions.

Alper

On Fri, Jun 3, 2016 at 5:19 PM, Alexander Pelov <[email-masked]> wrote:

> Dear all,
>
> Please find below a draft agenda for the 6LPWA BoF for Berlin. It is not
> settled yet, but I think we are looking at a good start for discussions.
>
> * Note: I have arbitrarily assigned names for the presenters, coming from
> the mailing list activity. People that are mentioned - please confirm your
> availability and your willingness to work + present during the BoF.
> * Note 2: I’d expect all presentations mentioned in this program to be
> accompanied by a draft document which gives background to the presentation.
> We’ll have extremely tight schedule, so being able to look this in advance
> will be of great importance. I’d say that we should have the drafts by the
> end of June.
>
> - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - WG scope,
> gaps, initial work (20 mins, < 10 min per presentation)
>
> - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Work
> items, charter  (Discussion, Charter text bashing, < 1H)
>
> - IPv6 over LPWA with compression context - Laurent Toutain (
> draft-toutain-lp-wan-compression-context-00 )
> - Optimized 6LoWPAN Fragmentation Header for LPWA - Carles Gomez (
> draft-gomez-lpwan-fragmentation-header-01 )
> - AAA in LPWA : LoRaWAN Authentication in RADIUS and Diameter - Dan Garcia
> ( draft-garcia-radext-radius-lorawan-00 and
> draft-garcia-dime-diameter-lorawan-00 )
> As you can see, the schedule is extremely tight. We do need to get a sense
> of the technologies. We do need to explore the gaps, areas where IETF work
> can be beneficial. On that foundation, we want to validate the proposed
> charter, to be confirmed on the ML, and that's probably the topic on which
> most of the discussion at the meeting should focus. If we can, we would
> also like to show that we already have meaningful solution work, be it only
> to demonstrate that we are not boiling the Ocean here. But then, that will
> be if time permits.
>
> I would suggest that all presenters work with the chairs of the BoF
> (Pascal and I acting, to be confirmed by Suresh) so that we can streamline
> the process. In particular, we could agree on a skeleton 4-5 slides that
> would be instantiated for each technologies for their 10mn slot.
>
> What do you all think?
>
> Best,
> Alexander
>
> TLDR:

---

From: Alexander Pelov <[email-masked]>
Date: Mon, 6 Jun 2016 10:16:50 +0200

Dear Alper,

Great, thanks! 

See inline.

> Le 6 juin 2016 à 10:09, Alper Yegin <[email-masked]> a écrit :
> 
> Hello Alexander,
> 
> Looks good.
> 
> One comment: I suggest we don't discuss any solution drafts at this meeting. If we can agree on the problem statement, and work scope, that's already a major and important accomplishment. And we need to get it right. It'd be too early to be looking at the solutions.

Yes, completely agree that it would be an important point to have the problem statement and the charter voted at this meeting. I am hoping to get a convergence on this before the meeting and this is the reason I’d love to see the baseline technology providers write up some informational documents before the end of this month.

Would you be willing to initiate the draft for the LoRaWAN technology? 

Best,
Alexander

> 
> Alper
> 
> 
> On Fri, Jun 3, 2016 at 5:19 PM, Alexander Pelov <[email-masked] <mailto:[email-masked]>> wrote:
> Dear all,
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 06 Jun 2016 10:24:57 +0200

Alper Yegin wrote:
> meeting. If we can agree on the problem statement, and work scope,
> that's already a major and important accomplishment. And we need to get
> it right. It'd be too early to be looking at the solutions.

Right, the formal BOF itself should entirely be reserved for outlining
and scoping the work.

This does not have to stop us from having a few hallway meetings ("Bar
BOFs") around specific solution approaches, before and/or after the
formal BOF meeting.  We might even want to get a room, if there is
sufficient material where discussion would benefit from a projector.

Grüße, Carsten

---

From: Alper Yegin <[email-masked]>
Date: Mon, 6 Jun 2016 11:27:33 +0300

Good idea.
A Sunday meeting would be good.

Alper

---

From: Alexander Pelov <[email-masked]>
Date: Mon, 6 Jun 2016 10:33:23 +0200

Sounds great.

We have to make sure that new arrivals can attend the newcomers training. Also, if we manage to have the BoF on Monday that would be indeed a great slot to prepare the BoF.

Alexander

> Le 6 juin 2016 à 10:27, Alper Yegin <[email-masked]> a écrit :
> 
> Good idea.
> On Mon, Jun 6, 2016 at 11:24 AM, Carsten Bormann <[email-masked] <mailto:[email-masked]>> wrote:
> Alper Yegin wrote:

---

From: Alper Yegin <[email-masked]>
Date: Mon, 6 Jun 2016 11:07:57 +0300

Hello Alexander,

Looks good.

Alper

---

From: "weigengyu" <[email-masked]>
Date: Mon, 6 Jun 2016 19:34:13 +0800

Hi， 

Please pay attention to the problem about IP context and usage of CoAP/DTLS/UDP stack. 
As 6LPWA wants to have CoAP/DTLS be used in 6LPWA networks, 
without IP context the DTLS does not work by current RFC.

Regards,

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Alper Yegin 
Sent: Monday, June 06, 2016 4:09 PM
To: Alexander Pelov ; Pascal Thubert (pthubert) 
Cc: lp-wan 
Subject: [lp-wan] Fwd: Draft agenda for the BoF in Berlin

Hello Alexander,

Looks good.

Alper

  Dear all,

  Solution drafts (QSP)

  What do you all think?

  Best,
  Alexander

  TLDR:

--------------------------------------------------------------------------------
_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Mon, 6 Jun 2016 14:02:31 +0000

I have similar views on the agenda. Discussion/presentations should be
more about the problem statement and not steer the charter on specific
solution approaches. Before we discuss the solution approaches, lets get
consensus on each of the work item, its relevance to each SDO and then
allow the WG members to come back with specific proposals for discussion.
Will the signaling protocol be CoAP or some thing else, is unknown and
that discussion needs to happen. In that sense the discussion on the
solution drafts for this meeting is premature. I¹d rather use that time to
discuss the work items and relative prioritization.

Sri

On 6/3/16, 7:19 AM, "lp-wan on behalf of Alexander Pelov"
<[email-masked] on behalf of [email-masked]> wrote:

>the mailing list activity. People that are mentioned - please confirm
>your availability and your willingness to work + present during the BoF.
>accompanied by a draft document which gives background to the
>presentation. We’ll have extremely tight schedule, so being able to look
>this in advance will be of great importance. I’d say that we should have
>the drafts by the end of June.
>
>Technology (40 mins, < 10 min per presentation)
>
>- AAA in LPWA : LoRaWAN Authentication in RADIUS and Diameter - Dan
>Garcia ( draft-garcia-radext-radius-lorawan-00 and
>As you can see, the schedule is extremely tight. We do need to get a
>sense of the technologies. We do need to explore the gaps, areas where
>IETF work can be beneficial. On that foundation, we want to validate the
>proposed charter, to be confirmed on the ML, and that's probably the
>topic on which most of the discussion at the meeting should focus. If we
>can, we would also like to show that we already have meaningful solution
>work, be it only to demonstrate that we are not boiling the Ocean here.
>But then, that will be if time permits.
>
>(Pascal and I acting, to be confirmed by Suresh) so that we can
>streamline the process. In particular, we could agree on a skeleton 4-5
>slides that would be instantiated for each technologies for their 10mn
>slot.
>
>What do you all think?
>
>Best,
>Alexander
>
>TLDR:

---

From: Alexander Pelov <[email-masked]>
Date: Mon, 6 Jun 2016 19:47:32 +0200

Dear Sri, 

yes, sure, I agree entirely with you. 

Doing a separate track on the proposed solutions (as a bar BoF or other format) is great - we’ll have the time to get into more details. 

One thing I would really like to avoid is to leave all issues for the BoF. We need to prepare the points beforehand, so that we have a structured dialogue. This is the reason I think having technology-based drafts before the end of this month would be a great starting point.  

This is the updated version of the presentation schedule, without the solutions. 

- General introduction, 6LPWA architecture - Alexander Pelov, P. Thubert
- Technology slot 1: 3GPP LPWA (NB-IoT / EC-GSM-IoT / Cat-M1) - Antti
Ratilainen
- Technology slot 2: IEEE LPWA (Wi-SUN, IEEE 802.15.4g) - Bob Heile,
Jonathan Munoz
- Technology slot 3: LoRa - Alper Yegin
- Technology slot 4: SIGFOX - Juan Carlos Zuniga

Gap analysis, IPv6 applicability for LPWA (20 min)
- LPWA Gap analysis - Ana Minaburo (
draft-minaburo-lp-wan-gap-analysis-01 )
- Analysis of IPv6 over LPWA: design space and challenges - Carles Gomez
( draft-gomez-lpwan-ipv6-analysis-00 )

Best,
Alexander

> Le 6 juin 2016 à 16:02, Sri Gundavelli (sgundave) <[email-masked]> a écrit :
> 
>

---

From: Alexander Pelov <[email-masked]>
Date: Mon, 6 Jun 2016 19:52:11 +0200

Dear Carsten,

Yes, this sounds great. It seems to me that there are many people working in similar topics and I would really like to have such a track where we can sit down and talk on specific solutions and the way they could work together.

Best,
Alexander

> Le 6 juin 2016 à 10:24, Carsten Bormann <[email-masked]> a écrit :
> 
> Alper Yegin wrote:

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 7 Jun 2016 07:35:13 +0000

Dear all:

> > that's already a major and important accomplishment. And we need to
> > get it right. It'd be too early to be looking at the solutions.
> 
> Right, the formal BOF itself should entirely be reserved for outlining and scoping
> the work.

Please note that it always was;

The solution drafts in the original agenda were marked Quantum Satis, in case there would be time left at the end of the meeting. It was also a way to give visibility to the work; I'm fine removing those entries if that clarifies the goal of the meeting. 

Organizing a barbof is a great idea; it has to be on Sunday or Monday evening, though, otherwise we'll love LoRa and some of the 6TiSCH crowds.

Cheers,

Pascal

> -----Original Message-----
> From: lp-wan [mailto:[email-masked]] On Behalf Of Carsten Bormann
> Sent: lundi 6 juin 2016 10:25
> To: Alper Yegin <[email-masked]>
> Cc: lp-wan <[email-masked]>; Pascal Thubert (pthubert)
> <[email-masked]>; Alexander Pelov <[email-masked]>
> Subject: Re: [lp-wan] Fwd: Draft agenda for the BoF in Berlin
> 
> Alper Yegin wrote:
> > that's already a major and important accomplishment. And we need to
> > get it right. It'd be too early to be looking at the solutions.
> 
> Right, the formal BOF itself should entirely be reserved for outlining and scoping
> the work.
> 
> BOFs") around specific solution approaches, before and/or after the formal BOF
> meeting.  We might even want to get a room, if there is sufficient material
> where discussion would benefit from a projector.
> 
> Grüße, Carsten
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 7 Jun 2016 07:50:15 +0000

Hello Alex and all:

I updated the BoF Wiki: https://trac.tools.ietf.org/bof/trac/wiki/WikiStart  as follows:

    General introduction, 6LPWA architecture - Alexander Pelov, P. Thubert

    Selected technologies: presentation and characterization [40mn]
        Technology slot 1: 3GPP LPWA (NB-IoT / EC-GSM-IoT / Cat-M1) - Antti Ratilainen
        Technology slot 2: IEEE LPWA (Wi-SUN, IEEE 802.15.4g) - Bob Heile, Jonathan Munoz
        Technology slot 3: LoRa? - Alper Yegin
        Technology slot 4: SIGFOX - Juan Carlos Zuniga 

    Applicability and gap analysis of Internet protocols [20mn]
        LPWA Gap analysis - Ana Minaburo (draft-minaburo-lp-wan-gap-analysis)
        Analysis of IPv6 over LPWA: design space and challenges - Carles Gomez (draft-gomez-lpwan-ipv6-analysis) 

    Charter and work Items Discussions, led by chairs (< 1H)
        Interaction model with LPWA technologies (just cross participations? ISGs?)
        Review proposed work items, one by one

Please note that the applicability is not limited to IPv6 but has Internet protocols, so as to include CoAP etc...

Works?

Pascal

> From: lp-wan [mailto:[email-masked]] On Behalf Of Alexander Pelov
> Sent: lundi 6 juin 2016 19:48
> To: Sri Gundavelli (sgundave) <[email-masked]>
> Cc: lp-wan <[email-masked]>
> Subject: Re: [lp-wan] Draft agenda for the BoF in Berlin
> 
> Dear Sri,
> 
> Doing a separate track on the proposed solutions (as a bar BoF or other format)
> is great - we’ll have the time to get into more details.
> 
> One thing I would really like to avoid is to leave all issues for the BoF. We need
> to prepare the points beforehand, so that we have a structured dialogue. This is
> the reason I think having technology-based drafts before the end of this month
> would be a great starting point.
> 
> > solution approaches. Before we discuss the solution approaches, lets
> > get consensus on each of the work item, its relevance to each SDO and
> > then allow the WG members to come back with specific proposals for
> discussion.
> > solution drafts for this meeting is premature. I¹d rather use that
> > time to discuss the work items and relative prioritization.
> >
> > Sri
> >
> >
> >
> >
> >
> >
> >> Please find below a draft agenda for the 6LPWA BoF for Berlin. It is
> >> not settled yet, but I think we are looking at a good start for discussions.
> >>
> >> * Note: I have arbitrarily assigned names for the presenters, coming
> >> from the mailing list activity. People that are mentioned - please
> >> confirm your availability and your willingness to work + present during the
> BoF.
> >> * Note 2: I’d expect all presentations mentioned in this program to
> >> be accompanied by a draft document which gives background to the
> >> presentation. We’ll have extremely tight schedule, so being able to
> >> look this in advance will be of great importance. I’d say that we
> >> should have the drafts by the end of June.
> >>
> >> - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - WG
> >> scope, gaps, initial work (20 mins, < 10 min per presentation)
> >>
> >> - Analysis of IPv6 over LPWA: design space and challenges - Carles
> >> Gomez ( draft-gomez-lpwan-ipv6-analysis-00 )
> >>
> >> in progress  (QSP, < 5mn per presentation)
> >>
> >> Solution drafts (QSP)
> >> sense of the technologies. We do need to explore the gaps, areas
> >> where IETF work can be beneficial. On that foundation, we want to
> >> validate the proposed charter, to be confirmed on the ML, and that's
> >> probably the topic on which most of the discussion at the meeting
> >> should focus. If we can, we would also like to show that we already
> >> have meaningful solution work, be it only to demonstrate that we are not
> boiling the Ocean here.
> >> streamline the process. In particular, we could agree on a skeleton
> >> 4-5 slides that would be instantiated for each technologies for their
> >> 10mn slot.
> >>
> >> What do you all think?
> >>
> >> Best,
> >> Alexander
> >>
> >> TLDR:
> >> Baseline technology drafts: Deadline June 31st Presentation list:
> >> Add/Remove?
> >>

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Mon, 13 Jun 2016 01:27:09 +0000

Hi Pascal, Alexander,

The agenda looks ok to me. 

There was also the idea of agreeing on a 4-5 slides skeleton for the presenters. Since there will be limited time for each technology. I think having a common template is a good idea to help with timing and structure.

     - Are you planning to send a proposal for this skeleton/template?

Also, if you decide to go ahead with the Bar BoF on Sunday, please avoid conflict with the IEEE 802 tutorial that will take place on Sunday afternoon.

Best,

Juan Carlos 

-----Original Message-----
From: lp-wan [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: June 7, 2016 9:50 AM
To: Alexander Pelov <[email-masked]>; lp-wan <[email-masked]>
Subject: Re: [lp-wan] Draft agenda for the BoF in Berlin

Hello Alex and all:

Works?

Pascal

> Doing a separate track on the proposed solutions (as a bar BoF or 
> other format) is great - we’ll have the time to get into more details.
> 
> One thing I would really like to avoid is to leave all issues for the 
> BoF. We need to prepare the points beforehand, so that we have a 
> structured dialogue. This is the reason I think having 
> technology-based drafts before the end of this month would be a great starting point.
> 
> > Le 6 juin 2016 à 16:02, Sri Gundavelli (sgundave) 
> > <[email-masked]> a
> écrit :
> >
> >
> > I have similar views on the agenda. Discussion/presentations should 
> > be more about the problem statement and not steer the charter on 
> > specific solution approaches. Before we discuss the solution 
> > approaches, lets get consensus on each of the work item, its 
> > relevance to each SDO and then allow the WG members to come back 
> > with specific proposals for
> discussion.
> > Will the signaling protocol be CoAP or some thing else, is unknown 
> > and that discussion needs to happen. In that sense the discussion on 
> > the solution drafts for this meeting is premature. I¹d rather use 
> > that time to discuss the work items and relative prioritization.
> >
> > Sri
> >
> >
> >
> >
> >
> >
> >> Please find below a draft agenda for the 6LPWA BoF for Berlin. It 
> >> is not settled yet, but I think we are looking at a good start for discussions.
> >>
> >> * Note: I have arbitrarily assigned names for the presenters, 
> >> coming from the mailing list activity. People that are mentioned - 
> >> please confirm your availability and your willingness to work + 
> >> present during the
> BoF.
> >> Work items, charter  (Discussion, Charter text bashing, < 1H)
> >>
> >> Work in progress  (QSP, < 5mn per presentation)
> >>
> >> Solution drafts (QSP)
> >> As you can see, the schedule is extremely tight. We do need to get 
> >> a sense of the technologies. We do need to explore the gaps, areas 
> >> validate the proposed charter, to be confirmed on the ML, and 
> >> that's probably the topic on which most of the discussion at the 
> >> meeting should focus. If we can, we would also like to show that we 
> >> already have meaningful solution work, be it only to demonstrate 
> >> that we are not
> boiling the Ocean here.
> >> 4-5 slides that would be instantiated for each technologies for 
> >> their 10mn slot.
> >>
> >> What do you all think?
> >>
> >> Best,
> >> Alexander
> >>
> >> TLDR: