Subject: Re: [lp-wan] [hackathon] SCHC testing

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 26 Jun 2017 18:36:31 +0000

Moving that maturity needle forward is one of the primary goals of the hackathon. It is great to see projects that work with established standards and produce code and tools that help others use and develop solutions on top of those standards, but it is even better to have projects that speed up and improve the quality of emerging standards.

Cheers,
Charles

From: hackathon <[email-masked]> on behalf of "Pascal Thubert (pthubert)" <[email-masked]>
Date: Monday, June 26, 2017 at 1:32 AM
To: weigengyu <[email-masked]>, Laurent Toutain <[email-masked]>, lp-wan <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [hackathon] [lp-wan] SCHC testing

Hello Gengyu

I thing that by ”mature” Laurent meant “stable”. And I agree it is stable. It works. We are now getting ready for last call. I agree that real maturity will come with deployment experience.

Cheers;

Pascal
From: lp-wan [mailto:[email-masked]] On Behalf Of weigengyu
Sent: vendredi 23 juin 2017 08:15
To: Laurent Toutain <[email-masked]>; lp-wan <[email-masked]>; [email-masked]
Subject: Re: [lp-wan] SCHC testing

Hi all,
The doc is just a draft.

> The LPWAN compression mechanism SCHC defined in draft-ietf-lpwan-ipv6-static-context-hc is mature
From a technical view point, it is not a mature because it can be optimize apparently.

Regards,

Gengyu WEI
Network Technology Center
School of Computer
Beijing University of Posts and Telecommunications

From: Laurent Toutain<mailto:[email-masked]>
Sent: Friday, June 23, 2017 2:10 AM
To: lp-wan<mailto:[email-masked]> ; [email-masked]<mailto:[email-masked]>
Subject: [lp-wan] SCHC testing

Hi,

The LPWAN compression mechanism SCHC defined in draft-ietf-lpwan-ipv6-static-context-hc is mature and at least 3 implementations already exist. During the next Hackathon in Prague, a LoRaWAN and a Sigfox network will be available to perform test of SCHC with several objectives:

-       allow developers to understand SCHC behavior and implement their own version of the mechanism

-       test interoperability between the existing implementations

-       define compression and fragmentation rules related to specific traffic
Come with your own devices or use the pycom devices we will bring to participate to the real Internet of Things. To participate you need to register as quickly as possible on http://ietf.org/hackathon/99-hackathon.html

We will provide more technical details on the coming days.

Laurent
________________________________
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: "weigengyu" <[email-masked]>
Date: Tue, 27 Jun 2017 11:48:59 +0800

Hi, 

The intention of suppression in the draft is to save bits.
Suppose that an IPv6 packet is partioned into N fragments and the length of Rule ID is R bits. 
Using/Adding 2 bits in Dtag as an indication. 
As a result, it can save (N-1)*R bits by costing 2*N bits. 

I am not sure whether it is worth to save these bits by trading off a few days.  

Regards, 

Gengyu WEI

From: Charles Eckel (eckelcu) 
Sent: Tuesday, June 27, 2017 2:36 AM
To: Pascal Thubert (pthubert) ; weigengyu ; Laurent Toutain ; lp-wan ; [email-masked] 
Subject: Re: [lp-wan] [hackathon] SCHC testing

Cheers,

Charles 

Hello Gengyu 

Cheers;

Pascal

Hi all,

The doc is just a draft. 

Regards, 

Gengyu WEI

From: Laurent Toutain 

To: lp-wan ; [email-masked] 

Hi,

Laurent

--------------------------------------------------------------------------------

[email-masked]

--------------------------------------------------------------------------------
_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan