Subject: [lp-wan] identifying lost fragment in the last window

From: Arun <[email-masked]>
Date: Wed, 14 Jun 2017 19:00:47 +0200

Hi All, 

Reference: doc:draft-ietf-lpwan-ipv6-static-context-hc-03, page:34, figure 18;

from the receiver point of view, 
how does he know that CFN=4 is lost ? when he receives the CFN=7 ?  to create the bitmap of 11010001. 

MIC check will fail after CFN=7 but I couldn't get to understand how the receiver can identify if only CFN=4 is lost or CFN=3,2,1(if any)... are also lost.

Am I missing something ?

	    Sender     	         Receiver
             |-----W=1, CFN=6----->|
             |-----W=1, CFN=5----->|
             |-----W=1, CFN=4--X-->|
             |-----W=1, CFN=3----->|
             |-----W=1, CFN=2--X-->|
             |-----W=1, CFN=1----->|
             |-----W=1, CFN=0----->|
             |<-------ACK----------|bitmap:11010111
             |-----W=1, CFN=4----->|
             |-----W=1, CFN=2----->|
             |<-------ACK----------|no bitmap
             |-----W=0, CFN=6----->|
             |-----W=0, CFN=5----->|
             |-----W=0, CFN=4--X-->|
             |-----W=0, CFN=7----->|MIC checked
             |<-------ACK----------|bitmap:11010001
             |-----W=0, CFN=4----->|MIC checked =>
             |<-------ACK----------|no bitmap
           (End)

similar question on Figure 16. Ack on Error.

thanks,
Arun

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Thu, 15 Jun 2017 15:22:17 +0200

Hi Arun,

Thanks for pointing this out!

Yes, this kind of ambiguity can be easily removed if in the last window
(the one that contains the "all ones CFN", CFN=7 in the example), a
receiver only uses the last bit in the bitmap to report about the "all
ones CFN".

In that case, the last bitmap in the example would be 11000001.

We will make sure that the next draft update (the -04 that is coming soon)
reflects this behavior correctly.

Cheers,

Carles

> MIC check will fail after CFN=7 but I couldn't get to understand how the
> receiver can identify if only CFN=4 is lost or CFN=3,2,1(if any)... are
> also lost.
>
> Am I missing something ?
>
> 	    Sender     	         Receiver
>              |-----W=1, CFN=6----->|
>              |-----W=1, CFN=5----->|
>              |-----W=1, CFN=4--X-->|
>              |-----W=1, CFN=3----->|
>              |-----W=1, CFN=2--X-->|
>              |-----W=1, CFN=1----->|
>              |-----W=1, CFN=0----->|