Subject: [lp-wan] Shepherd writeup: IPR on SCHC

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 28 Nov 2018 17:11:06 +0000

Dear all:

The -18 edition will conclude the WG process for SCHC/IP, and as shepherd I will now ask for publication.

Thanks you all for the extraordinary work that was done in a very short time, leading to very quick acceptance by some of the supported LPWAN technologies, more to come from IEEE I expect..

When -18 is published, I'm asking all the authors, and anyone who would reply with a YES, please answer the following:

Are you aware of any IPR that applies to drafts identified above?

To reply please use either:

"No, I'm not aware of any IPR that applies to this draft"

or

"Yes, I'm aware of IPR that applies to this draft"

Many thanks again;

Pascal

---

From: <[email-masked]>
Date: Wed, 28 Nov 2018 17:15:27 +0000

Hello Pascal,

No, I'm not aware of any IPR that applies to this draft.
Best regards

Dominique

De : Pascal Thubert <[email-masked]<mailto:[email-masked]>>
Date : Wednesday 28 November 2018 18:11
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : Shepherd writeup: IPR on SCHC
Renvoyer - De : <[email-masked]<mailto:[email-masked]>>
Renvoyer - À : <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Carles Montenegro <[email-masked]<mailto:[email-masked]>>, Dominique Barthel <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Renvoyer - Date : Wednesday 28 November 2018 18:11

Dear all:

When -18 is published, I’m asking all the authors, and anyone who would reply with a YES, please answer the following:

or

Many thanks again;

Pascal

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Wed, 28 Nov 2018 18:22:19 +0100

Dear Pascal,

Cheers,

Carles

> Thanks you all for the extraordinary work that was done in a very short
> time, leading to very quick acceptance by some of the supported LPWAN
> technologies, more to come from IEEE I expect..
>
>
>
> When -18 is published, I'm asking all the authors, and anyone who would
> reply with a YES, please answer the following:
>
>
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 28 Nov 2018 09:23:07 -0800

Hello Pascal,

I don't see how you can request publication for a document that doesn't 
exist yet.  I didn't even send in all of my comments yet. Moreover, the 
Last Call came out less than a month after the publication of a really 
major rewrite for the fragmentation.  I emphasize that the fragmentation 
specification is highly nontrivial, and deserves careful consideration 
by other people than just myself.  And, some of the other recent 
discussion seems to be beneficial, even if not directly related to the 
putative subject of the last Last Call.

Wouldn't it be a good idea for the interested people in the Working 
Group to at least have a chance to read the document before you 
recommend publication?

Regards,
Charlie P.

PS. The document does not seem to disallow arbitrary/random bit patterns 
for padding.  Has anyone else other than myself analyzed the effect of that?

On 11/28/2018 9:11 AM, Pascal Thubert (pthubert) wrote:
> Thanks you all for the extraordinary work that was done in a very 
> short time, leading to very quick acceptance by some of the supported 
> LPWAN technologies, more to come from IEEE I expect..
>
> When -18 is published, I’m asking all the authors, and anyone who 
> would reply with a YES, please answer the following:
>

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Wed, 28 Nov 2018 17:27:43 +0000

Hello Pascal,

Best,

Juan Carlos

From: Pascal Thubert (pthubert) <[email-masked]>
Sent: November 28, 2018 12:11 PM
To: [email-masked]
Cc: [email-masked]
Subject: Shepherd writeup: IPR on SCHC

Dear all:

or

Many thanks again;

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 28 Nov 2018 18:41:26 +0000

Hello Charlie:

I think I wrote < When -18 is published, ..." didn't you see?

Also; we discussed at the interim today the changes to be done from -17 after the WGLC. They are all editorial. So people at the call who know what to expect already answered.

All the best,

Pascal

From: Charlie Perkins <[email-masked]>
Sent: mercredi 28 novembre 2018 18:23
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Cc: [email-masked]; Suresh Krishnan <[email-masked]>
Subject: Re: [lp-wan] Shepherd writeup: IPR on SCHC

Hello Pascal,

I don't see how you can request publication for a document that doesn't exist yet.  I didn't even send in all of my comments yet.  Moreover, the Last Call came out less than a month after the publication of a really major rewrite for the fragmentation.  I emphasize that the fragmentation specification is highly nontrivial, and deserves careful consideration by other people than just myself.  And, some of the other recent discussion seems to be beneficial, even if not directly related to the putative subject of the last Last Call.

Wouldn't it be a good idea for the interested people in the Working Group to at least have a chance to read the document before you recommend publication?

Regards,
Charlie P.

PS. The document does not seem to disallow arbitrary/random bit patterns for padding.  Has anyone else other than myself analyzed the effect of that?

Dear all:

or

Many thanks again;

Pascal

lp-wan mailing list

[email-masked]<mailto:[email-masked]>

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 28 Nov 2018 10:50:23 -0800

Hello Pascal,

Thanks for pointing out the quoted passage.  But I was responding to the 

> shepherd I will now ask for publication.

I noticed the word "now".  Besides that, predicting that an unpublished 
document would conclude the WG Last Call process seems wrong to me.  Of 
course we can hope for the best.

During a recent conversation with the authors, I was left with the 
impression that my remaining comments on draft ...-17.txt would still be 
welcome.  Is that no longer the case?

Regards,
Charlie P.

On 11/28/2018 10:41 AM, Pascal Thubert (pthubert) wrote:
>
> Hello Charlie:
>
> I think I wrote « When -18 is published, …” didn’t you see?
>
> Also; we discussed at the interim today the changes to be done from 
> -17 after the WGLC. They are all editorial. So people at the call who 
> know what to expect already answered.
>
> All the best,
>
> Pascal
>
> *From:*Charlie Perkins <[email-masked]>
> *Sent:* mercredi 28 novembre 2018 18:23
> *To:* Pascal Thubert (pthubert) <[email-masked]>; 
> [email-masked]
> *Cc:* [email-masked]; Suresh Krishnan <[email-masked]>
> *Subject:* Re: [lp-wan] Shepherd writeup: IPR on SCHC
>
> Hello Pascal,
>
> I don't see how you can request publication for a document that 
> doesn't exist yet.  I didn't even send in all of my comments yet.  
> Moreover, the Last Call came out less than a month after the 
> publication of a really major rewrite for the fragmentation.  I 
> emphasize that the fragmentation specification is highly nontrivial, 
> and deserves careful consideration by other people than just myself.  
> And, some of the other recent discussion seems to be beneficial, even 
> if not directly related to the putative subject of the last Last Call.
>
> PS. The document does not seem to disallow arbitrary/random bit 
> patterns for padding.  Has anyone else other than myself analyzed the 
> effect of that?
>
>     short time, leading to very quick acceptance by some of the
>     supported LPWAN technologies, more to come from IEEE I expect..
>
>     [email-masked]  <mailto:[email-masked]>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 28 Nov 2018 18:58:06 +0000

Hello Charlie :

Yes, the "now" should be a "then", pardon my French. For some reason I missed your edits but Dominique mentioned them at the interim. I understand they are all editorial and it is up to Dominique to accept them or not. In any fashion, the discussion did not give an impression that the proposed modifications could induce any IPR or major delay. So yes, since we have all the comments in hand, we are confident that -18 will the final word of the WG before INT AREA LC.

Take care,

Pascal

From: Charlie Perkins <[email-masked]>
Sent: mercredi 28 novembre 2018 19:50
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: [email-masked]; Suresh Krishnan <[email-masked]>
Subject: Re: [lp-wan] Shepherd writeup: IPR on SCHC

Hello Pascal,

Thanks for pointing out the quoted passage.  But I was responding to the following:
The -18 edition will conclude the WG process for SCHC/IP, and as shepherd I will now ask for publication.

I noticed the word "now".  Besides that, predicting that an unpublished document would conclude the WG Last Call process seems wrong to me.  Of course we can hope for the best.

During a recent conversation with the authors, I was left with the impression that my remaining comments on draft ...-17.txt would still be welcome.  Is that no longer the case?

Regards,
Charlie P.

All the best,

Pascal

From: Charlie Perkins <[email-masked]><mailto:[email-masked]>
Sent: mercredi 28 novembre 2018 18:23
To: Pascal Thubert (pthubert) <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Suresh Krishnan <[email-masked]><mailto:[email-masked]>
Subject: Re: [lp-wan] Shepherd writeup: IPR on SCHC

Hello Pascal,

Regards,
Charlie P.

Dear all:

or

Many thanks again;

Pascal

lp-wan mailing list

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 28 Nov 2018 14:15:14 -0500

Hi Charlie,

> On Nov 28, 2018, at 1:50 PM, Charlie Perkins <[email-masked]> wrote:
> 
> Hello Pascal,
> 
This is certainly conditional on the issues being addressed by -18. If you do find open issues in -18 I am sure they will be addressed before the document leaves the WG.
> During a recent conversation with the authors, I was left with the impression that my remaining comments on draft ...-17.txt would still be welcome.  Is that no longer the case?

Do you have an ETA to complete your review? As long as you can get this done pretty soon, I don’t see why your comments will not be welcome.

Thanks
Suresh

---

From: <[email-masked]>
Date: Wed, 28 Nov 2018 21:09:47 +0000

Hello Charlie,

In my presentation at the interim meeting today, I said we were expecting another round of comments from you.
It's written page 10  in the slide deck, see https://datatracker.ietf.org/doc/agenda-interim-2018-lpwan-16-lpwan-01/
On page 11 and 12, I picked two topics (one technical, the other one editorial) that I felt I needed the group opinion on.
On the other topics we discussed over the phone, I think we pretty much know what we want to do, therefore they were not described to the group.
Together with the discussion on optional MIC, it pretty much filled the one hour slot.
As far as I'm concerned, I'm still interested in the rest of your comments.
Best regards

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Charlie Perkins <[email-masked]<mailto:[email-masked]>>
Date : Wednesday 28 November 2018 19:50
À : Pascal Thubert <[email-masked]<mailto:[email-masked]>>
Cc : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Suresh Krishnan <[email-masked]<mailto:[email-masked]>>
Objet : Re: [lp-wan] Shepherd writeup: IPR on SCHC

Hello Pascal,

Regards,
Charlie P.

All the best,

Pascal

Hello Pascal,

Regards,
Charlie P.

Dear all:

or

Many thanks again;

Pascal

lp-wan mailing list

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 28 Nov 2018 13:17:12 -0800

Hello Dominique,

Thanks very much for your interest.  I just sent my comment files to the 
[lp-wan] mailing list, but the email was held for moderator approval.  
If there is a moderator reading this message, please approve the email, 
or else let me know that I need to reformulate it somehow.  Thanks in 
advance!

Regards,
Charlie P.

On 11/28/2018 1:09 PM, [email-masked] wrote:
> Hello Charlie,
>
> In my presentation at the interim meeting today, I said we were 
> expecting another round of comments from you.
> It's written page 10  in the slide deck, see 
> https://datatracker.ietf.org/doc/agenda-interim-2018-lpwan-16-lpwan-01/
> On page 11 and 12, I picked two topics (one technical, the other one 
> editorial) that I felt I needed the group opinion on.
> On the other topics we discussed over the phone, I think we pretty 
> much know what we want to do, therefore they were not described to the 
> group.
> De : lp-wan <[email-masked] <mailto:[email-masked]>> 
> on behalf of Charlie Perkins <[email-masked] 
> <mailto:[email-masked]>>
> À : Pascal Thubert <[email-masked] <mailto:[email-masked]>>
> Cc : "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>, Suresh Krishnan <[email-masked] 
> <mailto:[email-masked]>>
> I noticed the word "now".  Besides that, predicting that an 
> unpublished document would conclude the WG Last Call process seems 
> wrong to me.  Of course we can hope for the best.
>
> impression that my remaining comments on draft ...-17.txt would still 
> be welcome.  Is that no longer the case?
>
> Regards,
> Charlie P.
>
>

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 28 Nov 2018 13:10:53 -0800

Hello folks,

Attached to this email, please find a file containing my comments on 
draft-ietf-lpwan-ipv6-static-context-hc-17.txt.   Most of my substantive 
comments are inserted as 'pretend-xml' comments prefixed by "<!--  
CEP".  Earlier I had sent about half of these comments to the authors, 
thus my updated filename contains "cepB".  I also append a diff file for 
my comments versus draft-ietf-lpwan-ipv6-static-context-hc-17.txt, as 
well as the diff file between these comments and my previous comments to 
the authors.  I believe the authors already accepted most of the 
comments I had sent to them earlier.

The great majority of the comments are editorial.  Some of the comments 
would be construed as technical comments aimed at modifying the strength 
of certain mandates, and reducing the chance for misinterpretation.

Since I am in a hurry to get these comments into consideration, I had to 
stop reviewing at page 50.   I would like to provide comments for the 
remainder of the document.  Later today I will list the most important 
questions and comments I have about the document.

Thanks for your consideration of these review comments.

Regards,
Charlie P.

On 11/28/2018 11:15 AM, Suresh Krishnan wrote:
> Hi Charlie,
>
>> On Nov 28, 2018, at 1:50 PM, Charlie Perkins 
>> <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Hello Pascal,
>>
> This is certainly conditional on the issues being addressed by -18. If 
> you do find open issues in -18 I am sure they will be addressed before 
> the document leaves the WG.
>>
> Do you have an ETA to complete your review? As long as you can get 
> this done pretty soon, I don’t see why your comments will not be welcome.
>
> Thanks
> Suresh
>

---

From: ana minaburo <[email-masked]>
Date: Fri, 30 Nov 2018 09:00:16 +0100

Hello Pascal,

Ana

On Wed, Nov 28, 2018 at 6:11 PM Pascal Thubert (pthubert) <
[email-masked]> wrote:

> When -18 is published, I’m asking all the authors, and anyone who would

---

From: Laurent Toutain <[email-masked]>
Date: Fri, 30 Nov 2018 09:25:07 +0100

Hi,

Laurent