Subject: [lp-wan] Alissa Cooper's No Objection on draft-ietf-lpwan-ipv6-static-context-hc-21: (with COMMENT)

From: Alissa Cooper via Datatracker <[email-masked]>
Date: Wed, 21 Aug 2019 18:03:15 -0700

Alissa Cooper has entered the following ballot position for
draft-ietf-lpwan-ipv6-static-context-hc-21: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lpwan-ipv6-static-context-hc/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Please respond to the Gen-ART review.

It seems as though RFC 8376 should be a normative reference given its use in
the terminology section.

---

From: <[email-masked]>
Date: Fri, 23 Aug 2019 12:55:47 +0000

Hello Alissa,

Thanks for having taken the time to review our draft, and thanks for your
comments.

Here are my responses:

1) since you posted your ballot, we have responded to Gen-ART review.

2) Regarding a normative ref to RFC 8376: this is not a topic I'm very
familiar with, so please bear with my ignorance.
I've read 
https://www.ietf.org/blog/iesg-statement-normative-and-informative-referenc
es/ and RFC3967/BCP97, which states that
"For example, a   standards track document may not have a normative
reference to an   informational RFC.".
Nonetheless, if you tell me "just make it a normative ref", I'll do so!
Otherwise:
Regarding the terminology section in RFC8376, it is merely composed of 5
terms (https://www.rfc-editor.org/rfc/rfc8376.html#page-24).
The definition of 4 of them is already copied in our draft, and we don't
use the 5th one. 
Therefore, I can easily tweak our text in Section 3 to say "we re-use the
following terms from RFC8376", remove from our Terminology Section the
sentence "It extends the terminology of [RFC8376].", and away goes the
absolute need to read RFC 8376 before being able to implement our draft.
Hence RFC 8376 can remain an informative ref.
Which course of action do you suggest?

Best regards

Dominique

Le 22/08/19 03:03, « Alissa Cooper via Datatracker » <[email-masked]> a

>https://datatracker.ietf.org/doc/draft-ietf-lpwan-ipv6-static-context-hc/

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.