Subject: [Lsr] Implementations of draft-ietf-ospf-link-overload

From: Alvaro Retana <[email-masked]>
Date: Fri, 6 Apr 2018 11:49:27 -0700

Dear lsr WG:

draft-ietf-ospf-link-overload [1] defines a new BGP-LS
Graceful-Link-Shutdown TLV.  When an early allocation was requested, it was
mistakenly requested from the "BGP-LS NLRI-Types" registry [2], not from
the "BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and
Attribute TLVs” registry [3].  IANA allocated a value according to the
request: 1101.

The mistake wasn't noticed until the document was in IESG Evaluation -- we
are in the process of correcting it.  However, the 1101 code point is
already allocated [*] in the "BGP-LS Node Descriptor, Link Descriptor,
Prefix Descriptor, and Attribute TLVs” registry, so a different value is
needed - the current suggested value is 1121.

Are there implementations of draft-ietf-ospf-link-overload with the 1101
code point?  Are there deployments of those implementations?  What will be
the impact of changing the value to 1121?

Thanks!

Alvaro.

[*] The 1101 code point in the "BGP-LS Node Descriptor, Link Descriptor,
Prefix Descriptor, and Attribute TLVs” registry corresponds to the
Peer-Node-SID, an early allocation made to
draft-ietf-idr-bgpls-segment-routing-epe [4], which says that "several
early implementations exist".

[1] https://datatracker.ietf.org/doc/draft-ietf-ospf-link-overload/
[2]
https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#nlri-types

[3]
https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#node-descriptor-link-descriptor-prefix-descriptor-attribute-tlv

[4]
https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-segment-routing-epe/

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Sat, 7 Apr 2018 09:27:39 +0000

Hi Alvaro/All,

I am not aware of an implementation of this draft that uses the proposed BGP-LS TLV. So there is no issue with using the suggested value of 1121 (or any other available).

Thanks,
Ketan

From: Lsr <[email-masked]> On Behalf Of Alvaro Retana
Sent: 07 April 2018 00:19
To: [email-masked]
Cc: [email-masked]; [email-masked]; Acee Lindem (acee) <[email-masked]>
Subject: [Lsr] Implementations of draft-ietf-ospf-link-overload

Dear lsr WG:

draft-ietf-ospf-link-overload [1] defines a new BGP-LS Graceful-Link-Shutdown TLV.  When an early allocation was requested, it was mistakenly requested from the "BGP-LS NLRI-Types" registry [2], not from the "BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute TLVs” registry [3].  IANA allocated a value according to the request: 1101.

The mistake wasn't noticed until the document was in IESG Evaluation -- we are in the process of correcting it.  However, the 1101 code point is already allocated [*] in the "BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute TLVs” registry, so a different value is needed - the current suggested value is 1121.

Are there implementations of draft-ietf-ospf-link-overload with the 1101 code point?  Are there deployments of those implementations?  What will be the impact of changing the value to 1121?

Thanks!

Alvaro.

[*] The 1101 code point in the "BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute TLVs” registry corresponds to the Peer-Node-SID, an early allocation made to draft-ietf-idr-bgpls-segment-routing-epe [4], which says that "several early implementations exist".

[1] https://datatracker.ietf.org/doc/draft-ietf-ospf-link-overload/
[2] https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#nlri-types
[3] https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#node-descriptor-link-descriptor-prefix-descriptor-attribute-tlv
[4] https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-segment-routing-epe/

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 7 Apr 2018 17:49:39 +0000

Hi Alvaro,

The BGP-LS TLV was added based on WG discussions of avoiding a separate BGP-LS IDR draft just for a single TLV. The overlapping suggested value (1101) was added to the -09 version (8/14/17). It was corrected once we realized there was an overlap.

Thanks,
Acee

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Saturday, April 7, 2018 at 5:27 AM
To: Alvaro Retana <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Acee Lindem <[email-masked]>
Subject: RE: [Lsr] Implementations of draft-ietf-ospf-link-overload

Hi Alvaro/All,

Thanks,
Ketan

Dear lsr WG:

Thanks!

Alvaro.