Subject: [Lsr] Hi, Here are some clarification questions about the flex-algo draft.

From: Huzhibo <[email-masked]>
Date: Thu, 26 Apr 2018 07:50:28 +0000

Hi,
Here are some clarification questions about the flex-algo draft.
1. As described in section 5, in path computation for a flex-algorithm, the node firstly needs to prune the links not included for this flex-algorithm, then run SPF or other algorithm within the pruned topology. If a node supports multiple algorithms, does this mean the node needs to maintain multiple pruned topologies?
2. If one path computed in algorithm-1 with latency metric and another path computed in algorithm-2 with bandwidth metric traverse the same link(s) in the network, can the latency or bandwidth SLA be guaranteed for the service? Or the path may need to be re-computed and adjusted to another link to avoid potential performance degradation?

ZhiBo Hu
发件人: Lsr [mailto:[email-masked]] 代表 Acee Lindem (acee)
发送时间: 2018年4月17日 22:44
收件人: [email-masked]
主题: [Lsr] LSR Working Group Adoption Poll for Flex Algorithm Drafts

This begins a two-week adoption poll for the following Flex Algorithm drafts:

https://datatracker.ietf.org/doc/draft-hegdeppsenak-isis-sr-flex-algo/
https://datatracker.ietf.org/doc/draft-ppsenak-ospf-sr-flex-algo/

The adoption poll will end at 12:00 AM EST on May 2nd, 2018. Please indicate your support of opposition of the drafts.

Additionally, the authors are amenable to combining the drafts into a single draft. If you have an opinion, please state that as well.

Thanks,
Acee

---

From: Peter Psenak <[email-masked]>
Date: Thu, 26 Apr 2018 11:51:56 +0200

Hi ZhiBo

On 26/04/18 09:50 , Huzhibo wrote:
> 1. As described in section 5, in path computation for a flex-algorithm,
> the node firstly needs to prune the links not included for this
> flex-algorithm, then run SPF or other algorithm within the pruned
> topology. If a node supports multiple algorithms, does this mean the
> node needs to maintain multiple pruned topologies?

no, there is no need to maintain any additional topologies for Flex-algo 
functionality.

There is however a need to run multiple SPFs, one for each Flex-algo in 
which the calculating node participates.

>
> 2. If one path computed in algorithm-1 with latency metric and another
> path computed in algorithm-2 with bandwidth metric traverse the same
> link(s) in the network, can the latency or bandwidth SLA be guaranteed
> for the service? Or the path may need to be re-computed and adjusted to
> another link to avoid potential performance degradation?

above depends on how you define you Flex-algo 1 and 2 respectively. If 
you define it in a way that they may share links, they may impact each 
other. If you define in in a way that they would never share any link, 
they would not impact each other. You choose the behavior you need - 
that's the beauty of the Flex-algo solution.

thanks,
Peter

>
> ZhiBo Hu
>
> *发件人:*Lsr [mailto:[email-masked]] *代表 *Acee Lindem (acee)
> *发送时间:*2018年4月17日22:44
> *收件人:[email-masked]
> *主题:*[Lsr] LSR Working Group Adoption Poll for Flex Algorithm Drafts
>
> The adoption poll will end at 12:00 AM EST on May 2^nd , 2018. Please
> indicate your support of opposition of the drafts.
>
> Additionally, the authors are amenable to combining the drafts into a
> single draft. If you have an opinion, please state that as well.
>
> Thanks,
>
> Acee
>
>
>
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr
>