Subject: [Lsr] Gentle Reminder!!!Re: draft-ietf-isis-te-app: Clarification on Application Identifier bits

From: Mahend Negi <[email-masked]>
Date: Sun, 10 Jun 2018 08:05:11 +0530

Dear Authors,

Could you please help me with the query.

Please confirm about the new bit for SRv6-TE applications.
We are working on this draft implementation.

Regards,
Mahendra

On Wed, Jun 6, 2018, 11:49 Mahend Negi <[email-masked]> wrote:

>
> Dear Authors,
> I seek few clarifications on "Application Identifier bits".
>
> As defined in the draft:
>
> R-bit: RSVP-TE
> S-bit: Segment Routing Traffic Engineering
>
> F-bit: Loop Free Alternate
> X-bit: Flex-Algo
>
>
> Am I right, when I say:
>
> R-bit: For RSVP-TE on IPv6 and IPv4 networks.
>
> S-bit: For SR MPLS and SRv6-TE applications.
>
>
> I think a bit to be allocated for SRv6-TE applications?
>
> Not sure about RSVP-TE IPv6 case.
>
> If you please your opinion.
>
>
> Regards,
>
> Mahendra
>
>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 11 Jun 2018 14:07:36 +0000

Mahend –

In regards to IPv4/IPv6, in IS-IS there are two ways to support this:

1)Multi-topology mode

Here there are topology specific neighbor advertisements and therefore topology specific link attribute advertisements. Hence no benefit from having afi-specific bits.

2)Single topology mode

Both address-families are supported on a single topology. Every link in the topology MUST support both address families for this configuration to work.
So although we do not have afi specific neighbors, the topology congruence argues against any need for AFI specific link attribute advertisements.

As regards SR-MPLS/SRv6, I expect that – other than as a transition strategy – we won’t have deployments where both technologies are in use for IPv6.  (You certainly could have SR-MPLS for IPv4 and SRv6 for IPv6.) Therefore, in combination with MT, there does not seem to be a use case for different advertisements for SR-MPLS/SRv6.

(BTW, the same arguments hold for OSPF – and even more so because there would be different instances of the protocol for each address family.)

   Les

From: Mahend Negi <[email-masked]>
Sent: Saturday, June 09, 2018 7:35 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; Les Ginsberg (ginsberg) <[email-masked]>; [email-masked]
Subject: Gentle Reminder!!!Re: draft-ietf-isis-te-app: Clarification on Application Identifier bits

Dear Authors,

Regards,
Mahendra
On Wed, Jun 6, 2018, 11:49 Mahend Negi <[email-masked]<mailto:[email-masked]>> wrote:

Dear Authors,

As defined in the draft:

R-bit: RSVP-TE

X-bit: Flex-Algo

Am I right, when I say:

Regards,

Mahendra