Subject: [Lsr] Regd covering BGP-LS extensions for IGP ELC drafts

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 25 Jul 2019 22:43:10 +0000

Hi Acee/All,

During the LSR WG meeting on Monday, we talked about covering the BGP-LS aspects of the following two IGP drafts in those drafts instead of requiring a separate document:

https://datatracker.ietf.org/doc/draft-ietf-isis-mpls-elc/
https://datatracker.ietf.org/doc/draft-ietf-ospf-mpls-elc/

Originally, these IGP drafts introduced a new node capability that required a new BGP-LS TLV and this was captured in the IDR WG document https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-segment-routing-rld/

However after the discussion in the LSR WG over the last few months, the approach has changed such that the IGP signalling is being done by introduction of new flags and MSD-type. This makes the corresponding BGP-LS updates quite trivial and as discussed in the LSR WG, I would recommend to add some text (proposed below) to the two IGP documents.

OSPF:

The OSPF extensions defined in this document can be advertised via BGP-LS [RFC7752] using existing BGP-LS TLVs. The flags field of the OSPFv2 Extended Prefix TLV and the OSPFv3 PrefixOptions where the ELC Flag introduced in this document is advertised using the Prefix Attribute Flags TLV (TLV 1170) of the BGP-LS IPv4/IPv6 Prefix NLRI Attribute [https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-ext-16#section-2.3.2]. The new ERLD MSD-type introduced for OSPF by this document is advertised using the Node MSD TLV (TLV 266) of BGP-LS Node NLRI Attribute [https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-msd-05#section-3].

ISIS:

The IS-IS extensions defined in this document can be advertised via BGP-LS [RFC7752] using existing BGP-LS TLVs. The Prefix Attribute Flags sub-TLV where the ELC Flag is introduced in this document is advertised using the Prefix Attribute Flags TLV (TLV 1170) of the BGP-LS IPv4/IPv6 Prefix NLRI Attribute [https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-ext-16#section-2.3.2]. The new ERLD MSD-type introduced for IS-IS by this document is advertised using the Node MSD TLV (TLV 266) of BGP-LS Node NLRI Attribute [https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-msd-05#section-3].

I am copying the IDR WG and authors of the BGP-LS ERLD draft as well for their inputs/feedback.

Thanks,
Ketan

From: Lsr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: 25 July 2019 16:28
To: [email-masked]
Subject: [Lsr] IETF 105 LSR Working Group Meeting Minutes

I think we had some very good discussions in our sessions this week. I’ve uploaded the minutes for the both LSR sessions on Monday. Thanks much to Yingzhen Qu for taking them.

https://datatracker.ietf.org/meeting/105/materials/minutes-105-lsr-00

Thanks,
Acee

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 25 Jul 2019 18:58:59 -0400

+1 Ketan

Cheers,
Jeff
On Jul 25, 2019, 6:43 PM -0400, Ketan Talaulikar (ketant) <[email-masked]>, wrote:
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 25 Jul 2019 22:57:59 -0400

Ketan and Acee:

The IDR co-chairs (John and I) wish to reduce the number of trivial drafts for BGP-LS allocations that could be done with 1 sentence.   We discussed with the LSR chairs (Acee and Chris) that it would be reasonable for LSR to do what Ketan has requested. 

We suggest that the WG LC is sent to IDR and LSR in case someone wants to discuss a concern.   The LSR chairs are capable and smart.   Acee and Chris can help shepherd these LSR drafts with BGP TLV language.  

Sue  

PS – has anyone heard if Chris Hopps is a father yet? 

From: Lsr [mailto:[email-masked]] On Behalf Of Ketan Talaulikar (ketant)
Sent: Thursday, July 25, 2019 6:43 PM
To: Acee Lindem (acee); [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Lsr] Regd covering BGP-LS extensions for IGP ELC drafts

Hi Acee/All,

OSPF:

ISIS:

Thanks,

Ketan

Thanks,
Acee

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 26 Jul 2019 12:54:37 +0000

Hi Sue,

From: Susan Hares <[email-masked]>
Date: Thursday, July 25, 2019 at 10:58 PM
To: "Ketan Talaulikar (ketant)" <[email-masked]>, Acee Lindem <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: IDR List <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Lsr] Regd covering BGP-LS extensions for IGP ELC drafts

Ketan and Acee:

We will include the IDR list on the WG last call for drafts that specify BGP-LS.

Sue

Not yet.

Thanks,
Acee

Hi Acee/All,

OSPF:

ISIS:

Thanks,
Ketan

Thanks,
Acee

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 26 Jul 2019 15:54:34 +0000

Hi Sue,

In this specific case, I would like to point that we would be marking an IDR WG document (https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-segment-routing-rld/) as being “replaced” by the 2 LSR documents below.

Thanks,
Ketan

From: Susan Hares <[email-masked]>
Sent: 25 July 2019 22:58
To: Ketan Talaulikar (ketant) <[email-masked]>; Acee Lindem (acee) <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Lsr] Regd covering BGP-LS extensions for IGP ELC drafts

Ketan and Acee:

Sue

From: Lsr [mailto:[email-masked]] On Behalf Of Ketan Talaulikar (ketant)
Sent: Thursday, July 25, 2019 6:43 PM
To: Acee Lindem (acee); [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Lsr] Regd covering BGP-LS extensions for IGP ELC drafts

Hi Acee/All,

OSPF:

ISIS:

Thanks,
Ketan

From: Lsr <[email-masked]<mailto:[email-masked]>> On Behalf Of Acee Lindem (acee)
Sent: 25 July 2019 16:28
To: [email-masked]<mailto:[email-masked]>
Subject: [Lsr] IETF 105 LSR Working Group Meeting Minutes

Thanks,
Acee

---

From: Susan Hares <[email-masked]>
Date: Fri, 26 Jul 2019 15:19:26 -0400

KetanYep.  That's the mechanism.  Was there another question?SueSent via the Samsung Galaxy S7 edge, an AT&T 4G LTE smartphone
-------- Original message --------From: "Ketan Talaulikar (ketant)" <[email-masked]> Date: 7/26/19  11:54 AM  (GMT-05:00) To: Susan Hares <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>, [email-masked] Cc: [email-masked], [email-masked] Subject: RE: [Lsr] Regd covering BGP-LS extensions for IGP ELC drafts 

Hi Sue,
 
In this specific case, I would like to point that we would be marking an IDR WG document (https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-segment-routing-rld/)
 as being “replaced” by the 2 LSR documents below.

Thanks,
Ketan

Sent: 25 July 2019 22:58

Ketan and Acee:
 
The IDR co-chairs (John and I) wish to reduce the number of trivial drafts for BGP-LS allocations that could be done with 1 sentence.   We discussed with the LSR chairs (Acee and
 Chris) that it would be reasonable for LSR to do what Ketan has requested. 

We suggest that the WG LC is sent to IDR and LSR in case someone wants to discuss a concern.   The LSR chairs are capable and smart.   Acee and Chris can help shepherd these LSR
 drafts with BGP TLV language.  
 
Sue  

 

From: Lsr [mailto:[email-masked]]
On Behalf Of Ketan Talaulikar (ketant)
Sent: Thursday, July 25, 2019 6:43 PM
To: Acee Lindem (acee); [email-masked]
Cc: [email-masked]; 
[email-masked]
Subject: [Lsr] Regd covering BGP-LS extensions for IGP ELC drafts

Hi Acee/All,

 
Originally, these IGP drafts introduced a new node capability that required a new BGP-LS TLV and this was captured in the IDR WG document
https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-segment-routing-rld/
 
However after the discussion in the LSR WG over the last few months, the approach has changed such that the IGP signalling is being done by introduction of new flags and MSD-type. This makes the corresponding
 BGP-LS updates quite trivial and as discussed in the LSR WG, I would recommend to add some text (proposed below) to the two IGP documents.
 
OSPF:
The OSPF extensions defined in this document can be advertised via BGP-LS [RFC7752] using existing BGP-LS TLVs. The flags field of the OSPFv2 Extended Prefix TLV and the OSPFv3 PrefixOptions where the ELC Flag introduced in this document
 is advertised using the Prefix Attribute Flags TLV (TLV 1170) of the BGP-LS IPv4/IPv6 Prefix NLRI Attribute [https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-ext-16#section-2.3.2]. The new ERLD MSD-type introduced for OSPF by this document
 is advertised using the Node MSD TLV (TLV 266) of BGP-LS Node NLRI Attribute [https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-msd-05#section-3].

ISIS:
The IS-IS extensions defined in this document can be advertised via BGP-LS [RFC7752] using existing BGP-LS TLVs. The Prefix Attribute Flags sub-TLV where the ELC Flag is introduced in this document is advertised using the Prefix Attribute
 Flags TLV (TLV 1170) of the BGP-LS IPv4/IPv6 Prefix NLRI Attribute [https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-ext-16#section-2.3.2]. The new ERLD MSD-type introduced for IS-IS by this document is advertised using the Node MSD TLV (TLV
 266) of BGP-LS Node NLRI Attribute [https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-msd-05#section-3].

Thanks,
Ketan

From: Lsr <[email-masked]>
On Behalf Of Acee Lindem (acee)
Sent: 25 July 2019 16:28
To: [email-masked]
Subject: [Lsr] IETF 105 LSR Working Group Meeting Minutes

 
Thanks,
Acee

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 26 Jul 2019 22:38:50 +0000

Hi Sue,

No other question.

Thanks,
Ketan

Sent: 26 July 2019 15:19

Ketan

Yep.  That's the mechanism.  Was there another question?

Sue

Sent via the Samsung Galaxy S7 edge, an AT&T 4G LTE smartphone

-------- Original message --------
From: "Ketan Talaulikar (ketant)" <[email-masked]<mailto:[email-masked]>>
Date: 7/26/19 11:54 AM (GMT-05:00)
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Subject: RE: [Lsr] Regd covering BGP-LS extensions for IGP ELC drafts

Hi Sue,

Thanks,
Ketan

From: Susan Hares <[email-masked]<mailto:[email-masked]>>
Sent: 25 July 2019 22:58
To: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>; Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Lsr] Regd covering BGP-LS extensions for IGP ELC drafts

Ketan and Acee:

Sue

Hi Acee/All,

OSPF:

ISIS:

Thanks,
Ketan

Thanks,
Acee