Subject: [Lsr] Genart last call review of draft-ietf-ospf-yang-23

From: Erik Kline via Datatracker <[email-masked]>
Date: Wed, 17 Jul 2019 16:07:40 -0700

Reviewer: Erik Kline
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-ospf-yang-??
Reviewer: Erik Kline
Review Date: 2019-07-17
IETF LC End Date: 2019-07-17
IESG Telechat date: Not scheduled for a telechat

Summary:

Major issues:

Minor issues:

I feel like the "version" text in 2.3 was confusing.  The first thing I did was
glance back up the overview where I (a) didn't see "version" mentioned and (b)
initially thought that "af" was maybe a proxy for "version".

But then later on it seems that "version" is only a mandatory property of the
LSA.

I'm not sure that I have concretely useful suggestions for improving this text,
and in fact it might well be that for expected readers of the document this is
in fact a non-issue.  Just thought I'd relay my experience.

Nits/editorial comments:

Page 25: NMDA RFC is 8342, not 8242.

Page 81: references draft-ietf-bdf-yang-xx.txt. This is referenced
elsewhere in the doc (correctly), so I think just remove the -xx may
be fine?

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 30 Jul 2019 00:42:49 +0000

Hi Erik, 
Thanks for the review. The nits will be fixed in the -24 version.
Thanks,
Acee

On 7/17/19, 7:08 PM, "Erik Kline via Datatracker" <[email-masked]> wrote:

    Reviewer: Erik Kline

    

    Summary:
    
    Major issues:
    
    Minor issues:

    
    
    Nits/editorial comments: