Subject: Re: [Lsr] AD Review for draft-ietf-ospf-yang-21

From: Jeffrey Haas <[email-masked]>
Date: Mon, 1 Jul 2019 16:07:42 -0400

On Thu, Jun 27, 2019 at 03:11:21PM +0000, Les Ginsberg (ginsberg) wrote:
> I am firmly on the side of Acee on this one – and I think more attention needs to be paid to his initial answer: “B-F-D”.
> 
> The implications of this are that we do not expect control plane to have finer granularity than seconds – which is why routing protocol hold times are expressed in seconds (both adjacency hold times and LSA hold times).
> Which means that even if you had the ability to display “X.mmm seconds remaining” this would not mean that the actual reaction to the timeout would occur within milliseconds of the timer expiration.
> 
> I would also argue that operationally it does not matter if an adjacency times out in N seconds or N.5 seconds. This is not used as a fast failure detection mechanism.

I agree for a slightly different reason:
In general, if your protocol is concerned with second level granularity,
that's what should be presented at the management level.  

Not to mention let's not make all sorts of implementations have to go put in
a float to track what's probably been storing an integer for years.

-- Jeff

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 1 Jul 2019 22:58:39 +0000

Hi Alvaro,
I believe version -23 addresses your comments. For “config true” timers leaves, I couldn’t use the ietf-routing-types.yang types since the union included “infinity” and “not-set” which aren’t really applicable. I did use the RFC8294 types for “config false” timers.

https://datatracker.ietf.org/doc/draft-ietf-ospf-yang/

Thanks,
Acee
P.S. I did lose some changes that I hadn’t checked into GitHub. Hopefully, I’ve reconstructed them correctly.

From: Alvaro Retana <[email-masked]>
Date: Thursday, June 27, 2019 at 7:55 AM
To: Acee Lindem <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Stephane Litkowski <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: AD Review for draft-ietf-ospf-yang-21

On June 26, 2019 at 9:31:05 PM, Acee Lindem (acee) ([email-masked]<mailto:[email-masked]>) wrote:

...

...

3936       leaf dead-timer {

3937         type uint32;

3938         units "seconds";

3939         config false;

3940         description "This timer tracks the remaining time before

3941                      the neighbor is declared dead.";

3942       }

[major] For *-timer: Is tracking the remaining time in seconds enough?  I would assume that ms would be the right unit.  Why seconds?

<acee> Because sub-second hellos was a bad idea – three words: B-F-D…'

This question is not about sub-second Hellos…it’s about the *remaining time*.  Even if Hellos are x seconds apart, the “remaining time before the neighbor is declared dead” can still be in ms, right?  Why not?  Note that there are other places in the model that are characterized as tracking the remaining time.

I don’t feel that strongly. However, it would seem that one would use the same granularity as the configuration. No?

I wouldn’t think so.  If I was an operator I would like to know if there are 500ms left before my neighbor dies, and not just 1 or 0.  I think this may also be useful for troubleshooting.

But I’m not an operator…

Alvaro.

We found that the RFC 8294 timer types aren’t good for “config true” values since the values “infinity” and “not-set” are included in the union. Hence, they lend themselves better to operational state than configurable values.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 1 Jul 2019 22:58:38 +0000

Hi Jeff, 

On 7/1/19, 4:06 PM, "Jeffrey Haas" <[email-masked]> wrote:

    

Luckily,  no one is asking for floating point timers. The big mistake was almost 20 years ago when the TE folks decided to use IEEE floating point for bandwidth. 
    
    -- Jeff

---

From: Alvaro Retana <[email-masked]>
Date: Tue, 2 Jul 2019 10:24:33 -0400

On July 1, 2019 at 6:58:43 PM, Acee Lindem (acee) ([email-masked]) wrote:

I believe version -23 addresses your comments.

It does!

I’m starting the IETF LC.

Thanks!

Alvaro.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 2 Jul 2019 18:13:44 +0000

Thank Alvaro!

From: Lsr <[email-masked]> on behalf of Alvaro Retana <[email-masked]>
Date: Tuesday, July 2, 2019 at 10:33 AM
To: Acee Lindem <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Stephane Litkowski <[email-masked]>
Subject: Re: [Lsr] AD Review for draft-ietf-ospf-yang-21

On July 1, 2019 at 6:58:43 PM, Acee Lindem (acee) ([email-masked]<mailto:[email-masked]>) wrote:

It does!

Thanks!

Alvaro.