Subject: [Lsr] Mirja Kühlewind's No Objection on draft-ietf-ospf-xaf-te-06: (with COMMENT)

From: Mirja Kühlewind via Datatracker <[email-masked]>
Date: Tue, 30 Jul 2019 08:44:11 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-ospf-xaf-te-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ospf-xaf-te/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Sec 1: "This document updates [RFC5786] so that a router can also announce
   one or more local X-AF addresses using the corresponding Local
   Address sub-TLV.  Routers using the Node Attribute TLV [RFC5786] can
   include non-TE enabled interface addresses in their OSPF TE
   advertisements, and also use the same sub-TLVs to carry X-AF
   information, facilitating the mapping described above."
I wonder if this text should use normative language (s/can/MAY/) as this is the
part that actually updates RFC5786, however, I didn't check the exact wording
in RFC5786...

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 31 Jul 2019 00:53:59 +0000

On July 30, 2019 at 11:44:20 AM, Mirja Kühlewind via Datatracker ([email-masked]<mailto:[email-masked]>) wrote:

[Speaking as an author.]

Mirja:

Hi!

We left the Normative language in Section 3, where the actual specification is made.

I don’t have a strong opinion as to whether there’s a need for it in the Introduction…so I’ll defer to the AD.

Thanks!

Alvaro.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 31 Jul 2019 11:05:41 +0000

Speaking as document shepherd, I agree with Alvaro as to the placement of the normative text.
Thanks,
ACEE

From: Alvaro Retana <[email-masked]>
Date: Tuesday, July 30, 2019 at 8:54 PM
To: Mirja Kühlewind via Datatracker <[email-masked]>, Mirja Kühlewind <[email-masked]>, The IESG <[email-masked]>
Cc: Acee Lindem <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Lsr] Mirja Kühlewind's No Objection on draft-ietf-ospf-xaf-te-06: (with COMMENT)

[Speaking as an author.]

Mirja:

Hi!

Thanks!

Alvaro.