Subject: [Lsr] Alissa Cooper's No Objection on draft-ietf-ospf-yang-26: (with COMMENT)

From: Alissa Cooper via Datatracker <[email-masked]>
Date: Wed, 21 Aug 2019 06:29:34 -0700

Alissa Cooper has entered the following ballot position for
draft-ietf-ospf-yang-26: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ospf-yang/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Per the Gen-ART review, I think 2.3 may be a little clearer if it were to say
"The field 'version' is used to indicate the OSPF LSA version and is mandatory."

I did not review this entire document but I'm balloting based on the Gen-ART
review.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 21 Aug 2019 17:01:37 +0000

Hi Alissa,

On 8/21/19, 9:29 AM, "Alissa Cooper via Datatracker" <[email-masked]> wrote:

    

This change has already been made in response to the Gen-ART review.

2.3.  OSPFv2 and OSPFv3

   The data model defined herein supports both OSPFv2 and OSPFv3.

   The field 'version' is used to indicate the OSPF version and is
   mandatory.  Based on the configured version, the data model varies to
   accommodate the differences between OSPFv2 and OSPFv3.

Thanks,
Acee

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 21 Aug 2019 16:25:17 -0400

Hi Acee,

> On Aug 21, 2019, at 1:01 PM, Acee Lindem (acee) <[email-masked]> wrote:
> 
> Hi Alissa,
> 

My specific suggestion was to include “LSA” after “OSPF” since that seemed to be the source of the confusion.

Best,
Alissa

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 21 Aug 2019 21:52:08 +0000

Hi Alissa, 

On 8/21/19, 4:25 PM, "Alissa Cooper" <[email-masked]> wrote:

    Hi Acee,

This wouldn't be the intent since the version impacts more than just the LSA formats. For example, authentication options:

      case ospfv3-auth-ipsec {
          when "derived-from-or-self(../../../../../../rt:type, "
            +  "'ospfv3')" {
            description "Applied to OSPFv3 only.";
          }
          if-feature ospfv3-authentication-ipsec;
          leaf sa {
              type string;
              description
                "Security Association (SA) name.";
          }
    }

Thanks,
Acee
    
    Best,
    Alissa