Subject: [Lsr] IANA Request for Early Allocation for "Signaling Entropy Label Capability and Entropy Readable Label-stack Depth Using OSPF" - draft-ietf-ospf-mpls-elc-08

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 23 Aug 2019 14:50:17 +0000

We have a request for IANA allocation for this draft from a vendor implementing the draft. Please provide early allocation for the code points.

https://datatracker.ietf.org/doc/draft-ietf-ospf-mpls-elc/

Thanks,
Acee

---

From: Alvaro Retana <[email-masked]>
Date: Mon, 26 Aug 2019 17:13:25 -0400

On August 23, 2019 at 10:50:34 AM, Acee Lindem (acee) ([email-masked])
wrote:

Hi!

We have a request for IANA allocation for this draft from a vendor
implementing the draft. Please provide early allocation for the code points.

This request is fine with me.

However, IANA pointed out (separately) that the proposed bit (0x04) in
the OSPFv3 Prefix Options is a deprecated value which was assigned to MOSPF
at one time.  Even if, according to rfc5340, there are no known
implementations of MOSPF in OSPFv3, I would like to ask IANA to not assign
the the 0x04 value to this draft, but instead to assign the next available
value.

Thanks!

Alvaro.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 27 Aug 2019 10:34:33 +0000

FYI

On 8/27/19, 1:59 AM, "Amanda Baber via RT" <[email-masked]> wrote:

    Hi all,
    
    We've completed the early allocations for draft-ietf-ospf-mpls-elc. However, per Acee, the descriptions have been updated, and per Alvaro, we've assigned the next available value in the OSPFv3 Prefix Options (8 bits) registry rather than re-assigning deprecated value 0x04. 
    
    We've made the following early allocation in the OSPFv2 Extended Prefix TLV Flags registry:
    
    0x20	ELC-flag (TEMPORARY - registered 2019-08-26, expires 2020-08-26)	[draft-ietf-ospf-mpls-elc]
    
    Please see
    https://www.iana.org/assignments/ospfv2-parameters
    
    We've also made the following early allocation in the OSPFv3 Prefix Options (8 bits) registry:
    
    0x40	ELC-bit (TEMPORARY - registered 2019-08-26, expires 2020-08-26)	[draft-ietf-ospf-mpls-elc]
    
    Please see
    https://www.iana.org/assignments/ospfv3-parameters
    
    Please update the document to reflect the updated descriptions and bit value.
    
    If the document hasn't been approved for publication by that time, we'll contact you in July 2020 to ask you whether you want to renew the allocations for another year. Renewing for a third year would require IESG approval. 
    
    Best regards,
    
    Amanda Baber
    Lead IANA Services Specialist