Subject: [Lsr] draft-tgraf-ipfix-mpls-sr-label-type

From: <[email-masked]>
Date: Tue, 28 Jul 2020 08:11:38 +0000

Dear lsr,

I presented the following draft

Export of MPLS Segment Routing Label Type Information in IP Flow Information Export (IPFIX)
https://tools.ietf.org/html/draft-tgraf-ipfix-mpls-sr-label-type-04

at the spring working group at IETF 108 yesterday
https://www.ietf.org/proceedings/108/slides/slides-108-spring-ip-flow-information-export-ipfix-00.pdf

and today at OPSAWG where I call for adoption.

This draft adds additional segment routing code points for in the IANA IPFIX registry for IS-IS, OPSFv2 and OPSF v3 and segment routing SID types to gain further insights into the MPLS-SR forwarding-plane.

I have been asked to not only gather feedback from spring and opsawg but also from lsr and mpls working groups since these code points are related to link state routing protocols and mpls data plane.

I am looking forward to your feedback and input.

Best Wishes
Thomas Graf

---

From: Hannes Gredler <[email-masked]>
Date: Wed, 29 Jul 2020 09:31:15 +0200

Thomas,

I have one comment/suggestion to Paragraph 4 (IANA Considerations).

Please add also a code point for BGP Prefix-SID - it’s quite popular in DC deployments.
https://tools.ietf.org/html/rfc8669 <https://tools.ietf.org/html/rfc8669>

thanks,

/hannes

> On 28.07.2020, at 10:11, [email-masked] wrote:
> 
> Dear lsr,
>  
> https://tools.ietf.org/html/draft-tgraf-ipfix-mpls-sr-label-type-04 <https://tools.ietf.org/html/draft-tgraf-ipfix-mpls-sr-label-type-04>
>  
> https://www.ietf.org/proceedings/108/slides/slides-108-spring-ip-flow-information-export-ipfix-00.pdf <https://www.ietf.org/proceedings/108/slides/slides-108-spring-ip-flow-information-export-ipfix-00.pdf>
>  
> _______________________________________________
> Lsr mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lsr <https://www.ietf.org/mailman/listinfo/lsr>

---

From: <[email-masked]>
Date: Fri, 31 Jul 2020 15:21:55 +0000

Hi Hannes,

Thanks a lot for the feedback. Yes, makes completely sense. Will take it for the next update.

Best Wishes
Thomas

From: Hannes Gredler <[email-masked]>
Sent: Wednesday, July 29, 2020 9:31 AM
To: Graf Thomas, INI-NET-DCF <[email-masked]>
Cc: [email-masked]
Subject: Re: [Lsr] draft-tgraf-ipfix-mpls-sr-label-type

Thomas,

Please add also a code point for BGP Prefix-SID - it's quite popular in DC deployments.
https://tools.ietf.org/html/rfc8669<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc8669&data=02%7C01%7CThomas.Graf%40swisscom.com%7Cf76df67b9faf4c04426908d83391629e%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637316046801837133&sdata=NxcbyIGgKrjPmh5OZ5muKulfmzuM%2FlPvGo76WzrHpBM%3D&reserved=0>

thanks,

/hannes

On 28.07.2020, at 10:11, [email-masked]<mailto:[email-masked]> wrote:

Dear lsr,

Export of MPLS Segment Routing Label Type Information in IP Flow Information Export (IPFIX)
https://tools.ietf.org/html/draft-tgraf-ipfix-mpls-sr-label-type-04<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-tgraf-ipfix-mpls-sr-label-type-04&data=02%7C01%7CThomas.Graf%40swisscom.com%7Cf76df67b9faf4c04426908d83391629e%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637316046801847088&sdata=FhF3AgFGrHvqAYQ7Ec73TpqcQkeHzE9ZOMFGC8cuuDg%3D&reserved=0>

at the spring working group at IETF 108 yesterday
https://www.ietf.org/proceedings/108/slides/slides-108-spring-ip-flow-information-export-ipfix-00.pdf<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fproceedings%2F108%2Fslides%2Fslides-108-spring-ip-flow-information-export-ipfix-00.pdf&data=02%7C01%7CThomas.Graf%40swisscom.com%7Cf76df67b9faf4c04426908d83391629e%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637316046801847088&sdata=QZYs1ZXZuBy5cFfvXmrLnu00%2FQF0TiJbBgWHC%2Ffteic%3D&reserved=0>

Best Wishes
Thomas Graf
_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Flsr&data=02%7C01%7CThomas.Graf%40swisscom.com%7Cf76df67b9faf4c04426908d83391629e%7C364e5b87c1c7420d9beec35d19b557a1%7C1%7C0%7C637316046801847088&sdata=Twb%2F%2BDFnQxElkufzSIVWszZ54cphIssBgO2vawPRYT8%3D&reserved=0>