Subject: Re: [Lsr] WG adoption call for draft-acee-lsr-isis-yang-augmentation-v1-03

From: tom petch <[email-masked]>
Date: Tue, 5 Jan 2021 17:04:28 +0000

From: Christian Hopps
Sent: Tuesday, January 05, 2021 16:54
> On Jan 5, 2021, at 11:47 AM, tom petch <[email-masked]> wrote:
>
> From: Lsr <[email-masked]> on behalf of Christian Hopps <[email-masked]>
> Sent: 05 January 2021 09:19
>
> This begins a 2 week WG adoption call for the following draft:
>
>  https://datatracker.ietf.org/doc/draft-acee-lsr-isis-yang-augmentation-v1/
>
> Please indicate your support or objection by January 19th, 2021.
>
> <tp>
>
> Object, strongly.
>
> In an earlier version, there was one YANG module and the accompanying text related to that module.
>
> A second YANG module has been dropped into the I-D while the text is untouched.  Thus
> the Abstract is wrong
> the Introduction is wrong
> IANA Considerations  are wrong
> and so on.
>
> This second module lacks references while introducing technical objects such as udabm-length or r-flag with no indication where in the 68 documents credited to the LSR WG (plus those of ISO) information may be found to judge whether or not the YANG is suitable.
>
> The security considerations is out-of-date, the references do not reflect RFC published last year, YANG import lack references, the key references are listed as Informative.
>
> And, contrary to the announcement, the intended status of the I-D is  Informational.
>
> I am surprised that anyone should consider this to be in a state fit for adoption!

Adoption just means the WG is willing to take on the work. It does not imply that the work is done or even close to being done.

That said thanks for pointing out work that needs to be done prior to considering a WGLC on this document. :)

<tp>
Chris,

as you doubtless realise, I am saying that this version is not ready for adoption.  Intended status Informational?  That to me is a show-stopper (even if you do not consider the misleading Abstract and so on to be - which I do!)

Tom Petch

Thanks,
Chris.

>
> Tom Petch
>
>
> Authors, please respond to the list indicating whether you are aware of any IPR that applies to this draft.
>
> Thanks,
> Chris.
>

---

From: Christian Hopps <[email-masked]>
Date: Tue, 5 Jan 2021 12:17:22 -0500

> On Jan 5, 2021, at 12:04 PM, tom petch <[email-masked]> wrote:
> 
> From: Christian Hopps
> > On Jan 5, 2021, at 11:47 AM, tom petch <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > From: Lsr <[email-masked] <mailto:[email-masked]>> on behalf of Christian Hopps <[email-masked] <mailto:[email-masked]>>
> >  https://datatracker.ietf.org/doc/draft-acee-lsr-isis-yang-augmentation-v1/ <https://datatracker.ietf.org/doc/draft-acee-lsr-isis-yang-augmentation-v1/>
> >

At least in LSR these would be seen as WGLC blockers not necessarily adoption blockers.

Adoption is generally blocked when the intent or direction of the draft is not one which the WG wants to take, or if no-one actually wanted to work on the document, etc. It is not necessarily a quality check, unless of course the WG thinks that the quality would or could never be improved, that also could block adoption. A document having some problems (especially ones so obviously fixable and non-controversial as the ones you point out) are not a reason to block adoption as long as people are willing to address them.

That said, your objection of course is noted. Perhaps one of the authors can chime in with their intent to fix the issues you object to (or just fix them in a new version).

Thanks,
Chris.

> _______________________________________________
> Lsr mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lsr <https://www.ietf.org/mailman/listinfo/lsr>

---

From: Yingzhen Qu <[email-masked]>
Date: Tue, 5 Jan 2021 18:02:34 +0000

Hi Tom,

Thank you for your review and comments.

We’ll publish a new version to address your comments within a couple of days.

Thanks,
Yingzhen

On Jan 5, 2021, at 9:04 AM, tom petch <[email-masked]<mailto:[email-masked]>> wrote:

From: Christian Hopps
> On Jan 5, 2021, at 11:47 AM, tom petch <[email-masked]<mailto:[email-masked]>> wrote:
>
> From: Lsr <[email-masked]<mailto:[email-masked]>> on behalf of Christian Hopps <[email-masked]<mailto:[email-masked]>>
>  https://datatracker.ietf.org/doc/draft-acee-lsr-isis-yang-augmentation-v1/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-acee-lsr-isis-yang-augmentation-v1%2F&data=04%7C01%7Cyingzhen.qu%40futurewei.com%7Cf96fb105c9584062b16b08d8b19c19ea%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637454631848611295%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=P29DMgDpUUx5rPpJU3bn7bljP0ocMsgK7VLylx4KyWI%3D&reserved=0>
>

<tp>
Chris,

Tom Petch

Thanks,
Chris.

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr

---

From: Yingzhen Qu <[email-masked]>
Date: Thu, 21 Jan 2021 17:28:51 +0000

Hi Tom,

We published the new version a while back, so just wondering whether you got a chance to review the changes? Please kindly let us know if you have other comments.

Thanks,
Yingzhen

On Jan 5, 2021, at 10:02 AM, Yingzhen Qu <[email-masked]<mailto:[email-masked]>> wrote:

Hi Tom,

Thanks,
Yingzhen

From: Christian Hopps
>  https://datatracker.ietf.org/doc/draft-acee-lsr-isis-yang-augmentation-v1/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-acee-lsr-isis-yang-augmentation-v1%2F&data=04%7C01%7Cyingzhen.qu%40futurewei.com%7C2a746233cc21444a04b608d8b1a4393e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637454666271945908%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=P6mbsiz6uADWt%2FafxPcjh6ADttVUFNycty982MKy3AM%3D&reserved=0>
>

<tp>
Chris,

Tom Petch

Thanks,
Chris.

---

From: tom petch <[email-masked]>
Date: Fri, 22 Jan 2021 10:55:43 +0000

From: Yingzhen Qu <[email-masked]>
Sent: 21 January 2021 17:28

Hi Tom,

<tp>

Yes, I did see and look at it.  I would say that it addresses the points I gave as show-stoppers to adoption.  The period for the adoption call has now expired so I was expecting a follow-up from the Chairs.

I would leave further changes until the adoption is complete.

Tom Petch 

Thanks,
Yingzhen

Hi Tom,

Thanks,
Yingzhen

From: Christian Hopps

<tp>
Chris,

Tom Petch

Thanks,
Chris.