Subject: [Lsr] WG adoption call for draft-acee-lsr-ospf-admin-tags-07

From: Christian Hopps <[email-masked]>
Date: Tue, 5 Jan 2021 04:17:00 -0500

This begins a 2 week WG adoption call for the following draft:

  https://datatracker.ietf.org/doc/draft-acee-lsr-ospf-admin-tags/

Please indicate your support or objection by January 19th, 2021.

Authors, please respond to the list indicating whether you are aware of any IPR that applies to this draft.

Thanks,
Chris.

---

From: Peter Psenak <[email-masked]>
Date: Tue, 5 Jan 2021 10:43:55 +0100

Hi Chris,

I'm not aware of any undisclosed IPR that applies to this draft.

thanks,
Peter

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 5 Jan 2021 14:51:54 +0000

Speaking as co-author:

I am not aware of any IPR on the draft.
Thanks,
Acee

On 1/5/21, 4:17 AM, "Christian Hopps" <[email-masked]> wrote:

    Thanks,
    Chris.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 5 Jan 2021 14:56:49 +0000

I support WG adoption.
This functionality has proven very useful in IS-IS. OSPF should have the same capabilities.

   Les

> -----Original Message-----
> From: Lsr <[email-masked]> On Behalf Of Christian Hopps
> Sent: Tuesday, January 05, 2021 1:17 AM
> To: [email-masked]
> Cc: [email-masked]; Christian Hopps <[email-masked]>
> Subject: [Lsr] WG adoption call for draft-acee-lsr-ospf-admin-tags-07
>

---

From: "Aijun Wang" <[email-masked]>
Date: Thu, 7 Jan 2021 10:15:15 +0800

Hi, Acee and Peter:

https://tools.ietf.org/html/rfc8362#section-3.12 has defined the Route-Tag
Sub-TLV for External-Prefix, is it more straightforward to extend this
sub-TLV to be included in other Prefix TLVs(Inter-Area-Prefix TLV,
Intra-Area-Prefix TLV) to accomplish the aimed application scenario?
And, do we need to cover multiple tag scenario? Even for external prefix,
only one Route-Tag will be processed.

Anyway, I support its adoption.

Best Regards

Aijun Wang
China Telecom

-----Original Message-----
From: [email-masked] <[email-masked]> On Behalf Of Christian
Hopps
Sent: Tuesday, January 5, 2021 5:17 PM
To: [email-masked]
Cc: [email-masked]; Christian Hopps <[email-masked]>
Subject: [Lsr] WG adoption call for draft-acee-lsr-ospf-admin-tags-07

Authors, please respond to the list indicating whether you are aware of any
IPR that applies to this draft.

Thanks,
Chris.

---

From: Peter Psenak <[email-masked]>
Date: Thu, 7 Jan 2021 10:58:44 +0100

Hi Aijun,

> Intra-Area-Prefix TLV) to accomplish the aimed application scenario?

we can not change the semantics of the existing Route-Tag Sub-TLV as 
defined in rfc8362 - e.g. only single tag is supported.

So we defined a new TLV that carries multiple tags and that is supported 
by Itra-Aare/Inter-Area/External/NSSA Prefix-LSAs for OSPFv3.

> only one Route-Tag will be processed.

that is exactly what the draft-acee-lsr-ospf-admin-tags defines, see 
section 3.

thanks,
Peter

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 8 Jan 2021 02:45:30 -0500

The multi tag feature is a highly valuable feature for operators for route
manipulation and policies.

This nicely draws parity to BGP communities where you can have a string of
many additive communities.

There have been complex designs I had worked on in the past with mutual
redistribution between ospf and to prevent feedback loops required complex
BGP and OSPF redistribution policies and requires setting BGP community for
ospf2bgp and ospf tag from bgp2ospf, however since a single tag was per
prefix was only supported this made the policy drastically more complex.

Kind Regards

Gyan

On Thu, Jan 7, 2021 at 4:58 AM Peter Psenak <ppsenak=
[email-masked]> wrote:

> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 8 Jan 2021 09:45:38 +0100

Support.
R.

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 8 Jan 2021 16:33:05 -0800

yes/support

Cheers,
Jeff

---

From: Shraddha Hegde <[email-masked]>
Date: Wed, 20 Jan 2021 11:40:23 +0000

WG,

Its useful to have admin tag support for prefixes in OSPF.
I support the WG adoption.

I have below comments on the document.

  1.  I suggest to add subsections in the section 4 protocol operations to separately address sender side and receiver side protocol operations
  2.  Sender side need to talk about below cases
     *   Same admin tag should not be encoded multiple times
     *   For each Prefix TLV, only one admin tag sub-TLV should be included

(I don't see the need to support multiple admin tag sub-TLV in same prefix TLV)
                 Receiver side

  1.  If same tag appears multiple times in the admin tag sub-TLV , the first one MUST be  considered and others ignored
  2.  If there are more than one admin tag sub-TLVs in the ospfv2/ospfv3  prefix TLV only first one MUST be processed and others ignored
  3.  When both admin tag sub-TLV and existing tag in OSPFv2 and OSPFv3 AS-External-LSA and NSSA-LSA are received, the route should consider a union of all these tags.

  1.  Section 6 IANA

Change to

TBD - 32-bit Administrative Tag sub-TLV

  1.  Need to have some explicit statements on Route calculation.

Change in admin tag sub_TLV should at minimum trigger partial route calculation.

Rgds

Shraddha

Juniper Business Use Only
From: Lsr <[email-masked]> On Behalf Of Jeff Tantsura
Sent: Saturday, January 9, 2021 6:03 AM
To: [email-masked]; Christian Hopps <[email-masked]>
Cc: [email-masked]
Subject: Re: [Lsr] WG adoption call for draft-acee-lsr-ospf-admin-tags-07

[External Email. Be cautious of content]

yes/support

Cheers,
Jeff
On Jan 5, 2021, 1:17 AM -0800, Christian Hopps <[email-masked]<mailto:[email-masked]>>, wrote:
This begins a 2 week WG adoption call for the following draft:

Thanks,
Chris.

_______________________________________________
Lsr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsr

---

From: Christian Hopps <[email-masked]>
Date: Wed, 20 Jan 2021 14:59:59 -0500

The document is adopted, please republish as draft-ietf-lsr-ospf-admin-tags-00.

Thanks,
Chris.

> On Jan 5, 2021, at 4:17 AM, Christian Hopps <[email-masked]> wrote:
> 
> Signed PGP part

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 21 Jan 2021 16:22:53 +0000

Hi Shraddha,
Thanks for your review. I agree with your comments and will incorporate these in the -01 version.
Thanks,
Acee

From: Shraddha Hegde <[email-masked]>
Date: Wednesday, January 20, 2021 at 6:40 AM
To: Jeff Tantsura <[email-masked]>, "[email-masked]" <[email-masked]>, Christian Hopps <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [Lsr] WG adoption call for draft-acee-lsr-ospf-admin-tags-07
Resent-From: <[email-masked]>
Resent-To: Acee Lindem <[email-masked]>, Christian Hopps <[email-masked]>, Yingzhen Qu <[email-masked]>
Resent-Date: Wednesday, January 20, 2021 at 6:40 AM

WG,

a.       Same admin tag should not be encoded multiple times

b.       For each Prefix TLV, only one admin tag sub-TLV should be included

(I don’t see the need to support multiple admin tag sub-TLV in same prefix TLV)
                 Receiver side

a.       If same tag appears multiple times in the admin tag sub-TLV , the first one MUST be  considered and others ignored

b.       If there are more than one admin tag sub-TLVs in the ospfv2/ospfv3  prefix TLV only first one MUST be processed and others ignored

c.       When both admin tag sub-TLV and existing tag in OSPFv2 and OSPFv3 AS-External-LSA and NSSA-LSA are received, the route should consider a union of all these tags.

3.       Section 6 IANA

Change to

4.       Need to have some explicit statements on Route calculation.

Rgds

Shraddha

yes/support

Cheers,
Jeff

Thanks,
Chris.