Subject: [Lsr] Relationship between ASLA and Flex Algo

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Sun, 22 Aug 2021 14:48:40 +0000

Robert –

I have revised the subject since this is a different topic than the original thread.

If you want to discuss this further, please do so in the renamed thread.
Note that I am NOT encouraging you to continue this discussion – I am in full agreement with Peter. I do not think what you propose is desirable or needed.

   Les

From: Robert Raszuk <[email-masked]>
Sent: Sunday, August 22, 2021 6:33 AM
To: Peter Psenak (ppsenak) <[email-masked]>
Cc: Les Ginsberg (ginsberg) <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: [Lsr] New Version Notification for draft-hegde-lsr-asla-any-app-00.txt

Hey Peter,

> And I will perhaps say it again that to me flex-algo is more of a
> mechanism to build new applications then NEW APPLICATION itself.

no, flex-algo is a single application, it's not a mechanism to create
new applications. The fact that you can create many constraints
topologies using flex-algo, does not mean these should be considered as
different apps. You have to put and keep clear borders at clear places.
We have them defined by ASLA and by base flex-algo draft.

Why each constrained topology can not be intuitively called a different network application ?

Is there any real definition of "IGP application" LSR WG has converged and agreed upon ?

See your take that it is implicitly defined in flex-algo draft by setting one bit to it in SABM is IMO pretty weak. Maybe it would hold if you forbid to use UDABM for flex-algo metrics, but I do not see such restriction anywhere in flex-algo draft nor in ASLA drafts. That means that implementation may allow it.

So flex algo is a single app if we use SABM, but it can be multiple apps if we use UDABM ? Don't you think this is a bit loose definition ?

Cheers,
R.

---

From: Robert Raszuk <[email-masked]>
Date: Sun, 22 Aug 2021 20:17:18 +0200

Hi Les,

Well I was not really proposing anything just making an observation. If
anything adding few more SABM bits for flex-algo, but frankly I can live
without them just fine.

In the light of Peter's response the more interesting is the invention of
UDABM field. It is not IETF business so how would anyone accomplish multi
vendor interoperability using it ?

Question: Can I use UDABM to set bits in metrics for use with selective
flex-algo topologies ?

Even if it is "not something that IETF is going to specify" - if we define
something in the protocol should it be clear what is the intended use case
?

Many thx,
R.

On Sun, Aug 22, 2021 at 4:48 PM Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> Note that I am NOT encouraging you to continue this discussion – I am in
> full agreement with Peter. I do not think what you propose is desirable or
> needed.
>
>
>
>    Les
>
>
>
>
>
> *From:* Robert Raszuk <[email-masked]>
> *Sent:* Sunday, August 22, 2021 6:33 AM
> *To:* Peter Psenak (ppsenak) <[email-masked]>
> *Cc:* Les Ginsberg (ginsberg) <[email-masked]>; Ron Bonica <
> [email-masked]>; [email-masked]
> *Subject:* Re: [Lsr] New Version Notification for
> draft-hegde-lsr-asla-any-app-00.txt
>
>
>
> Hey Peter,
>
>
>
> See your take that it is implicitly defined in flex-algo draft by setting
> one bit to it in SABM is IMO pretty weak. Maybe it would hold if you forbid
> to use UDABM for flex-algo metrics, but I do not see such restriction
> anywhere in flex-algo draft nor in ASLA drafts. That means that
> implementation may allow it.
>
>
>
> So flex algo is a single app if we use SABM, but it can be multiple apps
> if we use UDABM ? Don't you think this is a bit loose definition ?
>
>
>
> Cheers,
> R.
>
>
>

---

From: Peter Psenak <[email-masked]>
Date: Mon, 23 Aug 2021 10:13:56 +0200

Hi Robert,

On 22/08/2021 20:17, Robert Raszuk wrote:
> In the light of Peter's response the more interesting is the invention 
> of UDABM field. It is not IETF business so how would anyone 
> accomplish multi vendor interoperability using it ?

setting a bit in UDABM can be done by any vendor. The usage of the bit 
on the Rx side is completely in hands of the user and the consuming 
application and not specified by IETF.

> Question: Can I use UDABM to set bits in metrics for use with selective 

no, all flex-algo constraints are defined in the flex-algo draft.

If you want to exclude/include links in flex-algo constrained topology 
you have affinities to do that.

> 
> Even if it is "not something that IETF is going to specify" - if we 
> define something in the protocol should it be clear what is the intended 
> use case ?

section 4, rfc8919:

   "In addition to supporting the advertisement of link attributes used
    by standardized applications, link attributes can also be advertised
    for use by user-defined applications.  Such applications are not
    subject to standardization and are outside the scope of this
    document.

thanks,
Peter

> 
> Many thx,
> R.
> 
> 
> 
> On Sun, Aug 22, 2021 at 4:48 PM Les Ginsberg (ginsberg) 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Robert –____
> 
>     __ __
> 
>     I have revised the subject since this is a different topic than the
>     original thread.____
> 
>     __ __
> 
>     If you want to discuss this further, please do so in the renamed
>     thread.____
> 
>     Note that I am NOT encouraging you to continue this discussion – I
>     am in full agreement with Peter. I do not think what you propose is
>     desirable or needed.____
> 
>     __ __
> 
>         Les____
> 
>     __ __
> 
>     __ __
> 
>     *From:* Robert Raszuk <[email-masked] <mailto:[email-masked]>>
>     *To:* Peter Psenak (ppsenak) <[email-masked]
>     <mailto:[email-masked]>>
>     *Cc:* Les Ginsberg (ginsberg) <[email-masked]
>     <mailto:[email-masked]>>; Ron Bonica <[email-masked]
>     <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
>     draft-hegde-lsr-asla-any-app-00.txt____
> 
>     __ __
> 
>     Hey Peter,____
> 
>     __ __
> 
>         We have them defined by ASLA and by base flex-algo draft.____
> 
>     __ __
> 
>     Why each constrained topology can not be intuitively called a
>     different network application ? ____
> 
>     __ __
> 
>     Is there any real definition of "IGP application" LSR WG has
>     converged and agreed upon ? ____
> 
>     __ __
> 
>     See your take that it is implicitly defined in flex-algo draft by
>     setting one bit to it in SABM is IMO pretty weak. Maybe it would
>     hold if you forbid to use UDABM for flex-algo metrics, but I do not
>     see such restriction anywhere in flex-algo draft nor in ASLA drafts.
>     That means that implementation may allow it. ____
> 
>     __ __
> 
>     So flex algo is a single app if we use SABM, but it can be multiple
>     apps if we use UDABM ? Don't you think this is a bit loose
>     definition ? ____
> 
>     __ __
> 
>     Cheers,
>     R.____
> 
>     __ __
>

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 23 Aug 2021 11:00:14 +0200

Peter,

> no, all flex-algo constraints are defined in the flex-algo draft.

That's news to me. And from what I am seeing not only to me.

So I ask vendor X & Y to allow me to set 2 bits in UDABM (that already is
not user defined but vendor defined, but ok). Then I signal some of the
existing metric with bits set only in UDABM. And I specify to run Dijkstra
on it. As a result I build a new topology and start forwarding traffic via
it.

So the only practical difference this topology has vs identical one buildl
with flex-algo SABM bit is that I used a different bit to propagate the
metric selectively for this topology (rather then sending it with X-bit and
applying affinities all over the place).

It seems that the current version of flex-algo draft has a bunch of hidden
assumptions - maybe it is past WG last call - but I do ask to state
explicitly there a sentence indicating that UDABM bits can not be used to
signal metrics for it. I don't think this requires a new WG last call as
this is purely clarification not a major change.

Thx for sharing it ...
Robert

---

From: Peter Psenak <[email-masked]>
Date: Mon, 23 Aug 2021 11:14:51 +0200

Robert,

On 23/08/2021 11:00, Robert Raszuk wrote:
> So I ask vendor X & Y to allow me to set 2 bits in UDABM (that already 
> is not user defined but vendor defined, but ok). Then I signal some of 
> the existing metric with bits set only in UDABM. And I specify to run 
> Dijkstra on it. As a result I build a new topology and start forwarding 
> traffic via it.

above would not be interoperable with any standard flex-algo 
implementation that follows the existing spec.

> 
> So the only practical difference this topology has vs identical one 
> buildl with flex-algo SABM bit is that I used a different bit to 
> propagate the metric selectively for this topology (rather then sending 
> it with X-bit and applying affinities all over the place).

1. using X-bit and affinities is standardized and as such interoperable. 
Using IDABM is not.

2. I don't see why setting a  UDABM bits on set of links is any better 
to setting affinities.

> 
> It seems that the current version of flex-algo draft has a bunch of 
> hidden assumptions - maybe it is past WG last call - but I do ask to 
> state explicitly there a sentence indicating that UDABM bits can not be 
> used to signal metrics for it. 

as I said previously, constraints are defined there, and usage of UDABM 
is not there. And even if you want to add it to the spec, it would not 
be possible because of the nature of the UDABM itself.

>I don't think this requires a new WG last 
> call as this is purely clarification not a major change.

no, usage of UDABM is outside of IETF specification as specified in RFC8919.

thanks,
Peter