Subject: [Lsvr] Questions on draft-keyupate-lsvr-bgp-spf-00.txt

From: Arthi Ayyangar <[email-masked]>
Date: Mon, 19 Mar 2018 14:29:01 +0000

Hi

Some questions for the authors:

1) Wrt convergence

At what threshold of ECMP are the perceived convergence benefits?People
have deployed very large ECMP networks without any of these enhancements;
so what problem would be the biggest motivation to adopt this extension esp
wrt SPF?

2) Wrt other benefits / drivers listed -
Why do we think FRR and LFA are even relevant in dense ECMP / CLOS networks?

3) In an EBGP design and with no route servers / controllers I assume this
cannot be used? Do you actually see MSDC designs with route servers /
controllers in the first place?

thanks,
-Arthi

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 19 Mar 2018 16:09:42 +0000

Arthi,

As for #2 - I believe Acee clarified, LFA in CLOS is not needed, local fast-rehash is the de facto technology used.

Regards,
Jeff

> On Mar 19, 2018, at 14:29, Arthi Ayyangar <[email-masked]> wrote:
> 
> Hi 
> 
> At what threshold of ECMP are the perceived convergence benefits?People have deployed very large ECMP networks without any of these enhancements; so what problem would be the biggest motivation to adopt this extension esp wrt SPF?
> 
> 3) In an EBGP design and with no route servers / controllers I assume this cannot be used? Do you actually see MSDC designs with route servers / controllers in the first place?
> 
> thanks,
> -Arthi
> _______________________________________________
> Lsvr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsvr

---

From: Arthi Ayyangar <[email-masked]>
Date: Mon, 19 Mar 2018 16:42:10 +0000

As for #2 - I believe Acee clarified, LFA in CLOS is not needed, local
> fast-rehash is the de facto technology used.
>

Correct. (sorry I had typed this up before the second draft discussion
started).
So maybe worth cleaning it up from the draft?  Also because it is reference
in the context of fast convergence on link failures; which may take away
from the other more relevant convergence discussion in the rest of the
draft.

thanks,
Arthi

Regards,

---

From: Arthi Ayyangar <[email-masked]>
Date: Mon, 19 Mar 2018 16:42:10 +0000

thanks,
Arthi

Regards,

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 26 Mar 2018 19:32:09 +0000

Hi Arthi, Jeff,

From: Jeff Tantsura <[email-masked]>
Date: Monday, March 19, 2018 at 12:09 PM
To: Arthi Ayyangar <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Keyur Patel <[email-masked]>, Acee Lindem <[email-masked]>
Subject: Re: [Lsvr] Questions on draft-keyupate-lsvr-bgp-spf-00.txt

Arthi,

As for #2 - I believe Acee clarified, LFA in CLOS is not needed, local fast-rehash is the de facto technology used.
I will add this to the BGP SPF applicability draft. Note that LFA could be used if there are East-West links. Is this at all interesting?
Regards,
Jeff

On Mar 19, 2018, at 14:29, Arthi Ayyangar <[email-masked]<mailto:[email-masked]>> wrote:
Hi

1) Wrt convergence

thanks,
-Arthi
_______________________________________________
Lsvr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lsvr