Subject: RE: [Ltru] 3166-1 state machie (was: Question)

From: "Addison Phillips" <[email-masked]>
Date: Mon, 28 Mar 2005 11:03:39 -0800

No, unless you mean "Frank" by "you". I was addressing Frank's comments that seemed (possibly only to me) to suggest that ccTLD codes would be candidates for the registry because they might have been erroneously used in legacy data. Valid 3166 codes from some non-arbitrary date: yes. Other two-letter codes for regions: no.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 
> -----Original Message-----
> From: Mark Davis [mailto:[email-masked]]
> Sent: lundi 28 mars 2005 10:24
> To: Addison Phillips; Frank Ellermann; [email-masked]
> Subject: Re: [Ltru] 3166-1 state machie (was: Question)
> 
> You appear to be jumping to some conclusion(s). I'm not at all saying that
> we want to add the ccTLD codes.
> 
> ‎Mark
> 
> ----- Original Message -----
> From: "Addison Phillips" <[email-masked]>
> To: "Frank Ellermann" <[email-masked]>; <[email-masked]>
> Sent: Monday, March 28, 2005 09:35
> Subject: RE: [Ltru] 3166-1 state machie (was: Question)
> 
> 
> The argument below does not follow. Although "no one" has a copy of
> 3166:1988, there are many documents that purport to list the codes
> assigned
> therein. Few of these include the (non-matching) ccTLD codes.
> 
> And these days 3166 posts the current set of assignments on the Web, which
> is where most people look when choosing values for their content or
> implementations right now this minute. The problem, of course, is that
> "right now this minute" occurs at different discrete moments...
> 
> In the more distant past, though, the situation was roughly analogous to
> where ISO 4217 is today. That standard's official list is not publicly
> available for free and thus there are many suspect references that purport
> to "be" the list (and have errors).
> 
> 3066bis corrects this for region codes: we are deciding the manner in
> which
> to correct this. We should be as inclusive as reasonable without causing
> ourselves extravagant future problems. For example, adding codes that were
> never valid in the past and which already have codes for the same value
> would be bad.
> 
> Addison
> 
> Addison P. Phillips
> Globalization Architect, Quest Software
> Chair, W3C Internationalization Core Working Group
> 
> Internationalization is not a feature.
> It is an architecture.
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> On
> > Behalf Of Frank Ellermann
> > Sent: dimanche 27 mars 2005 08:43
> > To: [email-masked]
> > Subject: [Ltru] 3166-1 state machie (was: Question)
> >
> > Doug Ewell wrote:
> >
> > > "Why they are reserved" is not important.  Either a code is
> > > currently assigned, or it was formerly assigned, or it is
> > > private-use ("user-assigned").  Distinctions between the
> > > different types of "reserved" are of interest only to the MA.
> >
> > I'm not sure, if "transitionally reserved" is essentially the
> > same as "deprecated", this could be relevant, and if all these
> > other "reservations" hide what we're interested in here, i.e.
> > "deprecated" vs. "unassigned", it could be also relevant.
> >
> > And for Mark's "Joe Blow" or my "Jane Blog" anything on the
> > 3166-1 web pages could be (ab)used.  Especially before 3066bis.
> >
> > If we don't have a copy of ISO 3166:1988, then Joe and Jane
> > also have no copy, that's why they (ab)use ccTLDs or reserved
> > codes.  Until the future 3066bis registry helps to catch such
> > errors.
> >         Bye, Frank
> >
> >
> >
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 28 Mar 2005 11:16:31 -0800

Sorry; got confused.

‎Mark

----- Original Message ----- 
From: "Addison Phillips" <[email-masked]>
To: "Mark Davis" <[email-masked]>; "Frank Ellermann"
<[email-masked]>; <[email-masked]>
Sent: Monday, March 28, 2005 11:03
Subject: RE: [Ltru] 3166-1 state machie (was: Question)

> No, unless you mean "Frank" by "you". I was addressing Frank's comments
that seemed (possibly only to me) to suggest that ccTLD codes would be
candidates for the registry because they might have been erroneously used in
legacy data. Valid 3166 codes from some non-arbitrary date: yes. Other
two-letter codes for regions: no.

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 30 Mar 2005 05:13:26 +0200

Addison Phillips wrote:

> I was addressing Frank's comments that seemed (possibly only
> to me) to suggest that ccTLD codes would be candidates for
> the registry because they might have been erroneously used
> in legacy data.

No, you and Doug convinced me that ccTLDs are a bad idea, let
ISO 3166 do "the right thing" for AC, GG, IM, and JE.  "Jane
Blog" was only a counter-example to "Joe Blow", and her RH is
no ccTLD, like Joe's BU.  They didn't check whois.iana.org ;-)

                          Bye, Frank