Subject: [Ltru] Re: Shelf life of data

From: "Doug Ewell" <[email-masked]>
Date: Sun, 27 Mar 2005 22:58:09 -0800

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

>> There's nothing magic about 10 years.
>
> For our purposes the last 10 years would allow us to get rid
> of the A-list country codes (after 1988, before RfC 1766):
>
> BU, DD, FX, NT, SU, TP, YD, YU, ZR.

FX was withdrawn in 1997, TP in 2002, YU in 2003, ZR in 1997.

"Getting rid of" these codes -- or, for that matter, the other five you
mentioned, which WERE withdrawn before 1995 -- will not significantly
improve the registry, but they may render some valid RFC 1766/3066 codes
invalid.  Group members, can we please come to a decision on this?

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 28 Mar 2005 08:33:46 -0800

Hi,

I agree with Addison below.  Let's go back to 1988, because it's
the most conservative approach to backwards compatibility.

We're wasting an awful lot of electronic ink on saving or losing
a very small number of existing (??) language tags.

Cheers,
- Ira

PS - Why do we care if someone ever tagged information with an
invalid language tag that used a ccTLD not in ISO 3166?  Misuse
of a standard is not a valid reason to revise the standard.

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Addison Phillips
Sent: Monday, March 28, 2005 9:57 AM
To: Doug Ewell; LTRU Working Group
Subject: RE: [Ltru] Re: Shelf life of data

Codes eliminated and not reassigned after RFC 1766 came into effect should
be in the registry. Period.

Codes prior to 1995 (or 1988 if you go with the reference's date) are really
the question. I'd support going back to 1988 with codes, since the reference
in RFC 1766 and 3066 is unclear and I well remember the days before the Web
(when getting code lists was an arcane art and not a science).

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: dimanche 27 mars 2005 22:58
> To: LTRU Working Group
> Subject: [Ltru] Re: Shelf life of data
>

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 28 Mar 2005 09:24:58 -0800

I refer you to Doug's prototype registry, which has reconstructed all of the necessary codes already. We are merely fighting over the table scraps here.

Addison

Addison P. Phillips

> From: JFC (Jefsey) Morfin [mailto:[email-masked]]
> Sent: lundi 28 mars 2005 08:11
> To: Addison Phillips; Doug Ewell; LTRU Working Group
> At 16:57 28/03/2005, Addison Phillips wrote:
> Yes.
> >Codes prior to 1995 (or 1988 if you go with the reference's date) are
> >really the question. I'd support going back to 1988 with codes, since the
> >reference in RFC 1766 and 3066 is unclear and I well remember the days
> >before the Web (when getting code lists was an arcane art and not a
> science).
> 
> Yes. Would you have a dated list we could use as a reference?
> Or would someone have one no one can dispute?
> 
> We started using alpha-3 by mid-77 and formalized it in oct 1978 (Mike
> Rude); and alpha-2 in 1981. Earlier entries are probably not necessary,
> unless for archives, historics and experience/testing.
> jfc
> 
> 
> 
> 
> 
>

---

From: "Peter Constable" <[email-masked]>
Date: Mon, 28 Mar 2005 12:35:09 -0800

> From: Mark Davis [mailto:[email-masked]]

> The only further question I'd have would require an actual copy of ISO
> 3166:1988 -- to make sure the exact set of codes that a reasonable
person
> would extract from it. (I don't necessarily trust the later analysis
> provided on the web).

I've purchased a copy of ISO 3166-3:1999. The following are items that
were valid in 1988 but were discontinued between 1988 and 1999:

Country                      Alpha-2  Alpha-3  Numeric  Valid from
Valid to
------------------------------------------------------------------------
-----
Burma                        BU       BUR      104      1974        1989
German Democratic Republic   DD       DDR      278      1974        1990
Yemen, Democratic            YD       YMD      720      1974        1990
Byelorussian SSR             BY       BYS      112      1974        1992
USSR                         SU       SUN      810      1974        1992
Czechoslovakia               CS       CSK      200      1974        1993
Neutral Zone                 NT       NTZ      536      1974        1993
Zaire                        ZR       ZAR      180      1974        1997

Peter Constable