Subject: RE: [Ltru] Re: Shelf life of data

From: "Peter Constable" <[email-masked]>
Date: Mon, 28 Mar 2005 07:51:13 -0800

I'd support including everything in ISO 3166:1988 to ensure not making
invalid anything that was valid in RFC 1766.

Peter

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
On
> Behalf Of Addison Phillips
> Sent: Monday, March 28, 2005 6:57 AM
> To: Doug Ewell; LTRU Working Group
> Subject: RE: [Ltru] Re: Shelf life of data
> 
> Codes eliminated and not reassigned after RFC 1766 came into effect
should
> be in the registry. Period.
> 
> Codes prior to 1995 (or 1988 if you go with the reference's date) are
> really the question. I'd support going back to 1988 with codes, since
the
> reference in RFC 1766 and 3066 is unclear and I well remember the days
> before the Web (when getting code lists was an arcane art and not a
> science).
> 
> Addison
> 
> Addison P. Phillips
> Globalization Architect, Quest Software
> Chair, W3C Internationalization Core Working Group
> 
> Internationalization is not a feature.
> It is an architecture.
> 
> > -----Original Message-----
> > From: [email-masked]
[mailto:[email-masked]]
> On
> > Behalf Of Doug Ewell
> > Sent: dimanche 27 mars 2005 22:58
> > To: LTRU Working Group
> > Subject: [Ltru] Re: Shelf life of data
> >
> > Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:
> >
> > >> There's nothing magic about 10 years.
> > >
> > > For our purposes the last 10 years would allow us to get rid
> > > of the A-list country codes (after 1988, before RfC 1766):
> > >
> > > BU, DD, FX, NT, SU, TP, YD, YU, ZR.
> >
> > FX was withdrawn in 1997, TP in 2002, YU in 2003, ZR in 1997.
> >
> > "Getting rid of" these codes -- or, for that matter, the other five
you
> > mentioned, which WERE withdrawn before 1995 -- will not
significantly
> > improve the registry, but they may render some valid RFC 1766/3066
codes
> > invalid.  Group members, can we please come to a decision on this?
> >
> > -Doug Ewell
> >  Fullerton, California
> >  http://users.adelphia.net/~dewell/
> >
> >
> >
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 28 Mar 2005 08:18:50 -0800

And I agree as well, of course.

The only further question I'd have would require an actual copy of ISO
3166:1988 -- to make sure the exact set of codes that a reasonable person
would extract from it. (I don't necessarily trust the later analysis
provided on the web). The wording is very vague (repeating again):

   In the first subtag:    -    All 2-letter codes are interpreted as ISO
3166 alpha-2
         country codes denoting the area in which the language is
         used.In the references, he sees:

         ISO 3166:1988 (E/F) - Codes for the representation of names
         of countries - The International Organization for
         Standardization, 3rd edition, 1988-08-15.

So it depends on what the user would read as "3166 alpha-2 country codes",
since 1766 does not distinguish between types of codes. If ISO 3166:1988
says "disallowed" or "unassigned", that is pretty clear. But I don't have
the exact spec here; anyone have an old copy?

‎Mark

----- Original Message ----- 
From: "Peter Constable" <[email-masked]>
To: "LTRU Working Group" <[email-masked]>
Sent: Monday, March 28, 2005 07:51
Subject: RE: [Ltru] Re: Shelf life of data

Peter

On
should
the
you
significantly
codes