Subject: Re: [Ltru] Re: Language transformation

From: "M.T. Carrasco Benitez" <[email-masked]>
Date: Thu, 31 Mar 2005 19:33:22 +0100 (BST)

> As far as language tags go, what one would be naming would be the *result*
> of applying such a transformation,

I agree. LTRU should only be concerned with tagging result.
 
> My main concern is that the actual variants used for transliterations not be
> a disaster like the IANA charset repository, where people can't tell what
> the registry is describing. The plan is for transliterations to be added to
> CLDR at some point, and that would provide stable, predictable IDs that
> could be used for variants. I suggest that we not try to incorporate
> transliteration variants prematurely. For some more formal, structured
> mechanism of describing the variants, it would a perfect case for the
> extension mechanism proposed in the draft, where some other RFC could have
> something like ru-Latn-t-ungegn-t-en.

The proposal is to forseen the requirement in the syntax. LTRU should only be
concerned with the list of "transformation identifier". Example:

# Transformations
transformation | widegile | | yyyy-mm-dd | |
transformation | pinyin| | yyyy-mm-dd | |

The Registry of Schemes for Language Transformation (out of scope of LTRU)
should address the description of the transformation. Example:

%%
id:widegile
sourcelang:zh
targetlang:en
uri:http://somewhere.xxx/speficationofwidegiles
foo:foo
%%
id:pinyin
sourcelang:zh
targetlang:en
uri:http://somewhereelse.xxx/speficationofpinyin
foo:foo
%%

This registry should not address the methodology of the transformation. It should
just point with the URI to the entity maintaining the methodology.

Regards
Tomas

Send instant messages to your online friends http://uk.messenger.yahoo.com 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Thu, 31 Mar 2005 11:00:13 -0800

> uri:http://somewhere.xxx/speficationofwidegiles

That very policy has been a disaster with IANA charsets. The references
don't supply a complete description, or are not stable. That's why I think
this is premature.

‎Mark