Subject: RE: Question: (was Re: [Ltru] Re: Populating the initial registry:Languages)

From: "Addison Phillips" <[email-masked]>
Date: Thu, 24 Mar 2005 23:19:39 -0800

I dimly recall, perhaps not correctly, that a few 3166 codes from the dim past have been reused. Is the RFC 1766 date Frank cites of use in excluding long stale codes that have been reused (i.e. don't make certain values canonical, allow some newer meanings in)? Otherwise I tend to agree with Mark.

Of course you've not got to regions yet: this is only language codes. On language codes, I would say take them all.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: jeudi 24 mars 2005 22:06
> To: LTRU Working Group
> Subject: Re: Question: (was Re: [Ltru] Re: Populating the initial
> registry:Languages)
> 
> Mark Davis <mark dot davis at jtcsv dot com> wrote:
> 
> > The safest and most robust policy is allow all codes that have ever
> > been permitted by the source standards. My reasons are that
> > (a) because of the instability of such sources, it was indeed a
> > reasonable tactic to take use the first defined code for a given
> > semantic, and that tactic was in widespread use, and
> > (b) because 3066 and 1766 did not take into account the instability of
> > the source standards, it was never clear which codes were in fact
> > valid at any point in time for use in 3066 or 1766, so there was no
> > guidance as to which code to use, or with what semantics.
> 
> OK, so far we have Mark taking this stand, and Frank taking the stand
> that a cutoff date should be set, such as the publication of RFC 1766,
> such that language and country codes deprecated before that date would
> not be allowed in language tags.  And I agree with Mark.
> 
> Anyone else?  This is only 3 voices out of at least 15 active
> participants in the group, which is not what anyone would call
> consensus.
> 
> > However, because of the reuse of codes for unrelated entities by the
> > source standards, we do have to impose some order in those cases where
> > there is a conflict. For that, we have had in the drafts the use of a
> > cut-off date for deciding which semantic to use in case of a conflict,
> > such as with 'CS'.  In that particular case there is sufficient
> > consensus to make that after the redefinition of CS to mean "Serbia
> > and Montenegro": a date of January 1 2005 would capture that
> > consensus. It would be safest not to put it at date of publication,
> > simply because that take the risk (probably small, but unfortunately
> > real) that the source standards would redefine a code after the draft
> > has been discussed and approved, but before publication.
> 
> I wonder if we could solicit some sort of temporary moratorium from the
> MAs that they would refrain from doing this at least until we can get
> the RFCs out, presumably by the end of 2005.
> 
> -Doug Ewell
>  Fullerton, California
>  http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 24 Mar 2005 23:33:19 -0800

Addison Phillips <addison dot phillips at quest dot com> wrote:

> I dimly recall, perhaps not correctly, that a few 3166 codes from the
> dim past have been reused.

Based on Clive Feather's page:

AI originally meant French Afars and Issas, was removed in 1977, and
reassigned to Anguilla sometime between 1982 and 1988.

GE originally meant Gilbert and Ellice Islands, was removed in 1979, and
reassigned to Georgia in 1992.

SK originally meant Sikkim, was removed in 1975, and reassigned to
Slovakia in 1993.

And of course, the one we all know and love:
CS originally meant Czechoslovakia, was removed in 1993, and reassigned
to Serbia and Montenegro in 2003.

> Is the RFC 1766 date Frank cites of use in excluding long stale codes
> that have been reused (i.e. don't make certain values canonical, allow
> some newer meanings in)? Otherwise I tend to agree with Mark.

No codes that have been reused can possibly be used with their old
meaning, by definition.  We have to use them with their new meaning.  CS
was the lone exception, but that was changed last December.

> Of course you've not got to regions yet: this is only language codes.
> On language codes, I would say take them all.

I think if we're going to use different criteria for language codes and
country codes, we'd better have a really good, defensible reason for
doing so.

-Doug Ewell
 Fullerton, California

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 25 Mar 2005 10:11:28 +0100

Doug Ewell wrote:

> I think if we're going to use different criteria for language
> codes and country codes, we'd better have a really good,
> defensible reason for doing so.

That's rather simple:  Compared with countries languages "live"
much longer.  ISO 639 promised that they'll never add a new
alpha-2 code where an alpha-3 code already exists.  They have
no reason to ever reassign any alpha-2 or alpha-3 code.  What
they offer is by definition stable.

OTOH ISO 3166-1 has only a very limited set of alpha-2 codes,
and they try to use acronyms or other mnemonics.  They are
forced to reassign codes from time to time, and even if they'd
guarantee a transition period of 50 years for deprecated codes
what they offer is by definition _not_ stable.

If we want to "freeze" ISO 3166-1 for stable codes we should at
least not block future uses of old codes which were never used
in RfC 3066 language tags,
                            Bye, Frank