Subject: [Ltru] Language transformation

From: "M.T. Carrasco Benitez" <[email-masked]>
Date: Wed, 30 Mar 2005 17:49:32 +0100 (BST)

I am sending this today to the editor.

Regards
Tomas

-------------------------------------------------------------------

Internet-Draft                                   M.T. Carrasco Benitez 
Expires: 1 October 2005                            European Commission 
                                                         30 March 2005 

 
                     Codes for language transformation 
                    draft-carrasco-language-code-02.txt 

Intellectual Property Rights Statement 
    
   By submitting this Internet-Draft, each author represents that any 
   applicable patent or other IPR claims of which he or she is aware 
   have been or will be disclosed, and any of which he or she becomes 
   aware will be disclosed, in accordance with Section 6 of BCP 79. 
    
Status of this Memo  
    
   Internet-Drafts are working documents of the Internet Engineering 
   Task Force (IETF), its areas, and its working groups. Note that other 
   groups may also distribute working documents as Internet-Drafts.  
    
   Internet-Drafts are draft documents valid for a maximum of six months 
   and may be updated, replaced, or obsoleted by other documents at any 
   time. It is inappropriate to use Internet-Drafts as reference 
   material or to cite them other than as "work in progress."  
    
   The list of current Internet-Drafts can be accessed at 
   http://www.ietf.org/1id-abstracts.html  
    
   The list of Internet-Draft Shadow Directories can be accessed at 
   http://www.ietf.org/shadow.html 
        
Abstract  
    
   This document describes codes for language transformation such as 
   transliteration and transcription. 
    
   Language transformation means that a language is expressed in another 
   way (e.g., in another alphabet) for people familiar with the target 
   alphabet and language. For example, Greek converted to Latin script 
   for English users. 
    
   Note that this is not translation. The text continues to be in Greek, 
   but written in another alphabet. 

 
Carrasco                Expires 1 October 2005                [Page 1]

Internet-Draft         Language Transformation             March 2005 

1. Introduction
    
   Natural languages can be written in scripts that are not their usual 
   scripts. For example, the ideogram for the Chinese capital is 
   transliterated as "Beijing". 
    
   Transliteration tries to transform scripts. Transcription tries to 
   transform sounds. It is wise to avoid discussion on what is 
   transliteration or transcription: often transformation schemes are a 
   mixture of several approaches. Hence, this document uses the term 
   transformation. 
    
   Transformation is aimed at a target user. For example, transformation 
   from Greek for English is different from a transformation from Greek 
   for Arab: the scripts are different. 
    
   Scripts are not the only issue. Transformation from Greek for French 
   is different from transformation from Greek for Spanish: same target 
   script, different target languages; but different transformation 
   schemes. 
    
   One can also have more than one transformation scheme from a language 
   to another language. For example, there are several transformation 
   schemes from Chinese for English: same target script, same target 
   language; but different transformation schemes. 
    
   Hence, one needs a list of transformation schemes, each with one 
   unique identifier. The transformation identifier indicates the source 
   language(s), the source script, the target language(s) and the target 
   script. 
    
   Following the publication of the Internet-Draft Tags for 
   Identification of Languages [TID], this long expired Internet-Draft 
   is revived as a feedback to the ongoing work by the Language Tag 
   Registry Update (LTRU). 
    
2. Transformation
    
   To tag a transformed language one needs the following: 
    
   - Transformation indicator 
   - Source language 
   - Transformation scheme 
    
   Example: 
    
    tran-zh-wadegiles 
    
   This means: Transformation of Chinese using the Wade-Gide scheme. 

Carrasco                Expires 1 October 2005                [Page 2]

Internet-Draft         Language Transformation             March 2005 

   The above is a pseudo-code. In particular, it is not a syntactic 
   proposition for LTRU. This should come later, assuming that LTRU want 
   to consider language transformations. Indeed, the transformation 
   token does not need to be present and it could be implied. For 
   example; 
    
    zh-wadegiles 
    
3. Syntax
    
   Ideally, the syntax should be of the form: 
    
    zh-wadegiles 
    
   i.e., the transformation indicator should be implicit. 
    
   Otherwise, the syntax should be discussed in LTRU. 
    
4. Registries
    
   Two registries are need: 
    
   - IANA  
   - Schemes for Language Transformation  
    
   IANA must be concerned only with scheme identifiers. In the example 
   above the string "wadegiles". 
    
   The Registry of Schemes for Language Transformation must contain the 
   scheme identifier, source and target language(s)/script(s), 
   description, etc. A proposition will follow. 
    
5. Security Considerations
    
   The same as stated in TID, section 4. 
    
6. References
    
   [LIST] 
   Previous discussion in the list [email-masked] 
   http://lists.w3.org/Archives/Public/ 
   www-international/1998OctDec/0002.html 
    
   [LTRU] 
   Language Tag Registry Update (ltru) 
   http://www.ietf.org/html.charters/ltru-charter.html 

 
Carrasco                Expires 1 October 2005                [Page 3]

Internet-Draft         Language Transformation             March 2005 

   [TC46/SC2] 
   International Technical Committee 46 / Subcommittee 2 
   Conversion of Written Languages 
   This committee has little or no activities 
   http://elot.gr/tc46sc2 
    
   [TID] 
   Tags for Identifying Languages 
   Editors, A. Phillips, M. Davis. 
   http://www.ietf.org/internet-drafts/draft-ietf-ltru-registry-00.txt 
   Work in progress 
    
7. Author Address
    
   Manuel Tomas CARRASCO BENITEZ 
   European Commission 
   Jean Monnet Building 
   L-2920 Luxembourg 
    
   Telephone: +352 4301 36943 
   Email: [email-masked] 
    
8. Disclaimer
    
   Though the intention is of a feedback to LTRU, this document has not 
   been endorsed by LTRU. 
    
   This document represents the view of the author. It does not  
   necessarily represent the views of any other parties. 
    
9. Copyright Statement
    
   Copyright (C) The Internet Society (2005).  
    
   This document is subject to the rights, licenses and restrictions 
   contained in BCP 78, and except as set forth therein, the authors 
   retain all their rights.  
    
   This document and the information contained herein are provided on an 
   "AS IS" basis and THE CONTRIBUTOR, THE ORGANIZATION HE/SHE REPRESENTS 
   OR IS SPONSORED BY (IF ANY), THE INTERNET SOCIETY AND THE INTERNET 
   ENGINEERING TASK FORCE DISCLAIM ALL WARRANTIES, EXPRESS OR IMPLIED, 
   INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE 
   INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED 
   WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 

 
Carrasco                Expires 1 October 2005                [Page 4]


Send instant messages to your online friends http://uk.messenger.yahoo.com 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 31 Mar 2005 07:11:34 +0200

> I am sending this today to the editor.

Interesting, if I get it right you want LTRU to use a scheme
which allows the later addition of transliterations.  You
identify five relevant parts:

1: source language, 2: source script, 3: target laguage(s), 
3: target script, 5: (registered) transliteration scheme.

Two of these parts could be irrelevant, the source script,
and target language(s) if they are implied by the scheme.

This would fit into a lang + script + variant pattern, if 
you consider a "registered transliteration scheme" as some
kind of "registered variant".

Is that good enough for your purposes, and do you want it
as an example for "variants" in the registry draft ?

                   Bye, Frank