Subject: [Ltru] Registry in record-jar format

From: "Doug Ewell" <[email-masked]>
Date: Tue, 22 Mar 2005 22:44:15 -0800

At least one person expressed some interest in seeing the draft /
proposed / sample registry in record-jar format, so here it is:

http://users.adelphia.net/~dewell/lstreg-rj.txt

This has no official sanction or consensus; it's just there so people
can visualize it (which I guess is true for the other one as well).

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 23 Mar 2005 08:13:15 +0100

> http://users.adelphia.net/~dewell/lstreg-rj.txt

Great, thanks, but we still need the normal RfC (2)822 folding
for a proper I-D e.g. in line 4068 (107 characters).  The idea
is to replace a space <SP> by <CrLf><SP>:

%%
Type: grandfathered
Subtag: zh-min-nan
Description: Minnan, Hokkien, Amoy, Taiwanese, Southern Min,
 Southern Fujian, Hoklo, Southern Fukien, Ho-lo
Date: 2001-03-26
%%

You could also use <CrLf><HT><SP> in these cases: 

%%
Type: grandfathered
Subtag: zh-min-nan
Description: Minnan, Hokkien, Amoy, Taiwanese, Southern Min,
	 Southern Fujian, Hoklo, Southern Fukien, Ho-lo
Date: 2001-03-26
%%

> This has no official sanction or consensus

As soon as it's an I-D it's an "official draft registry".

At the moment I'm more worried about the size of the future
registry for 7000+ languages, IANA is probably forced to split
it somehow on its Web pages.
                              Bye, Frank

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 23 Mar 2005 10:54:18 -0800

Hi -

> From: "Doug Ewell" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>
> Sent: Tuesday, March 22, 2005 10:44 PM
> Subject: [Ltru] Registry in record-jar format
>

> can visualize it (which I guess is true for the other one as well).
...

Thanks for making this available.  It's always helpful to be able to see
just how a proposal might be realized.

(co-chair hat off)
I like this format better than the current one, for the following reasons:
   1) it's much easier to read, and consequently less error-prone for
      whoever ends up doing the actual edits to the registry files
   2) it's still machine-parseable
   3) it would permit the initial registry content to be documented in
       an internet draft

Randy