Subject: RE: [Ltru] Update to proposed registry

From: "Addison Phillips" <[email-masked]>
Date: Sat, 12 Mar 2005 13:02:31 -0800

See Appendix C in the registry I-D.

IMHO, there is no reason that the prototype registry has itself to be an internet draft. Merely that there be a process for creating and approving it. 

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: Saturday, March 12, 2005 12:36 PM
> To: LTRU Working Group
> Subject: Re: [Ltru] Update to proposed registry
> 
> Hi -
> 
> > From: "Doug Ewell" <[email-masked]>
> > To: "LTRU Working Group" <[email-masked]>
> > Sent: Saturday, March 12, 2005 11:21 AM
> > Subject: [Ltru] Update to proposed registry
> >
> 
> > Addison and Mark's new draft contains an important change: grandfathered
> > tags are allowed to have a canonical value.  This means grandfathered
> > tags can be formally deprecated, not just marked with a comment.  This
> > is a change we've talked about for some time.  The wording is still a
> > bit inconsistent, but I expect that will be cleared up soon.
> >
> > Accordingly, I've updated the proposed draft registry available at:
> >
> > http://users.adelphia.net/~dewell/lstreg.html
> > http://users.adelphia.net/~dewell/lstreg.txt
> >
> > to add canonical values to all the grandfathered tags that were
> > previously commented as "deprecated."  This update also removes the
> > variant subtag 'lojban' and changes the status of "art-lojban" from
> > redundant to grandfathered (with a canonical value of "jbo").
> >
> > There is also a change history at
> > http://users.adelphia.net/~dewell/lstreg-history.html.
> >
> > All comments within the scope of the charter are welcome.
> 
> (co-chair hat OFF)
> 
> Would it make sense to make this into a working group i-d?
> When (re-)populating a registry, it seems like it would be nice
> to be able to give IANA something that had been under WG change
> control, without having to incorporate it all in the registry document.
> On the other hand, the format of the entries would be hard to
> reconcile with the constraints on i-ds.  Many of the lines exceed
> 72 characters.  In any case, if the updated registry would contain
> information that cannot be derived algorithmically from the current
> registry contents, we *somehow* would have to provide that information
> to IANA, whether in the registry document itself or in a new companion
> document.  Ideas?
> 
> Randy
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 12 Mar 2005 13:18:10 -0800

Hi -

(co-chair hat off)

> From: "Addison Phillips" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Saturday, March 12, 2005 1:02 PM
> Subject: RE: [Ltru] Update to proposed registry
>

> IMHO, there is no reason that the prototype registry has itself to be an internet draft.

True, it's just that the procedures for change control and approval
of i-ds are already in place.  The material in appendix C of registry-00,
as you point out, would provide another way of accomplishing the same
thing.

> Merely that there be a process for creating and approving it.

I think it would make sense to move this material into the IANA
considerations section as a separate subsection, with a title
something like "Initialization of the Registry".

Randy