Subject: RE: [Ltru] zh-min-nan and en-GB-oed (was: Registry in record-jarformat)

From: "Addison Phillips" <[email-masked]>
Date: Wed, 30 Mar 2005 09:18:02 -0800

art-lojban is deprecated in favor of 'jbo'. Changes in draft-00 make it a grandfathered entry (it was formerly redundant) to prevent creating the variant subtag 'lojban'.

This also applies in various ways to some of the well-formed-but-not-valid values (no-nyn, for example).

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of John Cowan
> Sent: mardi 29 mars 2005 23:32
> To: Frank Ellermann
> Cc: [email-masked]
> Subject: Re: [Ltru] zh-min-nan and en-GB-oed (was: Registry in record-
> jarformat)
> 
> Frank Ellermann scripsit:
> 
> > They don't follow the normal lang + extlang + variant or
> > lang + region + variant patterns.  But if the parser isn't
> > broken it should find that these _must_ be grandfathered
> > tags, sorry, please ignore my stupid question.
> 
> This brings up an interesting point:
> 
> Of the 25 current grandfathered tags in the registry:
> 
> 	18 are not well-formed (en-gb-oed, i-*, sgn-*-*, zh-min-nan).
> 
> 	6 are of the reserved xx-yyy form:
> 		3 (zh-gan, zh-wuu, zh-yue) will be well-formed and valid
> 			in 3066ter;
> 		3 (zh-min, no-bok, no-nyn) will be well-formed but not
> 			valid in 3066ter.
> 
> 	1 is well-formed already (art-lojban) but appears to make
> 		"lojban" a variant, which it is not.
> 
> --
> John Cowan  [email-masked]  www.reutershealth.com
> www.ccil.org/~cowan
> Assent may be registered by a signature, a handshake, or a click of a
> computer
> mouse transmitted across the invisible ether of the Internet. Formality
> is not a requisite; any sign, symbol or action, or even willful inaction,
> as long as it is unequivocally referable to the promise, may create a
> contract.
>        --Specht v. Netscape
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Wed, 30 Mar 2005 12:46:39 -0500

Addison Phillips scripsit:

> art-lojban is deprecated in favor of 'jbo'. Changes in draft-00 make it
> a grandfathered entry (it was formerly redundant) to prevent creating
> the variant subtag 'lojban'.

Nobody knows that better than I; my name's on the registration requests
for both "art-lojban" and "jbo", not surprisingly.

> This also applies in various ways to some of the
> well-formed-but-not-valid values (no-nyn, for example).

Sure.  I was just interested in exploring how many of the grandfathered
tags were recognizable as such by their syntax alone (per Frank's
remarks).   In particular, is it a feasible strategy for RFC 3066bis
parsers to recognize grandfathered tags only after attempting to parse
the tag, in order not to expend cycles on tests for grandfathered tags
that will almost always fail?  Answer: almost.

/me goes back in time and kicks himself for registering art-lojban.

-- 
John Cowan  [email-masked]  www.reutershealth.com  www.ccil.org/~cowan
If a traveler were informed that such a man [as Lord John Russell] was
leader of the House of Commons, he may well begin to comprehend how the
Egyptians worshiped an insect.  --Benjamin Disraeli