Subject: RE: [Ltru] Re: Preparations for smart matching

From: "L.Gillam" <[email-masked]>
Date: Mon, 21 Mar 2005 15:47:05 -0000

John, 

<a_light_note>I think this is a time where one should at least ask questions of the messenger, and perhaps consider less extreme forms of punitive actions</a_light_note> - please see:

http://isotc.iso.org/livelink/livelink/fetch/2000/2122/687806/ISO_TC_037__Terminology_and_other_language_resources_.pdf?nodeid=1160801&vernum=0

The ISO NWIP was accepted in August 2004 - status apparently the same as 639-5. Draft documents, including those written for CD, are part of the standards workflow. Such a document, when submitted, would undergo ballot by member bodies of TC 37. CD is a natural progression of a NWIP. The CD is being prepared in follow-up to the NWIP. If by "official status" you mean "it hasn't been voted on" then I agree, but your comment could also be interpreted that what she is writing has nothing whatsoever to do with this process.

639-5 appears to provide a structure in which to make sense of 639-3 - looking awfully like the structure of Ethnologue. 639-5 will also fish the alpha3 pool. A draft (CD perhaps) of 639-5 contains a list of these alpha3s. Whether this list is included in the final document is not clear. Currently the alpha3 list of -3 will not be in the published standard as I understand it (Peter Constable should be able to confirm whether this position has changed). General principles and groups of languages may be irrelevant to 3066bis, but eventually - in some none-too-distant future one suspects - smart matching will also have to take into account the specialisation/generalisation relationships as composed by these 2 - which is somewhat orthogonal to current 3066 "tag-dropping" practice. Additionally, the general principles will form a mechanism for integration with other ISO 11179-3 metadata registries such as those under development in other subcommittees of TC 37. -4 as currently perceived will be something like a "Language Description Framework", echoing principles applied in development of ISO 16642 (/ISO 12620 revision) to language codes. The terminology model (language [concept], language naming section [language section], language names [terms]) would, one hopes, provide a means for M. Morfin's thesaurus of language names, although not a fully-functional solution (OT - I've not yet understood if in having a .uk domain we can't include content in non-UK languages on a web-site. Perhaps I've missed the point here too).

At this point I should promote a related research activity http://portal.surrey.ac.uk/portal/page?_pageid=798,337934&_dad=portal&_schema=PORTAL for which the  actual website is in development at INRIA.

Best Regards.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of John Cowan
> Sent: 21 March 2005 14:37
> To: [email-masked]
> Subject: Re: [Ltru] Re: Preparations for smart matching
> 
> 
> Debbie Garside scripsit:
> 
> > My interest is that I am currently writing a Committee 
> Draft (CD) for the
> > proposed ISO 639-6 which covers language variation 
> (written/spoken/signed)
> > and provides a meta-model for an object orientated Language 
> Description
> > Framework (or language registry perhaps). 
> 
> I think it worth mentioning that there is no ISO 639-6 on the current
> programme of work of ISO TC 37 / SC 2.  (My reference in an earlier
> posting to ISO/IEC JTC 1 was a mistake, and should be disregarded.)
> So at the moment Debbie's draft has no official status with ISO.
> 
> ISO 639-4 (general principles) and ISO 639-5 (codes for groups of
> languages) are in progress, but are irrelevant to RFC 3066bis.
> 
> -- 
> How they ever reached any  conclusion at all    
> [email-masked]>
> is starkly unknowable to the human mind.        
> http://www.reutershealth.com
>         --"Backstage Lensman", Randall Garrett  
> http://www.ccil.org/~cowan
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Tue, 22 Mar 2005 10:06:15 -0500

L.Gillam scripsit:

> <a_light_note>I think this is a time where one should at least ask
> questions of the messenger, and perhaps consider less extreme forms
> of punitive actions</a_light_note> - please see:

I was merely reporting what the official ISO status page said.  No hostility
to anyone was intended or implied.

> http://isotc.iso.org/livelink/livelink/fetch/2000/2122/687806/ISO_TC_037__Terminology_and_other_language_resources_.pdf?nodeid=1160801&vernum=0

Thanks for this pointer.  This says that 639-3,4,5,6 are all at stage
20.00, meaning that they are part of the programme of work.  This is
clearly inaccurate for 639-3, which is elsewhere stated to be at 40.20
(DIS out for ballot).

> 639-5 appears to provide a structure in which to make sense of 639-3 -
> looking awfully like the structure of Ethnologue. 

I'm not surprised.

> General principles and groups of languages may be irrelevant to
> 3066bis, but eventually - in some none-too-distant future one
> suspects - smart matching will also have to take into account the
> specialisation/generalisation relationships as composed by these 2 -
> which is somewhat orthogonal to current 3066 "tag-dropping" practice.

I hope not.  The trouble with language collections is that if they are
defined extensionally (en+nl+de+yi+...) they may or may not reflect
anything real, and if they are defined intensionally ("Germanic language")
they are theory-dependent and are unstable, changing as linguistic theories
change.  (Granted, the Germanic family is quite stable, but this isn't
true in general.)

> At this point I should promote a related research activity
> http://portal.surrey.ac.uk/portal/page?_pageid=798,337934&_dad=portal&_schema=PORTAL
> for which the  actual website is in development at INRIA.

Hmm.  It would be nice to know what this is actually about.  :-)

-- 
John Cowan  [email-masked]  www.reutershealth.com  www.ccil.org/~cowan
I come from under the hill, and under the hills and over the hills my paths
led. And through the air. I am he that walks unseen.  I am the clue-finder,
the web-cutter, the stinging fly. I was chosen for the lucky number.  --Bilbo