Subject: RE: [Ltru] Re: Registry in record-jar format [choice of formats]

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 25 Mar 2005 10:37:52 -0800

Hi,

I'm most happy with option 1 (or option 4).

Because I'm convinced that record-jar format will
be much easier to extract information from when NOT
using XML parsers and XML-aware tools.  

I suppose filters using 'awk' or whatever might level
that difference.  But personally I write C utilities
when I want to extract items from IANA registries.
Hand-parsing XML is needless busywork, IMHO.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Addison Phillips
Sent: Friday, March 25, 2005 12:52 PM
To: LTRU Working Group
Subject: RE: [Ltru] Re: Registry in record-jar format

A real XML DTD would have to be carefully designed. My example in the email
was very much a back-of-the-envelope example.

I agree that everything has to be in the RFC governing the registry. If
there are to be multiple formats, then they all have to be documented, along
with their production methods, for IANA and others.

The key is getting consensus on what to do.

Right now I think the options are:

1. Change to record-jar format.
2. Change to an XML format. A proper DTD needs to be designed in this case.
3. Neither.
4. Both (record-jar is normative)
5. Both (XML is normative)

Right this second I support (2), but would be (almost) as happy with (1).

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of McDonald, Ira
> Sent: vendredi 25 mars 2005 09:14
> To: 'Doug Ewell'; LTRU Working Group
> Subject: RE: [Ltru] Re: Registry in record-jar format
> 
> Hi,
> 
> Please don't mis-use XML attributes to be the equivalent of
> 'attributes' in the object-oriented sense.  They aren't and
> the protocol specs I've seen that used them caused nightmares
> when trying to morph them into proper hierarchical elements.
> 
> And bear in mind what Scott Hollenbeck just reminded us about,
> to whit, _nothing_ is up to IANA to figure out.  This WG has
> to specify complete processes and formats for use by IANA in
> our 'IANA Considerations' section.
> 
> Cheers,
> - Ira
> 
> Ira McDonald (Musician / Software Architect)
> Blue Roof Music / High North Inc
> PO Box 221  Grand Marais, MI  49839
> phone: +1-906-494-2434
> email: [email-masked]
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Doug Ewell
> Sent: Friday, March 25, 2005 2:02 AM
> To: LTRU Working Group
> Subject: [Ltru] Re: Registry in record-jar format
> 
> 
> Addison Phillips <addison dot phillips at quest dot com> wrote:
> 
> > If we're going to consider different formats for the registry, might I
> > suggest that an even better format would be XML?
> 
> You might.
> 
> Oh, all right, I'll do an XML version too and post it, so you guys can
> see that one too.
> 
> XML has all the advantages and disadvantages that people have mentioned
> so far, and probably many more of both.  XML is sort of like California:
> anything anyone can say about it is true.
> 
> Actually I had wondered before about converting the registry to XML, but
> wasn't sure how it should be structured.  (The eternal question:
> "Elements or attributes?  Which will serve me best?")  For this version,
> I'll use Addison's example blindly, but without any extra information
> (such as URLs) that isn't already in the existing registry.  Don't hold
> your breath; I'll announce when it's ready.
> 
> -Doug Ewell
>  Fullerton, California
>  http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Sat, 26 Mar 2005 03:40:35 +0100

>Hand-parsing XML is needless busywork, IMHO.

idem. Full agreement.
jfc