Subject: RE: [Ltru] Language transformation

From: "Peter Constable" <[email-masked]>
Date: Thu, 31 Mar 2005 08:55:12 -0800

> From: [email-masked] [mailto:[email-masked]] On Behalf Of M.T.
> Carrasco Benitez

> We could use another term; for example, "conversion" as used by the TC46/SC2.
> I do not recommend to use either the terms "transliteration" or "transcription"
> as we risk to start a polemy.

I agree that "transliterations" are not as cut and dried as TC46 makes them out to be. My only point was that there are many things that fall in the category of "transcription" (clearly that and not transliteration), such as IPA, that really aren't conversions or transformations.

> > I have for some time assumed that it should be possible to accommodate
> > tags for transcriptions within a successor to RFC 3066, with requiring
> > any special new apparatus.
> 
> As long as I am aware, it is not possible. The original Internet-Draft is
> from 1998 and Alvestrand was involved in the discusison. Have a look to:
> 
> http://lists.w3.org/Archives/Public/www-international/1998OctDec/0002.html

Well, obviously I disagree with some of the opinions that were expressed. I think very definitely there should be a way to tag content to indicate both it's language variety and written form -- we've had consensus for some time that RFC3066 tags should be able to distinguish e.g. zh-Hans and zh-Hant. IMO, Chinese in phonetic transcription or in Wade-Giles are just additional written forms.

> Azeri is probably a worse case example. In less than a century it has used
> the Arabic, Cyrillic and Latin alphabets. These changes were supposed to be
> "permanent". Transformation does not addresses permanent changes, like Azeri
> or Turkish (changed in 1928). This should be addressed with other existing
> mechanisms in LTRU.
> 
> Transformation addresses expression "non-native" to the language. For example,
> Armenian transformed (or transliterated) into the Latin script.

I don't think your distinction between "permanent changes" and transformations is really relevant. (Note that someone might create a written representation for something like Azeri intending it to be permanent, but that doesn't mean it will be widely adopted, let alone endure.) All we need to concern ourselves with is what it takes to identify content in a given form, and to identify linguistic processing resources.

> > (BTW, I'm not a Sinologist, so don't know, but am curious: is Wade-Giles
> > a transcription/orthographic convention or a transliteration scheme?)
> 
> I am not a Sinologist, either. But even I am were one, I would not state
> if it is a transliteration or transcription. I learnt this the hard way:
> I am pretty certain that a non ending discussion will follow.

You're probably right, and it would be rather off topic.

> TC46/SC2 is defunct. 

I think you're right. 

> I have done some preliminary work. And we should look
> for an acceptable host.
> 
> (Martin Dürst: do you think that we could do it in Unicode ?)

Martin's not the right one to be asking that; you should be addressing the question to Mark Davis.

Peter Constable

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Thu, 31 Mar 2005 14:32:01 -0500

Peter Constable scripsit:
> I agree that "transliterations" are not as cut and dried as TC46
> makes them out to be. My only point was that there are many things
> that fall in the category of "transcription" (clearly that and not
> transliteration), such as IPA, that really aren't conversions or
> transformations.

I propose the term "trans*tions" for these unnatural acts of orthography,
thus covering transliteration, transcription, and transformation.

I further propose that the Right Thing with these is to use the
RFC 3066bis language, optional script, and variant fields, using
variants specifically chosen for the purpose:  thus Wade-Giles could
be zh-Latn-wadegiles, or just zh-wadegiles.  The English-language
trans*tion of Russian might be ru-transen or ru-Latn-transen; I think
it is unnecessary to introduce an extension feature for this purpose.

But I think it would be good to introduce an example (perhaps the
wadegiles one) into the draft, to make it clear that variants may be
orthographic as well as linguistic.

-- 
Her he asked if O'Hare Doctor tidings sent from far     John Cowan
coast and she with grameful sigh him answered that      www.ccil.org/~cowan
O'Hare Doctor in heaven was. Sad was the man that word  www.reutershealth.com
to hear that him so heavied in bowels ruthful. All      [email-masked]
she there told him, ruing death for friend so young,
algate sore unwilling God's rightwiseness to withsay.   Ulysses, "Oxen"