Subject: RE: [Ltru] Re: Language transformation

From: "Addison Phillips" <[email-masked]>
Date: Thu, 31 Mar 2005 10:22:10 -0800

No, I understood that script would only be a gross indicator of a transliteration and a rather inexact one at that. "zh-Latn" would cover both of your examples, but wouldn't convey much information about the content.

However, using variants complicates matters. The transformation applied to the text is only one dimension of the content. It may still have a language ("zh"), a dialect (in 3066ter a 639-3 extland code, such as wuu???), a script (Grek, Latn, Hant, etc.), a region (CN, HK, SG, TW...), and a variant not related to the transformation itself. These may be as important to tag the content with as the transformation applied.

Extensions allow this kind of semi-orthogonal, language-related distinction to be applied. Consider:

  zh-wuu-CN-t-wadegile

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of M.T. Carrasco Benitez
> Sent: jeudi 31 mars 2005 10:08
> To: [email-masked]
> Subject: RE: [Ltru] Re: Language transformation
> 
> > Transliteration seems like it might be handled using script codes in a
> gross sense. For the
> > finer sense this draft wants to convey, an extension seems like a better
> fit.
> 
> Script are not sufficient. Examples:
> 
>  <span lang="zh-widegiles">Peking</span>
>  <span lang="zh-pinyin">Beijing</span>
> 
> Regards
> Tomas
> 
> 
> Send instant messages to your online friends http://uk.messenger.yahoo.com
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Thu, 31 Mar 2005 14:44:30 -0500

Addison Phillips scripsit:

> However, using variants complicates matters. The transformation applied
> to the text is only one dimension of the content. It may still have
> a language ("zh"), a dialect (in 3066ter a 639-3 extland code, such
> as wuu???), a script (Grek, Latn, Hant, etc.), a region (CN, HK, SG,
> TW...), and a variant not related to the transformation itself. These
> may be as important to tag the content with as the transformation
> applied.

The variant unrelated to the trans*tion is the only issue that would
actually be a problem, and I'd like to see a RL example before I agree.

>   zh-wuu-CN-t-wadegile

FWIW, Wade-Giles romanization doesn't handle anything but Mandarin.

-- 
A: "Spiro conjectures Ex-Lax."                  John Cowan
Q: "What does Pat Nixon frost her cakes with?"  [email-masked]
  --"Jeopardy" for generative semanticists      http://www.ccil.org/~cowan