Subject: [Ltru] XML registries now available

From: "Doug Ewell" <[email-masked]>
Date: Sat, 26 Mar 2005 18:35:11 -0800

I've uploaded a couple of XML versions of the registry, again just so
everyone can visualize what they would look like.

One is in Addison's original "back of the envelope" format, at
http://users.adelphia.net/~dewell/lstreg-addison.xml:

<subtag type="language" value="aa" date="2004-07-06">
  <description>Afar</description>
</subtag>

while the other uses XML elements exclusively instead of attributes,
which may or may not have been what Ira McDonald had in mind, at
http://users.adelphia.net/~dewell/lstreg-ira.xml:

<subtag>
  <type>language</type>
  <value>aa</value>
  <description>Afar</description>
  <date>2004-07-06</date>
</subtag>

These are only up for illustration, not for advocacy.  Personally I
liked the old vertical-bar format, but if the group would prefer to see
a change, that's fine.

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Sun, 27 Mar 2005 04:46:44 +0200

>liked the old vertical-bar format, but if the group would prefer to see

I favor vertical bar: simple, visual, secure. IMHO the only advantage of 
XML is to be easily ported to ASN.1 (easy maintenance in case of changes). 
However I agree with Ira, the programing is much simpler and secure with 
vertical bars. It is also Excell compatible.
jfc

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 27 Mar 2005 18:23:46 +0200

Doug Ewell wrote:

> http://users.adelphia.net/~dewell/lstreg-addison.xml
[...]
> http://users.adelphia.net/~dewell/lstreg-ira.xml

Both nice, I can't judge the pro and con between these formats.

To get a simple parser in any language very fast record-jar
or similar is apparently good enough.  The XML formats would
allow Unicode for 3066ter ideas like "language name in its
native script(s)" or only a Latin-1 "French name".

> These are only up for illustration, not for advocacy.
> Personally I liked the old vertical-bar format

It's fine, but unusable in an I-D or RfC.  Therefore I'd opt
for record-jar or a variant with empty lines instead of "%%",
plus the normal MIME folding for too long lines.

                             Bye, Frank

---

From: John Cowan <[email-masked]>
Date: Sun, 27 Mar 2005 14:23:08 -0500

> plus the normal MIME folding for too long lines.

Empty lines easily get lost in RFC format if they appear at the
top or bottom of a page; the "%%" delimiter is not subject
to that problem.

-- 
We are lost, lost.  No name, no business, no Precious, nothing.  Only empty.
Only hungry: yes, we are hungry.  A few little fishes, nassty bony little
fishes, for a poor creature, and they say death.  So wise they are; so just,
so very just.  --Gollum        [email-masked]  www.ccil.org/~cowan