Subject: [Ltru] Re: Question

From: "Doug Ewell" <[email-masked]>
Date: Sat, 26 Mar 2005 17:59:21 -0800

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> Later 3066 speculates about the chances of an ISO 639-1:2000
> published in 2001, and forbids the user assigned codes AA, ZZ,
> QM-QZ, and XA-XZ, they were allowed in RfC 1766.

Because they were allowed in RFC 1766, and because they may be useful,
they should be allowed in RFC 3066bis.

> SNAFU.  It's the purpose of 3066bis to cleanup this mess, not
> to preserve it.  Apparently nobody has a copy of ISO 3166:1988.
> Doug is forced to guess using private Web pages what this old
> stuff is about.

I have to use Clive Feather's page anyway because I don't have a copy of
ISO 3166-3 that says when this code and that code were withdrawn.

Once again:  Anyone got a copy of ISO 3166-3?

> We found RH, BQ, FQ, and NQ, these codes are
> irrelevant and disgusting.  Nobody recognizes these codes, and
> nobody needs any ?Q for fantastic languages in the Antarctic.

See my other post, which proposes to exclude these codes because they
were not valid under earlier RFCs, not because they are "irrelevant and
disgusting."  The latter is subjective and arbitrary.  (It is funny,
though.)

>> *nowhere* in 1766 does it say that a code later deprecated in
>> ISO 639 or 3166 is not valid
>
> "additions to and changes in the list".  Country codes like NH,
> BQ, FQ, and NQ are shown as _unassigned_ on the 3166-1 page.
> Maybe _deprecated_ in ISO 639 is a different issue, but 3166-1
> has a clear list of states:
>
> officially assigned       - examples: AQ, AX, CS
> user assigned             - examples: AA. QQ, XX
> exceptionally reserved    - examples: AC, EU, IM
> transitionally reserved   - examples: BU, NT, SF
> indeterminately reserved  - examples: DY. FL, RH
> not used at present stage - examples: AP, BX, EF
> unassigned                - examples: BQ, DD, NH

"Why they are reserved" is not important.  Either a code is currently
assigned, or it was formerly assigned, or it is private-use
("user-assigned").  Distinctions between the different types of
"reserved" are of interest only to the MA.

> BTW, Doug has RH as Southern Rhodesia, the ISO 3166-1 Web page
> has RH as Haiti (indeterminately reserved).

RH for Haiti would probably be a car code for "Republic of Haiti."

"Indeterminately reserved" is not a category I have any faith or
confidence in, not since ISO 3166/MA indeterminately reserved ROU
(Republic of Uruguay) and then assigned it to Romania because the old
code, ROM, might be construed as referring to a disparaged ethnic group.

-Doug Ewell
 Fullerton, California
 http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 27 Mar 2005 18:42:31 +0200

Doug Ewell wrote:

> "Why they are reserved" is not important.  Either a code is
> currently assigned, or it was formerly assigned, or it is
> private-use ("user-assigned").  Distinctions between the
> different types of "reserved" are of interest only to the MA.

I'm not sure, if "transitionally reserved" is essentially the
same as "deprecated", this could be relevant, and if all these
other "reservations" hide what we're interested in here, i.e.
"deprecated" vs. "unassigned", it could be also relevant.

And for Mark's "Joe Blow" or my "Jane Blog" anything on the
3166-1 web pages could be (ab)used.  Especially before 3066bis.

If we don't have a copy of ISO 3166:1988, then Joe and Jane
also have no copy, that's why they (ab)use ccTLDs or reserved
codes.  Until the future 3066bis registry helps to catch such
errors.
        Bye, Frank