Subject: RE: [Ltru] [psg.com #1067] Further clarify distinction between localecodes and language tags

From: "Addison Phillips" <[email-masked]>
Date: Fri, 15 Jul 2005 17:03:49 -0700

I think there is no need to add any text; there is already some text (in the section on extensions) which says that this is somewhat the case. Implementations that choose to coerce locales (local programming constructs) from language tags are free to do so.

Putting my (W3C) chair hat on: in fact the I18N Core WG is chartered to produce a document (with the suggestive name "Language Tags and Locale Identifiers"--suggestive because it implies both a relationship and a separation of the two concepts) dealing with this precise subject. Perhaps a RFC 3066ter could reference that work. Appropriate contributions under W3C IPR policy are invited.

(hat off)

For now, I don't think there is anything in particular that needs to be added here.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: 2005?7?15? 16:27
> To: LTRU Working Group
> Subject: [Ltru] [psg.com #1067] Further clarify distinction between
> localecodes and language tags
> 
> Hi -
> 
> > ------------------------------------------------------------------------
> -
> > This is in many ways a continuation of the discussion of
> > issue #1061.  Message
> > http://www1.ietf.org/mail-archive/web/ltru/current/msg02701.html
> > suggests clarifying that the semantics of language tags are distinct
> > from
> > those of locale ids, even though they may constructed from some of the
> > same language and country codes
> > Discussion:
> > http://www1.ietf.org/mail-archive/web/ltru/current/msg02706.html
> 
> Can we quickly resolve this one way or the other?
> 
> Randy, ltru co-chair
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 15 Jul 2005 17:31:27 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Friday, July 15, 2005 5:03 PM
> Subject: RE: [Ltru] [psg.com #1067] Further clarify distinction between localecodes and language tags
>

> I think there is no need to add any text; there is already some text
> (in the section on extensions) which says that this is somewhat the
> case. Implementations that choose to coerce locales (local programming
> constructs) from language tags are free to do so.
...

As a technical contributor, I don't find what's currently there particularly helpful.
It says:

|3.6  Extensions and Extensions Namespace
|
|   Extension subtags are those introduced by single-letter subtags other
|   than 'x'.  They are reserved for the generation of identifiers which
|   contain a language component, and are compatible with applications
|   that understand language tags.  For example, they might be used to
|   define locale identifiers, which are generally based on language.

The first part is fine, but that last sentence is not particularly enlightening.
Language is probably the most important thing specified by a locale,
but saying locales are "based on language" won't help those who are at
all confused about the relationship.  I hope this isn't the best example
of how we envision extensions being used.

I suggest deleting this example (or replacing it with something more
enlightening) and adding the following paragraph as the second
paragraph in section 2.2.4 (Region Subtag):

"Although a language tag constructed from a primary language subtag
followed by a region subtag bears a syntactic resemblance to a locale
identifier, the two are not to be confused.  Locales typically provide
information well beyond the identification of the language in use, as
they are associated with modifying system and application behaviour."

Randy

---

From: r&d afrac <[email-masked]>
Date: Sat, 16 Jul 2005 03:21:42 +0200

>they are associated with modifying system and application behaviour."

Proposed text - as insert for relation with IESG pending an IESG decision:

"[Charter has explicitly said that langtags apply to HTML, XML, CLDR, etc. 
This WG has identified that this point of the Charter is to be requalified. 
In the case of CLDR, locales can certainly be described in using Langtags 
as many other language and country related objects and processes, such as 
publishing, reading, filtering, censoring, exchanging, communicating, 
classifying text, book, records, identifying expertise in a language, 
copyrights, etc. etc. However they also have the capacity to document non 
language related issues such as colors on a display, sound of a 
loudspeaker, process speed depending on a process pattern, default network 
addresses, etc.. They also can be partly patented to support patented 
processes. As such they may have to be identified in refering to patent 
references the "x-" escape sequence could support woud it not be limited to 
8-alpha/num for retro-compatibility with the never used before patent 
referencing. The WG hesitates to documents langtags for the CLDR and wishes 
to exclude langtags considerations from its charter, reserving to locale 
compilers the decision to use langtags as a part of, or an equivalent to, 
localtag or not. Should localtags be confirmed as directly belonging the 
Charter, a locale oriented "l-" final extension will be used where all the 
subsequent dashes would not be part of the Draft ABNF, in order to accept 
sequences of the form "-c-" included in some of the references to include.]"

jfc

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 15 Jul 2005 19:23:11 -0700

Hi -

> From: "r&d afrac" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>
> Sent: Friday, July 15, 2005 6:21 PM
> Subject: [Ltru] Last call: clarification between language tags and locales
...
...

As co-chair:
(1) For patent-related disclosure requirements, see http://www.ietf.org/rfc/rfc3979.txt
(2) Specifying locales is clearly beyond our scope.

As a technical contributor, I think Jefsey's proposed addition would be
counterproductive. reducing rather than improving the document's
intellegibility.  Consequently, I strongly oppose its inclusion.

Randy

---

From: Martin Duerst <[email-masked]>
Date: Sat, 16 Jul 2005 21:14:11 +0900

I agree with Randy both as a chair and as a technical contributor.

Regards,    Martin.