Subject: RE: [Ltru] Re: last call scheduled?

From: "Addison Phillips" <[email-masked]>
Date: Tue, 5 Jul 2005 13:48:07 -0700

Suggestion:

Use your powers as editor to either keep text or expunge text. If you are fearful that someone will want one or another phrase back, enclose the removed text in an XML comment: <!-- comment -->

People who don't care don't comment. There is an infinite supply of integers for fixing "editing mistakes" and if you wait for someone else to dictate the text, you might wait a long time. I've personally found it useful to stick a very definite stake in the ground (in the form of text).

Personally I would:

1. Change: 

Such tags must have their record changed ...

To read:

--
Such tags will have their record...
--

// Avoiding normative language which isn't appropriate here.

2. Keep:

Note that previous approval of a tag under RFC 3066 is not a guarantee of approval of a variant subtag under this document. The existing RFC 3066 tag maintains its validity, but the original reason for its registration might have become obsolete. 

// Explanations are good to keep in both places.

3. Remove:

For example, the subtag 'boont' could be registered, resulting in the change of the grandfathered tag "en-boont" to type "redundant" in the registry.

// Superfluous.

4. Remove:

[ [ Registrations that are in process under the rules defined in RFC 3066 may be completed under the former rules, at the discretion of the RFC 3066 language tag reviewer. ] ]

// Also superfluous.

5. Modify:

--
New registrations completed under RFC 3066 were entered into the ILSR using the rules defined above.
--

To read:

--
Any additional registrations completed after adoption of [draft-registry] using the rules in RFC 3066 will be incorporated into this document using the rules defined above or will have appropriate records separately submitted by the Language Subtag Reviewer according to the rules in [draft-registry].
--

6. Remove:

[ [ Users of tags that are grandfathered should consider registering appropriate subtags in the Language Subtag Registry (but are not required to). ] ]

Best Regards,

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: den 5 juli 2005 13:16
> To: LTRU Working Group
> Subject: [Ltru] Re: last call scheduled?
> 
> Addison Phillips <addison dot phillips at quest dot com> wrote:
> 
> > Are we waiting on Doug to post initial-01? I don't want the weeks to
> > slip away... I've been waiting on this work a long time.
> 
> I've been waiting for feedback on the double-bracketed items before
> submitting initial-01.  So far I have received none.
> 
> I've posted a new editor's copy with all bracketed items deleted (as I
> have proposed they should be), and with the "Middle French" date error
> corrected.  If I haven't received any feedback on this, public or
> private, before 1400 UTC Wednesday (7:00 am Pacific time), I'll submit
> it to IETF as is.  I share Addison's concern about needless delay.
> 
> http://users.adelphia.net/~dewell/draft-ietf-ltru-initial-01.txt
> (.html, .xml)
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 5 Jul 2005 14:23:23 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

> 2. Keep:
>
> Note that previous approval of a tag under RFC 3066 is not a guarantee
> of approval of a variant subtag under this document. The existing RFC
> 3066 tag maintains its validity, but the original reason for its
> registration might have become obsolete.

OK, except I've changed "this document" to [draft-registry] for obvious
reasons.

> Any additional registrations completed after adoption of [draft-
> registry] using the rules in RFC 3066 will be incorporated into this
> document using the rules defined above or will have appropriate
> records separately submitted by the Language Subtag Reviewer according
> to the rules in [draft-registry].

I assume this is supposed to replace both sentences in the paragraph.  I
made a minor edit to reflect that the additional registrations will be
incorporated into the Language Subtag Registry, not necessarily "this
document" (i.e. the *initial* registry), and I tweaked the somewhat
clumsy "registrations... will have records submitted" construction.

Replacing this paragraph also has the nice side effect of removing the
typo "eequest."

All other suggested changes seemed reasonable and were incorporated.
New editor's copy is now available.