Subject: RE: [Ltru] Introduction change: suggested text

From: "Addison Phillips" <[email-masked]>
Date: Thu, 14 Jul 2005 00:57:11 -0700

Okay, we're far out in the weeds now. How about:

--
The language tag is used to identify a language used for communication by human beings. Such a language may take a variety of forms: it can be spoken, written, signed, or otherwise signaled; the primary requirement is that it be what is sometimes called a 'natural language'. That is, it must be a language in the ordinary sense of the word, which can include constructed or artificially designed languages, such as Esperanto. It excludes languages not intended primarily for human communication, such as programming or computer languages as well as various notation systems created for specialized purposes and which could not serve as a person's native tongue.
--

If *that* doesn't slay the Wittgenstein in all of you, then we should probably give up trying to define what a language is so precisely, allow a certain parsimony to reign, and say far less:

--
The language tag is used to identify a language as may be spoken, written, signed or otherwise signaled and whose primary purpose is communication between people.
--

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 
> -----Original Message-----
> From: Martin Duerst [mailto:[email-masked]]
> Sent: 2005?7?13? 18:37
> To: Addison Phillips; Randy Presuhn; [email-masked]
> Subject: RE: [Ltru] Introduction change: suggested text
> 
> While we are at it, I propose that we change:
> 
> The language tag is used to identify a language as used (which includes
> being spoken, written, signed, or otherwise signaled) by human beings for
> communication of information to other human beings.
> 
> to:
> 
> The language tag is used to identify a language as used by human beings
> for communication of information to other human beings. This includes
> language being spoken, written, signed, or otherwise signaled.
> 
> [I'm not totally happy yet with the second sentence, but I'm happy that
> the parentheses, which were difficult to parse, are gone.]
> 
> Regards,   Martin.
> 
> 
> At 01:42 05/07/14, Addison Phillips wrote:
>  >I think that the following sentiments are a good summary of my position
> as well.
>  >
>  >In response to the particular suggestion of Martin's below, as well as a
>  >previous thread concerning artificial languages and whether those were
>  >excluded and so forth, I would like to propose that we change the text
> at
>  >the start of Section 2 from:
>  >
>  ><q>The language tag always defines a language as used (which includes
> being
>  >spoken, written, signed, or otherwise signaled) by human beings for
>  >communication of information to other human beings. Computer languages
> such
>  >as programming languages are explicitly excluded.</q>
>  >
>  >to read:
>  >
>  ><t>The language tag is used to identify a language as used (which
> includes
>  >being spoken, written, signed, or otherwise signaled) by human beings
> for
>  >communication of information to other human beings. A language of this
> type
>  >is sometimes called a 'natural language', and this includes constructed
> or
>  >artificially designed languages, such as Esperanto. Languages not
> intended
>  >primarily for human communication, such as programming and other
> computer
>  >languages, are explicitly excluded.</t>
>  >
>  >Addison
>  >
>  >Addison P. Phillips
>  >Globalization Architect, Quest Software
>  >Chair, W3C Internationalization Core Working Group
>  >
>  >Internationalization is not a feature.
>  >It is an architecture.
>  >
>  >> -----Original Message-----
>  >> From: [email-masked] [mailto:[email-masked]]
> On
>  >> Behalf Of Martin Duerst
>  >> Sent: 2005?7?13? 3:28
>  >> To: Randy Presuhn; [email-masked]
>  >> Subject: Re: [Ltru] Proposed addition after introduction (was:
> JerseyJE
>  >> andGuernsey GG Country Codes)
>  >>
>  >>
>  >> [with my co-chair hat off]
>  >> I quite a bit agree with the sentiment in some of the text.
>  >> (I have worked on Internationalization of the WWW and the
>  >> Internet for a long time, so I hope this doesn't come as a
>  >> surprise.)
>  >[Addison Phillips]
>  >
>  >Amen.
>  >
>  >However, as an engineer, I think that what counts
>  >> is the actual spec. As a technical project, the only thing
>  >> we can do is to try to produce good technology, and hope
>  >> it gets used the right way. Engineers in general, and the
>  >> IETF in particular, is rather bad at marketing and politics,
>  >> and I think we should stay away from it.
>  >[Addison Phillips]
>  >
>  >+1
>  >>
>  >> The only bit where I'd like a bit more time to check the current
>  >> draft text is JFCs first paragraph. If we are not clear enough
>  >> that the draft and the registry don't define languages, but
>  >> only provide identifiers, then I think may be a problem.
>  >> But if this is the case, then this should be fixed mostly
>  >> by word tweaking, rather than by grandiose declarations.
>  >> As an example, looking at the first sentence of section @,
>  >> it currently starts "The language tag always defines a language...".
>  >> I think this should be changed to say
>  >> "The language tag always identifies a language..."
>  >>
>  >I agree: this text leads away from the intentions of the document and
> from
>  >the spirit of RFC 1766 and RFC 3066 in general.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 14 Jul 2005 01:06:13 -0700

Hi -

As a technical contributor, I could live with either of the proposed versions.
I prefer the second, shorter one, but would not object to the long one.

Randy

----- Original Message ----- 
From: "Addison Phillips" <[email-masked]>
To: "Martin Duerst" <[email-masked]>; "Randy Presuhn" <[email-masked]>; <[email-masked]>
Sent: Thursday, July 14, 2005 12:57 AM
Subject: RE: [Ltru] Introduction change: suggested text

--
The language tag is used to identify a language used for communication by human beings. Such a language may take a variety of forms:
it can be spoken, written, signed, or otherwise signaled; the primary requirement is that it be what is sometimes called a 'natural
language'. That is, it must be a language in the ordinary sense of the word, which can include constructed or artificially designed
languages, such as Esperanto. It excludes languages not intended primarily for human communication, such as programming or computer
languages as well as various notation systems created for specialized purposes and which could not serve as a person's native
tongue.
--

If *that* doesn't slay the Wittgenstein in all of you, then we should probably give up trying to define what a language is so
precisely, allow a certain parsimony to reign, and say far less:

--
The language tag is used to identify a language as may be spoken, written, signed or otherwise signaled and whose primary purpose is
communication between people.
--
...

---

From: Marion Gunn <[email-masked]>
Date: Thu, 14 Jul 2005 09:06:43 +0100

> The language tag is used to identify a language as may be spoken, written, signed or otherwise signaled and whose primary purpose is communication between people.

Perhaps 'The language tag is used to identify WHICH language is being
spoken, written, signed or otherwise signalled for the purpose of
communication.'  

mg
-- 

Marion Gunn * EGTeo (Estab.1991)
27 Páirc an Fhéithlinn, Baile an 
Bhóthair, Co. Átha Cliath, Éire.
* [email-masked] * [email-masked] *

---

From: "Felix Sasaki" <[email-masked]>
Date: Thu, 14 Jul 2005 17:15:34 +0900

Hi -

I would prefer the shorter version, because the long one *does* slay the  
Wittgenstein in me :) And it might let think the linguistics out there  
that we want to make a contribute something to the question what language  
is. I wouldn't dare too ....

-- Felix

On Thu, 14 Jul 2005 17:06:13 +0900, Randy Presuhn  
<[email-masked]> wrote:

> To: "Martin Duerst" <[email-masked]>; "Randy Presuhn"  
> <[email-masked]>; <[email-masked]>
> The language tag is used to identify a language used for communication  
> by human beings. Such a language may take a variety of forms:
> it can be spoken, written, signed, or otherwise signaled; the primary  
> requirement is that it be what is sometimes called a 'natural
> language'. That is, it must be a language in the ordinary sense of the  
> word, which can include constructed or artificially designed
> languages, such as Esperanto. It excludes languages not intended  
> primarily for human communication, such as programming or computer
> languages as well as various notation systems created for specialized  
> purposes and which could not serve as a person's native
> tongue.
> --
>
> If *that* doesn't slay the Wittgenstein in all of you, then we should  
> probably give up trying to define what a language is so
> The language tag is used to identify a language as may be spoken,  
> written, signed or otherwise signaled and whose primary purpose is

---

From: Martin Duerst <[email-masked]>
Date: Thu, 14 Jul 2005 17:23:47 +0900

I like that text.    Regards,   Martin.

At 16:57 05/07/14, Addison Phillips wrote:
 >The language tag is used to identify a language used for communication by
 >human beings. Such a language may take a variety of forms: it can be
 >spoken, written, signed, or otherwise signaled; the primary requirement is
 >that it be what is sometimes called a 'natural language'. That is, it must
 >be a language in the ordinary sense of the word, which can include
 >constructed or artificially designed languages, such as Esperanto. It
 >excludes languages not intended primarily for human communication, such as
 >programming or computer languages as well as various notation systems
 >created for specialized purposes and which could not serve as a person's
 >native tongue.
 >--
 >
 >probably give up trying to define what a language is so precisely, allow a
 >certain parsimony to reign, and say far less:
 >
 >--
 >The language tag is used to identify a language as may be spoken, written,
 >signed or otherwise signaled and whose primary purpose is communication
 >between people.
 >--
 >
 >Addison P. Phillips

---

From: "Jukka K. Korpela" <[email-masked]>
Date: Thu, 14 Jul 2005 14:38:15 +0300 (EEST)

On Thu, 14 Jul 2005, Felix Sasaki wrote:

> Wittgenstein in me :) And it might let think the linguistics out there that 
> we want to make a contribute something to the question what language is. I 
> wouldn't dare too ....

I find both versions acceptable in this context, but I like the longer 
version very much, and I think it would be more useful here.

After all, the definition _needs_ to address the question what language 
is, in order to tell what kind of things may have a language code and 
therefore to exclude things that might be regarded as languages by some.
This is a limited and technical scope and it need not be construed as a 
scientific or philosophical definition or even a definition for "language" 
as a common word - only for "language" as a term used in the context of 
codes for languages.

-- 
Jukka "Yucca" Korpela, http://www.cs.tut.fi/~jkorpela/

---

From: "Felix Sasaki" <[email-masked]>
Date: Thu, 14 Jul 2005 21:21:21 +0900

On Thu, 14 Jul 2005 20:38:15 +0900, Jukka K. Korpela <[email-masked]>  
wrote:

>> I would prefer the shorter version, because the long one *does* slay  
>> the Wittgenstein in me :) And it might let think the linguistics out  
>> there that we want to make a contribute something to the question what  
>> language is. I wouldn't dare too ....
>

I also can life with both versions, but may preference is the other way  
around.

> therefore to exclude things that might be regarded as languages by some.

I agree with the purpose of the defintion: excluding what might be  
regarded as languages. If we use this definition:

--
The language tag is used to identify a language used for communication by  
human
beings. Such a language may take a variety of forms: it can be spoken,  
written,
signed, or otherwise signaled; the primary requirement is that it be what  
is
sometimes called a 'natural language'. That is, it must be a language in  
the ordinary
sense of the word, which can include constructed or artificially designed  
languages,
such as Esperanto. It excludes languages not intended primarily for human
communication, such as programming or computer languages as well as  
various notation
systems created for specialized purposes and which could not serve as a  
person's
native tongue.
--

I just see the danger that with a detailed definition, we encourage to  
include more than we want. A linguist who does not read this carefuly  
might think "Great, this is the tag I waited for for years!" and abuse it  
for
- language which is specific to a context, i.e. a speech situation
- language which is related to a development phase, e.g. first or second  
language acquisition
- language for specific purposes
- formal versus informal languages (closely related to the speech  
situation)
- gender- or sociolinguistic variants
- and so on ...
The problem with these beasts is that it will be hard to find two  
linguists / people who agree on the actual values of the categories. So I  
guess they are not good canidates for a reprosity.

To summarize my idea: keep the definition simple, and you will avoid  
misunderstanding.

-- Felix

> scientific or philosophical definition or even a definition for  
> "language" as a common word - only for "language" as a term used in the  
> context of codes for languages.
>

---

From: Erkki Kolehmainen <[email-masked]>
Date: Thu, 14 Jul 2005 15:53:00 +0300

I apologise for being so late in introducing a new aspect to the game.

However, I think that the statement "The language tag is used to 
identify a language..." is, in fact, somewhat contentious.

I'd rather say something along the following lines: "The language tag is 
used to associate the material at some level of available granularity 
with a language...".

This would make it clear that there's a lot of imperfection in both the 
definition of the language codes &al. and in the use of them.

Erkki I. Kolehmainen

Felix Sasaki wrote:

> On Thu, 14 Jul 2005 20:38:15 +0900, Jukka K. Korpela 
> <[email-masked]>  wrote:
> 
>>> there that we want to make a contribute something to the question 
>>> what  language is. I wouldn't dare too ....
>>
>>
>> I find both versions acceptable in this context, but I like the 
>> longer  version very much, and I think it would be more useful here.
> 
> 
> 
>> After all, the definition _needs_ to address the question what 
>> language  is, in order to tell what kind of things may have a language 
>> code and  therefore to exclude things that might be regarded as 
>> languages by some.
> 
> 
> by  human
> signed, or otherwise signaled; the primary requirement is that it be 
> what  is
> sometimes called a 'natural language'. That is, it must be a language 
> in  the ordinary
> sense of the word, which can include constructed or artificially 
> designed  languages,
> might think "Great, this is the tag I waited for for years!" and abuse 
> it  for
> - language which is related to a development phase, e.g. first or 
> second  language acquisition
> linguists / people who agree on the actual values of the categories. So 
> I  guess they are not good canidates for a reprosity.
> 
>> This is a limited and technical scope and it need not be construed as 
>> a  scientific or philosophical definition or even a definition for  
>> "language" as a common word - only for "language" as a term used in 
>> the  context of codes for languages.
>>
> 
> 
>

---

From: "Felix Sasaki" <[email-masked]>
Date: Thu, 14 Jul 2005 22:01:38 +0900

As I said before: I would keep the definitions in this area simple to  
avoid misunderstanding, but I could also live with the longer version from  
Addison. And I think, both Erkki and me are aiming at the same goal, only  
with different methods.

-- Felix

On Thu, 14 Jul 2005 21:53:00 +0900, Erkki Kolehmainen  
<[email-masked]> wrote:

>>    I also can life with both versions, but may preference is the other  
>> way  around.
>>
>>>
>>  -- The language tag is used to identify a language used for  
>> communication by  human
>> systems created for specialized purposes and which could not serve as  
>> a  person's
>> native tongue.
>> --  I just see the danger that with a detailed definition, we encourage  
>> to  include more than we want. A linguist who does not read this  
>> carefuly  might think "Great, this is the tag I waited for for years!"  
>> and abuse it  for

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 14 Jul 2005 14:06:20 +0100

How about:

"The language tag is used to identify a linguistic entity to the level of
granularity either required or available."

Regards

Debbie

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Erkki Kolehmainen
> Sent: 14 July 2005 13:53
> To: Felix Sasaki
> Cc: [email-masked]
> Subject: Re: [Ltru] Introduction change: suggested text
>

---

From: r&d afrac <[email-masked]>
Date: Thu, 14 Jul 2005 14:35:52 +0200

>spoken, written, signed or otherwise signalled for the purpose of

Purchased.
Except that I would write "to help indentifying" which language".
jfc

---

From: r&d afrac <[email-masked]>
Date: Thu, 14 Jul 2005 14:34:53 +0200

>is. I wouldn't dare too ....

We are IETF here. We are not interested in what linguists are interested 
in: we trust they know their job. Our role is their networking aspects.
jfc

---

From: Marion Gunn <[email-masked]>
Date: Thu, 14 Jul 2005 14:41:47 +0100

Yes. Thanks. 

'The language tag is used to HELP identify WHICH language is being
spoken, written, signed or otherwise signalled for the purpose of
communication.' 

(ALLCAPS to be lowercased, obviously.)
mg

--

---

From: Marion Gunn <[email-masked]>
Date: Thu, 14 Jul 2005 14:44:18 +0100

Way too wordy for most (tired) users, techie or otherwise.:-)
mg

--

---

From: r&d afrac <[email-masked]>
Date: Thu, 14 Jul 2005 18:56:01 +0200

At 15:41 14/07/2005, Marion Gunn wrote:
>'The language tag is used to help identify which language is being

+1
jfc

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 15 Jul 2005 12:32:09 +0200

r&d afrac wrote:

  [Marion Gunn wrote:]
>> 'The language tag is used to help identify which language is
>> being spoken, written, signed or otherwise signalled for the
>> purpose of communication.'

Okay, let's take the added "help".  After Addison mentioned
Wittgenstein I checked some quotes of Whorf, and the "help"
aspect is important (e.g. "en" as written by lawyers is
unrelated to "en" as spoken on any -001 or Klingon street).

                     Bye, Frank

---

From: Erkki Kolehmainen <[email-masked]>
Date: Fri, 15 Jul 2005 14:11:04 +0300

Fine by me!

Erkki I. Kolehmainen

---

From: "Felix Sasaki" <[email-masked]>
Date: Fri, 15 Jul 2005 21:34:55 +0900

+1

-- Felix
On Fri, 15 Jul 2005 20:11:04 +0900, Erkki Kolehmainen