Subject: RE: [Ltru] Last call: IANA adaptation of the UN disclaimer

From: "Addison Phillips" <[email-masked]>
Date: Sat, 16 Jul 2005 08:55:59 -0700

Might I suggest:

I think that including a giant piece of policy on behalf of IETF, ICANN, and IANA is probably inappropriate. However, I *can* see draft-registry making the statement that the registration process does not endorse any particular position and that registrations will be considered on an equal basis. The resulting text would be more useful. Perhaps:

<q>Registration requests are each considered on their own merits, based on the need to identify a language. The presence, absence or contents of any particular subtag and its associated fields in the registry do not imply a position on the legal status of any language, script, country, territory, region, or language variation. Nor do they endorse any particular position regarding the legal status, authority, frontiers, boundaries, or policies of any particular country or region. This includes any issues pertaining to the identity or usage of any language or script within any country or region.</q>

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Martin Duerst
> Sent: 2005?7?16? 5:10
> To: Randy Presuhn; [email-masked]
> Subject: Re: [Ltru] Last call: IANA adaptation of the UN disclaimer
> 
> [chair hat off]
> 
> I have to agree with Randy. Besides his arguments, I'd also
> like to mention that neither RFC 1766 nor RFC 3066 had any
> such disclaimer. Also, I'm affraid that if somebody with a
> traditional IETF background finds this paragraph, we might
> get some serious IETF Last Call comments.
> 
> Also, if (as JFC thinks) this is something for the IANA/
> ICANN/watever lawyers, then it's best if we keep out of it.
> If asked for, we can point to the various text proposals in
> the mailing list archive.
> 
> Regards,    Martin.
> 
> At 05:55 05/07/16, Randy Presuhn wrote:
>  >Hi -
>  >
>  >> From: "Addison Phillips" <[email-masked]>
>  >> To: "Peter Constable" <[email-masked]>; <[email-masked]>
>  >> Sent: Friday, July 15, 2005 11:29 AM
>  >> Subject: RE: [Ltru] Last call: IANA adaptation of the UN disclaimer
>  >>
>  >> The purpose and point of this text I agree with, but the form of the
> text
>  >> is not in keeping with the terminology or form of the rest of the
> document.
>  >> It is nearly incomprehensible.
>  >>
>  >> How about replacing your second paragraph with:
>  >>
>  >> <q>The presence, absence or contents of subtags and their associated
> fields
>  >> in the registry do not and should not be taken to imply an opinion on
> the
>  >part of
>  >> the IETF, ICANN and IANA concerning the legal status of any language,
> script,
>  >> country, territory, region, or language variation. Nor should they be
> taken to
>  >> endorse any particular position regarding the legal status, authority,
>  >frontiers,
>  >> boundaries, or cultural, political, economical, or educational
> policies of any
>  >> particular country or region. This includes any issues pertaining to
> the
>  >identity
>  >> or usage of any language or script within any country or region.</q>
>  >...
>  >
>  >As a technical contributor, I think there adding this text contributes
> no value
>  >to the document, and could in the longer term be harmful, regardless of
>  >its benign intent and content.
>  >
>  >None of the other IANA registries I've looked at has anything like this.
>  >As a very concrete example, the enterprise number registry  at
>  >http://www.iana.org/assignments/enterprise-numbers doesn't have
>  >lawerly verbiage about trademarks or the legal status of enterprise
> names.
>  >Similarly, http://www.iana.org/assignments/ianaaddressfamilynumbers-mib
>  >doesn't fret about trademarks.  Not even
> http://www.iana.org/assignments/idn/
>  >goes through such hand-wringing.  I think adding material like this
> would
>  >set a very bad precedent, because it could lead to folks misconstruing
>  >the absence of such disclaimers in other IANA-maintained registries.
>  >
>  >Randy
>  >
>  >
>  >
>  >
>  >_______________________________________________
>  >Ltru mailing list
>  >[email-masked]
>  >https://www1.ietf.org/mailman/listinfo/ltru
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 16 Jul 2005 12:10:09 -0700

Hi -

As a technical contributor...

> To: "Martin Duerst" <[email-masked]>; "Randy Presuhn" <[email-masked]>; <[email-masked]>
> Sent: Saturday, July 16, 2005 8:55 AM
...
> I think that including a giant piece of policy on behalf of IETF, ICANN, and
> IANA is probably inappropriate. However, I *can* see draft-registry making
> the statement that the registration process does not endorse any particular
> position and that registrations will be considered on an equal basis. The
> resulting text would be more useful. Perhaps:
>
> <q>Registration requests are each considered on their own merits, based
> on the need to identify a language.

This I could live with, though as instruction for the conduct of the review process,
"are" probably should be "are to be"

> The presence, absence or contents of any particular subtag and its associated
> fields in the registry do not imply a position on the legal status of any language,
> script, country, territory, region, or language variation. Nor do they endorse any
> particular position regarding the legal status, authority, frontiers, boundaries,
> or policies of any particular country or region. This includes any issues pertaining
> to the identity or usage of any language or script within any country or region.</q>
...

The last sentence bothers me a lot, since it can be construed as being at odds with
the very first sentence of the proposed paragraph.  If it were eliminated, I'd put up
with the rest if there were overwhelming support by the rest of the WG, though I
*really* don't like the idea of putting this kind of stuff into our documents.  We don't
do this for other registries, even in such highly competitive areas as network
management (where I spend most of my time).  This kind of material is the edge of
the slippery slope of endless additions on things that sound nice but really make
no technical difference whatsoever.

Randy

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 17 Jul 2005 03:17:03 +0200

Addison Phillips wrote:
 
> I think that including a giant piece of policy on behalf of
> IETF, ICANN, and IANA is probably inappropriate.

s/probably/certainly/ for ICANN and IANA.  The "giant piece of
policy on behalf of IETF" has about 3100 lines and 130 KB, it
is your draft -09.

> <q>Registration requests are each considered on their own
> merits, based on the need to identify a language. The
> presence, absence or contents of any particular subtag and
> its associated fields in the registry do not imply a position
> on the legal status of any language, script, country,
> territory, region, or language variation. Nor do they endorse
> any particular position regarding the legal status,
> authority, frontiers, boundaries, or policies of any
> particular country or region.

That's horrible EULA language, I prefer to delete the complete 
draft and close the WG without results.  The BCP 78 / 79 legal
boilerplates are already excessively annoying, imitating this
style voluntarily is FUBAR.
                               Bye, Frank

---

From: Martin Duerst <[email-masked]>
Date: Sun, 17 Jul 2005 11:27:29 +0900

I guess I could live with that (I very much agree with the sentiment,
but I think it's much more actual practice, past, present, and future,
than nice words, that will be judged).

Regards,   Martin.

At 00:55 05/07/17, Addison Phillips wrote:
 >Might I suggest:
 >
 >I think that including a giant piece of policy on behalf of IETF, ICANN,
 >and IANA is probably inappropriate. However, I *can* see draft-registry
 >making the statement that the registration process does not endorse any
 >particular position and that registrations will be considered on an equal
 >basis. The resulting text would be more useful. Perhaps:
 >
 >
 ><q>Registration requests are each considered on their own merits, based on
 >the need to identify a language. The presence, absence or contents of any
 >particular subtag and its associated fields in the registry do not imply a
 >position on the legal status of any language, script, country, territory,
 >region, or language variation. Nor do they endorse any particular position
 >regarding the legal status, authority, frontiers, boundaries, or policies
 >of any particular country or region. This includes any issues pertaining to
 >the identity or usage of any language or script within any country or 
region.</q>

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 16 Jul 2005 22:52:32 -0700

Hi -

As a contributor...

> From: "Frank Ellermann" <[email-masked]>
> To: <[email-masked]>
> Sent: Saturday, July 16, 2005 6:17 PM
> Subject: [Ltru] Re: Last call: IANA adaptation of the UN disclaimer
...
...

Would you be able to accept it if reduced to this?
  <q>Registration requests are to be considered on their own
  merits, based on the need to identify a language.</q>

Or would you be happier with no addition at all in resolution of this issue?

I am concerned that adding all that other stuff, and perhaps even such
a benign-sounding sentence as the above, runs the risk of making the
review process more subject to frivolous appeal or DoS attacks,
especially since there was no consensus to accept issue #1039.

I'm coming to prefer no addition at all. I could live with the single-
sentence statement above, if that will bring us to a rough consensus.
I dislike the longer one quoted above, though not as intensely as
the original proposal.

Randy

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 17 Jul 2005 09:08:16 +0200

>   merits, based on the need to identify a language.</q>

That's fine... 
 
> Or would you be happier with no addition at all in resolution

...better.  Anything that doesn't sound like an EULA or the
legal boilerplate.  There should be some room for judgement
calls by the language list and the language tag reviewer.

> I'm coming to prefer no addition at all. I could live with
> the single-sentence statement above, if that will bring us
> to a rough consensus.

Same here.  Bye, Frank

---

From: r&d afrac <[email-masked]>
Date: Sun, 17 Jul 2005 13:34:21 +0200

Randy,
the point I try to make is that this Draft should be judged on its on 
technical merits at the IETF Last Call and during the legal round. This 
means that it should show it has also taken into account its heavily 
politically loaded character. To do that it is to include appropriate legal 
language, copyright mentions and political disclaimers.

My propositions are to permit the Draft not to be rejected in block (again 
I only disagree on "replace/complement" RFC 3066). May be I have not been 
clear enough. My proposition is not to introduce final texts, but to 
introduce texts at appropriate places with the appropriate concerns and 
then to leave to the appropriate reviewers the care to craft the final 
appropriate wording.
.
The Draft is intended to be published, so this wording cannot be in the 
IANA section only. May be a simple solution would be to enter mentions to 
the Editors (who ever they will be at whatever technical, legal, political 
level) under the form "[the WG thinks there might be a text needed here to 
possibly address the following concerns by the IETF liaison with, the IASA 
lawyers, the IANA lawyers, ICANN, GAC]".

jfc.

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 18 Jul 2005 16:58:06 -0700

Hi -

> From: "r&d afrac" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; <[email-masked]>
> Sent: Sunday, July 17, 2005 4:34 AM
> Subject: Re: [Ltru] [psg.com #1073] Last call: IANA adaptation of the UN disclaimer
>
> Randy,
...

That's not how the process works.  What a working group hands to the IESG
is what that working group would like to see published as an RFC, with only
those formatting changes needed to account for the difference between
i-d and RFC formats.  Routinely, references will be updated and typos fixed.
The IESG may "DISCUSS" the document with the WG, which may result
in subsequent edits, as may the IETF last call.  If necessary, an updated
i-d will be handed to the RFC editor.  When publication time arrives, there is
the AUTH48 period during which the RFC editor verifies with the document's
editor that nothing has been broken by formatting changes, etc.  Documents'
editors rarely change during this entire process.

Randy