Subject: RE: [ltru] Initial language registry draft

From: "Addison Phillips" <[email-masked]>
Date: Mon, 11 Jul 2005 14:29:06 -0700

This is what the registration process exists for.

For the initial registry, IMO, we should stick to *exactly* what the underlying standard has. Cleanup such as breaking lists of names up into separate items (Low Saxon and friends, for example) is fine, but other changes should be avoided.

If controversy exists, let it play out using the established process of registration. Controversial or potentially controversial items should not be incorporated by the actions of this WG. It is the whole point of having a registration process to allow this kind of issue a way to surface and be resolved. Protracted discussion of all the potential subtag synonyms is a waste of time for this process.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: 2005?7?11? 14:12
> To: [email-masked]
> Subject: [ltru] Initial language registry draft
> 
> See issue below...  forwarded to the list for comment.
> 
> The registration of language name synonyms would definitely be useful to
> me when I reference the RFC 3066 work. Persian/Farsi, Bangla/Bengali,
> Irish/Gaelic/Scots Gaelic, and Catalan/Valencian cause a lot of headaches
> on the language lists I review.
> 
> I do realize synonym registration could be controversial. For my purposes,
> Catalan, Balear, and Valencian are synonyms, but I'm sure there's a
> linguist out there who would disagree. I think Ethnologue and SIL are
> working on language synonyms. Could these synonyms be incorporated for the
> languages found in 639-1 and 2? Do you have any thoughts on this Peter?
> 
> Karen Broome
> Metadata Systems Designer
> Sony Pictures Entertainment
> 
> 
> 
> 
> "Doug Ewell" <[email-masked]>
> 07/09/2005 12:31 AM
> 
> 
>         To:     <[email-masked]>
>         cc:
>         Subject:        Re: [Ltru] Re: I-D ACTION:draft-ietf-ltru-initial-
> 01.txt
> 
> 
> Hi Karen,
> 
> > Are you looking for comments on your draft of the registry entries? I
> > think I may have a few additions based on some of my research, though
> > this is my first look at this doc and I don't have much background on
> > it.
> >
> > For example: Would it be appropriate to add "Bangla" as a description
> > under the "Bengali" entry?
> >
> > I see these as two separate entries on a lot of the lists I've
> > reviewed.
> 
> This is a good question.  I copied the descriptions directly from the
> relevant ISO and UN standards as much as possible.  This was to avoid
> charges of bias or personal whimsy.  For example, for the region subtag
> KP, I dutifully used the ISO 3166 description "Korea, Democratic
> People's Republic of" even though I, and probably you and everyone else
> either of us knows, would call this country "North Korea."
> 
> Because the official ISO 639-2 code list did not include the name
> "Bangla" along with "Bengali," I did not include it.
> 
> That said, it is true that the name "Bangla" is also common,
> particularly among native speakers when writing in English and referring
> to their language.  It might be reasonable to entertain requests for
> additional description fields in the initial registry, but if you want
> to pursue that, I think we should move this question onto the WG list.
> It's their registry, after all, not just mine.  :-)  Remember that
> additional descriptions can always be proposed for registration (Section
> 3.3, item 2) and that description are not normative in any case.
> 
> Thanks for the feedback.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: [email-masked]
Date: Mon, 11 Jul 2005 14:43:59 -0700

I think we basically agree. I think registering *some* common troublesome 
synonyms would be useful, but I think it should be done with the same sort 
of oversight and review as found in the language name/code process. I was 
just wondering if Ethnologue had already "validated" some synonyms.

This is certainly not a time-critical issue for me (or you). But it would 
be useful to me, so I figure this might be useful to others. It seemed 
like synonyms were listed for some languages and not others and I wasn't 
sure why so I asked Doug privately about "Bangla". I don't think I 
suggested a protracted discussion of all language synonyms. Ouch!

Karen Broome
310.244.4384

"Addison Phillips" <[email-masked]>
07/11/2005 02:29 PM

        To:     <[email-masked]>, <[email-masked]>
        cc: 
        Subject:        RE: [ltru] Initial language registry draft

For the initial registry, IMO, we should stick to *exactly* what the 
underlying standard has. Cleanup such as breaking lists of names up into 
separate items (Low Saxon and friends, for example) is fine, but other 
changes should be avoided.

If controversy exists, let it play out using the established process of 
registration. Controversial or potentially controversial items should not 
be incorporated by the actions of this WG. It is the whole point of having 
a registration process to allow this kind of issue a way to surface and be 
resolved. Protracted discussion of all the potential subtag synonyms is a 
waste of time for this process.

Addison

Addison P. Phillips

---

From: "Peter Constable" <[email-masked]>
Date: Mon, 11 Jul 2005 16:01:23 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]

> languages found in 639-1 and 2? Do you have any thoughts on this Peter?

I think there are several cases in which it would be useful to include alternate names for a given language in the registry. (By that, I don't me names in additional languages.) Ethnologue tries to document alternates. (There is room for some improvement; e.g. I think it could do a little better job at how it tracks names used in different countries, and it could perhaps distinguish truly alternate names from mere alternate spellings‎.) ISO 639 also does this to some extent (it is possible to add alternate names where not already listed). 

For purposes of this registry, I think the initial registry should stick with what is published in ISO 639-1/-2, and that any additions people may desire should be handled by the ietf-languages registration process.

Peter Constable