Subject: RE: [Ltru] Reference lists; AND ABNF GRAMMARS

From: "Addison Phillips" <[email-masked]>
Date: Tue, 19 Jul 2005 16:09:50 -0700

We could do it like that. In some ways it is certainly more beautiful. I note a couple of things in your suggestions:

1. 2*4ALPHA / 4*8ALPHA isn't really wrong, but the repetition of the number 4 is confusing. It should be 2*4ALPHA/5*8ALPHA. (I'm aware that the original draft-09 grammar has this mistake in it: it is on my correction list for the next edit)

2. It should be noted that 4ALPHA language subtags are reserved, ostensibly for ISO 639-6. Extlangs are reserved, ostensibly for ISO 639-3 language codes that have macrolanguages. Under the current grammar, extlangs will never be legal except with 2*3ALPHA values in the first position and this is by design. (Note that extlangs are required to have a Prefix field in the registry which specifies the primary language subtag that they MUST be used with, even though the contents are not yet specified.)

With your revision, the ABNF would permit subtags other than ISO 639-1 or ISO 639-2/-3 from serving as the base subtag for an extended language subtag (of course the text could still forbid it).

The matching grammar is more elegant in your version. I am inclined to make these edits, provided there is general agreement that:

a) they don't represent a substantive change
b) that we want to make them

Other voices?

Best Regards,

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Kent Karlsson [mailto:[email-masked]]
> Sent: 2005?7?19? 15:51
> To: Addison Phillips
> Cc: LTRU Working Group
> Subject: RE: [Ltru] Reference lists; AND ABNF GRAMMARS
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 20 Jul 2005 01:44:28 +0200

Addison Phillips wrote:
 
> 1. 2*4ALPHA / 4*8ALPHA isn't really wrong

IBTD

> the repetition of the number 4 is confusing

ACK

> It should be 2*4ALPHA/5*8ALPHA.

No idea how that escaped us in -03..-09, that's seven drafts
with the same bug in the ABNF.  Obviously I didn't check it
after http://mid.gmane.org/[email-masked] :-(

                         Bye, Frank

---

From: "Kent Karlsson" <[email-masked]>
Date: Wed, 20 Jul 2005 07:08:43 +0200 (CEST)

> 1. 2*4ALPHA / 4*8ALPHA isn't really wrong, but the repetition of the
...

Ok. I thought it was an intentional overlap.

> 2. It should be noted that 4ALPHA language subtags are reserved,
...
> extlangs will never be legal except with 2*3ALPHA values in the first
...
> With your revision, the ABNF would permit subtags other than ISO 639-1 or
> ISO 639-2/-3 from serving as the base subtag for an extended language
> subtag (of course the text could still forbid it).

You mean it should be (putting this restriction in the grammar):

%% For -registry
extlang         = (2*3ALPHA
                   1*3("-" 3ALPHA)   ; reserved for future use

%% for -matching
extlang         = (2*3ALPHA
                   *2("-" 3ALPHA)
                   ("-"(3ALPHA / "*")))
                                     ; reserved for future use

(or with some non-terminal for 2*3ALPHA and maybe also for 3ALPHA)

     /kent k