Subject: [Ltru] Re: Introduction change: suggested text

From: Frank Ellermann <[email-masked]>
Date: Thu, 14 Jul 2005 02:47:37 +0200

Addison Phillips proposed:

| The language tag is used to identify a language as used
| (which includes being spoken, written, signed, or otherwise
| signaled) by human beings for communication of information to
| other human beings. A language of this type is sometimes
| called a 'natural language', and this includes constructed or
| artificially designed languages, such as Esperanto. Languages
| not intended primarily for human communication, such as
| programming and other computer languages, are explicitly
| excluded.

(= result after s/define/identify/ and some beautifications)

                FWIW, I like it, bye, Frank

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Misha Wolf <[email-masked]>
Date: Thu, 14 Jul 2005 14:07:32 +0100

I suggest that we declare victory and go home.

Misha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Erkki Kolehmainen
Sent: 14 July 2005 13:53
To: Felix Sasaki
Cc: [email-masked]
Subject: Re: [Ltru] Introduction change: suggested text

I apologise for being so late in introducing a new aspect to the game.

[...]

-----------------------------------------------------------------
        Visit our Internet site at http://www.reuters.com

To find out more about Reuters Products and Services visit http://www.reuters.com/productinfo 

Any views expressed in this message are those of  the  individual
sender,  except  where  the sender specifically states them to be
the views of Reuters Ltd.

---

From: "Peter Constable" <[email-masked]>
Date: Thu, 14 Jul 2005 06:34:55 -0700

> From: [email-masked] [mailto:[email-masked]]
On
> Behalf Of Jukka K. Korpela

> Well, my argument is indeed based on such things, but it did not mean
> classifying each speech act as a separate language. Instead, what I
wrote
> was about defining language as something used for communication, not
just
> communication of information.

I like the suggested change, but not for the reasons you give. I think
it's rather a stretch to suggest that "communication of information"
implies a particular speech act. *All* communication has information
content, regardless of speech act type. If the wording has said "for
making declarations", then your reasons would apply; but it does not say
that.

Peter Constable

---

From: "Peter Constable" <[email-masked]>
Date: Thu, 14 Jul 2005 06:53:31 -0700

On
> Behalf Of Misha Wolf
> Sent: Thursday, July 14, 2005 6:08 AM
> To: [email-masked]
> Subject: RE: [Ltru] Introduction change: suggested text
> 

I agree. Word-smithing by committee can always continue to fill whatever
time is available, and I don't think we're making any really significant
changes. Rather, we're examining a level of subtlety in our readings of
the text that will not be noticed by readers in general. 

If we make it clear that programming languages are excluded, I doubt the
registration process will have difficulty rejecting a tag that treated
bridge signaling and terminology as a separate language. (Last I knew,
"three spades", "ruff" etc. were English expressions.)

Peter Constable

---

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 14 Jul 2005 08:50:39 -0700

Hi,

Frankly, I don't care if the linguists dislike or disagree with our
definition.  Our definition is for use only with the IANA Language
Subtag Registry.

And I much prefer the long version because it makes that restriction
much clearer to the non-linguists (I think).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Addison Phillips
> Sent: Thursday, July 14, 2005 3:57 AM
> To: Martin Duerst; Randy Presuhn; [email-masked]
> Okay, we're far out in the weeds now. How about:
> 
> --
> The language tag is used to identify a language used for 
> communication by human beings. Such a language may take a 
> variety of forms: it can be spoken, written, signed, or 
> otherwise signaled; the primary requirement is that it be 
> what is sometimes called a 'natural language'. That is, it 
> must be a language in the ordinary sense of the word, which 
> can include constructed or artificially designed languages, 
> such as Esperanto. It excludes languages not intended 
> primarily for human communication, such as programming or 
> computer languages as well as various notation systems 
> created for specialized purposes and which could not serve as 
> a person's native tongue.
> --
> 
> If *that* doesn't slay the Wittgenstein in all of you, then 
> we should probably give up trying to define what a language 
> is so precisely, allow a certain parsimony to reign, and say far less:
> 
> --
> The language tag is used to identify a language as may be 
> spoken, written, signed or otherwise signaled and whose 
> primary purpose is communication between people.
> --
> 
> Addison P. Phillips
> Globalization Architect, Quest Software
> Chair, W3C Internationalization Core Working Group
> 
> Internationalization is not a feature.
> It is an architecture. 
> > From: Martin Duerst [mailto:[email-masked]]
> > Sent: 2005?7?13? 18:37
> > To: Addison Phillips; Randy Presuhn; [email-masked]
> > While we are at it, I propose that we change:
> > 
> > The language tag is used to identify a language as used 
> (which includes
> > being spoken, written, signed, or otherwise signaled) by 
> human beings for
> > communication of information to other human beings.
> > 
> > to:
> > 
> > The language tag is used to identify a language as used by 
> human beings
> > for communication of information to other human beings. 
> This includes
> > language being spoken, written, signed, or otherwise signaled.
> > 
> > [I'm not totally happy yet with the second sentence, but 
> I'm happy that
> > the parentheses, which were difficult to parse, are gone.]
> > 
> > Regards,   Martin.
> > 
> > 
> > At 01:42 05/07/14, Addison Phillips wrote:
> >  >I think that the following sentiments are a good summary 
> of my position
> > as well.
> >  >
> >  >In response to the particular suggestion of Martin's 
> below, as well as a
> >  >previous thread concerning artificial languages and 
> whether those were
> >  >excluded and so forth, I would like to propose that we 
> change the text
> > at
> >  >the start of Section 2 from:
> >  >
> >  ><q>The language tag always defines a language as used 
> (which includes
> > being
> >  >spoken, written, signed, or otherwise signaled) by human 
> beings for
> >  >communication of information to other human beings. 
> Computer languages
> > such
> >  >as programming languages are explicitly excluded.</q>
> >  >
> >  >to read:
> >  >
> >  ><t>The language tag is used to identify a language as used (which
> > includes
> >  >being spoken, written, signed, or otherwise signaled) by 
> human beings
> > for
> >  >communication of information to other human beings. A 
> language of this
> > type
> >  >is sometimes called a 'natural language', and this 
> includes constructed
> > or
> >  >artificially designed languages, such as Esperanto. Languages not
> > intended
> >  >primarily for human communication, such as programming and other
> > computer
> >  >languages, are explicitly excluded.</t>
> >  >
> >  >Addison
> >  >
> >  >Addison P. Phillips
> >  >Globalization Architect, Quest Software
> >  >Chair, W3C Internationalization Core Working Group
> >  >
> >  >Internationalization is not a feature.
> >  >It is an architecture.
> >  >
> >  >> Behalf Of Martin Duerst
> >  >> Sent: 2005?7?13? 3:28
> >  >> To: Randy Presuhn; [email-masked]
> >  >> Subject: Re: [Ltru] Proposed addition after introduction (was:
> > JerseyJE
> >  >> andGuernsey GG Country Codes)
> >  >>
> >  >>
> >  >> [with my co-chair hat off]
> >  >> I quite a bit agree with the sentiment in some of the text.
> >  >> (I have worked on Internationalization of the WWW and the
> >  >> Internet for a long time, so I hope this doesn't come as a
> >  >> surprise.)
> >  >[Addison Phillips]
> >  >
> >  >Amen.
> >  >
> >  >However, as an engineer, I think that what counts
> >  >> is the actual spec. As a technical project, the only thing
> >  >> we can do is to try to produce good technology, and hope
> >  >> it gets used the right way. Engineers in general, and the
> >  >> IETF in particular, is rather bad at marketing and politics,
> >  >> and I think we should stay away from it.
> >  >[Addison Phillips]
> >  >
> >  >+1
> >  >>
> >  >> The only bit where I'd like a bit more time to check the current
> >  >> draft text is JFCs first paragraph. If we are not clear enough
> >  >> that the draft and the registry don't define languages, but
> >  >> only provide identifiers, then I think may be a problem.
> >  >> But if this is the case, then this should be fixed mostly
> >  >> by word tweaking, rather than by grandiose declarations.
> >  >> As an example, looking at the first sentence of section @,
> >  >> it currently starts "The language tag always defines a 
> language...".
> >  >> I think this should be changed to say
> >  >> "The language tag always identifies a language..."
> >  >>
> >  >I agree: this text leads away from the intentions of the 
> document and
> > from
> >  >the spirit of RFC 1766 and RFC 3066 in general.
> 
> 
>

---

From: [email-masked]
Date: Thu, 14 Jul 2005 13:52:28 -0700

I think the "native tongue" text could be perceived to preclude languages 
such as Esperanto, Latin American Spanish, and (forgive me for mentioning 
it, but ISO recognizes it) Klingon. 

Karen Broome
Metadata Systems Designer
Sony Pictures Entertainment
310.244.4384

"Addison Phillips" <[email-masked]>
Sent by: [email-masked]
07/14/2005 12:57 AM

        To:     "Martin Duerst" <[email-masked]>, "Randy Presuhn" 
<[email-masked]>, <[email-masked]>
        cc: 
        Subject:        RE: [Ltru] Introduction change: suggested text

--
The language tag is used to identify a language used for communication by 
human beings. Such a language may take a variety of forms: it can be 
spoken, written, signed, or otherwise signaled; the primary requirement is 
that it be what is sometimes called a 'natural language'. That is, it must 
be a language in the ordinary sense of the word, which can include 
constructed or artificially designed languages, such as Esperanto. It 
excludes languages not intended primarily for human communication, such as 
programming or computer languages as well as various notation systems 
created for specialized purposes and which could not serve as a person's 
native tongue.
--

If *that* doesn't slay the Wittgenstein in all of you, then we should 
probably give up trying to define what a language is so precisely, allow a 
certain parsimony to reign, and say far less:

--
The language tag is used to identify a language as may be spoken, written, 
signed or otherwise signaled and whose primary purpose is communication 
between people.
--

Addison P. Phillips

> The language tag is used to identify a language as used (which includes
> being spoken, written, signed, or otherwise signaled) by human beings 
for
> The language tag is used to identify a language as used by human beings
> for communication of information to other human beings. This includes
> [I'm not totally happy yet with the second sentence, but I'm happy that
>  >I think that the following sentiments are a good summary of my 
position
> as well.
>  >
>  >In response to the particular suggestion of Martin's below, as well as 
a
>  >previous thread concerning artificial languages and whether those were
>  >excluded and so forth, I would like to propose that we change the text
> at
>  ><q>The language tag always defines a language as used (which includes
> being
>  >spoken, written, signed, or otherwise signaled) by human beings for
>  >communication of information to other human beings. Computer languages
> such
>  >being spoken, written, signed, or otherwise signaled) by human beings
> for
>  >communication of information to other human beings. A language of this
> type
>  >is sometimes called a 'natural language', and this includes 
constructed
>  >> From: [email-masked] 
[mailto:[email-masked]]
>  >> it currently starts "The language tag always defines a language...".
>  >I agree: this text leads away from the intentions of the document and
> from