Subject: [Ltru] Re: ABNF beautification...

From: "Doug Ewell" <[email-masked]>
Date: Tue, 26 Jul 2005 19:26:15 -0700

Mark Davis <mark dot davis at icu dash project dot org> wrote:

> Between the first subtag and the first E:
> - AAAA is always a script
> - AAA is always an extlang
> - AA or DDD is always a region
> - AEEEE..AEEEEEEE, and DEEE..DEEEEEEE is always a variant
> - others are errors: DD, and EE, EEE, AEEE if mixed (one E is an A and
> one is a D)

AEEE is also an error if all the E's are D's.

Mark's explanation was excellent and should demonstrate that parsing
these tags is not rocket science, even after extlangs and extensions are
factored in.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 26 Jul 2005 19:38:40 -0700

Thanks for catching that. I should have said "(one character is an A and one
is a D)"

‎Mark