Subject: RE: [Ltru] Re: Editorial nits

From: "Addison Phillips" <[email-masked]>
Date: Fri, 29 Jul 2005 09:42:11 -0700

> >> field-name = ALPHA [ *(ALPHA / DIGIT / "-") (ALPHA / DIGIT)]
> [...]
> > Your ABNF isn't strictly accurate, since it requires that
> > field names be at least two characters long
> 
> The square brackets [...] mean optional, zero or one.

Duh... you're right. That change will go in this morning.

> > But Unicode and ISO/IEC 10646 will never define scalar
> > values > 0x10FFFF.
> 
> That's what they say today, some years ago it was 31 bits,

I stand by the original statement: there will never be characters > 0x10FFFF in Unicode or ISO/IEC 10646. Although technically we could allow NCRs with an arbitrary number of preceding zeroes, in practice we want the registry to either use fixed length strings or shortest-form strings. 

You are correct that the source (XML 1.0 3e) is silent about the subject. I suppose we could enshrine restrictions in the text of the draft ("the encoded value MUST take the shortest possible form"), but the single normative "MAY" I included should get us close enough. If someone registers something that includes "&#x0300;" it won't be the end of the world.....

> Yes, sorry, I missed that, in another spec. it's different:
> 
> | [US-ASCII]
> |            American National Standards Institute (formerly United
> |            States of America Standards Institute), "USA Code for
> |            Information Interchange, X3.4", 1968.

Yes, I could have cited the ANSI definition. However, we had to create a reference for US-ASCII for CharMod not long ago and citing ISO 646 worked out to be the best approach there... hence I knew exactly where to get the reference for this document.

Best Regards,

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 29 Jul 2005 22:06:44 +0200

Addison Phillips wrote:

> there will never be characters > 0x10FFFF in Unicode

Let's discuss this after we can communicate with those
aliens and see their giant code book.

So that's that, no chance for a real last call in the
next week.  Scott, we're ready, beam it up... :-)  Bye.