Subject: RE: [Ltru] Referencing the Scheme within the Tag

From: "Addison Phillips" <[email-masked]>
Date: Mon, 4 Jul 2005 09:10:59 -0700

Okay, here's the main problem: we can't put a notation where you want it and have valid ABNF. "Language-Tag" is not just some string. It is an identifier.

Secondly, the whole document should be referenced, not just the ABNF (which will rarely be referenced). RFC numbers are not reused: it is their sole advantage. Referencing RFC3066bis is a permanent way to say which scheme you are using and will remain a useful reference even when there is a "3066ter".

Finally, there is a section in the document (2.2.9) that defines conformance. This proposal belongs in that section.

I'm not opposed to this minor adjustment, but I don't think it is practical.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Marion Gunn
> Sent: den 4 juli 2005 01:19
> Cc: [email-masked]
> Subject: Re: [Ltru] Referencing the Scheme within the Tag
> 
> Echoing DG's question (below). I see only advantage in her proposal.
> mg
> 
> Scríobh Debbie Garside:
> > ...
> > > Okay, I see what you're saying: someone might want to retag to use new,
> > > more granular semantics
> >
> > Yes! Now we are getting there!
> >
> > > (hmm... like ISO 639-6, eh?).
> >
> > Well yes, if you want to look at it that way... but not just 639-6 ANY
> other
> > additions/extensions that may occur in future updates...
> >
> > What harm is there in my proposal?
> >
> > Kind regards
> >
> > Debbie
> --
> 
> Marion Gunn * EGTeo (Estab.1991)
> 27 Páirc an Fhéithlinn, Baile an
> Bhóthair, Co. Átha Cliath, Éire.
> * [email-masked] * [email-masked] *
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Mon, 4 Jul 2005 21:33:48 +0100

Having looked at ABNF I revise the proposal as follows:

Language-Tag[RFC3066bis]=....

Regards

Debbie

> Behalf Of Addison Phillips
> Sent: 04 July 2005 17:11
> To: Marion Gunn
> Cc: [email-masked]
> Subject: RE: [Ltru] Referencing the Scheme within the Tag
> 
> Okay, here's the main problem: we can't put a notation where you want it
> and have valid ABNF. "Language-Tag" is not just some string. It is an
> identifier.
> 
> Secondly, the whole document should be referenced, not just the ABNF
> (which will rarely be referenced). RFC numbers are not reused: it is their
> sole advantage. Referencing RFC3066bis is a permanent way to say which
> scheme you are using and will remain a useful reference even when there is
> a "3066ter".
> 
> Finally, there is a section in the document (2.2.9) that defines
> conformance. This proposal belongs in that section.
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 4 Jul 2005 14:26:31 -0700

Hi -

> From: "Debbie Garside" <[email-masked]>
> To: "'Addison Phillips'" <[email-masked]>; "'Marion Gunn'" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, July 04, 2005 1:33 PM
...

Do you intend literally "RFC3066bis", or do you intend that the
"3066bis" portion would be replaced by whatever RFC number
is assigned to the registry draft during the publication process?

Randy

---

From: "Debbie Garside" <[email-masked]>
Date: Mon, 4 Jul 2005 22:42:09 +0100

Randy wrote:

>> or do you intend that the "3066bis" portion would be replaced by whatever
>>  RFC number is assigned to the registry draft during the publication 
>> process?

Yes! So perhaps my proposal should state:

Language-tag[RFC****]=...

Regards

Debbie

> Behalf Of Randy Presuhn
> Sent: 04 July 2005 22:27
> To: [email-masked]

---

From: r&d afrac <[email-masked]>
Date: Tue, 05 Jul 2005 05:40:47 +0200

Dear Marion,
multilingualisation is a top priority of the WGIG. We will therefore most 
probably extensively discuss it through the coming months. For the reasons 
Addison gives and I documented in another mail, RFC 3066 will probably stay 
around until replaced by BCP 47 documenting the Multilingual Internet 
Framework or the MGN (Multilingual Global NGN).

This is why we will keep http://rfc3066.org active and will document the 
various schemes (RFC 3066, "RFC 3066bis" and "RFC 3066ter" if they are 
published, x-tags, etc.). Once the issue stabilised, the site will be 
transfered to the CRC conference for a community management/
jfc