Subject: RE: [Ltru] Re: Reference lists; AND ABNF GRAMMARS

From: "Addison Phillips" <[email-masked]>
Date: Fri, 22 Jul 2005 13:21:43 -0700

We don't know that extlang never combines with "reglang" or with alpha-4 codes. Draft-registry doesn't actually say that.

Draft-matching's ABNF says it, but that is probably wrong.

What we do know is that, really, extlangs will be ISO 639-3 codes (can't be alpha2 or alpha4) whose prefix will be set by ISO 639-3 and thus will be either alpha2 or alpha3. Hence the matching ABNF being the way it is. 

The question is whether we should have a lot more ABNF rules in the draft-registry ABNF to exactly express a relationship embedded in the Prefix registry field and not actually specified now.

The tide appears to be in favor of modifying the ABNF, so I'll give it a look this afternoon.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: Friday, July 22, 2005 12:38 PM
> To: [email-masked]
> Subject: [Ltru] Re: Reference lists; AND ABNF GRAMMARS
> 
> r&d afrac wrote:
> 
> > is it correct or not?
> 
> We (TINW) wouldn't want the name 'genvariant':
> 
> variant         = regvariant
>                 / genvariant
> 
> regvariant      = 5*8alphanum        ; registered variant
> 
> genvariant      = (DIGIT 3alphanum)  ; generic variant
> 
> The original variant is better:
> 
> variant         =  5*8alphanum       ; registered variants
>                 / ( DIGIT 3alphanum )
> 
> Splitting region in <stdregion> / <unregion> is possible, but
> the original region is good enough:
> 
> region          = 2ALPHA             ; ISO 3166 code
>                 / 3DIGIT             ; UN country number
> 
> The <stdlangext> idea in Kent's proposal is apparently better
> than the original ABNF, because it clearly says that <extlang>
> is only combined with <stdlang>, never with <reglang>.
> 
> In fact it could go further there:  Debbie's alpha-4 <stdlang>
> is also never combined with <extlang>.  Maybe Kent could split
> <stdlang> extracting Debbie's <reslang> (reserved for future
> use by 3066ter or later).
>                             Bye, Frank
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Fri, 22 Jul 2005 22:15:53 +0100

> What we do know is that, really, extlangs will be ISO 639-3 codes (can't
> be alpha2 or alpha4) whose prefix will be set by ISO 639-3 and thus will
> be either alpha2 or alpha3. Hence the matching ABNF being the way it is.

Hmmm... can you explain this please?  I can perhaps understand that extlangs
cannot be alpha2 but am having difficulty with the alpha4 reference.
Although, that said, obviously alpha4's do not need extensions as they are
stand alone whereas any extension coding of alpha3 MAY duplicate an alpha3
primary subtag (a dangerous situation IMHO).

Thanks

Debbie

> Behalf Of Addison Phillips
> Sent: 22 July 2005 21:22
> To: Frank Ellermann; [email-masked]
> Subject: RE: [Ltru] Re: Reference lists; AND ABNF GRAMMARS
> 
> We don't know that extlang never combines with "reglang" or with alpha-4
> codes. Draft-registry doesn't actually say that.
> 
> What we do know is that, really, extlangs will be ISO 639-3 codes (can't
> be alpha2 or alpha4) whose prefix will be set by ISO 639-3 and thus will
> be either alpha2 or alpha3. Hence the matching ABNF being the way it is.
> 
> The question is whether we should have a lot more ABNF rules in the draft-
> registry ABNF to exactly express a relationship embedded in the Prefix
> registry field and not actually specified now.
>

---

From: "John.Cowan" <[email-masked]>
Date: Fri, 22 Jul 2005 17:40:58 -0400

> cannot be alpha2 but am having difficulty with the alpha4 reference.

An extlang subtag is always alpha3, by the syntax rules of RFC 3066bis.
If and when alpha4s are allowed, they will be allowed as language subtags,
never as extension subtags.

> primary subtag (a dangerous situation IMHO).

Actually, it can't.  An alpha3 code can belong to one of these groups:

1) Appears in 639-2 and 639-3 and has a counterpart in 639-1.  Forbidden;
use the 639-1 code instead.

2) Appears in 639-2 and 639-3 but has no 639-1 counterpart.  Allowed as
a language subtag but not an extlang subtag.

3) Appears in 639-3 as a individual language that is not part of a
macrolanguage.  Not currently allowed; will be allowed in 3RFC 3066ter
as a language subtag but not an extlang subtag.

4) Appears in 639-3 as a macrolanguage.  Not currently allowed; will be
allowed in 3RFC 3066ter as a language subtag but not an extlang subtag.

5) Appears in 639-3 as an individual language that is part of a
macrolanguage.  Not currently allowed; will be allowed in RFC 3066ter
as an extlang subtag but not a language subtag.

-- 
MEET US AT POINT ORANGE AT MIDNIGHT BRING YOUR DUCK OR PREPARE TO FACE WUGGUMS
John Cowan   http://www.reutershealth.com   [email-masked]

---

From: "Debbie Garside" <[email-masked]>
Date: Fri, 22 Jul 2005 22:48:36 +0100

Hi John

Thanks for the clarification :-)

Kind regards

Debbie

> From: John.Cowan [mailto:[email-masked]]
> Sent: 22 July 2005 22:41
> To: Debbie Garside
> Cc: 'Addison Phillips'; 'Frank Ellermann'; [email-masked]
> Subject: Re: [Ltru] Re: Reference lists; AND ABNF GRAMMARS
> 
> Debbie Garside scripsit:
>