Subject: RE: [Ltru] [psg.com #1061] eliminate (or proscribe) Private Use Tags

From: "Peter Constable" <[email-masked]>
Date: Fri, 8 Jul 2005 06:52:35 -0700

[re posting with appropriate subject]

> From: [email-masked] [mailto:[email-masked]]
On
> Behalf Of Dylan N. Pierce

> But if it's doing "Just this," then let's put our money where our
mouths
> are and say, "Just this." We don't need private use tags at all

We cannot eliminate private-use tags completely: we must at least retain

x *("-" 1*8Alpha)

to remain backward compatible with existing implementations of 3066. I
don't think we want current users' tags to break on new parsers.

Peter Constable

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Sun, 10 Jul 2005 09:23:18 -0700

I had a devil of a time squaring the thread with modifications to section 2.2.7 and section 4.5. What I ended up doing was adding this "rule" to section 2.2.7:

<t>Private use subtags are NOT RECOMMENDED where alternatives exist or for general interchange. See <xref target="privateuse"></xref> for more information on private use subtag choice.</t>

... and then doing all the requested editing in section 4.5.

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Doug Ewell [mailto:[email-masked]]
> Sent: 2005年7月10日 8:54
> To: LTRU Working Group
> Cc: Addison Phillips
> Subject: Re: [Ltru] Re: [psg.com #1061] eliminate (or proscribe) Private
> Use Tags
> 
> Addison Phillips <addison dot phillips at quest dot com> wrote:
> 
> > In reading this thread: did anyone look at the existing section 4.5?!?
> 
> I did; it was my basis for claiming the wording was already strong
> enough.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
>