Subject: Fw: [Ltru] Re: [psg.com #1061] eliminate (or proscribe) Private Use Tags

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 13 Jul 2005 16:36:44 -0700

Hi -

Another message from Jefsey clearly intended for the WG mailing list.

Randy

----- Original Message ----- 
> From: "r&d afrac" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Sent: Wednesday, July 13, 2005 7:08 AM
> Subject: Re: [Ltru] Re: [psg.com #1061] eliminate (or proscribe) Private Use Tags
>
> On 09:01 13/07/2005, Randy Presuhn said:
> >Hi -
> >
> > > From: "r&d afrac" <[email-masked]>
> > > To: "Randy Presuhn" <[email-masked]>; "LTRU Working
> > Group" <[email-masked]>
> > > Sent: Tuesday, July 12, 2005 5:28 PM
> > > Subject: Re: [Ltru] Re: [psg.com #1061] eliminate (or proscribe)
> > Private Use Tags
> > >
> > > At 22:28 09/07/2005, Randy Presuhn wrote:
> > > >Hi -
> > > > > From: "Doug Ewell" <[email-masked]>
> > > > > To: "LTRU Working Group" <[email-masked]>
> > > > > Sent: Saturday, July 09, 2005 1:00 PM
> > > > > Subject: [Ltru] Re: [psg.com #1061] eliminate (or proscribe) Private
> > > > Use Tags
> > > > >
> > > >
> > > > > In the interest of achieving consensus, I won't argue further about the
> > > > > exact wording of this section.  I do insist that private-use tags and
> > > > > subtags in "x-" not be removed from the grammar, or proscribed
> > entirely.
> > > > > It MUST be legal for consenting adults to generate and interpret
> > > > > "x-this" and "en-x-that" in the privacy of their homes.
> > > >...
> > > >
> > > >I think we're all agreed on that.  Based on the discussion, I'll leave
> > it to
> > > >the editors to pick appropriate words to reflect our rough consensus that
> > > >private use tags and subtags should remain in the document, but there
> > should
> > > >be a "health warning" regarding the risks associated with using
> > them.  Several
> > > >alternative wordings have been offered, and I think the feedback on the
> > > >mailing
> > > >list will provide sufficient guidance to the editors to form text we
> > can live
> > > >with.
> > >
> > > I am obliged to come back on this. If the editors are to form a text we can
> > > live with, I think we also could. And if cannot, we should make clear in a
> > > note, or through a consensus of this group, that it has never been
> > > considered that "x-" tags could ever have to do with pornography (or
> > > exclusion as some of comments I received during the ICANN meeting).
> > >
> > > >With that, I'll mark this issue resolved.  If someone finds the words they
> > > >choose unacceptable, we can re-open the issue.
> > >
> > > I reopen the issue, not necessarily on the text itself but about the
> > > guidance given to the editor.
> > > jfc
> >
> >If you really believe issue #1061 needs to be re-opened,
> >please identify the specific text in the draft you object to and
> >the text you would propose in its place.
>
> "The use of "x-" has no particular meaning regarding the nature of the
> private subtags."
> or
> "The use of "x-" is to introduce the private extension of the format. It
> may in particular be used for multilingual or punycoded subtags."
>
> The Alpha8 is discreminatory against internationalised subtags, as punycode
> can imply punycoded string of different length for internationalised
> strings of similar length.
> jfc
>
>
> >Randy, ltru co-chair
> >
> >
> >
> >
> >_______________________________________________
> >Ltru mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/ltru
>

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 13 Jul 2005 16:58:25 -0700

Hi -

Can I get a hum on whether to add the proposed text?

Randy, ltru co-chair

...
...

Presumably this would go in 2.2 where it currently says:
   o  The single letter subtag 'x' is reserved to introduce a sequence
      of private-use subtags.  The interpretation of any private-use
      subtags is defined solely by private agreement and is not defined
      by the rules in this section or in any standard or registry
      defined in this document.

---

From: Martin Duerst <[email-masked]>
Date: Thu, 14 Jul 2005 10:07:29 +0900

I'm clearly against it, for several reasons:

- I don't like punycode, and I don't think it should get any mention
   or use in any context other than internationalized domain names
   (where it should be strictly limited to use within the protocol,
   and the necessary application stubs, but not be exposed to the user).

- I think that of all things, language tags should stay ASCII only.
   I have worked, and am still working, to get more and more of the
   Web and the Internet internationalized. This includes Web
   addresses and domain names. The reason for the difference between
   language tags and domain names and so is that language tags are
   on a lower level. I.e. it doesn't make sense to have language tags
   in multiple languages or scripts, because this would create difficult
   bootstrap issues.

- Please note that alpha-8 is discriminatory for languages that use
   the Latin script, too. Many words are longer than 8 letters.

Regards,    Martin.