Subject: RE: [Ltru] Private Use Tags

From: "L.Gillam" <[email-masked]>
Date: Mon, 11 Jul 2005 10:42:02 +0100

Peter,
 
In the neutral corner, if there is such a thing, the distinction may not be so clear for people whose reasoning goes that both use language codes and country codes, and excluding differences in separator use they look identical. As you identify, it is the intention of the combination that differs. Some, who might process such metadata items into their components may wonder how there can be a difference between "en" in one context and "en" in another context. And this is something that a certain section, I can't recall which, in WD 639-4, doesn't cover - it just shows that various combinations are valid. Something to be looked at in August no doubt.
 
In addition, I may have interpreted something from another contributor to this list that may appear obvious to those involved, but may be less than crystal clear to some new users - that currently the "registry" uses codes for the representation of the "names" of languages, combines them with codes for the "names" of countries, and creates a new semantic around these such that the names can now used as identifiers for (some fragment of) linguistic content. Nothing unusual in human activity, but these differences in expectation for some as alluded to in the previous paragraph, may be the cause of some misunderstandings as seen on this list.
 
I don't claim to know what Sun do, but they may be combining a currency value with a locale to identify "common" items that can be associated to some locales but not generally others. It's a guess, but again you'd need to know what their intention was in making such combinations. 
 
Such discussions, perhaps, help to draw these "shared" understandings out into the open. Pointers to prior discussions of this nature may also be of some use.

________________________________

From: [email-masked] on behalf of Peter Constable
Sent: Thu 07/07/2005 17:36
To: ltru
Subject: RE: [Ltru] Private Use Tags

> From: [email-masked] [mailto:[email-masked]]
On Behalf Of
> Dylan N. Pierce

> It is, in fact, the locale ID. But it would be disingenuous to present
> that distinction as a significant difference. Effectively, the locale
ID
> /is/ a language ID "plus."

True, insofar as every locale has language as one of its constituent
properties. But I believe (as others here have heard me say) that there
is a definite difference. A language tag is a metadata element used to
declare attributes of content wrt language variety and written form, or
to request content according to those attributes; a locale ID is an API
parameter used to tailor software processes, or to tag resources used to
tailor those processes, wrt a variety of cultural parameters, some of
which pertain to language but others of which do not. Very often, the
information in a language tag is sufficient for use as a locale ID, but
not in the general case.

> According to Sun's own documentation, "The language argument is a
valid
> ISO Language Code. These codes are the lower-case, two-letter codes as
> defined by ISO-639....  The country argument is a valid ISO Country
> Code. These codes are the upper-case, two-letter codes as defined by
> ISO-3166." And its purpose is so that applications can decide in what
> language to serve the documents (in this case, UI output).

I haven't reviewed their implementation or documentation, but something
doesn't make sense here: if the purpose of these IDs is only to select
UI strings, then I wouldn't expect these IDs would ever need to include
a component for currency.

Peter Constable

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 11 Jul 2005 12:23:56 -0700

Hi -

While these are interesting observations, I must ask that you be clear whether
you're voicing an objection to any text present in the i-d, or requesting that any
any specific text be added to address your concerns.  We're in working group
last call on the registry-related drafts, so I'd like to focus on any specific changes
necessary to reflect WG consensus, rather than open-ended discussion.
If you have specific text to suggest, particularly if it will help avoid confusion,
please post it.

Randy, ltru co-chair

----- Original Message ----- 
From: "L.Gillam" <[email-masked]>
To: "petercon" <[email-masked]>; "ltru" <[email-masked]>
Sent: Monday, July 11, 2005 2:42 AM
Subject: RE: [Ltru] Private Use Tags

Peter,

In the neutral corner, if there is such a thing, the distinction may not be so clear for people whose reasoning goes that both use
language codes and country codes, and excluding differences in separator use they look identical. As you identify, it is the
intention of the combination that differs. Some, who might process such metadata items into their components may wonder how there
can be a difference between "en" in one context and "en" in another context. And this is something that a certain section, I can't
recall which, in WD 639-4, doesn't cover - it just shows that various combinations are valid. Something to be looked at in August no
doubt.

In addition, I may have interpreted something from another contributor to this list that may appear obvious to those involved, but
may be less than crystal clear to some new users - that currently the "registry" uses codes for the representation of the "names" of
languages, combines them with codes for the "names" of countries, and creates a new semantic around these such that the names can
now used as identifiers for (some fragment of) linguistic content. Nothing unusual in human activity, but these differences in
expectation for some as alluded to in the previous paragraph, may be the cause of some misunderstandings as seen on this list.

I don't claim to know what Sun do, but they may be combining a currency value with a locale to identify "common" items that can be
associated to some locales but not generally others. It's a guess, but again you'd need to know what their intention was in making
such combinations.

Such discussions, perhaps, help to draw these "shared" understandings out into the open. Pointers to prior discussions of this
nature may also be of some use.

...