Subject: RE: [Ltru] Re: ABNF beautification...

From: "Addison Phillips" <[email-masked]>
Date: Wed, 27 Jul 2005 09:52:33 -0700

Please see my previous message. The beautified ABNF is posted in an editor's copy:

http://www.inter-locale.com/ID/draft-ietf-ltru-registry-10.html
http://www.inter-locale.com/ID/draft-ietf-ltru-registry-10.txt

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: Wednesday, July 27, 2005 8:31 AM
> To: [email-masked]
> Subject: Re: [Ltru] Re: ABNF beautification...
> 
> Hi -
> 
> There have been quite a few deltas in the "ABNF beautification", but
> it sounds like there is quite a bit of support.  I'd like the editors to
> post
> a message with the ABNF as they see it based on the comments so far,
> and I'd like to hear from the rest of the WG participants on whether they
> support or oppose the revision, in order to be clear whether there is
> indeed a rough consensus to make this change.
> 
> Randy, ltru co-chair
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 28 Jul 2005 14:30:14 +0200

Addison Phillips wrote:

> The beautified ABNF is posted in an editor's copy:

ACK.  I don't find the time to read it loud word for word,
but at least I scanned it (= complete text) visually for
minor nits:

~~~ old ~~~
field-name = *(ALPHA / DIGIT / "-")
~~~ new ~~
field-name = ALPHA [ *(ALPHA / DIGIT / "-") (ALPHA / DIGIT)]
~~~ end ~~~

Verified with Bill's parser.  AFAIK that's what you want:

A field-name can't be empty, starts with ALPHA, and doesn't
end with a hyphen.

Okay, I should have said so earlier, OTOH I did IIRC <gd&r>

| Note that the hexadecimal notation MAY have between two and
| six digits.

The given XML source allows also one hex. digit, e.g. &#x9;

Maybe delete that note, or s/two/one/ (dubious, the source
also allows more than six hex. digits, e.g. &#x00000026;)

| records of whose Type has one

Some upper case Type, many 'Type', maybe s/ Type / 'Type' /g

| Long screeds about a particular subtag are frowned upon.

Rarely I need a dictionary for en2de (often for de2en, that's
another issue).  It says "fig. coll." for "screed", how about
s/screeds/comments/ ?

| This field MAY appear at most one time

Are you sure about "MAY at most" ?  I'd say "MUST at most".

|      1.  The region code 'TL' was assigned to the country

You don't want the "1." here, this list has only one item.

Other sublists at this level use letters, but a sublist only
with "A." (no "B.") is strange.  Elsewhere you use a bullet
for lists with only one item.

The format of the "registration form" in 3.4 is also strange,
maybe try "artwork" to get something like this:

~~~ new ~~~
   LANGUAGE SUBTAG REGISTRATION FORM
   1. Name of requester:
   2. E-mail address of requester:
   3. Record Requested:
      Type:
      Subtag:
      Description:
      Prefix:
      Preferred-Value:
      Deprecated:
      Suppress-Script:
      Comments:
   4. Intended meaning of the subtag:
   5. Reference to published description
      of the language (book or article):
   6. Any other relevant information:
~~~ end ~~~

| Any new registrations submitted after the adoption of this
| document MUST be rejected.

Is that necessary ?  IMHO it's obvious.

| Subtags of type 'Region' that have a Preferred-Value mapping
| in the IANA registry (see Section 3.1) SHOULD be replaced
| with their mapped value.

Add:  "In rare cases this step has to repeated".

| Example: The language tag "en-NH"

s/NH/BU/g and s/VU/MM/g - we want an example visible in the
registry, not an obsolete case eliminated by the "date A" rule.

I don't see the US-ASCII reference proposed by Scott, did you
forget it ?
                         Bye, Frank

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 28 Jul 2005 23:45:25 +0100

Hi All

Just to clarify, does the beautified ABNF mean that should 639-6 come to
pass it needs to wait for ter before it can be used or can it be used in
bis?  If the latter then I am happy if not then I could be unhappy; given
the time it has taken to get bis to this stage!

Regards

Debbie

> Behalf Of Addison Phillips
> Sent: 27 July 2005 17:53
> To: Randy Presuhn; [email-masked]
> Subject: RE: [Ltru] Re: ABNF beautification...
>

---

From: r&d afrac <[email-masked]>
Date: Fri, 29 Jul 2005 10:28:04 +0200

>the time it has taken to get bis to this stage!

I am not good at ABNF. But I rose a Last Call point that language subtags 
are treated equal from 2 to 8 alphanums (what permits to ensure reasonable 
compatibility with every ISO and non ISO standard the IETF or the Internet 
Community ad-hoc entities would adopt). If this is not the case I rise 
another Last Call point, and if the Last Call is finished, this would be a 
new exclusion point to be addressed in their turn by IETF, IESG, IAB, IANA 
and GAC with appeal to WTO. But by that time everything will be ruled 
discussed on the UN Internet Governance Forum.

So, I am not sure you can deduce anything from the current status of 
"numerobis" (cf. Asterix & Cleopatre). I suppose that ISO 639-6 will be for 
long in use in various network protocols before the current Draft is 
enforced by the IANA... This however depends on its authors.

I know some would love to make ISO 639-6 depend on this Draft and on its 
"consensus" that Randy and Martin will probably announce anytime soon 
(under their co-Chair responsibility). This is a mistake.
BTW I wait for the information I asked you.
jfc