Subject: RE: [Ltru] Last call: IANA adaptation of the UN disclaimer

From: "Addison Phillips" <[email-masked]>
Date: Fri, 15 Jul 2005 11:29:51 -0700

The purpose and point of this text I agree with, but the form of the text is not in keeping with the terminology or form of the rest of the document. It is nearly incomprehensible.

How about replacing your second paragraph with:

<q>The presence, absence or contents of subtags and their associated fields in the registry do not and should not be taken to imply an opinion on the part of the IETF, ICANN and IANA concerning the legal status of any language, script, country, territory, region, or language variation. Nor should they be taken to endorse any particular position regarding the legal status, authority, frontiers, boundaries, or cultural, political, economical, or educational policies of any particular country or region. This includes any issues pertaining to the identity or usage of any language or script within any country or region.</q>

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Constable
> Sent: 2005?7?15? 10:32
> To: [email-masked]
> Subject: RE: [Ltru] Last call: IANA adaptation of the UN disclaimer
> 
> > From: Addison Phillips [mailto:[email-masked]]
> 
> 
> > In draft-registry or draft-initial?
> >
> > If in draft-registry, *where*?
> 
> Sorry, I hadn't looked at the syntax for the registry for a while and
> was thinking it was possible to include comments -- indeed, I thought we
> were including some comments describing the fields of records, but that
> was probably something from before the switch to record jar format.
> Hence I was thinking this could be included as introductory comments. I
> guess since the syntax for the registry doesn't allow for comments, the
> only option would be somewhere in draft-registry.
> 
> In looking for a logical place such text might be included, I find there
> there's no place where the registry is introduced; the first reference
> (other than TOC or the page header "langtags-registry") is in 2.1:
> 
> "Thus a parser need not have an up-to-date copy (or any copy at all) of
> the subtag registry to perform most searching and matching operations."
> 
> That seems a bit odd to me. I suggest the following paragraphs be added
> at the end of the intro of section 2 (i.e. before the heading for 2.1):
> 
> <addition>
> The language tag is composed of one or more parts or "subtags". As
> described below, subtags available for use in a language tag are
> maintained in a registry (the 'subtag registry') that is administered by
> the Internet Assigned Numbers Authority (IANA).
> 
> The designations employed and the presentation of names of countries or
> regions, languages or scripts in the subtag registy do not imply the
> expression of any opinion whatsoever on the part of the IETF, ICANN and
> IANA concerning the legal status of any country, territory, region or of
> its authorities, or concerning the delimitation of frontiers or
> boundaries, or concerning any cultural, political, economical,
> educational sovereign issue within any country or region including any
> issues pertaining to the identity or usage of any language or script
> within any country or region.
> </addition>
> 
> A concomitant change would be made in the first paragraph of section
> 2.1:
> 
> - The language tag is composed of one or more parts or "subtags".  Each
>    subtag consists...
> 
> + Each subtag within a language tag consists...
> 
> 
> 
> Peter Constable
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 15 Jul 2005 13:55:45 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Peter Constable" <[email-masked]>; <[email-masked]>
> Sent: Friday, July 15, 2005 11:29 AM
> The purpose and point of this text I agree with, but the form of the text
> is not in keeping with the terminology or form of the rest of the document.
> It is nearly incomprehensible.
>
> <q>The presence, absence or contents of subtags and their associated fields
> in the registry do not and should not be taken to imply an opinion on the part of
> the IETF, ICANN and IANA concerning the legal status of any language, script,
> country, territory, region, or language variation. Nor should they be taken to
> endorse any particular position regarding the legal status, authority, frontiers,
> boundaries, or cultural, political, economical, or educational policies of any
> particular country or region. This includes any issues pertaining to the identity
> or usage of any language or script within any country or region.</q>
...

As a technical contributor, I think there adding this text contributes no value
to the document, and could in the longer term be harmful, regardless of
its benign intent and content.

None of the other IANA registries I've looked at has anything like this.
As a very concrete example, the enterprise number registry  at
http://www.iana.org/assignments/enterprise-numbers doesn't have
lawerly verbiage about trademarks or the legal status of enterprise names.
Similarly, http://www.iana.org/assignments/ianaaddressfamilynumbers-mib
doesn't fret about trademarks.  Not even http://www.iana.org/assignments/idn/
goes through such hand-wringing.  I think adding material like this would
set a very bad precedent, because it could lead to folks misconstruing
the absence of such disclaimers in other IANA-maintained registries.

Randy

---

From: Martin Duerst <[email-masked]>
Date: Sat, 16 Jul 2005 21:09:46 +0900

[chair hat off]

I have to agree with Randy. Besides his arguments, I'd also
like to mention that neither RFC 1766 nor RFC 3066 had any
such disclaimer. Also, I'm affraid that if somebody with a
traditional IETF background finds this paragraph, we might
get some serious IETF Last Call comments.

Also, if (as JFC thinks) this is something for the IANA/
ICANN/watever lawyers, then it's best if we keep out of it.
If asked for, we can point to the various text proposals in
the mailing list archive.

Regards,    Martin.

---

From: r&d afrac <[email-masked]>
Date: Sat, 16 Jul 2005 17:21:33 +0200

At 14:09 16/07/2005, Martin Duerst wrote:
>such disclaimer.

They did not confuse ISO 3166 and UN M.49. But I agree that RFC 3066 was a 
huge political mistake. However its lose application permitted it to 
survive. The ethical problem is with all those who use it.

>Also, I'm affraid that if somebody with a

The pity is that they accepted RFC 3066.
Could be a good IETF obituary.

>the mailing list archive.

Here I must disagree: what lawyers will want is to make sure the doctrine 
of the document is consistent with its political involvement and legal 
obligations/infrigements.

You cannot just do anything you want and then expect lawyers to save your day.
jfc