Subject: RE: [Ltru] Re: Finishing off #1026 (Was: Re: status? last call?)

From: "Addison Phillips" <[email-masked]>
Date: Sun, 10 Jul 2005 08:55:42 -0700

Which makes the text in rule 11 a problem: there is a MUST NOT followed by a MAY. I performed the requested edits, changed the MUST NOT to SHOULD NOT, referenced the registration process (the subtag reviewer does NOT register these things without a request), and did some editorial tugging as follows:

<t>Codes assigned by UN M.49 to countries or areas (as opposed to geographical regions and sub-regions) for which there is no corresponding ISO 3166 code SHOULD NOT be registered, except under the previous provisions (as a surrogate for an ISO 3166 code that is blocked from registration by an existing subtag). If it becomes necessary to identify a region for which only a UN M.49 code exists in language tags, then the registration authority for ISO 3166 SHOULD be petitioned to assign a code: such a code could then be registered for use in language tags. If the petition for a code assignment by ISO 3166 is refused
or not acted on in a timely manner, the registration process described in <xref target="registrationProc"></xref> MAY then be used to request and the Language Subtag Reviewer MAY
proceed with the registration of the corresponding UN M.49 code. At the time this document was written, there were only four such codes: 830 (Channel Islands), 831 (Guernsey), 832 (Jersey), and 833 (Isle of Man). This rule exists so that UN M.49 codes remain available as the value of last resort in cases where ISO 3166 reassigns a deprecated value in the registry.</t>

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mark Davis
> Sent: 2005年7月9日 14:58
> To: Randy Presuhn; LTRU Working Group
> Subject: Re: [Ltru] Re: Finishing off #1026 (Was: Re: status? last call?)
> 
> I agree with the clarification Randy suggests.
> 
> ‎Mark
> 
> ----- Original Message -----
> From: "Randy Presuhn" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>
> Sent: Saturday, July 09, 2005 13:55
> Subject: Re: [Ltru] Re: Finishing off #1026 (Was: Re: status? last call?)
> 
> 
> > Hi -
> >
> > As a technical contributor...
> >
> > > From: "Doug Ewell" <[email-masked]>
> > > To: "LTRU Working Group" <[email-masked]>
> > > Sent: Friday, July 08, 2005 11:46 PM
> > > Subject: [Ltru] Re: Finishing off #1026 (Was: Re: status? last call?)
> > ...
> > > The draft is not consistent with itself.  Section 2.2.4 (3E), quoted
> > > above, says we can register such subtags.  Section 3.4 (11), to which
> I
> > > referred, says we may not.
> > ...
> >
> > I think you mean section 3.3 (11).  The text there in the
> > http://www.ietf.org/internet-drafts/draft-ietf-ltru-registry-08.txt
> > draft says:
> >
> >    11.  Codes assigned by UN M.49 to countries or areas (as opposed to
> >         geographical regions and sub-regions) for which there is no
> >         corresponding ISO 3166 code MUST NOT be registered, except under
> >         the previous provisions (as a surrogate for an ISO 3166 code
> >         that cannot itself be registered).  If it is necessary to
> >         identify a region for which only a UN M.49 code exists in
> >         language tags, then the registration authority for ISO 3166
> >         SHOULD be petitioned to assign a code, which can then be
> >         registered for use in language tags.  At the time this document
> >         was written, there were only four such codes: 830 (Channel
> >         Islands), 831 (Guernsey), 832 (Jersey), and 833 (Isle of Man).
> >         This rule exists so that UN M.49 codes remain available as the
> >         value of last resort in cases where ISO 3166 reassigns a
> >         deprecated value in the registry.
> >
> > The difference in our understanding comes from the last sentence.  I
> think
> > Doug is reading it as the *sole* condition under which rule 3.3(11) may
> > be employed.  I, and I think Frank, read it as the *motivation* for the
> > rule, rather than a limiting condition.  The two readings play out
> > differently if the ISO 3166 registration authority fails to assign a
> > code when petitioned.  In Doug's reading, there's no registration,
> > and the party needing the code is out of luck.  In the alternative
> > reading, after some undefined (I'd leave it up to the collective
> > intelligence of the language tag mailing list) period, the UN M.49
> > code could be registered.  The question for the WG is which behaviour
> > is better / less bad?
> >
> > I propose adding one sentence to 3.3(11) to make it more consistent with
> > 2.2.4 (3E):  "If the petition for a code assignment ISO 3166 is refused
> > or not acted on in a timely manner, the Language Subtag Reviewer MAY
> > procede with the registration using the UN M.49 code."  Or words to
> > that effect.
> >
> > This is very much a pathological corner case, and I hate to see us
> > spending so much time on it, so let's pick one of the alternative,
> > make the text clear which one we've picked, and be done with it.
> >
> > Randy
> >
> >
> >
> >
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> >
> >
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 11 Jul 2005 05:35:57 +0200

Addison Phillips wrote:

>| registration authority for ISO 3166 SHOULD be petitioned to
>| assign a code:

Please insert </t><t> between "code:" and "such", s/such/Such/

                      Bye, Frank

---

From: "John.Cowan" <[email-masked]>
Date: Tue, 12 Jul 2005 09:59:44 -0400

Addison Phillips scripsit:

> If it becomes necessary to
> identify a region for which only a UN M.49 code exists in language tags,
> then the registration authority for ISO 3166 SHOULD be petitioned to
> assign a code: such a code could then be registered for use in language
> tags. 

I think this "could" ==> SHOULD, or at the very least MAY.

While I'm at it, in the 2005-7-11 draft:

	"could be included" in 3.4 ==> MAY;
	"might be interpreted", "could be taken", "could be regarded", "one
		could write", "could be used" ==> MAY;
	"could be used" in 4.5 ==> MAY;
	"cannot" in 2.2.3 ==> MUST NOT;
	"can" in 2.2.4 ==> MAY;
	"cannot" in 2.2.6 items 1 and 3 ==> MUST NOT;
	"can be split" and "can use the registry" in 3.1 ==> MAY;
	"can raise objections" in 3.4 ==> MAY;
	"can be registered" in 3.5 ==> MAY;
	"can only give possible examples" in 4.2 needs no modal, and
		==> "gives only possible examples";
	"can use" in 7 ==> MAY;
	"ought not" in 4.1 ==> SHOULD NOT;
	"will" in 2.2.1 item 5 ==> SHOULD or perhaps MUST;
	"will not be added" in 2.2.1 ==> MUST NOT;
	"will maintain" in 2.2.8 ==> MUST;
	"will be maintained" in 3 ==> MUST;
	"will consist" in 3.1 ==> MUST;
	"no registration records will be maintained" in 3.1 ==>
		"registration records MUST NOT be maintained";
	"will be in a modified" in 3.1 ==> MUST;
	"will evaluate" in 3.2 ==> MUST;
	"no new entries will be added and none of the entries will be removed"
		in 3.2 ==> "new entries MUST NOT be added or removed";
	"will be maintained" in 3.4 ==> MUST;
	"No subtags will be registered" in 3.5 ==> "Subtags MUST NOT
		be registered";
	TYPO: "will lend" in 3.6 ==> "will tend";
	"will use" and "will forward" in 3.6 ==> MUST;
	"will be initialized", "will be relabeled", "will be limited", and
		"will be sent" in 5.1 ==> MUST;
	"will include" in 5.2 ==> MUST;
	"will continue" in 8 ==> SHOULD;

Some of these changes may be inappropriate because of the broader context;
I haven't fully investigated.

-- 
Winter:  MIT,                                   John Cowan
Keio, INRIA,                                    [email-masked]
Issue lots of Drafts.                           http://www.ccil.org/~cowan
So much more to understand!                     http://www.reutershealth.com
Might simplicity return?                        (A "tanka", or extended haiku)